14:30:34 <ttereshc> #startmeeting Pulp Triage 2017-08-29
14:30:34 <ttereshc> #info ttereshc has joined triage
14:30:35 <pulpbot> Meeting started Tue Aug 29 14:30:34 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:35 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:35 <pulpbot> The meeting name has been set to 'pulp_triage_2017_08_29'
14:30:35 <pulpbot> ttereshc: ttereshc has joined triage
14:30:45 <ipanova> !here
14:30:45 <ipanova> #info ipanova has joined triage
14:30:45 <pulpbot> ipanova: ipanova has joined triage
14:30:47 <mansari> !here
14:30:47 <mansari> #info mansari has joined triage
14:30:47 <pulpbot> mansari: mansari has joined triage
14:31:27 <daviddavis> !here
14:31:27 <daviddavis> #info daviddavis has joined triage
14:31:27 <pulpbot> daviddavis: daviddavis has joined triage
14:31:32 <ttereshc> !next
14:31:33 <pulpbot> ttereshc: 3 issues left to triage: 2988, 2990, 2992
14:31:33 <ttereshc> #topic Exception when raising a user-Defined Exception that has a custom __init__ signature - http://pulp.plan.io/issues/2988
14:31:34 <pulpbot> Issue #2988 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:35 <pulpbot> Exception when raising a user-Defined Exception that has a custom __init__ signature - http://pulp.plan.io/issues/2988
14:31:49 <dalley> #info dalley has joined triage
14:31:49 <dalley> !here
14:31:49 <pulpbot> dalley: dalley has joined triage
14:32:06 <dkliban> !here
14:32:06 <dkliban> #info dkliban has joined triage
14:32:06 <pulpbot> dkliban: dkliban has joined triage
14:32:25 <dkliban> lets skip for now
14:32:28 <ttereshc> should we track it in External?
14:32:52 <dkliban> i am not sure
14:32:55 <ttereshc> or do you think we need more investigation?
14:33:04 <ipanova> haha 'MaybeEncodingError'
14:33:08 <asmacdo> !here
14:33:08 <asmacdo> #info asmacdo has joined triage
14:33:08 <pulpbot> asmacdo: asmacdo has joined triage
14:33:14 <ttereshc> yeah, that's hilarious
14:33:24 <dkliban> i think we need more investigation and really we need to have a plan for mitigating this problem in pulp 3
14:33:48 <ttereshc> do you want to skip it till bmbouter comes from pto?
14:33:56 <dkliban> ttereshc: let's do that
14:34:04 <ttereshc> !propose skip
14:34:04 <ttereshc> #idea Proposed for #2988: Skip this issue for this triage session.
14:34:04 <pulpbot> ttereshc: Proposed for #2988: Skip this issue for this triage session.
14:34:06 <asmacdo> +1, thats what we did friday
14:34:10 <ipanova> +1
14:34:21 <ttereshc> that's what we will do for a while then ;)
14:34:25 <ttereshc> !accept
14:34:25 <ttereshc> #agreed Skip this issue for this triage session.
14:34:25 <pulpbot> ttereshc: Current proposal accepted: Skip this issue for this triage session.
14:34:26 <pulpbot> ttereshc: 2 issues left to triage: 2990, 2992
14:34:26 <ttereshc> #topic Celery 4.x traceback upon restarting a worker while processing a task - http://pulp.plan.io/issues/2990
14:34:27 <pulpbot> Issue #2990 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:34:28 <pulpbot> Celery 4.x traceback upon restarting a worker while processing a task - http://pulp.plan.io/issues/2990
14:35:03 <dalley> not a terribly critical issue
14:35:40 <dalley> low / medium?
14:35:49 <daviddavis> +1
14:36:03 <ttereshc> so it does not prevent workers ti restart
14:36:04 <ttereshc> ?
14:36:53 <ttereshc> what's the impact? I mean what are the consequences of this issue?
14:37:00 <daviddavis> dalley
14:37:14 <asmacdo> I think its just a traceback in the log, without stopping the restart
14:37:27 <dalley> ^
14:37:31 <asmacdo> It would be nice to add a comment saying that, just to be clear
14:37:36 <daviddavis> +1
14:37:47 <asmacdo> the prio though--
14:37:47 <pulpbot> asmacdo: the prio though's karma is now -1
14:37:56 <asmacdo> lol, oops
14:38:01 <ttereshc> :)
14:38:02 <daviddavis> haha
14:38:14 <dkliban> lol
14:38:16 <asmacdo> anyway it seems like the severity is low to me
14:38:27 <dalley> the traceback actually happens when the initial worker shuts down afaik
14:38:36 <dalley> so no the restart should be unnaffected
14:38:56 <asmacdo> hows med/low or low/low?
14:39:07 <ttereshc> so it sounds low/low to me so far
14:39:13 <mansari> +1
14:39:17 <dalley> fine with me
14:39:27 <ipanova> +1
14:39:30 <ttereshc> dalley, could you leave a comment with some clarification what is the impact of this issue?
14:39:37 <dalley> yes
14:39:44 <ttereshc> !propose triage l/l
14:39:44 <pulpbot> ttereshc: (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
14:39:58 <ttereshc> !propose triage l l
14:39:58 <ttereshc> #idea Proposed for #2990: Priority: Low, Severity: Low
14:39:58 <pulpbot> ttereshc: Proposed for #2990: Priority: Low, Severity: Low
14:40:03 <ttereshc> #agreed Priority: Low, Severity: Low
14:40:03 <ttereshc> !accept
14:40:03 <pulpbot> ttereshc: Current proposal accepted: Priority: Low, Severity: Low
14:40:04 <pulpbot> ttereshc: 1 issues left to triage: 2992
14:40:04 <ttereshc> #topic GET by manifest digest should infer media type - http://pulp.plan.io/issues/2992
14:40:05 <pulpbot> Issue #2992 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:40:05 <ttereshc> ty dalley
14:40:06 <pulpbot> GET by manifest digest should infer media type - http://pulp.plan.io/issues/2992
14:41:18 <ttereshc> story? if we want to accept it
14:41:28 <ttereshc> ipanova, any thoughts?
14:41:39 <ipanova> i don't think we want to accept it
14:41:50 <ipanova> just because we would need to re-work many things
14:42:10 <ipanova> right now we do rely on the docker client talking to crane
14:42:20 <ipanova> which sets proper headers on which we rely
14:42:40 <ttereshc> convert to story but not a groomed one? or you'd like to close it right away?
14:42:57 <ttereshc> I guess that's more about user expectations
14:43:00 <ipanova> let's skip it for now, and i will take a closer look until next triage
14:43:09 <asmacdo> I like the convert to ungroomed story
14:43:10 <ttereshc> they always compare how docker registry works
14:44:00 <asmacdo> but if ipanova wants to skip im ok with that too
14:44:33 <ttereshc> I guess it won't hurt to skip
14:44:39 <ttereshc> !propose skip
14:44:39 <ttereshc> #idea Proposed for #2992: Skip this issue for this triage session.
14:44:39 <pulpbot> ttereshc: Proposed for #2992: Skip this issue for this triage session.
14:44:53 <ttereshc> !accept
14:44:53 <ttereshc> #agreed Skip this issue for this triage session.
14:44:53 <pulpbot> ttereshc: Current proposal accepted: Skip this issue for this triage session.
14:44:55 <pulpbot> ttereshc: No issues to triage.
14:45:01 <ttereshc> #endmeeting
14:45:01 <ttereshc> !end