14:30:07 <asmacdo> #startmeeting Pulp Triage 2017-09-29
14:30:07 <asmacdo> #info asmacdo has joined triage
14:30:08 <pulpbot> Meeting started Fri Sep 29 14:30:07 2017 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:08 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:08 <pulpbot> The meeting name has been set to 'pulp_triage_2017_09_29'
14:30:08 <pulpbot> asmacdo: asmacdo has joined triage
14:30:18 <daviddavis> !here
14:30:18 <daviddavis> #info daviddavis has joined triage
14:30:18 <pulpbot> daviddavis: daviddavis has joined triage
14:30:36 <mhrivnak> !here
14:30:36 <mhrivnak> #info mhrivnak has joined triage
14:30:38 <pulpbot> mhrivnak: mhrivnak has joined triage
14:30:41 <mansari> !here
14:30:41 <mansari> #info mansari has joined triage
14:30:42 <pulpbot> mansari: mansari has joined triage
14:30:45 <asmacdo> 11 issues today, so lets move quickly
14:31:04 <asmacdo> !next
14:31:05 <pulpbot> asmacdo: 11 issues left to triage: 3027, 3034, 3036, 3037, 3039, 3040, 3041, 3042, 3043, 3045, 3046
14:31:06 <asmacdo> #topic Pulp doesn't generate prestodelta.xml - http://pulp.plan.io/issues/3027
14:31:06 <pulpbot> Issue #3027 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:07 <pulpbot> Pulp doesn't generate prestodelta.xml - http://pulp.plan.io/issues/3027
14:31:28 <mhrivnak> !propose triage normal low
14:31:28 <mhrivnak> #idea Proposed for #3027: Priority: Normal, Severity: Low
14:31:28 <pulpbot> mhrivnak: Proposed for #3027: Priority: Normal, Severity: Low
14:31:34 <mhrivnak> There's an easy workaround.
14:31:38 <daviddavis> +1
14:31:44 <mhrivnak> which I think is even the default behavior.
14:31:58 <mansari> +1
14:32:06 <asmacdo> ipanova++
14:32:06 <pulpbot> asmacdo: ipanova's karma is now 8
14:32:19 <asmacdo> !accept
14:32:19 <asmacdo> #agreed Priority: Normal, Severity: Low
14:32:19 <pulpbot> asmacdo: Current proposal accepted: Priority: Normal, Severity: Low
14:32:20 <pulpbot> asmacdo: 10 issues left to triage: 3034, 3036, 3037, 3039, 3040, 3041, 3042, 3043, 3045, 3046
14:32:21 <asmacdo> #topic Pulp returns 500 when attempting to create a second importer for a repo - http://pulp.plan.io/issues/3034
14:32:21 <pulpbot> Issue #3034 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:32:22 <pulpbot> Pulp returns 500 when attempting to create a second importer for a repo - http://pulp.plan.io/issues/3034
14:32:27 <mhrivnak> !propose accept
14:32:27 <mhrivnak> #idea Proposed for #3034: Leave the issue as-is, accepting its current state.
14:32:27 <pulpbot> mhrivnak: Proposed for #3034: Leave the issue as-is, accepting its current state.
14:33:06 <asmacdo> +1
14:33:17 <mansari> +1
14:33:24 <daviddavis> +1
14:33:34 <asmacdo> !accept
14:33:34 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:33:34 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:33:35 <pulpbot> asmacdo: 9 issues left to triage: 3036, 3037, 3039, 3040, 3041, 3042, 3043, 3045, 3046
14:33:36 <asmacdo> #topic Pulp streamer dumps core on F26 - http://pulp.plan.io/issues/3036
14:33:36 <pulpbot> Issue #3036 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:33:37 <pulpbot> Pulp streamer dumps core on F26 - http://pulp.plan.io/issues/3036
14:34:21 <mhrivnak> !propose triage normal high
14:34:21 <mhrivnak> #idea Proposed for #3036: Priority: Normal, Severity: High
14:34:21 <pulpbot> mhrivnak: Proposed for #3036: Priority: Normal, Severity: High
14:34:28 <daviddavis> and add to sprint?
14:34:36 <daviddavis> regardless, +1 from me
14:34:37 <asmacdo> this struck me as higher than that mhrivnak
14:35:36 <mhrivnak> I could see it as high priority potentially. My thinking was basically that it's only on F26 which comes with this kind of risk in general, and its a coredump which would almost be impossible for us to cause.
14:36:09 <mhrivnak> So it's likely a bug in something we use that's shipped in F26.
14:36:30 <asmacdo> ack. +1 mhrivnak , +1 add to sprint
14:37:12 <asmacdo> !accept
14:37:12 <asmacdo> #agreed Priority: Normal, Severity: High
14:37:12 <pulpbot> asmacdo: Current proposal accepted: Priority: Normal, Severity: High
14:37:13 <pulpbot> asmacdo: 8 issues left to triage: 3037, 3039, 3040, 3041, 3042, 3043, 3045, 3046
14:37:14 <asmacdo> #topic sync progress reports all units added when errors downloading occur - http://pulp.plan.io/issues/3037
14:37:14 <pulpbot> Issue #3037 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:37:16 <pulpbot> sync progress reports all units added when errors downloading occur - http://pulp.plan.io/issues/3037
14:38:07 <daviddavis> !propose accept
14:38:07 <daviddavis> #idea Proposed for #3037: Leave the issue as-is, accepting its current state.
14:38:07 <pulpbot> daviddavis: Proposed for #3037: Leave the issue as-is, accepting its current state.
14:38:14 <mansari> +1
14:38:19 <mhrivnak> +1 at a minimum we need to clarify what this means.
14:38:42 <asmacdo> I'd like to talk about this in an MVP call
14:39:08 <mhrivnak> Sounds good.
14:39:42 <asmacdo> Ill mention it on the MVP thread and accept
14:39:49 <asmacdo> !accept
14:39:49 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:39:49 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:39:51 <pulpbot> asmacdo: 7 issues left to triage: 3039, 3040, 3041, 3042, 3043, 3045, 3046
14:39:51 <asmacdo> #topic Uninstalling pulp-rpm-handlers removes /etc/yum.repos.d/pulp.repo - http://pulp.plan.io/issues/3039
14:39:52 <pulpbot> Issue #3039 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:39:53 <pulpbot> Uninstalling pulp-rpm-handlers removes /etc/yum.repos.d/pulp.repo - http://pulp.plan.io/issues/3039
14:39:54 <bmbouter> !here
14:39:54 <bmbouter> #info bmbouter has joined triage
14:39:54 <pulpbot> bmbouter: bmbouter has joined triage
14:40:41 <jortel> !here
14:40:41 <jortel> #info jortel has joined triage
14:40:41 <pulpbot> jortel: jortel has joined triage
14:40:51 <mhrivnak> jortel thoughts on this?
14:40:59 * jortel reads
14:41:55 <mhrivnak> Perhaps we should skip it for now and have additional discussion about what the expected behavior is and should be?
14:42:01 <jortel> not off hand.  would need to look at the spec and handler code.
14:42:14 <jortel> been a while ..
14:42:19 <asmacdo> !propose skip
14:42:19 <asmacdo> #idea Proposed for #3039: Skip this issue for this triage session.
14:42:19 <pulpbot> asmacdo: Proposed for #3039: Skip this issue for this triage session.
14:42:48 <mhrivnak> +1
14:42:51 <asmacdo> !accept
14:42:51 <asmacdo> #agreed Skip this issue for this triage session.
14:42:51 <pulpbot> asmacdo: Current proposal accepted: Skip this issue for this triage session.
14:42:53 <asmacdo> #topic When a consumer is unbound from an RPM repository, that repository should be deleted from /etc/yum.repos.d/... - http://pulp.plan.io/issues/3040
14:42:53 <pulpbot> asmacdo: 6 issues left to triage: 3040, 3041, 3042, 3043, 3045, 3046
14:42:54 <pulpbot> Issue #3040 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:42:55 <pulpbot> When a consumer is unbound from an RPM repository, that repository should be deleted from /etc/yum.repos.d/... - http://pulp.plan.io/issues/3040
14:43:18 <mhrivnak> I wonder if it marks the repo as disabled.
14:44:02 <asmacdo> mhrivnak: i think that would be reasonable behavior
14:44:04 <mhrivnak> jortel do you recall what this behavior should be when unbinding? :)
14:45:19 <jortel> iirc, it should be removed from the .repo.  this is controlled server side.
14:45:37 <mhrivnak> Maybe let's skip for now and follow up on this one too?
14:45:46 <jortel> is this satellite?
14:45:54 <dkliban> no ... qe testing
14:45:56 <mhrivnak> no, I think just QE testing Pulp.
14:46:08 <jortel> okay.
14:46:18 <mhrivnak> !propose skip
14:46:18 <mhrivnak> #idea Proposed for #3040: Skip this issue for this triage session.
14:46:18 <pulpbot> mhrivnak: Proposed for #3040: Skip this issue for this triage session.
14:46:23 <asmacdo> !accept
14:46:23 <asmacdo> #agreed Skip this issue for this triage session.
14:46:23 <pulpbot> asmacdo: Current proposal accepted: Skip this issue for this triage session.
14:46:24 <pulpbot> asmacdo: 5 issues left to triage: 3041, 3042, 3043, 3045, 3046
14:46:24 <asmacdo> #topic It's impossible to track the status of a scheduled task - http://pulp.plan.io/issues/3041
14:46:25 <pulpbot> Issue #3041 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:46:26 <pulpbot> It's impossible to track the status of a scheduled task - http://pulp.plan.io/issues/3041
14:47:10 <mhrivnak> I wish he were here to answer a couple of questions.
14:47:16 <mhrivnak> I wonder if he tried using the normal task API.
14:47:33 <mhrivnak> !propose skip
14:47:33 <mhrivnak> #idea Proposed for #3041: Skip this issue for this triage session.
14:47:33 <pulpbot> mhrivnak: Proposed for #3041: Skip this issue for this triage session.
14:47:38 <mhrivnak> I'll ask on the issue if he did that.
14:47:43 <asmacdo> ty mhrivnak
14:47:47 <asmacdo> !accept
14:47:47 <asmacdo> #agreed Skip this issue for this triage session.
14:47:47 <pulpbot> asmacdo: Current proposal accepted: Skip this issue for this triage session.
14:47:48 <pulpbot> asmacdo: 4 issues left to triage: 3042, 3043, 3045, 3046
14:47:48 <asmacdo> #topic Scheduled tasks break GET calls to /pulp/api/v2/tasks/ - http://pulp.plan.io/issues/3042
14:47:49 <pulpbot> Issue #3042 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:47:50 <pulpbot> Scheduled tasks break GET calls to /pulp/api/v2/tasks/ - http://pulp.plan.io/issues/3042
14:48:28 <kersom> many of these issues were raised trying to use pulp-consumer-client to schedule installation and un-installation.
14:49:24 <kersom> to use pulp-consumer-client we have to install a bunch of other packages, and as part of clean-up remove them
14:49:27 <mhrivnak> Ah, maybe this is why he didn't see it in the task API. :)
14:50:13 <asmacdo> !propose accept
14:50:13 <asmacdo> #idea Proposed for #3042: Leave the issue as-is, accepting its current state.
14:50:13 <pulpbot> asmacdo: Proposed for #3042: Leave the issue as-is, accepting its current state.
14:50:19 <mhrivnak> +1
14:50:20 <kersom> we are trying to test this other issue https://pulp.plan.io/issues/2680
14:51:30 <asmacdo> ah, makes sense kersom
14:51:34 <asmacdo> !accept
14:51:34 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:51:34 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:51:35 <pulpbot> asmacdo: 3 issues left to triage: 3043, 3045, 3046
14:51:35 <asmacdo> #topic Race condition during orphan cleanup - http://pulp.plan.io/issues/3043
14:51:36 <pulpbot> Issue #3043 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:51:37 <pulpbot> Race condition during orphan cleanup - http://pulp.plan.io/issues/3043
14:52:03 <mhrivnak> FWIW the next issue proposes a work-around.
14:52:29 <asmacdo> and orphan cleanup is idempotent
14:52:55 <mhrivnak> !propose accept
14:52:55 <mhrivnak> #idea Proposed for #3043: Leave the issue as-is, accepting its current state.
14:52:56 <pulpbot> mhrivnak: Proposed for #3043: Leave the issue as-is, accepting its current state.
14:52:57 <asmacdo> so (fail + succeed = succeed)
14:53:09 <mhrivnak> exactly.
14:53:17 <asmacdo> I was thinking normal low
14:53:27 <mhrivnak> works for me.
14:53:32 <asmacdo> !propose triage normal low
14:53:32 <asmacdo> #idea Proposed for #3043: Priority: Normal, Severity: Low
14:53:32 <pulpbot> asmacdo: Proposed for #3043: Priority: Normal, Severity: Low
14:53:40 <mhrivnak> Easy work-around.
14:53:44 <mhrivnak> +1
14:53:45 <asmacdo> !accept
14:53:45 <asmacdo> #agreed Priority: Normal, Severity: Low
14:53:45 <pulpbot> asmacdo: Current proposal accepted: Priority: Normal, Severity: Low
14:53:47 <asmacdo> #topic Running orphan cleanup tasks simultaniously leads to high mongod cpu usage - http://pulp.plan.io/issues/3045
14:53:47 <pulpbot> asmacdo: 2 issues left to triage: 3045, 3046
14:53:48 <pulpbot> Issue #3045 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:53:49 <pulpbot> Running orphan cleanup tasks simultaniously leads to high mongod cpu usage - http://pulp.plan.io/issues/3045
14:54:37 <mhrivnak> !propose other high normal and add to sprint.
14:54:37 <mhrivnak> #idea Proposed for #3045: high normal and add to sprint.
14:54:37 <pulpbot> mhrivnak: Proposed for #3045: high normal and add to sprint.
14:54:43 <asmacdo> +1
14:54:50 <mansari> +1
14:55:13 <asmacdo> !accept
14:55:13 <asmacdo> #agreed high normal and add to sprint.
14:55:13 <pulpbot> asmacdo: Current proposal accepted: high normal and add to sprint.
14:55:14 <kersom> just to add more info related to these previous issues https://github.com/PulpQE/pulp-smash/compare/master...Ichimonji10:pr-770
14:55:14 <asmacdo> #topic pulp-rpm Merging Errata fails with KeyError exception - http://pulp.plan.io/issues/3046
14:55:15 <pulpbot> asmacdo: 1 issues left to triage: 3046
14:55:16 <pulpbot> Issue #3046 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:55:17 <pulpbot> pulp-rpm Merging Errata fails with KeyError exception - http://pulp.plan.io/issues/3046
14:55:53 <mhrivnak> !propose other accept, add to sprint, high-five daviddavis for already fixing it
14:55:53 <mhrivnak> #idea Proposed for #3046: accept, add to sprint, high-five daviddavis for already fixing it
14:55:53 <pulpbot> mhrivnak: Proposed for #3046: accept, add to sprint, high-five daviddavis for already fixing it
14:56:15 <asmacdo> lol +1
14:56:29 <daviddavis> I fixed this?
14:56:42 <mhrivnak> It's assigned to you and in POST
14:56:43 <asmacdo> mhrivnak: can you likn the other issue?
14:56:55 <asmacdo> oh. mhrivnak are you on 3046?
14:56:57 <mhrivnak> oh wait, sorry.
14:57:02 <mhrivnak> I skipped ahead. :)
14:57:06 <daviddavis> haha
14:57:14 <daviddavis> does this mean no high five?
14:57:18 <dkliban> lol
14:57:20 * mhrivnak puts it in reverse and visits 3046
14:58:22 <mhrivnak> I wonder if this is related to centos errata being slightly different.
14:58:53 <mhrivnak> !propose other skip and get Tanya's input next week
14:58:53 <mhrivnak> #idea Proposed for #3046: skip and get Tanya's input next week
14:58:53 <pulpbot> mhrivnak: Proposed for #3046: skip and get Tanya's input next week
14:58:59 <asmacdo> sounds good to me
14:59:04 <asmacdo> !accept
14:59:04 <asmacdo> #agreed skip and get Tanya's input next week
14:59:04 <pulpbot> asmacdo: Current proposal accepted: skip and get Tanya's input next week
14:59:05 <pulpbot> asmacdo: No issues to triage.
14:59:33 <mhrivnak> Just in time.
14:59:37 <asmacdo> !end
14:59:37 <asmacdo> #endmeeting