15:30:23 <dalley> #startmeeting Pulp Triage 2017-11-10
15:30:23 <dalley> #info dalley has joined triage
15:30:24 <pulpbot> Meeting started Fri Nov 10 15:30:23 2017 UTC and is due to finish in 60 minutes.  The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:24 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:24 <pulpbot> The meeting name has been set to 'pulp_triage_2017_11_10'
15:30:24 <pulpbot> dalley: dalley has joined triage
15:30:28 <ipanova> !here
15:30:28 <ipanova> #info ipanova has joined triage
15:30:29 <ttereshc> !here
15:30:29 <ttereshc> #info ttereshc has joined triage
15:30:29 <pulpbot> ipanova: ipanova has joined triage
15:30:30 <pulpbot> ttereshc: ttereshc has joined triage
15:30:38 <bizhang> !here
15:30:38 <bizhang> #info bizhang has joined triage
15:30:38 <pulpbot> bizhang: bizhang has joined triage
15:30:43 <mansari> #info mansari has joined triage
15:30:43 <mansari> !here
15:30:43 <pulpbot> mansari: mansari has joined triage
15:30:44 <mhrivnak> #info mhrivnak has joined triage
15:30:44 <mhrivnak> !here
15:30:45 <pulpbot> mhrivnak: mhrivnak has joined triage
15:30:55 <dalley> !next
15:30:56 <pulpbot> dalley: 3 issues left to triage: 3122, 3123, 3125
15:30:56 <dalley> #topic config layer is served gzip-compressed to docker client - http://pulp.plan.io/issues/3122
15:30:57 <pulpbot> Issue #3122 [POST] (mihai.ibanescu@gmail.com) - Priority: Normal | Severity: Medium
15:30:58 <pulpbot> config layer is served gzip-compressed to docker client - http://pulp.plan.io/issues/3122
15:31:00 <dkliban> !here
15:31:00 <dkliban> #info dkliban has joined triage
15:31:00 <pulpbot> dkliban: dkliban has joined triage
15:31:05 <mansari> Already in POST
15:31:17 <ipanova> community contribution ^_^
15:31:21 <mhrivnak> Valuable to get into 2.15.
15:31:29 <ipanova> mhrivnak: it should get
15:31:34 <dalley> !propose other accept & add to sprint
15:31:34 <dalley> #idea Proposed for #3122: accept & add to sprint
15:31:34 <pulpbot> dalley: Proposed for #3122: accept & add to sprint
15:31:38 <mhrivnak> +1
15:31:39 <ipanova> it is a bugfix
15:31:40 <daviddavis> !here
15:31:40 <daviddavis> #info daviddavis has joined triage
15:31:40 <pulpbot> daviddavis: daviddavis has joined triage
15:31:42 <ipanova> +1
15:31:50 <mansari> +1
15:31:52 <dalley> !accept
15:31:52 <dalley> #agreed accept & add to sprint
15:31:52 <pulpbot> dalley: Current proposal accepted: accept & add to sprint
15:31:52 <bizhang> +1
15:31:52 <ttereshc> do we add it to sprint, even it's fixed by community?
15:31:53 <pulpbot> dalley: 2 issues left to triage: 3123, 3125
15:31:53 <dalley> #topic The jwt reset endpoint should return 204 probably - http://pulp.plan.io/issues/3123
15:31:54 <pulpbot> Issue #3123 [ASSIGNED] (daviddavis@redhat.com) - Priority: Normal | Severity: Medium
15:31:55 <pulpbot> The jwt reset endpoint should return 204 probably - http://pulp.plan.io/issues/3123
15:32:04 <dalley> ttereshc, I think it's been done previously
15:32:09 <dalley> but, good question
15:32:13 <mhrivnak> ttereshc I think yes since it needs some help from us to get it merged.
15:32:18 <mhrivnak> and we want it merged soon.
15:32:24 <ttereshc> ok
15:32:34 <daviddavis> I can do #3123 in 5 min today
15:32:39 <mhrivnak> If it weren't for the urgency, it would not need to be on the sprint I think.
15:32:44 <ipanova> daviddavis: sold
15:32:46 <mhrivnak> +1
15:32:54 * mhrivnak grabs a stopwwatch
15:32:57 <dalley> !propose other accept and add to sprint
15:32:57 <dalley> #idea Proposed for #3123: accept and add to sprint
15:32:57 <pulpbot> dalley: Proposed for #3123: accept and add to sprint
15:33:05 <ipanova> +1
15:33:06 <ttereshc> +1
15:33:33 <dalley> !accept
15:33:33 <dalley> #agreed accept and add to sprint
15:33:33 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
15:33:34 <pulpbot> dalley: 1 issues left to triage: 3125
15:33:34 <dalley> #topic Importer and Publisher URIs are mutable - http://pulp.plan.io/issues/3125
15:33:35 <pulpbot> Issue #3125 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:33:36 <pulpbot> Importer and Publisher URIs are mutable - http://pulp.plan.io/issues/3125
15:34:09 <mhrivnak> I agree this is a bug, but the proposed resolution is a bigger change that feels like a task, if not a story.
15:34:25 <dkliban> i had it as a story initially
15:34:27 <bmbouter> !here
15:34:27 <bmbouter> #info bmbouter has joined triage
15:34:27 <pulpbot> bmbouter: bmbouter has joined triage
15:34:40 <mhrivnak> The "fix" to the simple bug is to make names immutable, which would make the originally-intended behavior correct.
15:34:47 <mhrivnak> I like the proposed behavior change.
15:34:58 <mhrivnak> But it does feel like more than just a fix to this bug.
15:35:12 <mhrivnak> It's like this bug is helping to illustrate why the change is valuable.
15:35:16 <dkliban> so do we want to convert to a story and then add to sprint?
15:35:23 <jortel> seems like a task
15:35:26 <bmbouter> +1 to putting on sprint either way
15:35:28 <ttereshc> dkliban, is it similar to the repositores' URI you recently posted PR for?
15:35:34 <dkliban> ttereshc: yes
15:35:35 <daviddavis> ttereshc: yes
15:35:39 <ttereshc> I see
15:35:57 <dalley> !propose other convert to task and add to sprint
15:35:57 <dalley> #idea Proposed for #3125: convert to task and add to sprint
15:35:58 <pulpbot> dalley: Proposed for #3125: convert to task and add to sprint
15:36:07 <mhrivnak> !propose other convert to task and groom it
15:36:07 <mhrivnak> #idea Proposed for #3125: convert to task and groom it
15:36:08 <pulpbot> mhrivnak: Proposed for #3125: convert to task and groom it
15:36:13 <dalley> ^
15:36:20 <mhrivnak> er, and by "Groom it", I mean let people review it and provide feedback.
15:36:24 <mhrivnak> then mark it groomed after that.
15:36:38 <dalley> sure, sounds good tm
15:36:39 <bmbouter> is there more to comment on?
15:36:39 <mhrivnak> and that can be soon of course. I don't mean to delay it.
15:36:43 <bmbouter> cool
15:37:10 <ttereshc> +1 to add to sprint right after grooming
15:37:16 <dalley> who will do the converting?
15:37:17 <ipanova> ttereshc: +1
15:37:19 <jortel> i suspect mainly needs grooming for completeness
15:37:21 <dkliban> we have a thread on pulp-dev list about it
15:37:30 <mhrivnak> yeah.
15:37:35 <asmacdo> i dont want to accept this one
15:37:53 <asmacdo> i think we need to talk about how we want our REST api from a higher level first
15:38:03 <asmacdo> I'm hoping we can discuss Monday
15:38:06 <dkliban> asmacdo: reply on pulp-dev list
15:38:14 <dkliban> asmacdo: i started a thread on there
15:38:20 <ipanova> can we at least agree for now that it needs more grooming and it needs to be a task?
15:38:26 <dkliban> ipanova: yes
15:38:28 <mhrivnak> +1
15:38:28 <asmacdo> yes
15:38:36 <dkliban> and let's skip it for now and go to the next issue
15:38:41 <asmacdo> +1
15:38:42 <bmbouter> yeah let's reply on list
15:38:47 <dalley> there is no next issue :)
15:38:51 <dkliban> perfect
15:38:52 <ipanova> and once we have it groomed then we can think of whether accepting it or not
15:39:00 <daviddavis> dkliban: why is this scoped to publishers/importers? what about other models like users?
15:39:04 <daviddavis> I can change username
15:39:23 <dkliban> daviddavis: good call. i  didn't realize that.
15:39:24 * daviddavis just tested to this to confirm
15:39:26 <bmbouter> everything should use pks I think
15:39:31 <daviddavis> bmbouter: +
15:39:33 <daviddavis> 1
15:39:34 <ipanova> !propose other convert to task and needs grooming
15:39:34 <ipanova> #idea Proposed for #3125: convert to task and needs grooming
15:39:34 <pulpbot> ipanova: Proposed for #3125: convert to task and needs grooming
15:39:38 <dkliban> daviddavis: Artifacts and Content alreayd are pks
15:39:45 <daviddavis> makes sense
15:39:48 <jortel> agreed.  everything
15:39:49 <dkliban> and we still dont' have a distribution
15:40:02 <dkliban> endpoint but when we do i expect it to also have a pk
15:40:06 <dalley> !accept
15:40:06 <dalley> #agreed convert to task and needs grooming
15:40:06 <pulpbot> dalley: Current proposal accepted: convert to task and needs grooming
15:40:07 <pulpbot> dalley: No issues to triage.
15:40:25 <dalley> !end
15:40:25 <dalley> #endmeeting