15:30:30 <dalley> #startmeeting Pulp Triage 2017-12-01
15:30:30 <dalley> #info dalley has joined triage
15:30:31 <pulpbot> Meeting started Fri Dec  1 15:30:30 2017 UTC and is due to finish in 60 minutes.  The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:31 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:31 <pulpbot> The meeting name has been set to 'pulp_triage_2017_12_01'
15:30:31 <pulpbot> dalley: dalley has joined triage
15:30:42 <asmacdo> #info asmacdo has joined triage
15:30:42 <asmacdo> !here
15:30:42 <pulpbot> asmacdo: asmacdo has joined triage
15:31:11 <bmbouter> !here
15:31:11 <bmbouter> #info bmbouter has joined triage
15:31:11 <pulpbot> bmbouter: bmbouter has joined triage
15:31:21 <daviddavis> !here
15:31:21 <daviddavis> #info daviddavis has joined triage
15:31:21 <pulpbot> daviddavis: daviddavis has joined triage
15:31:32 <jortel> !here
15:31:32 <jortel> #info jortel has joined triage
15:31:32 <pulpbot> jortel: jortel has joined triage
15:31:44 <ipanova> !here
15:31:44 <ipanova> #info ipanova has joined triage
15:31:44 <pulpbot> ipanova: ipanova has joined triage
15:32:01 <dkliban> !here
15:32:01 <dkliban> #info dkliban has joined triage
15:32:01 <pulpbot> dkliban: dkliban has joined triage
15:32:13 <ttereshc> !here
15:32:13 <ttereshc> #info ttereshc has joined triage
15:32:13 <pulpbot> ttereshc: ttereshc has joined triage
15:32:24 <dkliban> ipanova: are we still skipping 3128?
15:32:31 <dalley> !next
15:32:32 <pulpbot> dalley: 4 issues left to triage: 3128, 3156, 3161, 3162
15:32:33 <dalley> #topic Clarify image tagging vs. image naming - http://pulp.plan.io/issues/3128
15:32:33 <pulpbot> Issue #3128 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:32:34 <pulpbot> Clarify image tagging vs. image naming - http://pulp.plan.io/issues/3128
15:32:58 <ipanova> dkliban: well, i gave all the reasonable explanation i had on my mind so i am not sure what else i could add
15:33:16 <dkliban> ipanova: do we need any docs changes?
15:33:37 <ttereshc> mhrivnak, ^ (I think last triage mhrivnak wanted to add something to the issue)
15:34:16 <ipanova> dkliban: these are regular docker concept which can be find in docker specs
15:34:32 <ipanova> not sure if adding to our docs the links to the docker specs would help
15:34:57 <ipanova> dkliban: i will try to dedicate to this time on monday after i submit pr for the last docker blocker
15:34:58 <dkliban> i was just thinking we can accept this as a docs bug
15:35:43 <ttereshc> !propose other skip, ipanova will take a look before next triage
15:35:43 <ttereshc> #idea Proposed for #3128: skip, ipanova will take a look before next triage
15:35:43 <pulpbot> ttereshc: Proposed for #3128: skip, ipanova will take a look before next triage
15:35:56 <ipanova> dkliban: i don't this it is a bug at all
15:35:57 <dkliban> +1
15:36:00 <ipanova> but +1 to ttereshc
15:36:09 <asmacdo> could we change to a task?
15:36:12 <asmacdo> ungroomed
15:36:23 <asmacdo> then we could continue discussion, but not punt it 2x per week
15:36:35 <ipanova> asmacdo: let's leave this as it is
15:36:46 <ipanova> so we can solve it with next triage
15:37:10 <dalley> !accept
15:37:10 <dalley> #agreed skip, ipanova will take a look before next triage
15:37:10 <pulpbot> dalley: Current proposal accepted: skip, ipanova will take a look before next triage
15:37:11 <pulpbot> dalley: 3 issues left to triage: 3156, 3161, 3162
15:37:11 <dalley> #topic pulp-manage-db fails to run on FIPS enabled system. - http://pulp.plan.io/issues/3156
15:37:12 <pulpbot> Issue #3156 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:37:13 <pulpbot> pulp-manage-db fails to run on FIPS enabled system. - http://pulp.plan.io/issues/3156
15:37:45 <ipanova> i know that we were skipping this mainly because of me,. but i was busy with other highpriority stuff asmacdo
15:37:56 <asmacdo> no prob
15:38:03 <ipanova> asmacdo: <3
15:39:12 <ttereshc> maybe more investigation needed but so far it sounds like WONTFIX for me
15:39:18 <dkliban> yeah
15:39:18 <bmbouter> yeah I agree
15:39:21 <ipanova> i agree
15:39:23 <bmbouter> we can't add FIPS support to mongodb
15:39:36 <daviddavis> not with that attitude
15:39:45 <asmacdo> lol
15:39:52 <bmbouter> lol
15:39:53 <dalley> lol
15:40:07 <dalley> !propose other close WONTFIX
15:40:07 <dalley> #idea Proposed for #3156: close WONTFIX
15:40:07 <pulpbot> dalley: Proposed for #3156: close WONTFIX
15:40:12 <ipanova> +1
15:40:14 <bmbouter> +1
15:40:17 <ttereshc> yeah my only point is that I guess pulp is not the only one who can suffer from fips disabled encryption algorithms
15:40:24 <jortel> +1
15:40:35 <dalley> !accept
15:40:35 <dalley> #agreed close WONTFIX
15:40:35 <pulpbot> dalley: Current proposal accepted: close WONTFIX
15:40:37 <dalley> #topic Centos 7 debuginfo x86_64 | Malformed repository: metadata is missing for some packages in filelists.xml and in other.xml - http://pulp.plan.io/issues/3161
15:40:37 <ttereshc> and I think there're some downstream specific packages added to RHEL
15:40:38 <pulpbot> dalley: 2 issues left to triage: 3161, 3162
15:40:39 <pulpbot> Issue #3161 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:40:40 <pulpbot> Centos 7 debuginfo x86_64 | Malformed repository: metadata is missing for some packages in filelists.xml and in other.xml - http://pulp.plan.io/issues/3161
15:41:21 <ipanova> i propose to add a comment with the explanation and close the issue
15:41:47 <ttereshc> re #3156 ,never mind, I'm +1 in general for wontfix, but in theory there might be downstream solutions
15:42:49 <dalley> ipanova, you're speaking re: 3161?
15:42:54 <dalley> or the previous one
15:43:07 <ipanova> 3161
15:43:37 <ttereshc> I suggest to find a specific metadata due to which sync fails and report to fix it in centos repos
15:44:03 <daviddavis> +1
15:44:08 <ipanova> fine with me
15:44:11 <jortel> +1
15:44:13 <bmbouter> this cold also be pulp failing to handle encoding correctly
15:44:18 <ipanova> important to point out that it is not our issue
15:44:47 <ttereshc> bmbouter, I don't think so, it's all about the number of rpms listed in metadata in different files
15:44:56 <ipanova> ttereshc: +1
15:44:58 <dkliban> yeah ... we added a check for that
15:45:15 <bmbouter> ok cool
15:45:17 <ttereshc> !propose accept
15:45:17 <ttereshc> #idea Proposed for #3161: Leave the issue as-is, accepting its current state.
15:45:17 <pulpbot> ttereshc: Proposed for #3161: Leave the issue as-is, accepting its current state.
15:45:24 <bmbouter> +1
15:45:28 <asmacdo> +1
15:45:40 <dalley> +1
15:45:44 <dkliban> +1
15:46:02 <dalley> we can move it to the external tracker, if it requires no pulp-specific work
15:46:19 <dalley> or whatever it's called
15:46:39 <ttereshc> !propose other accept, ttereshc will figure out where the issue is and move the issue accordingly
15:46:39 <ttereshc> #idea Proposed for #3161: accept, ttereshc will figure out where the issue is and move the issue accordingly
15:46:40 <ipanova> i don't see point to move it to the external tracker since it should be closed
15:46:40 <pulpbot> ttereshc: Proposed for #3161: accept, ttereshc will figure out where the issue is and move the issue accordingly
15:46:44 <ipanova> imho
15:46:56 <bmbouter> I'm also not fond of the external tracker
15:47:07 <bmbouter> but +1 to this resolution
15:47:10 <dkliban> +1
15:47:11 <dalley> +1
15:47:18 <asmacdo> I think we should leave it open at least until we can link to an upstream bug
15:47:49 <ipanova> +1 to ttereshc
15:47:53 <dalley> !accept
15:47:53 <dalley> #agreed accept, ttereshc will figure out where the issue is and move the issue accordingly
15:47:53 <pulpbot> dalley: Current proposal accepted: accept, ttereshc will figure out where the issue is and move the issue accordingly
15:47:54 <pulpbot> dalley: 1 issues left to triage: 3162
15:47:54 <dalley> #topic Pulp failed to parse updateinfo.xml file. Gave unhelpful log message. - http://pulp.plan.io/issues/3162
15:47:55 <pulpbot> Issue #3162 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:47:56 <pulpbot> Pulp failed to parse updateinfo.xml file. Gave unhelpful log message. - http://pulp.plan.io/issues/3162
15:48:17 <daviddavis> this is similar to the last bug
15:48:23 <dkliban> theis updateinfo.xml was generated by Pulp, but then it coudlnt' be consumed by Pulp
15:48:30 <ttereshc> I don't think pulp should skip the error and continue
15:48:40 <ttereshc> but +1 to handle error more gracefully
15:48:55 <ttereshc> href has to be in erratum
15:48:55 <dkliban> Pulp shouldn't publish an updateinfo.xml that it can't then consume
15:49:03 <ttereshc> ah I see
15:49:15 <dkliban> So i think we should have enforcement when errata are uploaded
15:49:39 <ttereshc> there is an issue filed about errata validation
15:49:42 <asmacdo> we should (1) handle this case gracefully and (2) fix publish?
15:50:03 <daviddavis> works for me
15:50:26 <daviddavis> I can update the bug to that effect
15:50:31 <jortel> +1 errata enforcement
15:50:41 <ttereshc> and why do yiou think it was pulp who published it?
15:50:49 <ttereshc> I can't see it on the ticket
15:51:09 <dkliban> ttereshc: that's what release engineering said. there is another ticket that says it
15:51:16 <ttereshc> ok, thx
15:51:23 <dkliban> ttereshc: i'll point you in a PM
15:51:29 <ttereshc> I wonder if we can reproduce it with upstream version
15:51:43 <daviddavis> ttereshc: it's in this BZ https://bugzilla.redhat.com/show_bug.cgi?id=1503916#c0
15:52:04 <daviddavis> "Pulp doesn't render "href" attribute on <reference> tags in updateinfo XML if the string is empty"
15:52:31 <dalley> !propose other accept & daviddavis will update the issue
15:52:31 <dalley> #idea Proposed for #3162: accept & daviddavis will update the issue
15:52:31 <pulpbot> dalley: Proposed for #3162: accept & daviddavis will update the issue
15:53:35 <daviddavis> !accept
15:53:36 <ttereshc> +1 to accept as a bug, but I suggest to continue convo on the ticket what exactly should be fixed
15:53:49 <daviddavis> works for me
15:54:19 <ttereshc> daviddavis, you're not the triage leader :) you can't accept ;)
15:54:23 <daviddavis> lol
15:54:26 <ttereshc> :P
15:54:29 <dalley> :)
15:54:42 <dkliban> +1
15:55:19 <dalley> !accept
15:55:19 <dalley> #agreed accept & daviddavis will update the issue
15:55:19 <pulpbot> dalley: Current proposal accepted: accept & daviddavis will update the issue
15:55:20 <pulpbot> dalley: No issues to triage.
15:55:24 <dalley> !end
15:55:24 <dalley> #endmeeting