15:32:07 <asmacdo> #startmeeting Pulp Triage 2017-12-19
15:32:07 <pulpbot> Meeting started Tue Dec 19 15:32:07 2017 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:32:07 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:32:07 <pulpbot> The meeting name has been set to 'pulp_triage_2017_12_19'
15:32:07 <asmacdo> #info asmacdo has joined triage
15:32:07 <pulpbot> asmacdo: asmacdo has joined triage
15:32:10 <ttereshc> !here
15:32:10 <ttereshc> #info ttereshc has joined triage
15:32:10 <pulpbot> ttereshc: ttereshc has joined triage
15:32:14 <asmacdo> !next
15:32:15 <pulpbot> asmacdo: 4 issues left to triage: 3208, 3210, 3216, 3217
15:32:15 <asmacdo> #topic Clarify docs to import an uploaded v1 docker image to repository. - http://pulp.plan.io/issues/3208
15:32:16 <pulpbot> Issue #3208 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:32:17 <pulpbot> Clarify docs to import an uploaded v1 docker image to repository. - http://pulp.plan.io/issues/3208
15:32:39 * asmacdo was engrossed in daviddavis's versioned repos email :)
15:32:45 <daviddavis> lol
15:32:59 <ipanova|home> let's accept as is
15:33:03 <ttereshc> there's a PR fr that
15:33:05 <asmacdo> so i already changed this one to a docs story, i think we can accept
15:33:10 <ttereshc> I'll add it
15:33:11 <dkliban> yeah
15:33:16 <asmacdo> !propose accept
15:33:16 <asmacdo> #idea Proposed for #3208: Leave the issue as-is, accepting its current state.
15:33:16 <pulpbot> asmacdo: Proposed for #3208: Leave the issue as-is, accepting its current state.
15:33:22 <daviddavis> +1
15:33:33 <ipanova|home> +1
15:33:34 <asmacdo> !accept
15:33:34 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
15:33:34 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:33:35 <pulpbot> asmacdo: 3 issues left to triage: 3210, 3216, 3217
15:33:35 <asmacdo> #topic Update Importer configuration fails. - http://pulp.plan.io/issues/3210
15:33:36 <pulpbot> Issue #3210 [POST] (ttereshc) - Priority: Normal | Severity: Medium
15:33:37 <pulpbot> Update Importer configuration fails. - http://pulp.plan.io/issues/3210
15:33:46 <asmacdo> #idea Proposed for #3210: Leave the issue as-is, accepting its current state.
15:33:46 <asmacdo> !propose accept
15:33:46 <pulpbot> asmacdo: Proposed for #3210: Leave the issue as-is, accepting its current state.
15:33:50 <ipanova|home> +1
15:33:52 <asmacdo> since its at POST already
15:34:02 <bizhang> +1
15:34:06 <ttereshc> +1
15:34:14 <daviddavis> +1
15:34:38 <asmacdo> !accept
15:34:38 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
15:34:38 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:34:39 <pulpbot> asmacdo: 2 issues left to triage: 3216, 3217
15:34:39 <asmacdo> #topic CreatedResourceSerializer missing "Meta.model" attribute - http://pulp.plan.io/issues/3216
15:34:40 <pulpbot> Issue #3216 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:34:41 <pulpbot> CreatedResourceSerializer missing "Meta.model" attribute - http://pulp.plan.io/issues/3216
15:35:12 <daviddavis> accept and add to sprint?
15:35:23 <ipanova|home> +1
15:35:29 <bizhang> +1
15:35:31 <ttereshc> +1
15:35:43 <asmacdo> this issue needs to be addressed, but im not sure we can add a Meta.model
15:35:55 <bmbouter> +1
15:36:07 <asmacdo> it is supposed to be general right?
15:36:36 <bizhang> asmacdo, there is a CreatedResource model
15:36:39 <asmacdo> also it seems wrong to change the code so the docs render correctly
15:37:20 <asmacdo> ok, this must work differently than I thought it did
15:37:24 <asmacdo> +0
15:37:43 <asmacdo> im going to accept unless anyone else has anything
15:38:28 <ttereshc> we can discuss on the issue how exactly to workaround or fix that
15:38:38 <asmacdo> !propose other accept and add to the sprint
15:38:38 <asmacdo> #idea Proposed for #3216: accept and add to the sprint
15:38:39 <pulpbot> asmacdo: Proposed for #3216: accept and add to the sprint
15:39:17 <asmacdo> !accept
15:39:17 <asmacdo> #agreed accept and add to the sprint
15:39:17 <pulpbot> asmacdo: Current proposal accepted: accept and add to the sprint
15:39:18 <pulpbot> asmacdo: 1 issues left to triage: 3217
15:39:18 <asmacdo> #topic Error on updating ArrayField in Pulp3 - http://pulp.plan.io/issues/3217
15:39:19 <pulpbot> Issue #3217 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:39:20 <pulpbot> Error on updating ArrayField in Pulp3 - http://pulp.plan.io/issues/3217
15:40:56 <bmbouter> I don't fully understand it, but it looks legit
15:41:06 <daviddavis> should this be in the python plugin project?
15:41:19 <daviddavis> or is this bug in core?
15:41:20 <bmbouter> I think it's against core
15:41:23 <bmbouter> just reproduced w/ python
15:41:33 <asmacdo> it could be just a pulp_python issue
15:41:37 <bizhang> It would be an issue with any plugin that uses the arrayfield
15:41:43 <daviddavis> ah I see
15:41:45 <bizhang> which I think is just python for now
15:42:11 <asmacdo> it might be that we have to do arrayfields differently in the serializers (python) or it could be a bug in core
15:42:38 <asmacdo> lets accept as core, and adjust the issue as it becomes clear
15:42:42 <asmacdo> !propose accept
15:42:42 <asmacdo> #idea Proposed for #3217: Leave the issue as-is, accepting its current state.
15:42:42 <pulpbot> asmacdo: Proposed for #3217: Leave the issue as-is, accepting its current state.
15:43:03 <daviddavis> what's the difference between an arrayfield and listfield - http://www.django-rest-framework.org/api-guide/fields/#listfield
15:44:00 <bizhang> Arrayfield is a model field: https://docs.djangoproject.com/en/2.0/ref/contrib/postgres/fields/#arrayfield
15:44:16 <bizhang> Listfield is a serializer field
15:44:28 <daviddavis> I see
15:44:50 <daviddavis> I'm hesitant to use a postgresql specific field I guess
15:45:03 <bmbouter> agreed
15:45:04 <daviddavis> but +1 to accept
15:45:09 <bmbouter> +1 also
15:45:10 <bizhang> hmmm it could be that we need to revise the modeling in pulp_python
15:45:21 <bmbouter> I think users will want to also run on sqlite
15:45:24 <bmbouter> overall
15:45:28 <daviddavis> or mariadb
15:45:37 <daviddavis> no reason to lock down db
15:45:46 <daviddavis> to one technology if we don't have to
15:46:32 <bizhang> cool, I can rewrite this as a pulp_python modeling issue
15:46:37 <asmacdo> sounds good to me. how about we change to a pulp_python issue
15:46:44 <bizhang> +1
15:46:53 <asmacdo> !propose other accept and rewrite as a pulp_python modeling issue
15:46:53 <asmacdo> #idea Proposed for #3217: accept and rewrite as a pulp_python modeling issue
15:46:53 <pulpbot> asmacdo: Proposed for #3217: accept and rewrite as a pulp_python modeling issue
15:47:04 <daviddavis> +1
15:47:09 <asmacdo> !accept
15:47:09 <asmacdo> #agreed accept and rewrite as a pulp_python modeling issue
15:47:09 <pulpbot> asmacdo: Current proposal accepted: accept and rewrite as a pulp_python modeling issue
15:47:11 <pulpbot> asmacdo: No issues to triage.
15:47:14 <asmacdo> !end
15:47:14 <asmacdo> #endmeeting