15:30:42 <dalley> #startmeeting Pulp Triage 2018-01-05
15:30:42 <pulpbot> Meeting started Fri Jan  5 15:30:42 2018 UTC and is due to finish in 60 minutes.  The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:42 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:42 <pulpbot> The meeting name has been set to 'pulp_triage_2018_01_05'
15:30:42 <dalley> #info dalley has joined triage
15:30:42 <pulpbot> dalley: dalley has joined triage
15:30:46 <asmacdo> oh
15:30:48 <asmacdo> !here
15:30:48 <asmacdo> #info asmacdo has joined triage
15:30:48 <pulpbot> asmacdo: asmacdo has joined triage
15:30:49 <ttereshc> !here
15:30:49 <ttereshc> #info ttereshc has joined triage
15:30:50 <pulpbot> ttereshc: ttereshc has joined triage
15:30:52 <daviddavis> !here
15:30:52 <daviddavis> #info daviddavis has joined triage
15:30:52 <pulpbot> daviddavis: daviddavis has joined triage
15:31:08 <bizhang> !here
15:31:08 <bizhang> #info bizhang has joined triage
15:31:08 <pulpbot> bizhang: bizhang has joined triage
15:31:10 <ipanova> !here
15:31:10 <ipanova> #info ipanova has joined triage
15:31:11 <pulpbot> ipanova: ipanova has joined triage
15:31:23 <dalley> !next
15:31:25 <dalley> #topic Rewrite redirect URL - http://pulp.plan.io/issues/3227
15:31:25 <pulpbot> dalley: 9 issues left to triage: 3227, 3231, 3232, 3239, 3240, 3241, 3242, 3245, 3246
15:31:26 <pulpbot> Issue #3227 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:31:26 <dkliban> !here
15:31:26 <dkliban> #info dkliban has joined triage
15:31:27 <pulpbot> Rewrite redirect URL - http://pulp.plan.io/issues/3227
15:31:28 <pulpbot> dkliban: dkliban has joined triage
15:31:33 <dkliban> i think that's a story
15:31:49 <milan> !here
15:31:49 <milan> #info milan has joined triage
15:31:49 <pulpbot> milan: milan has joined triage
15:32:01 <dalley> yes, I think last triage we skipped so that we could take note of it before making it a story
15:32:08 <dalley> !propose other convert to story
15:32:08 <dalley> #idea Proposed for #3227: convert to story
15:32:08 <pulpbot> dalley: Proposed for #3227: convert to story
15:32:18 <ipanova> i'd like to hear more implementation details before accepting this?
15:33:08 <jortel> !here
15:33:08 <jortel> #info jortel has joined triage
15:33:08 <pulpbot> jortel: jortel has joined triage
15:33:11 <ipanova> initial purpose of crane was doing dumb redirects and nothing more, now it would need to dig into each url and chew on it
15:33:38 <dkliban> ipanova: let's discuss next week
15:33:38 <asmacdo> +1 skip
15:33:48 <ipanova> agreed
15:33:49 <dalley> !propose skip
15:33:49 <dalley> #idea Proposed for #3227: Skip this issue for this triage session.
15:33:49 <pulpbot> dalley: Proposed for #3227: Skip this issue for this triage session.
15:34:01 <ttereshc> +1
15:34:07 <jortel> +1
15:34:14 <dalley> !skip
15:34:15 <pulpbot> dalley: 8 issues left to triage: 3231, 3232, 3239, 3240, 3241, 3242, 3245, 3246
15:34:15 <dalley> #topic Docker image upload can be more efficient - http://pulp.plan.io/issues/3231
15:34:16 <pulpbot> Issue #3231 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:34:17 <pulpbot> Docker image upload can be more efficient - http://pulp.plan.io/issues/3231
15:34:28 <dkliban> triage is not for accepting stories ... i think we should convert it to a story so it stops showing up in triage
15:34:39 <dkliban> same for this one
15:34:49 <ipanova> i will leave a note on this one
15:35:00 <daviddavis> mind converting it to a story when you do so?
15:35:00 <ipanova> there is an effort ongoing with skopeo
15:35:08 <ipanova> will do
15:35:14 <daviddavis> ipanova++
15:35:14 <pulpbot> daviddavis: ipanova's karma is now 14
15:35:15 <dalley> dkliban, I agree with you but it seems generally useful just to get visibility for them
15:35:45 <ipanova> agree with dalley
15:36:01 <asmacdo> adding that to retro etherpad
15:36:05 <daviddavis> +1
15:36:06 <bmbouter> !here
15:36:06 <bmbouter> #info bmbouter has joined triage
15:36:06 <pulpbot> bmbouter: bmbouter has joined triage
15:36:09 <dalley> +1
15:36:36 <ttereshc> asmacdo, heh, we discussed it once I believe :) but only that
15:36:43 <dalley> !propose other ipanova will comment and convert to story
15:36:43 <dalley> #idea Proposed for #3231: ipanova will comment and convert to story
15:36:43 <pulpbot> dalley: Proposed for #3231: ipanova will comment and convert to story
15:36:59 <dalley> does this apply to the last one as well?
15:37:34 <ipanova> ok, i will convert both o fthem
15:37:51 <ipanova> and leave proper comments
15:38:02 <dalley> +1
15:38:10 <dalley> !accept
15:38:10 <dalley> #agreed ipanova will comment and convert to story
15:38:10 <pulpbot> dalley: Current proposal accepted: ipanova will comment and convert to story
15:38:11 <pulpbot> dalley: 7 issues left to triage: 3232, 3239, 3240, 3241, 3242, 3245, 3246
15:38:11 <dalley> #topic As a user, I should be told what I have just uploaded - http://pulp.plan.io/issues/3232
15:38:12 <pulpbot> Issue #3232 [POST] (unassigned) - Priority: Normal | Severity: Medium
15:38:13 <pulpbot> As a user, I should be told what I have just uploaded - http://pulp.plan.io/issues/3232
15:39:00 <dkliban> i was not sure if we should consider this a bug or a story
15:39:07 <ipanova> i see this more like a bug, because details are empty
15:39:26 <dkliban> i tend to agree with that also
15:39:29 <ipanova> so i suggest to make this an issue and accept as it is
15:39:34 <dkliban> +1
15:39:41 <dalley> !propose accept
15:39:41 <dalley> #idea Proposed for #3232: Leave the issue as-is, accepting its current state.
15:39:41 <pulpbot> dalley: Proposed for #3232: Leave the issue as-is, accepting its current state.
15:39:42 <ipanova> we have a PR already, i started to test it today
15:39:45 <bmbouter> is this backwards incompatible?
15:39:49 <bmbouter> one sec
15:40:02 <bmbouter> doesn't this change the return data format in a backwards incompatible way?
15:40:07 <bmbouter> or is it additive?
15:40:27 <ipanova> no, it just populates empty dict with info form details
15:40:36 <bmbouter> ok great, ty
15:40:39 <bmbouter> +1
15:40:40 <ipanova> until now details:{} where empty all the time
15:40:44 <bmbouter> perfect
15:40:46 <asmacdo> +1
15:40:52 <bizhang> +1
15:41:10 <dalley> !accept
15:41:10 <dalley> #agreed Leave the issue as-is, accepting its current state.
15:41:10 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:41:12 <dalley> #topic POST /api/v3/users/{user_id}/jwt_reset/ returns HTTP 500 - http://pulp.plan.io/issues/3239
15:41:12 <pulpbot> dalley: 6 issues left to triage: 3239, 3240, 3241, 3242, 3245, 3246
15:41:13 <pulpbot> Issue #3239 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:41:14 <pulpbot> POST /api/v3/users/{user_id}/jwt_reset/ returns HTTP 500 - http://pulp.plan.io/issues/3239
15:41:29 <daviddavis> I think we can close this out
15:41:32 <dalley> ipanova, if you're already testing the PR, should I add it to the sprint also?
15:41:51 <bmbouter> yes JWT is no longer in the MVP and it needs to be removed
15:42:01 <bmbouter> so + 1 to closing somehow
15:42:11 <dalley> !propose close
15:42:11 <pulpbot> dalley: Error: "propose" is not a valid command.
15:42:21 <dalley> !propose other close
15:42:21 <dalley> #idea Proposed for #3239: close
15:42:21 <pulpbot> dalley: Proposed for #3239: close
15:42:32 <daviddavis> +1
15:42:34 <asmacdo> close or just remove MVP tag?
15:42:38 <ipanova> dalley: i am not sure, are we ok to put on sprint contributions?
15:43:00 <bmbouter> I think close
15:43:02 <daviddavis> our new jwt code will probably be created from scratch so this route may not even exist
15:43:07 <bmbouter> a bug on code that doesnt' exit doesnt' make sense
15:43:11 <asmacdo> +1
15:43:20 <dalley> !accept
15:43:20 <dalley> #agreed close
15:43:20 <pulpbot> dalley: Current proposal accepted: close
15:43:20 <ttereshc> do we have story to bring jwt back?
15:43:21 <pulpbot> dalley: 5 issues left to triage: 3240, 3241, 3242, 3245, 3246
15:43:21 <dalley> #topic Add href_in_list as a filter for models - http://pulp.plan.io/issues/3240
15:43:22 <pulpbot> Issue #3240 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:43:23 <pulpbot> Add href_in_list as a filter for models - http://pulp.plan.io/issues/3240
15:43:33 <daviddavis> ttereshc: no
15:43:44 <ttereshc> ty
15:43:44 <daviddavis> we could create one but it'll be post-MVP
15:44:00 <ttereshc> yeah, we will need to create a bunch of stories anyway
15:44:06 <daviddavis> yea
15:44:12 <ttereshc> I'm just asking if there's already one, thanks
15:44:18 <daviddavis> np
15:44:27 <daviddavis> we kind of punted on this id_in_list and href_in_list
15:44:27 <asmacdo> this should be a story
15:44:30 <daviddavis> +1
15:44:41 <dalley> !propose other convert to story
15:44:41 <dalley> #idea Proposed for #3240: convert to story
15:44:41 <pulpbot> dalley: Proposed for #3240: convert to story
15:44:45 <asmacdo> +1
15:44:46 <daviddavis> also, something we need to think about is query string size
15:45:04 <daviddavis> katello wants to filter by 100s of ids/hrefs for example
15:45:11 <daviddavis> so we may need to figure out filtering by POST
15:45:18 <daviddavis> also, should this be in the mvp?
15:45:43 <daviddavis> anyway, i can update the story
15:45:53 <daviddavis> let's keep it in the mvp for now
15:46:41 <ttereshc> +1 to move on and continue discussion on the issue
15:46:41 <asmacdo> all sounds good, we can discuss on the issue
15:46:46 <ttereshc> :)
15:46:50 <daviddavis> +1
15:46:52 <jortel> +1
15:47:10 <dalley> !accept
15:47:10 <dalley> #agreed convert to story
15:47:10 <pulpbot> dalley: Current proposal accepted: convert to story
15:47:11 <pulpbot> dalley: 4 issues left to triage: 3241, 3242, 3245, 3246
15:47:12 <dalley> #topic docker_distributor_web does not advertise supporting docker_manifest, docker_tag, docker_blob (any v2 unit types) - http://pulp.plan.io/issues/3241
15:47:12 <pulpbot> Issue #3241 [POST] (unassigned) - Priority: Normal | Severity: High
15:47:13 <pulpbot> docker_distributor_web does not advertise supporting docker_manifest, docker_tag, docker_blob (any v2 unit types) - http://pulp.plan.io/issues/3241
15:47:49 <asmacdo> !propose accept
15:47:49 <asmacdo> #idea Proposed for #3241: Leave the issue as-is, accepting its current state.
15:47:49 <pulpbot> asmacdo: Proposed for #3241: Leave the issue as-is, accepting its current state.
15:47:51 <ipanova> +1
15:47:56 <dkliban> +1
15:48:13 <asmacdo> misa++
15:48:13 <pulpbot> asmacdo: misa's karma is now 4
15:48:38 <dalley> !accept
15:48:38 <dalley> #agreed Leave the issue as-is, accepting its current state.
15:48:38 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:48:39 <pulpbot> dalley: 3 issues left to triage: 3242, 3245, 3246
15:48:39 <dalley> #topic copying a tag does not preserve its pulp_user_metadata - http://pulp.plan.io/issues/3242
15:48:40 <pulpbot> Issue #3242 [NEW] (unassigned) - Priority: Normal | Severity: High
15:48:41 <pulpbot> copying a tag does not preserve its pulp_user_metadata - http://pulp.plan.io/issues/3242
15:49:06 <ipanova> !propose accept
15:49:06 <ipanova> #idea Proposed for #3242: Leave the issue as-is, accepting its current state.
15:49:06 <pulpbot> ipanova: Proposed for #3242: Leave the issue as-is, accepting its current state.
15:49:07 <asmacdo> !propose accept
15:49:13 <ipanova> asmacdo: ha!
15:49:15 <asmacdo> +1 :)
15:49:55 <ttereshc> +1
15:50:08 <dalley> !accept
15:50:08 <dalley> #agreed Leave the issue as-is, accepting its current state.
15:50:08 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:50:09 <pulpbot> dalley: 2 issues left to triage: 3245, 3246
15:50:09 <dalley> #topic Broken link to protected-branches.py - http://pulp.plan.io/issues/3245
15:50:10 <pulpbot> Issue #3245 [POST] (milan) - Priority: Low | Severity: Low
15:50:11 <pulpbot> Broken link to protected-branches.py - http://pulp.plan.io/issues/3245
15:50:21 <dalley> !propose accept
15:50:21 <dalley> #idea Proposed for #3245: Leave the issue as-is, accepting its current state.
15:50:21 <pulpbot> dalley: Proposed for #3245: Leave the issue as-is, accepting its current state.
15:50:32 <milan> fwiw a oneliner docs update
15:50:39 <daviddavis> +1
15:50:44 <asmacdo> +1
15:51:05 <dalley> !accept
15:51:05 <dalley> #agreed Leave the issue as-is, accepting its current state.
15:51:05 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:51:07 <dalley> #topic Update branching.rst to match pup-0003 - http://pulp.plan.io/issues/3246
15:51:07 <pulpbot> dalley: 1 issues left to triage: 3246
15:51:08 <pulpbot> Issue #3246 [POST] (milan) - Priority: Normal | Severity: Medium
15:51:09 <pulpbot> Update branching.rst to match pup-0003 - http://pulp.plan.io/issues/3246
15:51:20 <asmacdo> should this be merged to 2.15-dev?
15:51:33 <asmacdo> </joke>
15:51:36 <daviddavis> asmacdo: 3245 or 3246?
15:51:38 <daviddavis> ha
15:51:42 <ttereshc> :)
15:51:46 <dalley> this one I believe there was some questions over whether it should wait
15:51:57 <daviddavis> yea, we should talk to the build team
15:51:57 <dalley> since the process may change when it gets implemented
15:52:09 <daviddavis> I think we can triage this though and follow up with them
15:52:14 <bmbouter> agreed
15:52:15 <daviddavis> our docs def need to be updated
15:52:17 <bmbouter> the merging changes are already inplace
15:52:26 <bmbouter> as in "always merge to master"
15:52:35 <dalley> !propose other accept and continue discussion on issue
15:52:35 <dalley> #idea Proposed for #3246: accept and continue discussion on issue
15:52:35 <pulpbot> dalley: Proposed for #3246: accept and continue discussion on issue
15:52:36 <asmacdo> !propose accept
15:52:44 <ttereshc> +1
15:52:45 <asmacdo> argh, no luck today
15:52:49 <asmacdo> +1
15:52:49 <dalley> lol asmacdo
15:53:05 <daviddavis> milan: I want to ping pcreech on monday about 3246 and then we can merge (if that's ok). he's on PTO until then.
15:53:20 <dalley> slow on the draw :)  break has diminished your reflexes xD
15:53:25 <milan> daviddavis, sure, thx!
15:53:32 <asmacdo> my hands are too cold to type fast
15:53:42 <dalley> !accept
15:53:42 <dalley> #agreed accept and continue discussion on issue
15:53:42 <pulpbot> dalley: Current proposal accepted: accept and continue discussion on issue
15:53:43 <daviddavis> asmacdo: you have no idea what cold is :)
15:53:44 <pulpbot> dalley: No issues to triage.
15:53:48 <dalley> !end
15:53:48 <dalley> #endmeeting