15:30:23 <dalley> #startmeeting Pulp Triage 2018-01-19
15:30:23 <dalley> #info dalley has joined triage
15:30:24 <pulpbot> Meeting started Fri Jan 19 15:30:23 2018 UTC and is due to finish in 60 minutes.  The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:24 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:24 <pulpbot> The meeting name has been set to 'pulp_triage_2018_01_19'
15:30:24 <pulpbot> dalley: dalley has joined triage
15:30:40 <asmacdo> !here
15:30:40 <asmacdo> #info asmacdo has joined triage
15:30:40 <pulpbot> asmacdo: asmacdo has joined triage
15:30:53 <dkliban> !here
15:30:53 <dkliban> #info dkliban has joined triage
15:30:53 <pulpbot> dkliban: dkliban has joined triage
15:31:28 <daviddavis> !here
15:31:28 <daviddavis> #info daviddavis has joined triage
15:31:29 <pulpbot> daviddavis: daviddavis has joined triage
15:32:31 <bmbouter> #info bmbouter has joined triage
15:32:31 <bmbouter> !here
15:32:32 <pulpbot> bmbouter: bmbouter has joined triage
15:32:34 <ttereshc> !here
15:32:34 <ttereshc> #info ttereshc has joined triage
15:32:34 <pulpbot> ttereshc: ttereshc has joined triage
15:32:38 <dalley> !next
15:32:40 <dalley> #topic pulp-consumer does not remove binding if repo is no longer available on server - http://pulp.plan.io/issues/3255
15:32:40 <pulpbot> dalley: 9 issues left to triage: 3255, 3283, 3286, 3288, 3292, 3294, 3303, 3304, 3305
15:32:41 <pulpbot> Issue #3255 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:32:42 <pulpbot> pulp-consumer does not remove binding if repo is no longer available on server - http://pulp.plan.io/issues/3255
15:33:04 <dalley> we skipped this one the last two triages
15:33:24 <ttereshc> let's close as not a bug
15:33:30 <dkliban> +1
15:33:35 <asmacdo> i think we can close and invite to reopen with if there is more info
15:33:42 <bmbouter> +1
15:33:45 <jortel_> +1
15:33:51 <dkliban> dalley: i'll close and leave a comment
15:34:06 <ttereshc> !propose other close as notabug
15:34:06 <ttereshc> #idea Proposed for #3255: close as notabug
15:34:06 <pulpbot> ttereshc: Proposed for #3255: close as notabug
15:34:13 <dalley> wfm
15:34:26 <dalley> dkliban^
15:34:58 <dkliban> +1
15:35:01 <milan_> !here
15:35:01 <milan_> #info milan_ has joined triage
15:35:01 <pulpbot> milan_: milan_ has joined triage
15:35:07 <dalley> !accept
15:35:07 <dalley> #agreed close as notabug
15:35:07 <pulpbot> dalley: Current proposal accepted: close as notabug
15:35:08 <pulpbot> dalley: 7 issues left to triage: 3286, 3288, 3292, 3294, 3303, 3304, 3305
15:35:08 <dalley> #topic Sync logic should not assume on schema1 by default existence - http://pulp.plan.io/issues/3286
15:35:09 <pulpbot> Issue #3286 [ASSIGNED] (ipanova@redhat.com) - Priority: High | Severity: High
15:35:10 <pulpbot> Sync logic should not assume on schema1 by default existence - http://pulp.plan.io/issues/3286
15:35:31 <ttereshc> #idea Proposed for #3286: Leave the issue as-is, accepting its current state.
15:35:31 <ttereshc> !propose accept
15:35:31 <pulpbot> ttereshc: Proposed for #3286: Leave the issue as-is, accepting its current state.
15:35:34 <asmacdo> +1
15:35:36 <daviddavis> +1
15:35:39 <ttereshc> it's assigned and on the sprint already
15:35:45 <ipanova> #info ipanova has joined triage
15:35:45 <ipanova> !here
15:35:45 <pulpbot> ipanova: ipanova has joined triage
15:35:54 <ttereshc> and here's an assignee :)
15:35:57 <dkliban> +1
15:35:59 <dalley> !accept
15:35:59 <dalley> #agreed Leave the issue as-is, accepting its current state.
15:35:59 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:36:00 <pulpbot> dalley: 6 issues left to triage: 3288, 3292, 3294, 3303, 3304, 3305
15:36:01 <dalley> #topic Make syslog facility a configurable option - http://pulp.plan.io/issues/3288
15:36:01 <pulpbot> Issue #3288 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:36:03 <pulpbot> Make syslog facility a configurable option - http://pulp.plan.io/issues/3288
15:36:44 <ttereshc> story
15:36:47 <bmbouter> this needs to be rewritten as a story and needs details
15:36:54 <ttereshc> +1
15:36:56 <jortel> +1
15:37:04 <ipanova> +1
15:37:04 <dkliban> should we ask the author to update it?
15:37:12 <dalley> !propose other convert to story and groom
15:37:12 <dalley> #idea Proposed for #3288: convert to story and groom
15:37:12 <pulpbot> dalley: Proposed for #3288: convert to story and groom
15:37:20 <ipanova> maybe ask for contribution since he said that's a easy change? :(
15:37:22 <ipanova> :)
15:37:25 <ttereshc> I'll take care of that, there are more details which they want
15:37:28 <asmacdo> +1 story, -1 groomed
15:37:33 <bmbouter> exactly
15:37:38 <dkliban> ttereshc: thank youy
15:37:57 <dalley> #idea Proposed for #3288: convert to story, ttereshc will work with the author to add detail
15:37:57 <dalley> !propose other convert to story, ttereshc will work with the author to add detail
15:37:57 <pulpbot> dalley: Proposed for #3288: convert to story, ttereshc will work with the author to add detail
15:38:05 <asmacdo> +1
15:38:07 <ttereshc> +1
15:38:12 <ipanova> +1
15:38:15 <bmbouter> ttereshc: it can get visibility on the list too if he emails pulp-dev or you can proxy at sprint planning either way
15:38:17 <bmbouter> ty!
15:38:19 <bmbouter> +1
15:38:24 <dalley> !accept
15:38:24 <dalley> #agreed convert to story, ttereshc will work with the author to add detail
15:38:24 <pulpbot> dalley: Current proposal accepted: convert to story, ttereshc will work with the author to add detail
15:38:25 <pulpbot> dalley: 5 issues left to triage: 3292, 3294, 3303, 3304, 3305
15:38:25 <dalley> #topic Switch Pulp2 to use AMQP 1.0 - http://pulp.plan.io/issues/3292
15:38:26 <pulpbot> Issue #3292 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:38:27 <pulpbot> Switch Pulp2 to use AMQP 1.0 - http://pulp.plan.io/issues/3292
15:38:32 <daviddavis> CLOSE WONTFIX
15:38:35 <asmacdo> lol
15:38:37 <daviddavis> jk
15:38:38 <bmbouter> exactly!
15:38:39 <dkliban> lol
15:38:50 <daviddavis> accept?
15:38:52 <asmacdo> !propose convert to refactor
15:38:52 <pulpbot> asmacdo: Error: "propose" is not a valid command.
15:38:55 <dkliban> it's a story
15:38:58 <daviddavis> +1
15:39:02 <ipanova> story
15:39:03 <bmbouter> I don't think it's really any of these
15:39:06 <dkliban> hha
15:39:07 <ipanova> task!!
15:39:10 <bmbouter> it's not really a pulp feature
15:39:17 <bmbouter> +1 to task
15:39:24 <dkliban> +1 to task
15:39:25 <dalley> !propose other convert to task
15:39:25 <dalley> #idea Proposed for #3292: convert to task
15:39:25 <pulpbot> dalley: Proposed for #3292: convert to task
15:39:28 <ttereshc> +1
15:39:33 <asmacdo> thats so meta
15:39:35 <daviddavis> bmbouter: do we plan to keep supporting the current amqp version?
15:39:44 <daviddavis> or will users have to use proton
15:39:52 <daviddavis> just curious
15:40:02 <bmbouter> they can choose to run an old kombu
15:40:11 <bmbouter> pre 4.1 will be < amqp 1.0
15:40:12 <dalley> we aren't doing anything else with this right now correct? just convert to task while bmbouter works on it?
15:40:24 <bmbouter> dalley: yes exactly, and it's part of the epic tracker already
15:40:30 <dalley> cool
15:40:32 <daviddavis> sounds good
15:40:44 <asmacdo> +1 dalley, not groomed so we can keep moving
15:40:44 <dalley> #agreed convert to task
15:40:44 <dalley> !accept
15:40:44 <pulpbot> dalley: Current proposal accepted: convert to task
15:40:46 <dalley> #topic Update Python plugin to sync with versioned repositories - http://pulp.plan.io/issues/3294
15:40:46 <pulpbot> dalley: 4 issues left to triage: 3294, 3303, 3304, 3305
15:40:47 <pulpbot> Issue #3294 [ASSIGNED] (amacdona@redhat.com) - Priority: Normal | Severity: Medium
15:40:49 <pulpbot> Update Python plugin to sync with versioned repositories - http://pulp.plan.io/issues/3294
15:41:05 <dkliban> accept
15:41:07 <bmbouter> +1
15:41:09 <dkliban> add to sprint later
15:41:18 <asmacdo> !propose other convert to task
15:41:18 <asmacdo> #idea Proposed for #3294: convert to task
15:41:18 <pulpbot> asmacdo: Proposed for #3294: convert to task
15:41:18 <dkliban> or add to srpint now?
15:41:19 <ttereshc> it's already assigned
15:41:20 <bmbouter> it's in assigned
15:41:24 <bmbouter> +1 to now
15:41:30 <jortel> seems that should be a task instead of issue?
15:41:32 <bmbouter> it's part of th repoversion work (in my mind)
15:41:37 <dalley> !propose other convert to task, add to sprint
15:41:37 <dalley> #idea Proposed for #3294: convert to task, add to sprint
15:41:38 <pulpbot> dalley: Proposed for #3294: convert to task, add to sprint
15:41:40 <dkliban> +1
15:41:42 <asmacdo> yes bmbouter
15:41:51 <asmacdo> +1
15:42:16 <dalley> !accept
15:42:16 <dalley> #agreed convert to task, add to sprint
15:42:16 <pulpbot> dalley: Current proposal accepted: convert to task, add to sprint
15:42:17 <pulpbot> dalley: 3 issues left to triage: 3303, 3304, 3305
15:42:18 <dalley> #topic v2.py: Accept header handling is sketchy - http://pulp.plan.io/issues/3303
15:42:18 <pulpbot> Issue #3303 [NEW] (unassigned) - Priority: Normal | Severity: Low
15:42:20 <pulpbot> v2.py: Accept header handling is sketchy - http://pulp.plan.io/issues/3303
15:42:47 <ipanova> let's change to refactor and accept
15:42:52 <dkliban> +1
15:43:05 <dalley> !propose other change to refactor
15:43:05 <dalley> #idea Proposed for #3303: change to refactor
15:43:05 <pulpbot> dalley: Proposed for #3303: change to refactor
15:43:07 <ttereshc> maybe move to post and assign reporter?
15:43:21 <ttereshc> I meant PR authror
15:43:29 <bmbouter> +1
15:43:31 <dkliban> +1
15:43:34 <bmbouter> there is a PR posted
15:43:41 <dkliban> yeah ... i already looked at it
15:43:46 <asmacdo> +1
15:43:46 <bmbouter> can someone review+merge?
15:43:51 <dalley> #idea Proposed for #3303: change to refactor, move to post, assign to reporter
15:43:51 <dalley> !propose other change to refactor, move to post, assign to reporter
15:43:51 <pulpbot> dalley: Proposed for #3303: change to refactor, move to post, assign to reporter
15:43:52 <dkliban> i will
15:44:26 <dalley> !accept
15:44:26 <dalley> #agreed change to refactor, move to post, assign to reporter
15:44:26 <pulpbot> dalley: Current proposal accepted: change to refactor, move to post, assign to reporter
15:44:27 <pulpbot> dalley: 2 issues left to triage: 3304, 3305
15:44:28 <dalley> #topic Repository Version content can be added infinite number of times  - http://pulp.plan.io/issues/3304
15:44:28 <pulpbot> Issue #3304 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:44:29 <pulpbot> Repository Version content can be added infinite number of times  - http://pulp.plan.io/issues/3304
15:44:38 <daviddavis> so I see two possible paths for this problem: either we keep the current db implementation but filter by distinct content id when displaying content or we change the db model so we only allow one repositorycontent per content unit to be created
15:45:01 <dkliban> per repo pre content unit
15:45:11 <daviddavis> yes
15:45:26 <daviddavis> regardless, we should accept and add to sprint I think
15:45:30 <dkliban> +1
15:45:34 <ttereshc> +2
15:45:42 <jortel> +1
15:45:48 <daviddavis> but please update this bug if you have thoughts around which solution we should go with
15:46:12 <dalley> !propose other accept and add to sprint
15:46:12 <dalley> #idea Proposed for #3304: accept and add to sprint
15:46:12 <pulpbot> dalley: Proposed for #3304: accept and add to sprint
15:46:41 <ttereshc> +1
15:46:56 <dkliban> +1
15:47:00 <dalley> !accept
15:47:00 <dalley> #agreed accept and add to sprint
15:47:00 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
15:47:01 <pulpbot> dalley: 1 issues left to triage: 3305
15:47:01 <dalley> #topic Travis reports problems with every Crane PR - http://pulp.plan.io/issues/3305
15:47:02 <pulpbot> Issue #3305 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:47:03 <pulpbot> Travis reports problems with every Crane PR - http://pulp.plan.io/issues/3305
15:47:42 <asmacdo> !propose triage high high
15:47:42 <asmacdo> #idea Proposed for #3305: Priority: High, Severity: High
15:47:42 <pulpbot> asmacdo: Proposed for #3305: Priority: High, Severity: High
15:48:12 <dkliban> is anyone opposed to adding this to the sprint?
15:48:22 <asmacdo> +1 add to sprint
15:48:28 <bmbouter> +1 add to sprint
15:48:29 <ttereshc> +1
15:48:47 <dalley> !propose other high/high add to sprint
15:48:47 <dalley> #idea Proposed for #3305: high/high add to sprint
15:48:47 <pulpbot> dalley: Proposed for #3305: high/high add to sprint
15:49:17 <ttereshc> +!
15:49:19 <ttereshc> +1
15:49:19 <jortel> +1
15:49:26 <dalley> #agreed high/high add to sprint
15:49:26 <dalley> !accept
15:49:26 <pulpbot> dalley: Current proposal accepted: high/high add to sprint
15:49:27 <pulpbot> dalley: No issues to triage.
15:49:32 <dalley> #endmeeting
15:49:32 <dalley> !end