15:30:02 <dalley> #startmeeting Pulp Triage 2018-02-02
15:30:02 <dalley> #info dalley has joined triage
15:30:02 <pulpbot> Meeting started Fri Feb  2 15:30:02 2018 UTC and is due to finish in 60 minutes.  The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:02 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:02 <pulpbot> The meeting name has been set to 'pulp_triage_2018_02_02'
15:30:02 <pulpbot> dalley: dalley has joined triage
15:30:13 <asmacdo> !here
15:30:13 <asmacdo> #info asmacdo has joined triage
15:30:13 <pulpbot> asmacdo: asmacdo has joined triage
15:30:28 <jortel> !here
15:30:28 <jortel> #info jortel has joined triage
15:30:28 <pulpbot> jortel: jortel has joined triage
15:31:35 <dalley> everyone is at FOSDEM today
15:31:41 <dalley> !next
15:31:41 <bizhang> !here
15:31:42 <pulpbot> dalley: 4 issues left to triage: 3335, 3338, 3342, 3343
15:31:42 <dalley> #topic pulp fails to use SASL methods other than PLAIN - http://pulp.plan.io/issues/3335
15:31:42 <bizhang> #info bizhang has joined triage
15:31:43 <pulpbot> Issue #3335 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:31:44 <pulpbot> pulp fails to use SASL methods other than PLAIN - http://pulp.plan.io/issues/3335
15:31:45 <pulpbot> bizhang: bizhang has joined triage
15:31:48 <mansari> !here
15:31:48 <mansari> #info mansari has joined triage
15:31:49 <pulpbot> mansari: mansari has joined triage
15:33:17 <jortel> This should be filed against kombu, not pulp.
15:33:54 <asmacdo> either way, bmbouter will see it :)
15:35:07 <jortel> perhaps we should leave this untriaged til next week when bmbouter can comment?
15:35:08 <asmacdo> jortel would you be comfortable filing that bug?
15:35:20 <asmacdo> ^ sounds good to me also
15:35:25 <dalley> I'd be fine to skip for now
15:35:35 <bizhang> +1 skip
15:35:36 <dalley> !propose skip
15:35:36 <dalley> #idea Proposed for #3335: Skip this issue for this triage session.
15:35:36 <pulpbot> dalley: Proposed for #3335: Skip this issue for this triage session.
15:35:51 <dalley> !accept
15:35:51 <dalley> #agreed Skip this issue for this triage session.
15:35:51 <pulpbot> dalley: Current proposal accepted: Skip this issue for this triage session.
15:35:52 <pulpbot> dalley: 3 issues left to triage: 3338, 3342, 3343
15:35:53 <dalley> #topic rsync distributor syncs symlinks to wrong directory if repo_relative_path starts with / - http://pulp.plan.io/issues/3338
15:35:53 <pulpbot> Issue #3338 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:35:54 <pulpbot> rsync distributor syncs symlinks to wrong directory if repo_relative_path starts with / - http://pulp.plan.io/issues/3338
15:36:40 <asmacdo> i read over this, my first instinct was "relative paths shouldnt start with a /"
15:37:03 <jortel> easy fix.  let's triage put it on the sprint as is.
15:37:40 <asmacdo> jortel: that seems fine. why is the relative path starting with a / though?
15:38:52 <jortel> yeah, good question.  I think the fix needs to prevent it and deal with invalid data
15:38:58 <jortel> that has already been stored.
15:39:24 <asmacdo> ah cool. +1 easyfix/add to sprint
15:39:35 <mansari> +1
15:39:38 <dalley> !propose accept and add to sprint
15:39:38 <pulpbot> dalley: propose accept Propose accepting the current issue in its current state.
15:39:44 <jortel> probably should fail to publish
15:39:54 <jortel> I'll add a comment.
15:40:03 <dalley> !accept
15:40:03 <pulpbot> dalley: No action proposed, nothing to accept.
15:40:16 <dalley> !propose other accept, easyfix and add to sprint
15:40:16 <dalley> #idea Proposed for #3338: accept, easyfix and add to sprint
15:40:17 <pulpbot> dalley: Proposed for #3338: accept, easyfix and add to sprint
15:40:18 <dalley> !accept
15:40:18 <dalley> #agreed accept, easyfix and add to sprint
15:40:18 <pulpbot> dalley: Current proposal accepted: accept, easyfix and add to sprint
15:40:20 <dalley> #topic Relative import breaks Python 2.4 (RHEL 5) - http://pulp.plan.io/issues/3342
15:40:20 <pulpbot> dalley: 2 issues left to triage: 3342, 3343
15:40:21 <pulpbot> Issue #3342 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:40:22 <pulpbot> Relative import breaks Python 2.4 (RHEL 5) - http://pulp.plan.io/issues/3342
15:41:38 <asmacdo> common is imported by the client code, which needs to be able to run in python 2.4
15:41:52 <jortel> asmacdo: is there a bz for this?
15:42:00 <asmacdo> no
15:42:06 <bmbouter> !here
15:42:06 <bmbouter> #info bmbouter has joined triage
15:42:06 <pulpbot> bmbouter: bmbouter has joined triage
15:43:10 <dalley> !propose other accept, easyfix, add to sprint
15:43:10 <dalley> #idea Proposed for #3342: accept, easyfix, add to sprint
15:43:10 <pulpbot> dalley: Proposed for #3342: accept, easyfix, add to sprint
15:45:05 <asmacdo> +1
15:45:17 <mansari> +1
15:46:27 <dalley> !accept
15:46:27 <dalley> #agreed accept, easyfix, add to sprint
15:46:27 <pulpbot> dalley: Current proposal accepted: accept, easyfix, add to sprint
15:46:28 <pulpbot> dalley: 1 issues left to triage: 3343
15:46:29 <dalley> #topic Context manager is not usable with Python 2.4 (RHEL 5) - http://pulp.plan.io/issues/3343
15:46:29 <pulpbot> Issue #3343 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:46:30 <pulpbot> Context manager is not usable with Python 2.4 (RHEL 5) - http://pulp.plan.io/issues/3343
15:46:38 <dalley> !issue 3335
15:46:38 <dalley> #topic pulp fails to use SASL methods other than PLAIN - http://pulp.plan.io/issues/3335
15:46:39 <pulpbot> Issue #3335 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:46:40 <pulpbot> pulp fails to use SASL methods other than PLAIN - http://pulp.plan.io/issues/3335
15:46:54 <dalley> bmbouter, since you're here, what do you think about this one?
15:50:10 <bmbouter> I think these should all be attached to the epic
15:50:25 <bmbouter> and for practical reasons I hope they are continued to be filed in pulp's tracker
15:50:50 <dalley> which epic?
15:50:59 <bmbouter> https://pulp.plan.io/issues/3291
15:51:03 <bmbouter> dalley: that one
15:51:22 <bmbouter> feel free to accept and attach to that
15:51:26 <bmbouter> I'll see them all there and investigate
15:51:44 <dalley> !propose other accept and attach to 3291
15:51:44 <dalley> #idea Proposed for #3335: accept and attach to 3291
15:51:44 <pulpbot> dalley: Proposed for #3335: accept and attach to 3291
15:52:33 <asmacdo> bmbouter: are we not using the external tracker anymore?
15:53:38 <bmbouter> I don't use it
15:53:56 <asmacdo> ack. +1
15:54:05 <dalley> !accept
15:54:05 <dalley> #agreed accept and attach to 3291
15:54:05 <pulpbot> dalley: Current proposal accepted: accept and attach to 3291
15:54:07 <dalley> #topic Context manager is not usable with Python 2.4 (RHEL 5) - http://pulp.plan.io/issues/3343
15:54:07 <pulpbot> dalley: 1 issues left to triage: 3343
15:54:08 <pulpbot> Issue #3343 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:54:09 <pulpbot> Context manager is not usable with Python 2.4 (RHEL 5) - http://pulp.plan.io/issues/3343
15:55:51 <asmacdo> similar to 3342, but probably needs to point to an issue filed with gofer
15:56:21 <jortel> This is pretty unrelated to pulp for a few reasons, 1. I don't think we support el5, 2. The tools code is not used by pulp users.  3. it's a 3rd party project.
15:57:14 <jortel> I'm fine with leaving this in our redmine but don't see the point.  Normally, I just assign the BZ to myself and fix upstream.
15:59:02 <jortel> Or, we can wait to decide.  I really need to see the trace to understand how a sat user could be hitting this.
15:59:14 <asmacdo> !propose skip
15:59:14 <asmacdo> #idea Proposed for #3343: Skip this issue for this triage session.
15:59:14 <pulpbot> asmacdo: Proposed for #3343: Skip this issue for this triage session.
16:01:17 <jortel> On 2nd thought, let's close here the gofer CLI (yes, it has a cli) is way outside the pulp/sat usecases.
16:02:33 <dalley> close - wontfix?
16:03:23 <jortel> whatever is fine
16:03:37 <asmacdo> lets just skip for today until we have a plan
16:03:57 <asmacdo> i dont want this to get lost
16:06:25 <dalley> !skip
16:06:26 <dalley> !end
16:06:26 <dalley> #endmeeting
16:06:26 <pulpbot> dalley: No issues to triage.