15:39:07 <dalley> #startmeeting Pulp Triage 2018-02-16
15:39:07 <dalley> #info dalley has joined triage
15:39:07 <bizhang> bmbouter, there's an issue filed for that: https://pulp.plan.io/issues/3355
15:39:07 <pulpbot> Meeting started Fri Feb 16 15:39:07 2018 UTC and is due to finish in 60 minutes.  The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:39:07 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:39:07 <pulpbot> The meeting name has been set to 'pulp_triage_2018_02_16'
15:39:07 <pulpbot> dalley: dalley has joined triage
15:39:12 <dkliban> !here
15:39:12 <dkliban> #info dkliban has joined triage
15:39:12 <pulpbot> dkliban: dkliban has joined triage
15:39:14 <bizhang> !here
15:39:14 <bizhang> #info bizhang has joined triage
15:39:14 <pulpbot> bizhang: bizhang has joined triage
15:39:16 <mansari> #info mansari has joined triage
15:39:16 <mansari> !here
15:39:16 <pulpbot> mansari: mansari has joined triage
15:39:29 <ipanova|home> !here
15:39:29 <ipanova|home> #info ipanova|home has joined triage
15:39:29 <pulpbot> ipanova|home: ipanova|home has joined triage
15:39:37 <asmacdo> !here
15:39:37 <asmacdo> #info asmacdo has joined triage
15:39:37 <pulpbot> asmacdo: asmacdo has joined triage
15:39:44 <dalley> bizhang, bmbouter there's also a PR to fix it https://github.com/pulp/pulp-ci/pull/468
15:39:51 <dalley> !next
15:39:52 <pulpbot> dalley: 3 issues left to triage: 3362, 3365, 3368
15:39:53 <dalley> #topic Pypi install commands are missing the migrations and they produce broken installations - http://pulp.plan.io/issues/3362
15:39:53 <pulpbot> Issue #3362 [NEW] (unassigned) - Priority: High | Severity: Medium
15:39:55 <pulpbot> Pypi install commands are missing the migrations and they produce broken installations - http://pulp.plan.io/issues/3362
15:39:57 <daviddavis> !here
15:39:57 <daviddavis> #info daviddavis has joined triage
15:39:57 <pulpbot> daviddavis: daviddavis has joined triage
15:40:00 <asmacdo> lets make this a docs issue and accept
15:40:27 <bmbouter> !here
15:40:27 <bmbouter> #info bmbouter has joined triage
15:40:27 <pulpbot> bmbouter: bmbouter has joined triage
15:40:46 <bmbouter> bizhang, dalley: thanks
15:41:20 <dalley> +1 Austin
15:41:35 <daviddavis> is checking in the migrations a possible solution?
15:41:55 <asmacdo> daviddavis: lets wait until right before we cut the beta
15:42:08 <daviddavis> ok, works for me
15:42:18 <ttereshc> !here
15:42:18 <ttereshc> #info ttereshc has joined triage
15:42:19 <pulpbot> ttereshc: ttereshc has joined triage
15:42:20 <dalley> yeah, it's more a question of are we prepared to do that
15:42:43 <dalley> any objections?
15:42:47 <asmacdo> are we prepared to commit the migrations before the beta?
15:42:56 <asmacdo> is that what you mean dalley?
15:43:12 <bmbouter> we should accept
15:43:14 <daviddavis> no, I think he means now
15:43:20 <asmacdo> oh ok
15:43:20 <bmbouter> I do
15:43:36 <bmbouter> really this issue should read as "someone go through and fix the pypi installation"
15:43:38 <bmbouter> haha
15:43:47 <bmbouter> but I know it's just missing migrations from the plugin writer's workshop
15:43:47 <dalley> I meant that re: daviddavis we "could" but I don't think we want to
15:43:52 <dalley> yet*
15:43:56 <daviddavis> dalley: yea
15:44:03 <bmbouter> +1 to docs issue and adding to sprint
15:44:06 <daviddavis> +1
15:44:08 <dkliban> +1
15:44:24 <dalley> !propose other make a docs issue, accept, add to sprint
15:44:24 <dalley> #idea Proposed for #3362: make a docs issue, accept, add to sprint
15:44:24 <pulpbot> dalley: Proposed for #3362: make a docs issue, accept, add to sprint
15:44:25 <dalley> !accept
15:44:25 <dalley> #agreed make a docs issue, accept, add to sprint
15:44:26 <pulpbot> dalley: Current proposal accepted: make a docs issue, accept, add to sprint
15:44:27 <dalley> #topic @id@ on the inherited content unit conflicts with a content unit which also uses @id@ - http://pulp.plan.io/issues/3365
15:44:27 <pulpbot> dalley: 2 issues left to triage: 3365, 3368
15:44:28 <pulpbot> Issue #3365 [NEW] (unassigned) - Priority: Normal | Severity: Low
15:44:29 <pulpbot> @id@ on the inherited content unit conflicts with a content unit which also uses @id@ - http://pulp.plan.io/issues/3365
15:45:10 <daviddavis> this seems like it's a doc issue? we have to have an id field that is a reserved name
15:45:31 <bmbouter> I'm also not sure how to resolve
15:45:36 <bmbouter> so I'm hesitant to accept
15:45:54 <bmbouter> does django require us to use 'id' as the field name or drf or something?
15:46:38 <asmacdo> i dont understand the problem
15:46:53 <asmacdo> there is an id already provided by the base class
15:46:56 <asmacdo> right?
15:46:57 <ipanova|home> i suggest to defer until milan will elaborate more on this?
15:46:59 <daviddavis> asmacdo: plugin writers are creating Content models and they want to store their own ids
15:47:09 <daviddavis> like I want to store errata id in a field called id
15:47:15 <bmbouter> he retold is second hand from feedback I gave
15:47:25 <daviddavis> but I can't because id is being used by the base content model to store PK
15:47:31 <asmacdo> oh ok
15:47:35 <bmbouter> yeah exactly
15:47:37 <bmbouter> that is the problem
15:47:43 <asmacdo> well, i think we should not change that
15:47:45 <daviddavis> I think we should just add docs that id is a reserved field name IMO
15:47:47 <bmbouter> I can't tell if we've arbitrarily chosen 'id' or not
15:47:55 <daviddavis> asmacdo: technically we can rename the PK field and not use id
15:48:02 <bmbouter> wel he figured it out so it wasn't a docs issue
15:48:04 <daviddavis> django lets us do it I think
15:48:08 <asmacdo> i dont want to do that daviddavis
15:48:14 <asmacdo> we had that problem in pulp 2
15:48:15 <daviddavis> asmacdo: me neither
15:48:16 <bmbouter> in the content types' case they specifically have something called 'id'
15:48:25 <daviddavis> I am just saying it's tech possible
15:48:28 <bmbouter> so we can defer for now obviuosly not ready to accept
15:48:33 <asmacdo> k
15:48:38 <asmacdo> +1 defer
15:48:40 <bmbouter> and I'm saying we should consider this because when they subclass they ran into this problem
15:48:45 <dalley> !propose skip
15:48:45 <dalley> #idea Proposed for #3365: Skip this issue for this triage session.
15:48:46 <pulpbot> dalley: Proposed for #3365: Skip this issue for this triage session.
15:48:47 <bmbouter> +1 skip
15:48:51 <daviddavis> +1
15:48:57 <bizhang> +1
15:49:00 <dalley> #agreed Skip this issue for this triage session.
15:49:00 <dalley> !accept
15:49:00 <pulpbot> dalley: Current proposal accepted: Skip this issue for this triage session.
15:49:01 <pulpbot> dalley: 1 issues left to triage: 3368
15:49:01 <dalley> #topic batch_regenerate_applicability tasks have no action tag, so pulp-admin can't tell you what they were - http://pulp.plan.io/issues/3368
15:49:02 <pulpbot> Issue #3368 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:49:03 <pulpbot> batch_regenerate_applicability tasks have no action tag, so pulp-admin can't tell you what they were - http://pulp.plan.io/issues/3368
15:50:51 <dalley> this is more of an annoyance than a major issue, so low / low
15:50:59 <dalley> #idea Proposed for #3368: Priority: Low, Severity: Low
15:50:59 <dalley> !propose triage low low
15:50:59 <pulpbot> dalley: Proposed for #3368: Priority: Low, Severity: Low
15:51:04 <dkliban> +1
15:51:15 <ttereshc> yeah and it's been this way always I think
15:51:17 <ttereshc> +1
15:51:25 <ipanova|home> +1
15:51:28 <mansari> +1
15:51:42 <dalley> !accept
15:51:42 <dalley> #agreed Priority: Low, Severity: Low
15:51:42 <pulpbot> dalley: Current proposal accepted: Priority: Low, Severity: Low
15:51:43 <pulpbot> dalley: No issues to triage.
15:51:46 <dalley> !end
15:51:46 <dalley> #endmeeting