15:31:33 <dalley> #startmeeting Pulp Triage 2018-02-23
15:31:33 <dalley> #info dalley has joined triage
15:31:33 <pulpbot> Meeting started Fri Feb 23 15:31:33 2018 UTC and is due to finish in 60 minutes.  The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:31:33 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:31:33 <pulpbot> The meeting name has been set to 'pulp_triage_2018_02_23'
15:31:33 <pulpbot> dalley: dalley has joined triage
15:31:36 <dkliban> !here
15:31:36 <dkliban> #info dkliban has joined triage
15:31:36 <pulpbot> dkliban: dkliban has joined triage
15:31:56 <ipanova> !here
15:31:56 <ipanova> #info ipanova has joined triage
15:31:56 <pulpbot> ipanova: ipanova has joined triage
15:32:28 <asmacdo> !here
15:32:28 <asmacdo> #info asmacdo has joined triage
15:32:29 <pulpbot> asmacdo: asmacdo has joined triage
15:32:49 <bizhang> !here
15:32:49 <bizhang> #info bizhang has joined triage
15:32:49 <pulpbot> bizhang: bizhang has joined triage
15:32:59 <dalley> !next
15:33:00 <pulpbot> dalley: 6 issues left to triage: 3387, 3388, 3390, 3391, 3392, 3393
15:33:00 <dalley> #topic Improve error message when uploading a file already in Pulp3 - http://pulp.plan.io/issues/3387
15:33:01 <pulpbot> Issue #3387 [NEW] (unassigned) - Priority: Low | Severity: Low
15:33:02 <pulpbot> Improve error message when uploading a file already in Pulp3 - http://pulp.plan.io/issues/3387
15:33:03 <mansari> !here
15:33:03 <mansari> #info mansari has joined triage
15:33:04 <pulpbot> mansari: mansari has joined triage
15:33:59 <dalley> !propose accept
15:33:59 <dalley> #idea Proposed for #3387: Leave the issue as-is, accepting its current state.
15:33:59 <pulpbot> dalley: Proposed for #3387: Leave the issue as-is, accepting its current state.
15:34:08 <asmacdo> this behavior seems right to me
15:34:29 <asmacdo> I'm not sure what else we can say other than the checksum isnt unique
15:34:49 <dkliban> the message could make it clear that the artifact already exists
15:34:55 <dalley> ^
15:35:02 <dkliban> it's clear to us, but not to a new user
15:35:04 <milan_> !here
15:35:04 <milan_> #info milan_ has joined triage
15:35:04 <pulpbot> milan_: milan_ has joined triage
15:35:08 <kersom> I agree with dkliban
15:35:09 <asmacdo> +1 accept
15:35:12 <dkliban> +1
15:35:17 <mansari> +1
15:35:23 <dalley> !accept
15:35:23 <dalley> #agreed Leave the issue as-is, accepting its current state.
15:35:23 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:35:24 <pulpbot> dalley: 5 issues left to triage: 3388, 3390, 3391, 3392, 3393
15:35:24 <dalley> #topic Syncing Debian (Ubuntu) example repo fails - http://pulp.plan.io/issues/3388
15:35:25 <pulpbot> Issue #3388 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:35:26 <pulpbot> Syncing Debian (Ubuntu) example repo fails - http://pulp.plan.io/issues/3388
15:35:43 <dkliban> skip ?
15:35:46 <dalley> re: that last one, mark easy fix?
15:35:56 <dkliban> dalley: i don't know how easy it is :)
15:35:59 <dalley> fair
15:36:36 <asmacdo> lets move this one to the deb tracker
15:36:42 <dalley> agree
15:36:59 <dalley> !propose other move to the pulp_deb tracker
15:36:59 <dalley> #idea Proposed for #3388: move to the pulp_deb tracker
15:36:59 <pulpbot> dalley: Proposed for #3388: move to the pulp_deb tracker
15:37:24 <bizhang> +1
15:37:48 <asmacdo> my money is on a permissions problem in the dev environment
15:38:03 <asmacdo> s/dev//
15:38:43 <dkliban> yeah .... or something is broken
15:38:57 <dkliban> misa: do you want us to triage this issue>?
15:39:07 <dalley> brb
15:40:26 <asmacdo> unless misa wants to do something else IMO we should skip and ask some questions on the ticket
15:41:21 <dkliban> ok
15:41:25 <dkliban> +1 to skip
15:43:20 <dalley> any objection to skipping?
15:43:25 <dalley> !propose skip
15:43:25 <dalley> #idea Proposed for #3388: Skip this issue for this triage session.
15:43:25 <pulpbot> dalley: Proposed for #3388: Skip this issue for this triage session.
15:44:11 <dalley> !accept
15:44:11 <dalley> #agreed Skip this issue for this triage session.
15:44:11 <pulpbot> dalley: Current proposal accepted: Skip this issue for this triage session.
15:44:13 <dalley> #topic Missing repository field when syncing an importer - http://pulp.plan.io/issues/3390
15:44:13 <pulpbot> dalley: 4 issues left to triage: 3390, 3391, 3392, 3393
15:44:14 <pulpbot> Issue #3390 [NEW] (unassigned) - Priority: Low | Severity: Low
15:44:15 <pulpbot> Missing repository field when syncing an importer - http://pulp.plan.io/issues/3390
15:44:40 <asmacdo> This one and the next one share the same core problem with coreapi
15:44:58 <asmacdo> but the specific problem should be filed against pulp_file
15:46:11 <dkliban> this is a docs issue
15:46:21 <dkliban> the docs don't match the API
15:46:29 <dalley> asmacdo, are you suggesting that this one and the next be consolidated into one issue?
15:46:57 <asmacdo> the underlying issue might already have a ticket... bizhang?
15:47:33 <asmacdo> not sure how that ticket will resolve, but i think we should keep them both for now
15:48:13 <dalley> but they should be moved to the pulp_file tracker?
15:48:41 <bizhang> I think this is a dupe of https://pulp.plan.io/issues/3351#note-6
15:49:31 <dkliban> it is
15:49:44 <asmacdo> since we have to create a schema for each detail route, shouldnt we keep an issue for each one that needs it?
15:49:45 <bizhang> !propose other close-duplicate
15:49:45 <bizhang> #idea Proposed for #3390: close-duplicate
15:49:45 <pulpbot> bizhang: Proposed for #3390: close-duplicate
15:49:55 <dkliban> i agree asmacdo
15:50:25 <bizhang> #3353 is for both publish and sync
15:50:42 <asmacdo> +1 close
15:50:56 <dalley> I think it is reasonable to have one to cover adding the schema for both
15:51:04 <dkliban> alright
15:51:09 <dkliban> i am ok with this plan
15:51:46 <dalley> !accept
15:51:46 <dalley> #agreed close-duplicate
15:51:46 <pulpbot> dalley: Current proposal accepted: close-duplicate
15:51:47 <pulpbot> dalley: 3 issues left to triage: 3391, 3392, 3393
15:51:47 <dalley> #topic Missing repository field when creating a publication  - http://pulp.plan.io/issues/3391
15:51:48 <pulpbot> Issue #3391 [NEW] (unassigned) - Priority: Low | Severity: Low
15:51:49 <pulpbot> Missing repository field when creating a publication  - http://pulp.plan.io/issues/3391
15:51:54 <dalley> !propose other close-duplicate
15:51:54 <dalley> #idea Proposed for #3391: close-duplicate
15:51:54 <pulpbot> dalley: Proposed for #3391: close-duplicate
15:51:58 <asmacdo> +1
15:52:32 <dalley> !accept
15:52:32 <dalley> #agreed close-duplicate
15:52:32 <pulpbot> dalley: Current proposal accepted: close-duplicate
15:52:33 <pulpbot> dalley: 2 issues left to triage: 3392, 3393
15:52:34 <dalley> #topic Redudant fields for distribution model - http://pulp.plan.io/issues/3392
15:52:34 <pulpbot> Issue #3392 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:52:35 <pulpbot> Redudant fields for distribution model - http://pulp.plan.io/issues/3392
15:52:54 <asmacdo> i didnt understand this one
15:53:29 <asmacdo> kersom: does it change things that we have removed the relationship between publishers and repositories?
15:53:56 <dkliban> kersom noticed that the fields are not needed
15:54:19 <dkliban> because a distribution has a relationship to a publication. the publication has a relationship to a repository version and to a publisher
15:54:19 <kersom> asmacdo, not sure.
15:54:29 <kersom> yeah
15:54:37 <asmacdo> a publisher is needed for auto-distribute
15:54:57 <asmacdo> repo is needed for the  same reason
15:54:57 <kersom> but then you can add a publication, and a publisher and repo that are not related
15:54:58 <dkliban> is that a feature for teh MVP?
15:55:24 <dkliban> let's skip for now and discuss on the ticket
15:55:28 <asmacdo> jortel: we already pretty much have this right?
15:55:37 <dkliban> asmacdo: jortel is not in triage right now
15:56:01 <asmacdo> +1 skip
15:56:02 <dkliban> skip for now and i'll comment on the ticket
15:56:08 <dalley> !propose skip
15:56:08 <dalley> #idea Proposed for #3392: Skip this issue for this triage session.
15:56:08 <pulpbot> dalley: Proposed for #3392: Skip this issue for this triage session.
15:56:39 <bizhang> +1
15:56:56 <dalley> !accept
15:56:56 <dalley> #agreed Skip this issue for this triage session.
15:56:56 <pulpbot> dalley: Current proposal accepted: Skip this issue for this triage session.
15:56:58 <dalley> #topic API break: unit_key became mandatory during RPM upload - http://pulp.plan.io/issues/3393
15:56:58 <pulpbot> dalley: 1 issues left to triage: 3393
15:56:59 <pulpbot> Issue #3393 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:57:00 <pulpbot> API break: unit_key became mandatory during RPM upload - http://pulp.plan.io/issues/3393
15:57:10 <dkliban> this is not good
15:57:12 <ipanova> this one was already reported
15:57:15 <ipanova> it is a dupe
15:57:18 <dkliban> oh ok
15:57:23 <ipanova> https://pulp.plan.io/issues/3307
15:57:56 <ipanova> the API docs never sais unit_key is an optional key
15:58:01 <asmacdo> dkliban: (previous issue) fyi auto publish is on the mvp in red
15:58:04 <ipanova> https://docs.pulpproject.org/dev-guide/integration/rest-api/content/upload.html#import-into-a-repository
15:58:41 <ipanova> i think what we did - we just fixed the gap in the code
15:58:56 <dkliban> ipanova: so was this 'fixed' on purpose?
15:59:25 <ipanova> dkliban: i don't think so, we need to look into the commi
15:59:26 <ipanova> t
15:59:45 <ipanova> i just hightlight that in in docs we never said it is optional
16:01:09 <dalley> well, even if it was never declared optional, it is still technically backwards-incompatible
16:01:25 <dkliban> yeah ... i don't think this ticket https://pulp.plan.io/issues/2754 meant to make this change
16:01:37 <ipanova> it is, but it;s kinda user's fault he did not follow the docs specs
16:02:25 <dkliban> i would argue that the docs are wrong
16:02:38 <dkliban> anyway
16:02:42 <ipanova> let's fix it but we will need cautious not to break other things which rely on the fact the unit_key cannot be null
16:02:44 <dkliban> let's close it as a duplicate
16:03:13 <ipanova> yeah #3393 needs to be closed
16:03:19 <dalley> should we reprioritize the original since there is a second report?
16:03:25 <dkliban> yes
16:03:27 <dalley> !propose other close-duplicate
16:03:27 <dalley> #idea Proposed for #3393: close-duplicate
16:03:27 <pulpbot> dalley: Proposed for #3393: close-duplicate
16:03:27 <dkliban> for sure
16:03:51 <ipanova> +1
16:04:05 <dalley> !accept
16:04:05 <dalley> #agreed close-duplicate
16:04:05 <pulpbot> dalley: Current proposal accepted: close-duplicate
16:04:06 <pulpbot> dalley: No issues to triage.
16:04:08 <dalley> !issue 3307
16:04:09 <dalley> #topic import_upload: improve data validation - http://pulp.plan.io/issues/3307
16:04:09 <pulpbot> Issue #3307 [NEW] (unassigned) - Priority: Normal | Severity: Medium
16:04:10 <pulpbot> import_upload: improve data validation - http://pulp.plan.io/issues/3307
16:04:57 <ipanova> i think it needs to get on the sprint
16:05:02 <asmacdo> can we add a comment to accept unit_key: null which will default to {}
16:05:03 <dkliban> yes
16:06:41 <dalley> !propose other add to sprint, add relation to 3393
16:06:41 <dalley> #idea Proposed for #3307: add to sprint, add relation to 3393
16:06:41 <pulpbot> dalley: Proposed for #3307: add to sprint, add relation to 3393
16:06:50 <ipanova> +1
16:07:20 <ipanova> asmacdo: will you add the comment to the issue with the outcome of our discussion?
16:07:29 <asmacdo> sure
16:07:45 <ipanova> asmacdo++
16:07:45 <pulpbot> ipanova: asmacdo's karma is now 34
16:08:06 <ichimonji10> dkliban, We're a few merges away from this: https://travis-ci.org/Ichimonji10/devel/builds/345313538
16:08:23 <dkliban> nice
16:08:56 <dalley> !accept
16:08:56 <dalley> #agreed add to sprint, add relation to 3393
16:08:56 <pulpbot> dalley: Current proposal accepted: add to sprint, add relation to 3393
16:08:58 <pulpbot> dalley: No issues to triage.
16:08:59 <dalley> !end
16:08:59 <dalley> #endmeeting