15:30:59 <dalley> #startmeeting Pulp Triage 2018-03-02
15:30:59 <dalley> #info dalley has joined triage
15:30:59 <pulpbot> Meeting started Fri Mar  2 15:30:59 2018 UTC and is due to finish in 60 minutes.  The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:59 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:59 <pulpbot> The meeting name has been set to 'pulp_triage_2018_03_02'
15:30:59 <pulpbot> dalley: dalley has joined triage
15:31:02 <asmacdo> !here
15:31:02 <asmacdo> #info asmacdo has joined triage
15:31:02 <pulpbot> asmacdo: asmacdo has joined triage
15:31:09 <dkliban> !here
15:31:09 <dkliban> #info dkliban has joined triage
15:31:09 <pulpbot> dkliban: dkliban has joined triage
15:31:12 <ipanova> !here
15:31:12 <ipanova> #info ipanova has joined triage
15:31:12 <pulpbot> ipanova: ipanova has joined triage
15:31:14 <bizhang> !here
15:31:14 <bizhang> #info bizhang has joined triage
15:31:14 <pulpbot> bizhang: bizhang has joined triage
15:31:19 <dalley> !next
15:31:20 <pulpbot> dalley: 8 issues left to triage: 3406, 3410, 3411, 3412, 3413, 3416, 3418, 3419
15:31:21 <dalley> #topic /var/cache/pulp shoudl not be required by pulp workers - http://pulp.plan.io/issues/3406
15:31:21 <pulpbot> Issue #3406 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:31:22 <pulpbot> /var/cache/pulp shoudl not be required by pulp workers - http://pulp.plan.io/issues/3406
15:31:49 <dalley> !propose other s/shoudl/should :)
15:31:49 <dalley> #idea Proposed for #3406: s/shoudl/should :)
15:31:49 <dkliban> i want to accept and aadd to sprint
15:31:49 <pulpbot> dalley: Proposed for #3406: s/shoudl/should :)
15:32:20 <daviddavis> !here
15:32:20 <daviddavis> #info daviddavis has joined triage
15:32:20 <pulpbot> daviddavis: daviddavis has joined triage
15:32:27 <asmacdo> dkliban: is that what causes that problem with pulp deb from last week?
15:32:41 <dkliban> asmacdo: this is pulp 3
15:33:29 <ttereshc> !here
15:33:29 <ttereshc> #info ttereshc has joined triage
15:33:30 <pulpbot> ttereshc: ttereshc has joined triage
15:34:13 <asmacdo> oh right, pulp_deb inst pulp 3 yet :)
15:34:13 <dalley> !propose other accept and add to sprint
15:34:13 <dalley> #idea Proposed for #3406: accept and add to sprint
15:34:14 <pulpbot> dalley: Proposed for #3406: accept and add to sprint
15:34:16 <bmbouter> +1
15:34:17 <asmacdo> +1
15:34:40 <ipanova> +1
15:34:49 <asmacdo> dkliban: i think this probably also needs a PR to pulp/devel
15:36:48 <bmbouter> asmacdo: can you comment w/ what that pulp/devel change should contain on the issue?
15:36:53 <asmacdo> yes
15:36:56 <bmbouter> ty!
15:36:57 <dalley> !accept
15:36:57 <dalley> #agreed accept and add to sprint
15:36:57 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
15:36:58 <pulpbot> dalley: 7 issues left to triage: 3410, 3411, 3412, 3413, 3416, 3418, 3419
15:36:59 <dalley> #topic Rename variable path to name - reading content from a repository - http://pulp.plan.io/issues/3410
15:36:59 <pulpbot> Issue #3410 [NEW] (unassigned) - Priority: Low | Severity: Low
15:37:00 <pulpbot> Rename variable path to name - reading content from a repository - http://pulp.plan.io/issues/3410
15:37:59 <kersom> I files this one, it is just a a suggestion to clarify the meaning behind variable name
15:38:11 <dkliban> we may need to provide better docs to explain to the API user what this means
15:38:43 <dkliban> or a better name
15:38:45 <asmacdo> !propose triage other accept and change subject to rename variable path to relative_path
15:38:45 <pulpbot> asmacdo: (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
15:38:47 <daviddavis> I like the idea that dalley/asmacdo propose
15:38:55 <asmacdo> !propose other accept and change subject to rename variable path to relative_path
15:38:55 <asmacdo> #idea Proposed for #3410: accept and change subject to rename variable path to relative_path
15:38:55 <pulpbot> asmacdo: Proposed for #3410: accept and change subject to rename variable path to relative_path
15:38:59 <kersom> I see the variable use in many other parts of the api, holding a file name
15:39:05 <kersom> variable path*
15:39:13 <ttereshc> +1 to relative_path
15:39:29 <asmacdo> kersom for the simple case it is just file name
15:39:39 <asmacdo> but there could be a directory structure too
15:39:42 <kersom> ok
15:40:00 <dalley> I can rewrite the issue.  sprint + or -?
15:40:02 <dkliban> so +1 to renaming but we also need to make sure the REST API docs explain this
15:40:11 <dalley> ^
15:40:36 <asmacdo> i can add that to the issue
15:40:44 <dkliban> asmacdo: that would be great ... thank you
15:40:44 <ipanova> let's make it as a checklist
15:40:47 <bmbouter> dkliban: also calling out where in the docs would be helpful
15:40:52 <bmbouter> +1 checklist
15:41:04 <asmacdo> help_text in the serializer is all i know of. anywhere else bmbouter?
15:41:10 <dkliban> bmbouter: the REST API documentation.
15:41:12 <dalley> +1 checklist
15:41:22 <asmacdo> REST API is generated from the help_text
15:41:22 <dkliban> so what asmacdo is suggesting is sufficient
15:41:59 <dalley> !propose other accept, asmacdo will append to the issue relevant docs changes
15:41:59 <dalley> #idea Proposed for #3410: accept, asmacdo will append to the issue relevant docs changes
15:41:59 <pulpbot> dalley: Proposed for #3410: accept, asmacdo will append to the issue relevant docs changes
15:42:21 <dalley> !propose other accept, dalley will rename/rewrite, asmacdo will append to the issue relevant docs changes
15:42:21 <dalley> #idea Proposed for #3410: accept, dalley will rename/rewrite, asmacdo will append to the issue relevant docs changes
15:42:21 <pulpbot> dalley: Proposed for #3410: accept, dalley will rename/rewrite, asmacdo will append to the issue relevant docs changes
15:42:55 <asmacdo> +1
15:44:29 <ipanova> +1
15:44:46 <dalley> !accept
15:44:46 <dalley> #agreed accept, dalley will rename/rewrite, asmacdo will append to the issue relevant docs changes
15:44:46 <pulpbot> dalley: Current proposal accepted: accept, dalley will rename/rewrite, asmacdo will append to the issue relevant docs changes
15:44:48 <dalley> #topic Document Implications that Pulp2 does not support metalink for rpm syncing - http://pulp.plan.io/issues/3411
15:44:48 <pulpbot> dalley: 6 issues left to triage: 3411, 3412, 3413, 3416, 3418, 3419
15:44:49 <pulpbot> Issue #3411 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:44:50 <pulpbot> Document Implications that Pulp2 does not support metalink for rpm syncing - http://pulp.plan.io/issues/3411
15:45:27 <ttereshc> !propose other accept and add to sprint
15:45:27 <ttereshc> #idea Proposed for #3411: accept and add to sprint
15:45:27 <pulpbot> ttereshc: Proposed for #3411: accept and add to sprint
15:45:33 <bmbouter> I'm +1 to adding this onto the sprint and I can handle it in a few min
15:45:38 <daviddavis> why add to sprint?
15:45:44 <asmacdo> oh you know what
15:45:45 <bmbouter> a user was very concerned about this
15:45:54 <ipanova> agreed with bmbouter
15:45:58 <asmacdo> the path field is on the file plugin
15:46:05 <asmacdo> this should be a pulp_file issue
15:46:08 <bmbouter> and it takes almost no time to fix
15:46:13 <daviddavis> +1 then
15:46:16 <dalley> #agreed accept and add to sprint
15:46:16 <dalley> !accept
15:46:16 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
15:46:16 <bmbouter> if it took more than 20 min I would not accept
15:46:17 <dalley> #topic Trailing slash in distribution base_path causes breakage (Pulp 3) - http://pulp.plan.io/issues/3412
15:46:17 <pulpbot> dalley: 5 issues left to triage: 3412, 3413, 3416, 3418, 3419
15:46:18 <daviddavis> asmacdo: +1 to moving
15:46:19 <pulpbot> Issue #3412 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:46:20 <pulpbot> Trailing slash in distribution base_path causes breakage (Pulp 3) - http://pulp.plan.io/issues/3412
15:46:41 <daviddavis> accept this issue and if this blocks qe, maybe add to sprint
15:47:07 <dalley> !propose accept
15:47:07 <dalley> #idea Proposed for #3412: Leave the issue as-is, accepting its current state.
15:47:07 <pulpbot> dalley: Proposed for #3412: Leave the issue as-is, accepting its current state.
15:47:18 <dalley> asmacdo, daviddavis I'll go back to that issue at the end
15:47:24 <daviddavis> ok
15:47:38 <daviddavis> I'd maybe add this to the sprint actually. we only have 5-6 unassigned issues last I checked
15:47:45 <bmbouter> +1
15:48:01 <dalley> !propose other accept and add to sprint
15:48:01 <dalley> #idea Proposed for #3412: accept and add to sprint
15:48:02 <pulpbot> dalley: Proposed for #3412: accept and add to sprint
15:48:20 <ttereshc> +1
15:48:41 <dalley> !accept
15:48:41 <dalley> #agreed accept and add to sprint
15:48:41 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
15:48:42 <pulpbot> dalley: 4 issues left to triage: 3413, 3416, 3418, 3419
15:48:42 <dalley> #topic "http" and "https" options in distribution have no effect - http://pulp.plan.io/issues/3413
15:48:43 <pulpbot> Issue #3413 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:48:44 <pulpbot> "http" and "https" options in distribution have no effect - http://pulp.plan.io/issues/3413
15:48:54 <daviddavis> this is broken. accept and add to sprint.
15:49:05 <dkliban> +1
15:49:17 <bmbouter> is the fix to have the content app check the protocol type?
15:49:21 <dalley> !propose other accept and add t osprint
15:49:21 <dalley> #idea Proposed for #3413: accept and add t osprint
15:49:21 <pulpbot> dalley: Proposed for #3413: accept and add t osprint
15:49:26 <dalley> !propose other accept and add to sprint
15:49:26 <dalley> #idea Proposed for #3413: accept and add to sprint
15:49:26 <daviddavis> bmbouter: yep
15:49:26 <pulpbot> dalley: Proposed for #3413: accept and add to sprint
15:49:27 <bmbouter> it has an opportunity to do that right?
15:49:30 <bmbouter> great, +1
15:49:39 <daviddavis> yea, it has the request and the distributor
15:49:45 <bmbouter> perfect
15:50:00 <daviddavis> actually...
15:50:13 <daviddavis> if it's behind apache or nginx, will it have that info?
15:50:36 <bmbouter> it should I think as part of the standard WSGI
15:50:40 <daviddavis> like maybe the original request is https but someone is pointing apache to our content app using http
15:50:42 <daviddavis> oh ok
15:51:05 <bmbouter> yeah I see that deployment model won't work w/ this feature
15:51:09 <bmbouter> but we can still make the feature work
15:51:13 <daviddavis> +1
15:51:16 <bmbouter> and we'll have to think more about what you've just brought up
15:51:16 <dalley> !accept
15:51:16 <dalley> #agreed accept and add to sprint
15:51:16 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
15:51:17 <pulpbot> dalley: 3 issues left to triage: 3416, 3418, 3419
15:51:17 <dalley> #topic Pulp Jenkins jobs use the development webserver - http://pulp.plan.io/issues/3416
15:51:18 <pulpbot> Issue #3416 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:51:19 <pulpbot> Pulp Jenkins jobs use the development webserver - http://pulp.plan.io/issues/3416
15:51:30 <bmbouter> I commented on this one for more info (just before triage)
15:52:04 <daviddavis> let's skip for now?
15:52:35 <bmbouter> I'm hoping for more input before we accept
15:52:47 <dkliban> let's skip
15:52:48 <dalley> !propose skip
15:52:48 <dalley> #idea Proposed for #3416: Skip this issue for this triage session.
15:52:50 <pulpbot> dalley: Proposed for #3416: Skip this issue for this triage session.
15:52:52 <ttereshc> +1
15:53:12 <dalley> #agreed Skip this issue for this triage session.
15:53:12 <dalley> !accept
15:53:12 <pulpbot> dalley: Current proposal accepted: Skip this issue for this triage session.
15:53:13 <pulpbot> dalley: 2 issues left to triage: 3418, 3419
15:53:13 <dalley> #topic I can delete a content unit used by a repo version - http://pulp.plan.io/issues/3418
15:53:14 <pulpbot> Issue #3418 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:53:15 <pulpbot> I can delete a content unit used by a repo version - http://pulp.plan.io/issues/3418
15:53:38 <ttereshc> story?
15:53:47 <dalley> +1 story
15:53:49 <daviddavis> I think this is a bug
15:53:56 <asmacdo> +1 bug
15:53:56 <daviddavis> repo versions are supposed to be immutable
15:54:10 <ttereshc> ah,right, I read it the other way
15:54:13 <ipanova> +1 bug
15:54:17 <ttereshc> +1 to bug
15:54:25 <dalley> !propose other accept and add to sprint
15:54:25 <dalley> #idea Proposed for #3418: accept and add to sprint
15:54:25 <pulpbot> dalley: Proposed for #3418: accept and add to sprint
15:54:31 <daviddavis> +1
15:54:33 <ipanova> +1
15:54:37 <bmbouter> +1
15:54:40 <dalley> !accept
15:54:40 <dalley> #agreed accept and add to sprint
15:54:40 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
15:54:41 <dalley> #topic Lacking AUTHORS and COPYRIGHT file - http://pulp.plan.io/issues/3419
15:54:42 <pulpbot> dalley: 1 issues left to triage: 3419
15:54:43 <pulpbot> Issue #3419 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:54:44 <pulpbot> Lacking AUTHORS and COPYRIGHT file - http://pulp.plan.io/issues/3419
15:54:57 <asmacdo> !propose other accept and add to sprint
15:54:57 <asmacdo> #idea Proposed for #3419: accept and add to sprint
15:54:57 <pulpbot> asmacdo: Proposed for #3419: accept and add to sprint
15:55:01 <daviddavis> +1
15:55:02 <ttereshc> +1
15:55:12 <asmacdo> change to task if you feel like it
15:55:14 <daviddavis> I can do this today. good friday afternoon task.
15:55:20 <ttereshc> :)
15:55:20 <dalley> cool
15:55:34 <dalley> !propose other convert to task, add to sprint
15:55:34 <dalley> #idea Proposed for #3419: convert to task, add to sprint
15:55:35 <pulpbot> dalley: Proposed for #3419: convert to task, add to sprint
15:55:39 <bmbouter> +1
15:55:40 <ttereshc> +1
15:55:50 <dalley> #agreed convert to task, add to sprint
15:55:50 <dalley> !accept
15:55:50 <pulpbot> dalley: Current proposal accepted: convert to task, add to sprint
15:55:51 <pulpbot> dalley: No issues to triage.
15:55:52 <bmbouter> dalley: can we fixup that one issue asmacdo reraised
15:55:57 <dalley> !issue #3410
15:55:57 <pulpbot> dalley: Error: '#3410' is not a valid positive integer.
15:56:00 <dalley> !issue 3410
15:56:00 <dalley> #topic Rename content field "path" to "relative_path" - http://pulp.plan.io/issues/3410
15:56:01 <rchan> daviddavis: perhaps a good new hire task?
15:56:01 <pulpbot> Issue #3410 [NEW] (unassigned) - Priority: Low | Severity: Low
15:56:02 <pulpbot> Rename content field "path" to "relative_path" - http://pulp.plan.io/issues/3410
15:56:02 <asmacdo> https://pulp.plan.io/issues/3410
15:56:11 <asmacdo> i think ive done what needs doing
15:56:14 <daviddavis> rchan: +1
15:56:21 <daviddavis> asmacdo: looking
15:56:39 <bmbouter> asmacdo: I agree thanks. that looks right
15:56:54 <daviddavis> asmacdo: lgtm
15:56:54 <bmbouter> I think we're done then :)
15:57:07 <dalley> !skip
15:57:08 <pulpbot> dalley: No issues to triage.
15:57:12 <dalley> !end
15:57:12 <dalley> #endmeeting