15:30:32 <dalley> #startmeeting Pulp Triage 2018-03-09
15:30:32 <pulpbot> Meeting started Fri Mar  9 15:30:32 2018 UTC and is due to finish in 60 minutes.  The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:32 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:32 <pulpbot> The meeting name has been set to 'pulp_triage_2018_03_09'
15:30:32 <dalley> #info dalley has joined triage
15:30:32 <pulpbot> dalley: dalley has joined triage
15:30:35 <dalley> hehe
15:30:43 <dalley> not yet y'all
15:30:50 <dkliban> !here
15:30:50 <dkliban> #info dkliban has joined triage
15:30:50 <pulpbot> dkliban: dkliban has joined triage
15:31:44 <dalley> !next
15:31:45 <pulpbot> dalley: 10 issues left to triage: 3416, 3435, 3436, 3440, 3441, 3443, 3444, 3445, 3446, 3447
15:31:46 <dalley> #topic Pulp Jenkins jobs use the development webserver - http://pulp.plan.io/issues/3416
15:31:46 <pulpbot> Issue #3416 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:31:48 <pulpbot> Pulp Jenkins jobs use the development webserver - http://pulp.plan.io/issues/3416
15:31:52 <daviddavis> !here
15:31:52 <daviddavis> #info daviddavis has joined triage
15:31:52 <pulpbot> daviddavis: daviddavis has joined triage
15:33:00 <ipanova> !here
15:33:00 <ipanova> #info ipanova has joined triage
15:33:00 <pulpbot> ipanova: ipanova has joined triage
15:33:01 <dkliban> i don't think there is much to do here. especially as it relates to issue https://pulp.plan.io/issues/3413 ... the Distribution just shouldn't have the 'http' and 'https' attributes
15:33:39 <daviddavis> dkliban: why shouldn't distribution have http/https?
15:33:59 <dkliban> the content app serving up content is likely not going to receive an SSL connection anyway if there is a reverse proxy in front of it.
15:34:21 <dkliban> so it's up to the person deplyoing pulp to set up ssl enforcement
15:34:30 <daviddavis> does the request object in django not contain the original url?
15:34:45 <asmacdo> #info asmacdo has joined triage
15:34:45 <asmacdo> !here
15:34:45 <pulpbot> asmacdo: asmacdo has joined triage
15:34:52 <dkliban> i don't think that it always will
15:35:02 <dalley> !propose other accept and add a relation to #3413
15:35:02 <dalley> #idea Proposed for #3416: accept and add a relation to #3413
15:35:02 <pulpbot> dalley: Proposed for #3416: accept and add a relation to #3413
15:35:15 <dkliban> +1
15:35:24 <daviddavis> in cases that it does though, it might be nice for users to be able to select whether it uses http/https
15:35:26 <dkliban> daviddavis: i'll comment on the issue
15:35:36 <daviddavis> ok
15:35:46 <dalley> !accept
15:35:46 <dalley> #agreed accept and add a relation to #3413
15:35:46 <pulpbot> dalley: Current proposal accepted: accept and add a relation to #3413
15:35:47 <pulpbot> dalley: 9 issues left to triage: 3435, 3436, 3440, 3441, 3443, 3444, 3445, 3446, 3447
15:35:48 <dalley> #topic Account for different datetime format in Suse errata - http://pulp.plan.io/issues/3435
15:35:48 <pulpbot> Issue #3435 [NEW] (unassigned) - Priority: Normal | Severity: High
15:35:49 <pulpbot> Account for different datetime format in Suse errata - http://pulp.plan.io/issues/3435
15:38:20 <dkliban> not a bug?
15:38:27 <dkliban> ttereshc: bizhang ^
15:38:44 <bizhang> !propose other close notabug
15:38:44 <bizhang> #idea Proposed for #3435: close notabug
15:38:44 <bizhang> #info bizhang has joined triage
15:38:45 <pulpbot> bizhang: bizhang has joined triage
15:38:46 <pulpbot> bizhang: Proposed for #3435: close notabug
15:39:09 <daviddavis> +1
15:39:12 <dkliban> +1
15:39:43 <dalley> !accept
15:39:43 <dalley> #agreed close notabug
15:39:43 <pulpbot> dalley: Current proposal accepted: close notabug
15:39:44 <pulpbot> dalley: 8 issues left to triage: 3436, 3440, 3441, 3443, 3444, 3445, 3446, 3447
15:39:45 <dalley> #topic Creating duplicate content results in 500 IntegrityError - http://pulp.plan.io/issues/3436
15:39:45 <pulpbot> Issue #3436 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:39:47 <pulpbot> Creating duplicate content results in 500 IntegrityError - http://pulp.plan.io/issues/3436
15:39:51 <pcreech> ichimonji10: https://github.com/pcreech/django-demo
15:39:58 <ttereshc> bizhang, re suse, have you checked that it's not blank?
15:40:16 <ttereshc> !here
15:40:16 <ttereshc> #info ttereshc has joined triage
15:40:16 <pulpbot> ttereshc: ttereshc has joined triage
15:40:35 <bizhang> ttereshc, for synced issued data?
15:40:38 <bizhang> it's not blank
15:41:05 <dkliban> daviddavis: this needs a Pulp 3 tag
15:41:15 <dalley> !propose high medium
15:41:15 <pulpbot> dalley: Error: "propose" is not a valid command.
15:41:21 <ttereshc> bizhang, I'll ask jcalla where he saw it, maybe using pulp-admin
15:41:30 <daviddavis> dkliban: yes, yes it does
15:41:36 <dalley> !propose triage high medium
15:41:36 <dalley> #idea Proposed for #3436: Priority: High, Severity: Medium
15:41:36 <pulpbot> dalley: Proposed for #3436: Priority: High, Severity: Medium
15:41:45 <dalley> #idea Proposed for #3436: Priority: Normal, Severity: High
15:41:45 <dalley> !propose triage normal high
15:41:45 <pulpbot> dalley: Proposed for #3436: Priority: Normal, Severity: High
15:41:57 <daviddavis> !propose triage normal high add pulp 3 tag
15:41:57 <pulpbot> daviddavis: (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
15:42:00 <dalley> that ordering always gets me
15:42:10 <daviddavis> !propose triage normal high other add pulp 3 tag
15:42:10 <pulpbot> daviddavis: (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
15:42:14 <daviddavis> I give up
15:42:20 <dalley> !propose other normal high add pulp 3 tag
15:42:20 <dalley> #idea Proposed for #3436: normal high add pulp 3 tag
15:42:20 <pulpbot> dalley: Proposed for #3436: normal high add pulp 3 tag
15:42:32 <daviddavis> thanks :)
15:42:40 <dkliban> +1
15:43:06 <ttereshc> +1
15:43:10 <dalley> we should eventually modify triage bot to accept notes
15:43:13 <dalley> !accept
15:43:13 <dalley> #agreed normal high add pulp 3 tag
15:43:13 <pulpbot> dalley: Current proposal accepted: normal high add pulp 3 tag
15:43:15 <dalley> #topic It is not possible to skip SRPMs during sync, only together with RPMs - http://pulp.plan.io/issues/3440
15:43:15 <pulpbot> dalley: 7 issues left to triage: 3440, 3441, 3443, 3444, 3445, 3446, 3447
15:43:16 <pulpbot> Issue #3440 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:43:17 <pulpbot> It is not possible to skip SRPMs during sync, only together with RPMs - http://pulp.plan.io/issues/3440
15:43:33 <daviddavis> story?
15:43:49 <ttereshc> it depends how to look at it
15:44:03 <ttereshc> if it's a story than it should go into 2.16
15:44:11 <ttereshc> s/than/then/
15:44:28 <ttereshc> so it should be done by Tuesday
15:44:38 <daviddavis> why 2.16?
15:44:44 <ttereshc> for downstream
15:45:26 <dkliban> i think it's a bug
15:45:28 <ttereshc> it should be done in ~5 weeks for downstream, and downstream will use 2.16 as a base
15:45:43 <dalley> !propose other convert to story, high prio, add to sprint
15:45:43 <dalley> #idea Proposed for #3440: convert to story, high prio, add to sprint
15:45:43 <pulpbot> dalley: Proposed for #3440: convert to story, high prio, add to sprint
15:45:45 <daviddavis> I'm hesitant to classify something as a bug just so we have more time to work on it
15:45:58 <dkliban> daviddavis: let's discuss after triage
15:46:03 <daviddavis> dkliban: ok
15:46:11 <dalley> leave as issue for now?
15:46:20 <daviddavis> skip I would say
15:46:21 <daviddavis> ?
15:46:23 <dkliban> skip
15:46:27 <ttereshc> !propose skip
15:46:27 <ttereshc> #idea Proposed for #3440: Skip this issue for this triage session.
15:46:27 <pulpbot> ttereshc: Proposed for #3440: Skip this issue for this triage session.
15:46:31 <dalley> !accept
15:46:31 <dalley> #agreed Skip this issue for this triage session.
15:46:31 <pulpbot> dalley: Current proposal accepted: Skip this issue for this triage session.
15:46:32 <pulpbot> dalley: 6 issues left to triage: 3441, 3443, 3444, 3445, 3446, 3447
15:46:32 <dalley> #topic Syncing does not properly handle roles which have no versions - http://pulp.plan.io/issues/3441
15:46:33 <pulpbot> Issue #3441 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:46:34 <pulpbot> Syncing does not properly handle roles which have no versions - http://pulp.plan.io/issues/3441
15:47:08 <dkliban> accept
15:47:24 <daviddavis> that works for me. although it's kind of a story I guess
15:47:29 <daviddavis> I'll follow up with bmbouter
15:47:44 <ttereshc> convert to a story? or skip?
15:47:55 <daviddavis> convert to a story and accept
15:47:58 <daviddavis> I think
15:48:07 <daviddavis> or no accept I guess since it's a story
15:48:11 <ttereshc> !propose other convert to a story
15:48:11 <ttereshc> #idea Proposed for #3441: convert to a story
15:48:11 <pulpbot> ttereshc: Proposed for #3441: convert to a story
15:48:33 <ttereshc> !propose other convert to a story and daviddavis will follow up with bmbouter
15:48:33 <ttereshc> #idea Proposed for #3441: convert to a story and daviddavis will follow up with bmbouter
15:48:33 <pulpbot> ttereshc: Proposed for #3441: convert to a story and daviddavis will follow up with bmbouter
15:49:01 <dalley> does someone want to handle updating the wording of the issue for story?
15:49:30 <dalley> ah, just noticed it's empty
15:49:55 <dalley> !accept
15:49:55 <dalley> #agreed convert to a story and daviddavis will follow up with bmbouter
15:49:55 <pulpbot> dalley: Current proposal accepted: convert to a story and daviddavis will follow up with bmbouter
15:49:56 <pulpbot> dalley: 5 issues left to triage: 3443, 3444, 3445, 3446, 3447
15:49:57 <dalley> #topic As an API user, I want to upload skopeo tar components individually - http://pulp.plan.io/issues/3443
15:49:57 <pulpbot> Issue #3443 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:49:58 <pulpbot> As an API user, I want to upload skopeo tar components individually - http://pulp.plan.io/issues/3443
15:50:21 <ipanova> let's skip this for now
15:50:28 <daviddavis> can we at least convert to a story?
15:50:38 <asmacdo> sure
15:50:45 <ipanova> btw, it is not a pulp issue
15:50:47 <ipanova> but skopeo
15:50:58 <dalley> daviddavis, I can't edit ansible issues, you will have to do that for now
15:50:58 <misa> ipanova: is it not related to the one about uploading individual blobs?
15:50:58 <ipanova> because skopeo does not do partial output
15:51:20 <ipanova> misa: it is, and i am in progress or replying on the list
15:51:31 <dalley> !propose other convert to story
15:51:32 <dalley> #idea Proposed for #3443: convert to story
15:51:32 <pulpbot> dalley: Proposed for #3443: convert to story
15:51:35 <ipanova> but let's convert this to the story not to lose time
15:51:38 <asmacdo> +1
15:51:41 <ttereshc> +1
15:51:48 <dalley> !accept
15:51:48 <dalley> #agreed convert to story
15:51:48 <pulpbot> dalley: Current proposal accepted: convert to story
15:51:49 <dalley> #topic I can sign packages ONLY with gpg, and only with one key - http://pulp.plan.io/issues/3444
15:51:50 <pulpbot> dalley: 4 issues left to triage: 3444, 3445, 3446, 3447
15:51:51 <pulpbot> Issue #3444 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:51:52 <pulpbot> I can sign packages ONLY with gpg, and only with one key - http://pulp.plan.io/issues/3444
15:52:21 <misa> (the reason I joined the meeting :-)
15:52:33 <dkliban> i think this is a duplicate ... but i haven't found the other issue yet
15:52:57 <dkliban> either way, there is a PR for it already
15:53:29 <daviddavis> is this a story?
15:53:44 <daviddavis> probably should be at POST too
15:53:45 <misa> daviddavis: it's a bug to me :-) it can be argued either way
15:53:58 <dkliban> it's a story i think
15:54:17 <misa> daviddavis: the PR is not complete yet, I will change to POST as soon as I am done
15:54:47 <daviddavis> cool
15:55:04 <misa> +0 to convert to story
15:55:18 <daviddavis> !propose convert to story
15:55:18 <pulpbot> daviddavis: Error: "propose" is not a valid command.
15:55:29 <dkliban> +1
15:55:29 <daviddavis> !propose other convert to story
15:55:29 <daviddavis> #idea Proposed for #3444: convert to story
15:55:29 <pulpbot> daviddavis: Proposed for #3444: convert to story
15:55:51 <dalley> dkliban, if you run across the original, could you follow up with making sure one of the two gets marked closed-dup?
15:56:00 <dalley> or anyone, really
15:56:25 <dkliban> yeah
15:56:33 <dalley> !accept
15:56:33 <dalley> #agreed convert to story
15:56:33 <pulpbot> dalley: Current proposal accepted: convert to story
15:56:35 <dalley> #topic I can delete content units that are being actively used by tasks - http://pulp.plan.io/issues/3445
15:56:35 <pulpbot> dalley: 3 issues left to triage: 3445, 3446, 3447
15:56:36 <pulpbot> Issue #3445 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:56:37 <pulpbot> I can delete content units that are being actively used by tasks - http://pulp.plan.io/issues/3445
15:58:13 <dalley> #idea Proposed for #3445: Priority: Normal, Severity: High
15:58:13 <dalley> !propose triage normal high
15:58:14 <pulpbot> dalley: Proposed for #3445: Priority: Normal, Severity: High
15:58:47 <daviddavis> works for me
15:58:50 <dkliban> +1
15:59:18 <ttereshc> +1
15:59:25 <dalley> !accept
15:59:25 <dalley> #agreed Priority: Normal, Severity: High
15:59:25 <pulpbot> dalley: Current proposal accepted: Priority: Normal, Severity: High
15:59:26 <pulpbot> dalley: 2 issues left to triage: 3446, 3447
15:59:26 <dalley> #topic Using null=True with CharField and TextField is a no-op and recommended against by the Django & DRF docs - http://pulp.plan.io/issues/3446
15:59:27 <pulpbot> Issue #3446 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:59:28 <pulpbot> Using null=True with CharField and TextField is a no-op and recommended against by the Django & DRF docs - http://pulp.plan.io/issues/3446
15:59:40 <daviddavis> this is also a problem in core btw
15:59:51 <daviddavis> I think
16:00:11 <dalley> only in a couple places I think.  I did look and most of the places where null=True was being used, blank=True and unique=True were also being used, which makes it acceptable
16:00:20 <daviddavis> I see
16:00:24 <dalley> but I agree we should look over it closer
16:00:33 <dalley> maybe those flags aren't necessary
16:00:47 <dalley> *in all places
16:00:58 <daviddavis> accept?
16:01:12 <ttereshc> !propose accept
16:01:12 <ttereshc> #idea Proposed for #3446: Leave the issue as-is, accepting its current state.
16:01:12 <pulpbot> ttereshc: Proposed for #3446: Leave the issue as-is, accepting its current state.
16:01:28 <dalley> +1
16:01:32 <dkliban> +1
16:01:59 <dalley> !accept
16:01:59 <dalley> #agreed Leave the issue as-is, accepting its current state.
16:01:59 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
16:02:00 <pulpbot> dalley: 1 issues left to triage: 3447
16:02:01 <dalley> #topic Document the differences between stories/tasks/issues - http://pulp.plan.io/issues/3447
16:02:01 <pulpbot> Issue #3447 [NEW] (unassigned) - Priority: Normal | Severity: Medium
16:02:02 <pulpbot> Document the differences between stories/tasks/issues - http://pulp.plan.io/issues/3447
16:02:15 <dalley> !propose accept
16:02:15 <dalley> #idea Proposed for #3447: Leave the issue as-is, accepting its current state.
16:02:16 <pulpbot> dalley: Proposed for #3447: Leave the issue as-is, accepting its current state.
16:02:17 <daviddavis> kind of opened this because I wasn't sure if this already exists?
16:02:27 <dkliban> i'd say this is a task
16:02:27 <asmacdo> im working on this for the contributor docs
16:02:40 <daviddavis> dkliban: I disagree
16:02:41 <daviddavis> jk
16:02:45 <dkliban> LOL
16:02:50 <daviddavis> but it's hard to agree without knowing what a task is :)
16:02:56 <dkliban> i know
16:03:04 <ttereshc> +1 to daviddavis disagreement :P
16:03:08 <daviddavis> ha
16:03:11 <daviddavis> task works for me
16:03:21 <dalley> #idea Proposed for #3447: convert to task, make a subtask of contributor docs task
16:03:21 <dalley> !propose other convert to task, make a subtask of contributor docs task
16:03:21 <pulpbot> dalley: Proposed for #3447: convert to task, make a subtask of contributor docs task
16:03:29 <daviddavis> +1
16:03:29 <dalley> assuming a contributor docs task exists?
16:04:01 <daviddavis> asmacdo: ^
16:04:14 <asmacdo> yeah, ill take care of the paperwork
16:04:20 <daviddavis> thx
16:04:26 <dalley> cool thanks
16:04:32 <ttereshc> +1
16:04:41 <dalley> !accept
16:04:41 <dalley> #agreed convert to task, make a subtask of contributor docs task
16:04:41 <pulpbot> dalley: Current proposal accepted: convert to task, make a subtask of contributor docs task
16:04:43 <pulpbot> dalley: No issues to triage.
16:04:46 <dalley> !end
16:04:46 <dalley> #endmeeting