14:30:06 <dalley> #startmeeting Pulp Triage 2018-03-16
14:30:06 <dalley> #info dalley has joined triage
14:30:07 <pulpbot> Meeting started Fri Mar 16 14:30:06 2018 UTC and is due to finish in 60 minutes.  The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:07 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:07 <pulpbot> The meeting name has been set to 'pulp_triage_2018_03_16'
14:30:07 <pulpbot> dalley: dalley has joined triage
14:30:39 <asmacdo> !here
14:30:39 <asmacdo> #info asmacdo has joined triage
14:30:39 <pulpbot> asmacdo: asmacdo has joined triage
14:31:14 <daviddavis> !here
14:31:14 <daviddavis> #info daviddavis has joined triage
14:31:14 <pulpbot> daviddavis: daviddavis has joined triage
14:32:02 <mansari> !here
14:32:02 <mansari> #info mansari has joined triage
14:32:03 <pulpbot> mansari: mansari has joined triage
14:32:32 <dkliban> !here
14:32:32 <dkliban> #info dkliban has joined triage
14:32:33 <pulpbot> dkliban: dkliban has joined triage
14:32:34 <dawalker> !here
14:32:34 <dawalker> #info dawalker has joined triage
14:32:34 <pulpbot> dawalker: dawalker has joined triage
14:32:39 <dalley> !next
14:32:40 <pulpbot> dalley: 8 issues left to triage: 3460, 3472, 3473, 3474, 3475, 3476, 3487, 3497
14:32:40 <dalley> #topic Pulp does not include srpm packages when generating errata - http://pulp.plan.io/issues/3460
14:32:41 <pulpbot> Issue #3460 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:32:42 <pulpbot> Pulp does not include srpm packages when generating errata - http://pulp.plan.io/issues/3460
14:32:49 <dalley> we skipped this one last time
14:33:01 <ipanova> !here
14:33:01 <ipanova> #info ipanova has joined triage
14:33:02 <pulpbot> ipanova: ipanova has joined triage
14:34:20 <dkliban> accept ? or do we still want more discussion?
14:34:25 <ipanova> accept
14:34:34 <ipanova> there is updated description
14:34:42 <ipanova> --> @tanya tracked down the cause to here [0] where we only look at RPMs when creating a list of packages in a repo.
14:35:25 <dalley> !propose accept
14:35:25 <dalley> #idea Proposed for #3460: Leave the issue as-is, accepting its current state.
14:35:26 <pulpbot> dalley: Proposed for #3460: Leave the issue as-is, accepting its current state.
14:35:28 <dkliban> +1
14:35:33 <daviddavis> +1
14:35:34 <ipanova> +1
14:35:43 <dawalker> +1
14:35:43 <dalley> !accept
14:35:43 <dalley> #agreed Leave the issue as-is, accepting its current state.
14:35:43 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:35:44 <pulpbot> dalley: 7 issues left to triage: 3472, 3473, 3474, 3475, 3476, 3487, 3497
14:35:45 <dalley> #topic Plugin writers can define types which conflict with other plugins - http://pulp.plan.io/issues/3472
14:35:45 <pulpbot> Issue #3472 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:35:46 <pulpbot> Plugin writers can define types which conflict with other plugins - http://pulp.plan.io/issues/3472
14:36:16 <ttereshc> !here
14:36:16 <ttereshc> #info ttereshc has joined triage
14:36:16 <pulpbot> ttereshc: ttereshc has joined triage
14:37:04 <asmacdo> We don't have a mechanism to check for this, so I think this should follow the "story" guidelines
14:37:12 <dkliban> yeah ... this should be a story
14:37:15 <dalley> I like asmacdo's solution to the problem.  I also agree that it's a story
14:37:24 <daviddavis> dalley: which solution?
14:37:34 <dalley> daviddavis, see comments
14:37:36 <ipanova> daviddavis: #4 on the issue
14:37:41 <daviddavis> he mentions two solutions though, no?
14:37:50 <daviddavis> v3/content/<plugin>/<type>/
14:37:52 <daviddavis> or
14:37:58 <asmacdo> yeah content/plugin/type and content/plugin-type
14:38:00 <daviddavis> v3/content/<plugin>-<type>/
14:38:09 <daviddavis> one is a docs solution the other requires code
14:38:28 <dalley> ah I meant the 2nd
14:38:38 <dalley> !propose other convert to story
14:38:38 <dalley> #idea Proposed for #3472: convert to story
14:38:38 <pulpbot> dalley: Proposed for #3472: convert to story
14:39:08 <daviddavis> I agree on converting to a story but maybe let's discuss more what the solution should be?
14:39:17 <daviddavis> or is everyone good with v3/content/<plugin>-<type>/ ?
14:39:33 <asmacdo> once its a story, we can mark it groomed once we have consensus
14:39:33 <dkliban> not during triage
14:39:40 <dalley> ^
14:39:45 <daviddavis> dkliban: wasn't recommending during triage
14:39:49 <ipanova> daviddavis: would it be v3/content/rpm-rpm? then?
14:39:56 <asmacdo> content/rpm
14:40:14 <daviddavis> let's just convert it to a story and I'll bring it up on pulp-dev list
14:40:18 <asmacdo> +1
14:40:20 <ipanova> +1
14:40:22 <dalley> +1
14:40:23 <dawalker> +1
14:40:28 <dalley> !accept
14:40:28 <dalley> #agreed convert to story
14:40:28 <pulpbot> dalley: Current proposal accepted: convert to story
14:40:28 <mansari> +1
14:40:29 <pulpbot> dalley: 6 issues left to triage: 3473, 3474, 3475, 3476, 3487, 3497
14:40:30 <dalley> #topic No way to create api endpoints and be sure that they don't conflict with other plugins and pulpcore - http://pulp.plan.io/issues/3473
14:40:30 <pulpbot> Issue #3473 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:40:31 <pulpbot> No way to create api endpoints and be sure that they don't conflict with other plugins and pulpcore - http://pulp.plan.io/issues/3473
14:40:43 <daviddavis> I can bring this up too
14:40:55 <daviddavis> probably should be part of the same discussion
14:40:59 <ttereshc> +1
14:41:00 <dkliban> yeah
14:41:03 <dkliban> +1
14:41:11 <dalley> convert to story?
14:41:14 <daviddavis> +1
14:41:17 <dkliban> +1
14:41:18 <asmacdo> disagree that this is part of the same discussion
14:41:18 <dalley> !propose other convert to story
14:41:18 <dalley> #idea Proposed for #3473: convert to story
14:41:21 <pulpbot> dalley: Proposed for #3473: convert to story
14:41:21 <dawalker> +1
14:41:32 <asmacdo> +1 story
14:42:08 <dalley> !accept
14:42:08 <dalley> #agreed convert to story
14:42:08 <pulpbot> dalley: Current proposal accepted: convert to story
14:42:10 <pulpbot> dalley: 5 issues left to triage: 3474, 3475, 3476, 3487, 3497
14:42:10 <dalley> #topic gpg_cmd configuration option should not be accepted in repo config or overrides - http://pulp.plan.io/issues/3474
14:42:11 <pulpbot> Issue #3474 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:42:12 <pulpbot> gpg_cmd configuration option should not be accepted in repo config or overrides - http://pulp.plan.io/issues/3474
14:43:00 <dkliban> accept
14:43:16 <ttereshc> this one came up with the recent gpg feature mihai provided
14:43:16 <daviddavis> +1
14:43:19 <ttereshc> +1 to accept
14:43:28 <dalley> !propose accept
14:43:28 <dalley> #idea Proposed for #3474: Leave the issue as-is, accepting its current state.
14:43:28 <pulpbot> dalley: Proposed for #3474: Leave the issue as-is, accepting its current state.
14:43:29 <ipanova> +1
14:43:47 <dalley> add to sprint also, or is Mihai handling it?
14:44:20 <dkliban> no idea
14:44:24 <dkliban> just accept for now
14:44:27 <ttereshc> I don't know if he is handling it or not but I don't suggest to add it to the sprint anyway
14:44:42 <dalley> alright
14:44:44 <dalley> #agreed Leave the issue as-is, accepting its current state.
14:44:44 <dalley> !accept
14:44:44 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:44:45 <pulpbot> dalley: 4 issues left to triage: 3475, 3476, 3487, 3497
14:44:46 <dalley> #topic Invalid base path error could be more helpful - http://pulp.plan.io/issues/3475
14:44:46 <pulpbot> Issue #3475 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:44:47 <pulpbot> Invalid base path error could be more helpful - http://pulp.plan.io/issues/3475
14:45:10 <daviddavis> accept. easy fix maybe too?
14:45:36 <ipanova> +1
14:45:40 <dkliban> +1
14:45:43 <dawalker> +1
14:45:46 <ttereshc> +1
14:46:04 <dalley> !propose other accept and mark easy fix
14:46:05 <dalley> #idea Proposed for #3475: accept and mark easy fix
14:46:05 <pulpbot> dalley: Proposed for #3475: accept and mark easy fix
14:46:06 <dalley> !accept
14:46:06 <dalley> #agreed accept and mark easy fix
14:46:06 <pulpbot> dalley: Current proposal accepted: accept and mark easy fix
14:46:07 <pulpbot> dalley: 3 issues left to triage: 3476, 3487, 3497
14:46:07 <dalley> #topic Base path validation on distributions doesn't work depending on your hostname - http://pulp.plan.io/issues/3476
14:46:08 <pulpbot> Issue #3476 [POST] (daviddavis@redhat.com) - Priority: Normal | Severity: Medium
14:46:09 <pulpbot> Base path validation on distributions doesn't work depending on your hostname - http://pulp.plan.io/issues/3476
14:46:26 <asmacdo> s/distributor/distribution/
14:46:37 <daviddavis> just wait until we rename importers asmacdo
14:46:49 <asmacdo> lol :)
14:46:55 <ttereshc> it's in post already
14:46:59 <dalley> looks like it's already in POST so, accept and add to sprint
14:47:00 <dalley> ?
14:47:02 <daviddavis> +1
14:47:03 <ttereshc> yeah
14:47:04 <ipanova> +1
14:47:15 <daviddavis> I fixed it already since it's blocking QE
14:47:19 <dawalker> +1
14:47:24 <dalley> !propose other accept and add to sprint
14:47:24 <dalley> #idea Proposed for #3476: accept and add to sprint
14:47:24 <pulpbot> dalley: Proposed for #3476: accept and add to sprint
14:47:26 <dalley> !accept
14:47:26 <dalley> #agreed accept and add to sprint
14:47:26 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
14:47:27 <pulpbot> dalley: 2 issues left to triage: 3487, 3497
14:47:28 <dalley> #topic Investigate jenkins job failure - http://pulp.plan.io/issues/3487
14:47:28 <pulpbot> Issue #3487 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:47:29 <pulpbot> Investigate jenkins job failure - http://pulp.plan.io/issues/3487
14:47:48 <dkliban> accept and add to sprint
14:47:58 <asmacdo> +21
14:48:05 <asmacdo> er, just 1
14:48:07 <dkliban> lol
14:48:20 <ipanova> asmacdo: i thought you are so eager to fix that :D
14:48:25 <dkliban> LOL
14:48:25 <dawalker> haha
14:48:29 <dalley> !propose other accept and add to sprint
14:48:29 <dalley> #idea Proposed for #3487: accept and add to sprint
14:48:29 <pulpbot> dalley: Proposed for #3487: accept and add to sprint
14:48:39 <daviddavis> move to docker too?
14:48:45 <dkliban> sure
14:48:52 <dalley> !propose other accept and add to sprint and move to docker support
14:48:52 <dalley> #idea Proposed for #3487: accept and add to sprint and move to docker support
14:48:52 <pulpbot> dalley: Proposed for #3487: accept and add to sprint and move to docker support
14:49:12 <ttereshc> +1
14:49:42 <dkliban> +1
14:49:46 <dawalker> +1
14:50:21 <dalley> !accept
14:50:21 <dalley> #agreed accept and add to sprint and move to docker support
14:50:21 <pulpbot> dalley: Current proposal accepted: accept and add to sprint and move to docker support
14:50:23 <dalley> #topic As a user, I can upload skopeo tar that references existing layers. - http://pulp.plan.io/issues/3497
14:50:23 <pulpbot> dalley: 1 issues left to triage: 3497
14:50:24 <pulpbot> Issue #3497 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:50:25 <pulpbot> As a user, I can upload skopeo tar that references existing layers. - http://pulp.plan.io/issues/3497
14:50:30 <dkliban> convert to story
14:50:30 <asmacdo> !propose other convert to story
14:50:30 <asmacdo> #idea Proposed for #3497: convert to story
14:50:31 <pulpbot> asmacdo: Proposed for #3497: convert to story
14:50:44 <ttereshc> +1
14:50:45 <daviddavis> +1
14:50:54 <dalley> +1
14:50:58 <dawalker> +1
14:51:01 <dalley> !accept
14:51:01 <dalley> #agreed convert to story
14:51:01 <pulpbot> dalley: Current proposal accepted: convert to story
14:51:02 <pulpbot> dalley: No issues to triage.
14:51:04 <dalley> !end
14:51:04 <dalley> #endmeeting