14:34:24 <dalley> #startmeeting Pulp Triage 2018-03-27
14:34:24 <dalley> #info dalley has joined triage
14:34:25 <pulpbot> Meeting started Tue Mar 27 14:34:24 2018 UTC and is due to finish in 60 minutes.  The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:34:25 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:34:25 <pulpbot> The meeting name has been set to 'pulp_triage_2018_03_27'
14:34:25 <pulpbot> dalley: dalley has joined triage
14:34:27 <milan_> lol :D
14:34:34 <asmacdo> !here
14:34:34 <asmacdo> #info asmacdo has joined triage
14:34:34 <pulpbot> asmacdo: asmacdo has joined triage
14:34:51 <dalley> !next
14:34:52 <pulpbot> dalley: 3 issues left to triage: 3521, 3524, 3525
14:34:52 <dalley> #topic last_override_config exposes sensitive info - http://pulp.plan.io/issues/3521
14:34:53 <pulpbot> Issue #3521 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:34:54 <pulpbot> last_override_config exposes sensitive info - http://pulp.plan.io/issues/3521
14:35:05 <milan_> !here
14:35:05 <milan_> #info milan_ has joined triage
14:35:05 <pulpbot> milan_: milan_ has joined triage
14:35:20 <bmbouter> I was thinking this would be fixed by a feature
14:35:54 <bmbouter> unless the "sensitive" fields are the same on all pulp systems
14:36:20 <asmacdo> is there a reason we need last_override_config to be exposed at all?
14:36:23 <bmbouter> another option is to hide all fields
14:36:36 <bmbouter> probably only for convenience
14:37:03 <ipanova> asmacdo: not really
14:37:06 <bmbouter> if we did that we could do it as a bugfix
14:37:14 <ipanova> it is needed for force-full sync logic
14:37:25 <bmbouter> and just accept
14:37:43 <dkliban> !here
14:37:43 <dkliban> #info dkliban has joined triage
14:37:43 <pulpbot> dkliban: dkliban has joined triage
14:38:00 <asmacdo> !propose other accept and hide last_override_config in API
14:38:00 <asmacdo> #idea Proposed for #3521: accept and hide last_override_config in API
14:38:00 <pulpbot> asmacdo: Proposed for #3521: accept and hide last_override_config in API
14:38:09 <ipanova> bmbouter: about which feature fix you talking about?
14:38:13 <dalley> +1 asmacdo
14:38:21 <ipanova> +1
14:38:43 <dkliban> +1
14:38:55 <dawalker> +1
14:38:58 <bmbouter> ipanova this issue which I was thinking would be fixed by a feature
14:39:04 <bmbouter> but +1 to removing it altogether
14:39:18 <dalley> !accept
14:39:18 <dalley> #agreed accept and hide last_override_config in API
14:39:18 <pulpbot> dalley: Current proposal accepted: accept and hide last_override_config in API
14:39:19 <pulpbot> dalley: 2 issues left to triage: 3524, 3525
14:39:20 <dalley> #topic Changeset exception during sync - http://pulp.plan.io/issues/3524
14:39:20 <pulpbot> Issue #3524 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:39:21 <pulpbot> Changeset exception during sync - http://pulp.plan.io/issues/3524
14:39:54 <bmbouter> daviddavis and I were going to look into this
14:40:01 <bmbouter> he was requesting it be put onto the sprint
14:40:18 <asmacdo> lets convert to a story but leave ungroomed for now
14:40:28 <dalley> w/r/t that last one, can I also mark easy fix?
14:40:40 <dalley> and sprint candiate?
14:40:59 <asmacdo> dalley: sprint candidate yes, easy fix no. we don't want this to be a "starter" bug
14:41:09 <dalley> cool
14:41:11 <asmacdo> it probably will be easy though
14:42:30 <dalley> I think I'm +1 on add to sprint and I don't see why it should be converted to story?
14:43:04 <dalley> 3524 that is
14:43:04 <asmacdo> either story or refactor
14:43:15 <asmacdo> the problem is that the only fields on an Artifact are digests
14:43:27 <asmacdo> so I'm not seeing how they can be referenced without digests
14:43:58 <dkliban> let's add to sprint
14:44:01 <dkliban> and accept as is
14:44:13 <dkliban> we can figure out more details as some planning happens
14:44:15 <dalley> !propose other accept and add to sprint
14:44:15 <dalley> #idea Proposed for #3524: accept and add to sprint
14:44:15 <pulpbot> dalley: Proposed for #3524: accept and add to sprint
14:44:52 <asmacdo> im fine with someone working on it for this sprint, but it seems like an important design change
14:45:33 <ipanova> daviddavis: mentioned it's a blocker for plugins
14:45:40 <bmbouter> yeah we also have a beta item to look at the changesets overall
14:45:57 <bmbouter> so I think we're kind of making our way towards that and this is one of those related pieces
14:46:22 <pcreech> RC is being smashed now
14:47:08 <bmbouter> ty I'll prepare announcements
14:47:22 <dalley> so, what is the action here?
14:47:26 <ipanova> !propose other add to sprint and mark related to another "beta item to look at the changesets overall"
14:47:26 <ipanova> #idea Proposed for #3524: add to sprint and mark related to another beta item to look at the changesets overall
14:47:26 <ipanova> #info ipanova has joined triage
14:47:27 <pulpbot> ipanova: ipanova has joined triage
14:47:28 <pulpbot> ipanova: Proposed for #3524: add to sprint and mark related to another beta item to look at the changesets overall
14:47:38 <ipanova> bmbouter: whis is which? ^^
14:47:57 <dalley> is the "beta item" an actual issue or is it just a list item on an etherpad somewhere
14:48:11 <dkliban> it's an item in an etherpad and mojo
14:48:14 <asmacdo> its really unclear how this is going to be fixed, and it seems like a design change
14:48:30 <bmbouter> we need to talk through the changeset design anyway
14:48:58 <asmacdo> yeah, but we arent putting "impement changeset changes" on the sprint until we discuss the design
14:49:14 <ipanova> let's just accept this
14:49:30 <bmbouter> I think david's reasoning actually was that it is plugin blocking
14:49:36 <ipanova> jeff is out, changesets won't be reviewed until then i guess
14:49:49 <dalley> !propose accept, continue discussion, figure out what precisely to do with the issue later
14:49:49 <pulpbot> dalley: Error: "propose" is not a valid command.
14:49:52 <dkliban> exactly ... so it's pointless to discuss further now
14:49:55 <asmacdo> i agree on the importance, im just asking for a proposal
14:49:58 <dalley> !propose other accept, continue discussion, figure out what precisely to do with the issue later
14:49:58 <dalley> #idea Proposed for #3524: accept, continue discussion, figure out what precisely to do with the issue later
14:49:58 <pulpbot> dalley: Proposed for #3524: accept, continue discussion, figure out what precisely to do with the issue later
14:50:12 <bmbouter> david's request was to put it on to the sprint
14:50:13 <dkliban> asmacdo: we need to get some input from jortel
14:50:19 <bmbouter> yeah definitly
14:50:27 <dkliban> and he is out
14:50:33 <bmbouter> I think that is what he means when he says he wants to take it as assigned
14:50:42 <bmbouter> haha a lot of pronouns
14:50:48 <dkliban> yeah :(
14:50:59 <asmacdo> who wants to take this as assigned?
14:50:59 <bmbouter> david was going to talk to jortel
14:51:07 <bmbouter> david who couldn't attend triage atm
14:51:38 <bmbouter> so I'm proxying his request
14:51:38 <asmacdo> ok we can move on.
14:51:39 <dalley> "add to sprint" means actively working on it, to me
14:51:46 <ipanova> i don't want to guss what other people think, they can speak up when they are present, i propose to accept for now.
14:51:57 <dkliban> the pulp 2 issue yes
14:52:00 <dalley> +1 accept
14:52:02 <asmacdo> add to sprint means that we have accepted the design because it cant be added until its groomed
14:52:17 <bmbouter> I hear you on that
14:52:29 <dkliban> ok ... let's skip this issue for today
14:52:31 <bmbouter> but we are definitly all seeing different things in what a sprint means
14:52:34 <dalley> !accept
14:52:34 <dalley> #agreed accept, continue discussion, figure out what precisely to do with the issue later
14:52:34 <pulpbot> dalley: Current proposal accepted: accept, continue discussion, figure out what precisely to do with the issue later
14:52:36 <dalley> #topic No rpm group sync - empty comps xml - http://pulp.plan.io/issues/3525
14:52:36 <pulpbot> dalley: 1 issues left to triage: 3525
14:52:37 <pulpbot> Issue #3525 [NEW] (unassigned) - Priority: Normal | Severity: High
14:52:38 <pulpbot> No rpm group sync - empty comps xml - http://pulp.plan.io/issues/3525
14:54:34 <ipanova> that looks like regresstion
14:54:39 <ipanova> regression
14:54:48 <ipanova> if the metadata is correct
14:54:53 <ipanova> this needs investigation
14:55:29 <dalley> #idea Proposed for #3525: Priority: High, Severity: Medium
14:55:29 <dalley> !propose triage high medium
14:55:29 <pulpbot> dalley: Proposed for #3525: Priority: High, Severity: Medium
14:55:35 <dalley> !propose triage normal high
14:55:35 <dalley> #idea Proposed for #3525: Priority: Normal, Severity: High
14:55:35 <pulpbot> dalley: Proposed for #3525: Priority: Normal, Severity: High
14:56:04 <dalley> I forget if we automatically mark regressions higher sev/prio
14:56:05 <dkliban> +1
14:56:10 <ipanova> +1
14:56:13 <bmbouter> +1
14:56:17 <dawalker> +1
14:56:21 <dalley> #agreed Priority: Normal, Severity: High
14:56:21 <dalley> !accept
14:56:21 <pulpbot> dalley: Current proposal accepted: Priority: Normal, Severity: High
14:56:22 <pulpbot> dalley: No issues to triage.
14:56:32 <dalley> !end
14:56:32 <dalley> #endmeeting