14:29:41 <dawalker> #startmeeting Pulp Triage 2018-06-08
14:29:41 <dawalker> #info dawalker has joined triage
14:29:42 <pulpbot> Meeting started Fri Jun  8 14:29:41 2018 UTC and is due to finish in 60 minutes.  The chair is dawalker. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:42 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:42 <pulpbot> The meeting name has been set to 'pulp_triage_2018_06_08'
14:29:42 <pulpbot> dawalker: dawalker has joined triage
14:29:46 <jortel> !here
14:29:46 <jortel> #info jortel has joined triage
14:29:46 <pulpbot> jortel: jortel has joined triage
14:29:46 <dkliban> !here
14:29:46 <dkliban> #info dkliban has joined triage
14:29:47 <pulpbot> dkliban: dkliban has joined triage
14:29:59 <dalley> !here
14:29:59 <dalley> #info dalley has joined triage
14:29:59 <pulpbot> dalley: dalley has joined triage
14:30:04 <ttereshc> #info ttereshc has joined triage
14:30:04 <ttereshc> !here
14:30:04 <pulpbot> ttereshc: ttereshc has joined triage
14:30:15 <asmacdo> !here
14:30:15 <asmacdo> #info asmacdo has joined triage
14:30:16 <pulpbot> asmacdo: asmacdo has joined triage
14:30:17 <bizhang> !here
14:30:17 <bizhang> #info bizhang has joined triage
14:30:18 <pulpbot> bizhang: bizhang has joined triage
14:30:20 <dawalker> Alright, we have a lot of bugs today, so let's get started!
14:30:20 <daviddavis> #info daviddavis has joined triage
14:30:20 <daviddavis> !here
14:30:21 <pulpbot> daviddavis: daviddavis has joined triage
14:30:21 <dawalker> !next
14:30:23 <dawalker> #topic When the checksum type of the upstream repository changed, syncing a "on_demand" repository will fail - http://pulp.plan.io/issues/3736
14:30:23 <pulpbot> dawalker: 10 issues left to triage: 3736, 3737, 3738, 3739, 3742, 3743, 3745, 3747, 3748, 3749
14:30:25 <pulpbot> Issue #3736 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:30:26 <pulpbot> When the checksum type of the upstream repository changed, syncing a "on_demand" repository will fail - http://pulp.plan.io/issues/3736
14:30:36 <dawalker> ttereshc, what's the update on this?
14:30:41 <ttereshc> it's a bug
14:30:51 <ttereshc> !propose accept
14:30:51 <ttereshc> #idea Proposed for #3736: Leave the issue as-is, accepting its current state.
14:30:51 <pulpbot> ttereshc: Proposed for #3736: Leave the issue as-is, accepting its current state.
14:30:52 <ipanova> !here
14:30:52 <ipanova> #info ipanova has joined triage
14:30:52 <pulpbot> ipanova: ipanova has joined triage
14:31:05 <dawalker> +1
14:31:06 <bmbouter> !here
14:31:06 <bmbouter> #info bmbouter has joined triage
14:31:06 <pulpbot> bmbouter: bmbouter has joined triage
14:31:34 <ipanova> +1
14:31:42 <dawalker> !accept
14:31:42 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:31:42 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:31:44 <dawalker> #topic [tests only] memory error in unittests when mock.MagicMock(parent='anything') is used - http://pulp.plan.io/issues/3737
14:31:44 <pulpbot> dawalker: 9 issues left to triage: 3737, 3738, 3739, 3742, 3743, 3745, 3747, 3748, 3749
14:31:45 <pulpbot> Issue #3737 [ASSIGNED] (amacdona@redhat.com) - Priority: Normal | Severity: Medium
14:31:46 <pulpbot> [tests only] memory error in unittests when mock.MagicMock(parent='anything') is used - http://pulp.plan.io/issues/3737
14:31:56 <dkliban> +1
14:32:02 <ttereshc> it's assigned
14:32:12 <asmacdo> !propose accept
14:32:12 <asmacdo> #idea Proposed for #3737: Leave the issue as-is, accepting its current state.
14:32:12 <pulpbot> asmacdo: Proposed for #3737: Leave the issue as-is, accepting its current state.
14:32:19 <ttereshc> does it mean it's already kinda on the sprint?
14:32:32 <jortel> seems that way
14:32:53 <dawalker> !accept
14:32:53 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:32:53 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:32:54 <dawalker> #topic update plugin_template to work with latest pulpcore - http://pulp.plan.io/issues/3738
14:32:55 <pulpbot> dawalker: 8 issues left to triage: 3738, 3739, 3742, 3743, 3745, 3747, 3748, 3749
14:32:56 <pulpbot> Issue #3738 [ASSIGNED] (amacdona@redhat.com) - Priority: Normal | Severity: Medium
14:32:57 <pulpbot> update plugin_template to work with latest pulpcore - http://pulp.plan.io/issues/3738
14:33:16 <asmacdo> accept and add to sprint
14:33:20 <dawalker> This one is also assigned
14:33:28 <dawalker> !propose accept and add to sprint
14:33:28 <pulpbot> dawalker: propose accept Propose accepting the current issue in its current state.
14:33:28 <asmacdo> i'm doing this as part of the bootstrap docker work
14:33:30 <bizhang> isn't 3737 just a PSA?
14:33:32 <dawalker> ah, ok
14:33:46 <bizhang> maybe it should be closed, since there's no actions to take for it
14:33:48 <asmacdo> bizhang: no, it also needs changes
14:33:52 <dawalker> !accept
14:33:52 <pulpbot> dawalker: No action proposed, nothing to accept.
14:33:54 <bizhang> asmacdo, ack
14:34:01 <bmbouter> I think we should delete plugin_template
14:34:06 <bmbouter> it's crazy out of date
14:34:08 <daviddavis> +1
14:34:10 <asmacdo> not anymore
14:34:13 <asmacdo> ive got it working
14:34:24 <dawalker> !propose accept
14:34:24 <dawalker> #idea Proposed for #3738: Leave the issue as-is, accepting its current state.
14:34:24 <pulpbot> dawalker: Proposed for #3738: Leave the issue as-is, accepting its current state.
14:34:27 <dawalker> !accept
14:34:27 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:34:27 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:34:28 <pulpbot> dawalker: 7 issues left to triage: 3739, 3742, 3743, 3745, 3747, 3748, 3749
14:34:29 <dawalker> #topic Migrations failure during vagrant up - http://pulp.plan.io/issues/3739
14:34:29 <pulpbot> Issue #3739 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:34:30 <pulpbot> Migrations failure during vagrant up - http://pulp.plan.io/issues/3739
14:34:40 <daviddavis> wait, I don't think we agreed on 3738
14:34:49 <bmbouter> yup
14:35:11 <dawalker> Oh, ok, since it was assigned as the previous, I moved on, sorry.
14:35:23 <ttereshc> dawalker, you can go back with !issue 3738
14:35:31 <dawalker> !issue 3738
14:35:31 <dawalker> #topic update plugin_template to work with latest pulpcore - http://pulp.plan.io/issues/3738
14:35:32 <pulpbot> Issue #3738 [ASSIGNED] (amacdona@redhat.com) - Priority: Normal | Severity: Medium
14:35:33 <pulpbot> update plugin_template to work with latest pulpcore - http://pulp.plan.io/issues/3738
14:35:33 <asmacdo> the template is really useful for bootstrapping plugins
14:35:33 <dawalker> thanks ttereshc
14:35:48 <daviddavis> I guess my concern is that it'll get out of date again
14:35:53 <asmacdo> it probably will
14:35:59 <asmacdo> i have some ideas for this
14:36:01 <bmbouter> that and also that pulp2 is the main priority
14:36:37 <asmacdo> well, it didnt take long to bring it back up to date enough to function
14:36:54 <daviddavis> I'm tempted to wait-and-see then
14:37:03 <asmacdo> and it took less time to fix it and use it to create the bootstrapped docker than it would have to write from scratch
14:37:57 <daviddavis> anyway, maybe we can discuss in another way. if it's fixed for now, we should probably just continue with triage.
14:38:11 <jortel> agreed
14:38:23 <asmacdo> +1, i can put together my ideas for the template and send to pulp-dev
14:38:30 <daviddavis> ok, sounds good. thanks asmacdo
14:39:08 <dawalker> !propose other pulp-dev discussion
14:39:08 <dawalker> #idea Proposed for #3738: pulp-dev discussion
14:39:08 <pulpbot> dawalker: Proposed for #3738: pulp-dev discussion
14:39:49 <ttereshc> +1
14:39:51 <daviddavis> +1
14:39:52 <jortel> +1
14:39:56 <dawalker> !accept
14:39:56 <dawalker> #agreed pulp-dev discussion
14:39:57 <pulpbot> dawalker: Current proposal accepted: pulp-dev discussion
14:39:58 <pulpbot> dawalker: 7 issues left to triage: 3739, 3742, 3743, 3745, 3747, 3748, 3749
14:39:58 <dawalker> #topic Migrations failure during vagrant up - http://pulp.plan.io/issues/3739
14:39:59 <pulpbot> Issue #3739 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:40:00 <pulpbot> Migrations failure during vagrant up - http://pulp.plan.io/issues/3739
14:40:30 <dkliban> accept and add to sprint
14:40:46 <dawalker> !propose accept and add to sprint
14:40:46 <pulpbot> dawalker: propose accept Propose accepting the current issue in its current state.
14:40:59 <bizhang> +1
14:41:03 <ttereshc> +1
14:41:21 <asmacdo> +1
14:41:22 <dawalker> +1
14:41:25 <dawalker> !accept
14:41:25 <pulpbot> dawalker: No action proposed, nothing to accept.
14:41:44 <dawalker> !propose other accept and add to sprint
14:41:44 <dawalker> #idea Proposed for #3739: accept and add to sprint
14:41:44 <pulpbot> dawalker: Proposed for #3739: accept and add to sprint
14:41:46 <dawalker> !accept
14:41:46 <dawalker> #agreed accept and add to sprint
14:41:46 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint
14:41:47 <pulpbot> dawalker: 6 issues left to triage: 3742, 3743, 3745, 3747, 3748, 3749
14:41:47 <dawalker> #topic Developer ansible installer migrations are not idempotent when used after systemd - http://pulp.plan.io/issues/3742
14:41:48 <pulpbot> Issue #3742 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:41:49 <pulpbot> Developer ansible installer migrations are not idempotent when used after systemd - http://pulp.plan.io/issues/3742
14:42:43 <asmacdo> same area as 3739, maybe we should mark them as related
14:43:17 <jortel> sounds reasonable
14:43:31 <ttereshc> asmacdo, when do you hit it?
14:43:40 <asmacdo> when you run a second time
14:43:49 <ttereshc> asmacdo, if you re-run playbook for the second time?
14:43:51 <ttereshc> manually?
14:44:05 <asmacdo> i think i did a vagrant halt, vagrant up
14:44:12 <asmacdo> but it should also happen on vagrant provision
14:44:30 <dawalker> how do you mark them as related?
14:44:43 <ttereshc> !propose accept
14:44:43 <ttereshc> #idea Proposed for #3742: Leave the issue as-is, accepting its current state.
14:44:43 <pulpbot> ttereshc: Proposed for #3742: Leave the issue as-is, accepting its current state.
14:44:47 <dawalker> is 3739 the parent?
14:44:57 <asmacdo> there is a button "Related issues" --------------------------------------------------------------------------------> [Add Button]
14:45:23 <ttereshc> yeah, it's outside of editing the issue itself
14:45:25 <dawalker> Ah, I see it now.  Was assuming it was in the edit
14:45:45 <dawalker> +1
14:46:39 <ttereshc> +1
14:46:57 <asmacdo> +1
14:46:59 <dawalker> !accept
14:46:59 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:46:59 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:47:01 <dawalker> #topic Make 3.0-dev the new master branch - http://pulp.plan.io/issues/3743
14:47:01 <pulpbot> dawalker: 5 issues left to triage: 3743, 3745, 3747, 3748, 3749
14:47:03 <pulpbot> Issue #3743 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:47:04 <pulpbot> Make 3.0-dev the new master branch - http://pulp.plan.io/issues/3743
14:47:13 <dkliban> this is done
14:47:17 <dkliban> i forgot to close it
14:47:19 <asmacdo> pulp-python
14:47:28 <ttereshc> !propose other convert to task
14:47:28 <ttereshc> #idea Proposed for #3743: convert to task
14:47:28 <pulpbot> ttereshc: Proposed for #3743: convert to task
14:47:38 <asmacdo> +1 task
14:47:40 <dkliban> oh yeah
14:47:44 <daviddavis> +1
14:47:45 <bizhang> +1
14:47:51 <jortel> +1
14:47:52 <dawalker> +1
14:47:54 <dkliban> +1
14:47:59 <daviddavis> +1
14:48:01 <dawalker> !accept
14:48:01 <dawalker> #agreed convert to task
14:48:01 <pulpbot> dawalker: Current proposal accepted: convert to task
14:48:02 <pulpbot> dawalker: 4 issues left to triage: 3745, 3747, 3748, 3749
14:48:03 <dawalker> #topic Applicability task fails if consumer is removed in the middle of the task - http://pulp.plan.io/issues/3745
14:48:03 <pulpbot> Issue #3745 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:48:04 <pulpbot> Applicability task fails if consumer is removed in the middle of the task - http://pulp.plan.io/issues/3745
14:49:09 <ttereshc> it's very easy to fix and few customers are affected by that
14:49:19 <dkliban> we should add to sprint
14:49:20 <ttereshc> it can wait the next sprint plannin though
14:49:40 <ttereshc> +1 to add to the sprint if no one objects
14:49:45 <dkliban> +1
14:49:47 <jortel> +1
14:49:54 <dawalker> #idea Proposed for #3745: accept and add to sprint
14:49:54 <dawalker> !propose other accept and add to sprint
14:49:54 <ipanova> +1
14:49:54 <pulpbot> dawalker: Proposed for #3745: accept and add to sprint
14:49:58 <dawalker> #agreed accept and add to sprint
14:49:58 <dawalker> !accept
14:49:58 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint
14:49:59 <ttereshc> +1
14:50:00 <pulpbot> dawalker: 3 issues left to triage: 3747, 3748, 3749
14:50:00 <dawalker> #topic Add a config option to the importer to accept foreign layers - http://pulp.plan.io/issues/3747
14:50:01 <pulpbot> Issue #3747 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:50:02 <pulpbot> Add a config option to the importer to accept foreign layers - http://pulp.plan.io/issues/3747
14:50:13 <dkliban> this is a story
14:50:20 <asmacdo> story +1
14:50:31 <dawalker> !propose other convert to story
14:50:31 <dawalker> #idea Proposed for #3747: convert to story
14:50:31 <pulpbot> dawalker: Proposed for #3747: convert to story
14:50:33 <ttereshc> +1
14:50:43 <ipanova> there have been some changes, we need to adapt them as well
14:51:04 <asmacdo> since it will be a story, it will be ungroomed, so i think thats ok
14:51:12 <jortel> yep
14:51:21 <dawalker> +1
14:51:23 <ttereshc> +1
14:51:34 <dawalker> !accept
14:51:34 <dawalker> #agreed convert to story
14:51:34 <pulpbot> dawalker: Current proposal accepted: convert to story
14:51:35 <pulpbot> dawalker: 2 issues left to triage: 3748, 3749
14:51:35 <dawalker> #topic documentation fails to mention that 'name' must be unique - http://pulp.plan.io/issues/3748
14:51:36 <pulpbot> Issue #3748 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:51:37 <pulpbot> documentation fails to mention that 'name' must be unique - http://pulp.plan.io/issues/3748
14:51:57 <ttereshc> !propose other accept and add to sprint
14:51:57 <ttereshc> #idea Proposed for #3748: accept and add to sprint
14:51:57 <pulpbot> ttereshc: Proposed for #3748: accept and add to sprint
14:51:57 <asmacdo> this is probably more general than the description
14:52:06 <dawalker> +1
14:52:24 <asmacdo> im betting that if uniqueness is not on those fields at that endpoint, its not included on every endpoint
14:52:55 <asmacdo> so not just name, but all unique fields
14:52:55 <jortel> agreed.  this is likely a widespread problem.
14:53:05 <ttereshc> asmacdo, mind leaving a comment?
14:53:08 <asmacdo> +1 add to sprint, ill comment
14:53:15 <ttereshc> ty
14:53:16 <jortel> +1
14:53:23 <dawalker> !accept
14:53:23 <dawalker> #agreed accept and add to sprint
14:53:23 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint
14:53:24 <pulpbot> dawalker: 1 issues left to triage: 3749
14:53:24 <dawalker> #topic Skip upload of the foreign layers - http://pulp.plan.io/issues/3749
14:53:25 <pulpbot> Issue #3749 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:53:26 <pulpbot> Skip upload of the foreign layers - http://pulp.plan.io/issues/3749
14:53:41 <ipanova> i just checked we already cover this use case
14:53:49 <ipanova> we can close it
14:54:11 <ttereshc> !propose other close as WORKFORME
14:54:11 <ttereshc> #idea Proposed for #3749: close as WORKFORME
14:54:11 <pulpbot> ttereshc: Proposed for #3749: close as WORKFORME
14:54:17 <ttereshc> !propose other close as WORKSFORME
14:54:17 <ttereshc> #idea Proposed for #3749: close as WORKSFORME
14:54:17 <pulpbot> ttereshc: Proposed for #3749: close as WORKSFORME
14:54:35 <dawalker> +1
14:54:44 <dkliban> +1
14:54:57 <dawalker> !accept
14:54:57 <dawalker> #agreed close as WORKSFORME
14:54:57 <pulpbot> dawalker: Current proposal accepted: close as WORKSFORME
14:54:58 <pulpbot> dawalker: No issues to triage.
14:55:10 <dawalker> Yay!
14:55:38 <daviddavis> !end
14:55:45 <ttereshc> :)
14:55:45 <dawalker> !end
14:55:45 <dawalker> #endmeeting