14:33:10 <dawalker> #startmeeting Pulp Triage 2018-09-07
14:33:10 <dawalker> !start
14:33:10 <dawalker> #info dawalker has joined triage
14:33:10 <pulpbot> Meeting started Fri Sep  7 14:33:10 2018 UTC and is due to finish in 60 minutes.  The chair is dawalker. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:33:10 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:33:10 <pulpbot> The meeting name has been set to 'pulp_triage_2018_09_07'
14:33:10 <pulpbot> dawalker: dawalker has joined triage
14:33:27 <dawalker> I said ten minutes when I should have said 5 so I split the difference.
14:33:33 <dawalker> Let's do this!
14:33:37 <dawalker> !next
14:33:39 <ipanova> ragbalak: your understanding is correct, rpms should have been removed along the way, the only thing is - you do not need to provide the recursive option, rpms are removed recursively by default
14:33:39 <pulpbot> dawalker: 14 issues left to triage: 3915, 3949, 3952, 3957, 3961, 3967, 3973, 3975, 3978, 3980, 3981, 3982, 3983, 3984
14:33:39 <dawalker> #topic The ArtifactFileField is deleting source files. - http://pulp.plan.io/issues/3915
14:33:40 <pulpbot> Issue #3915 [NEW] (unassigned) - Priority: High | Severity: High
14:33:41 <pulpbot> The ArtifactFileField is deleting source files. - http://pulp.plan.io/issues/3915
14:34:06 <ipanova> skip
14:34:16 <dkliban> +1
14:34:19 <dawalker> #idea Proposed for #3915: Skip this issue for this triage session.
14:34:19 <dawalker> !propose skip
14:34:19 <pulpbot> dawalker: Proposed for #3915: Skip this issue for this triage session.
14:34:22 <ragbalak> Thanks ipanova
14:34:23 <dalley> +1
14:34:25 <dawalker> #agreed Skip this issue for this triage session.
14:34:25 <dawalker> !accept
14:34:25 <pulpbot> dawalker: Current proposal accepted: Skip this issue for this triage session.
14:34:27 <dawalker> #topic The same package can have two (or more?) assigned metadata definitions - http://pulp.plan.io/issues/3949
14:34:27 <pulpbot> dawalker: 13 issues left to triage: 3949, 3952, 3957, 3961, 3967, 3973, 3975, 3978, 3980, 3981, 3982, 3983, 3984
14:34:28 <pulpbot> Issue #3949 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:34:29 <pulpbot> The same package can have two (or more?) assigned metadata definitions - http://pulp.plan.io/issues/3949
14:34:40 <ipanova> ragbalak: i can try to reproduce, but you can also open a bug
14:34:44 <dawalker> RPM team available?
14:35:00 <bmbouter> I think david was going to look at it
14:35:10 <bmbouter> to see if he could reproduce
14:35:17 <ipanova> i think rpm team had AI to try to producer this
14:35:20 <ipanova> skip
14:35:20 <dawalker> Since he's out, shall we skip for now?
14:35:22 <bmbouter> so I think skiup since he's out
14:35:25 <ragbalak> ipanova, : Sure , Will have a look once more and report if required
14:35:28 <bmbouter> ya
14:35:28 <dawalker> #idea Proposed for #3949: Skip this issue for this triage session.
14:35:28 <dawalker> !propose skip
14:35:28 <pulpbot> dawalker: Proposed for #3949: Skip this issue for this triage session.
14:35:28 <dkliban> let's skip
14:35:35 <ipanova> ragbalak: thanks!
14:35:38 <dkliban> +1
14:35:38 <dawalker> #agreed Skip this issue for this triage session.
14:35:38 <dawalker> !accept
14:35:38 <pulpbot> dawalker: Current proposal accepted: Skip this issue for this triage session.
14:35:40 <dawalker> #topic Using the ErrataRelatedModelSaver can result in creating incomplete content. - http://pulp.plan.io/issues/3952
14:35:40 <pulpbot> dawalker: 12 issues left to triage: 3952, 3957, 3961, 3967, 3973, 3975, 3978, 3980, 3981, 3982, 3983, 3984
14:35:41 <pulpbot> Issue #3952 [POST] (bmbouter) - Priority: Normal | Severity: Medium
14:35:42 <pulpbot> Using the ErrataRelatedModelSaver can result in creating incomplete content. - http://pulp.plan.io/issues/3952
14:35:46 <dawalker> Also rpm
14:35:53 <bmbouter> already at post
14:36:08 <dkliban> accept
14:36:09 <dawalker> Oh, ok.  Should we accept anyway?
14:36:14 <dawalker> #idea Proposed for #3952: Leave the issue as-is, accepting its current state.
14:36:14 <dawalker> !propose accept
14:36:15 <pulpbot> dawalker: Proposed for #3952: Leave the issue as-is, accepting its current state.
14:36:17 <bmbouter> +1
14:36:18 <dawalker> *thumbs up*
14:36:23 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:36:23 <dawalker> !accept
14:36:23 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:36:24 <dawalker> #topic  on_demand repositories should not allow remove_missing to be false - http://pulp.plan.io/issues/3957
14:36:25 <pulpbot> dawalker: 11 issues left to triage: 3957, 3961, 3967, 3973, 3975, 3978, 3980, 3981, 3982, 3983, 3984
14:36:26 <pulpbot> Issue #3957 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:27 <pulpbot> on_demand repositories should not allow remove_missing to be false - http://pulp.plan.io/issues/3957
14:36:28 <ipanova> ragbalak: i am pretty sure it was working, maybe something changed upstream with in the metadata or we managed to screw up our code
14:36:37 <dawalker> again with rpm, on a roll today
14:36:52 <dkliban> i was supposed to comment on it
14:36:55 <dkliban> let's accept for now
14:37:06 <dawalker> #idea Proposed for #3957: Leave the issue as-is, accepting its current state.
14:37:06 <dawalker> !propose accept
14:37:06 <pulpbot> dawalker: Proposed for #3957: Leave the issue as-is, accepting its current state.
14:37:41 <dawalker> !accept
14:37:41 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:37:41 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:37:42 <dawalker> #topic DeclarativeVersion doesn't respect plugin boundaries in mirror mode - http://pulp.plan.io/issues/3961
14:37:43 <pulpbot> dawalker: 10 issues left to triage: 3961, 3967, 3973, 3975, 3978, 3980, 3981, 3982, 3983, 3984
14:37:44 <pulpbot> Issue #3961 [NEW] (unassigned) - Priority: High | Severity: High
14:37:45 <pulpbot> DeclarativeVersion doesn't respect plugin boundaries in mirror mode - http://pulp.plan.io/issues/3961
14:38:32 <bmbouter> I commented on this since last time
14:38:57 <dawalker> Since we're aiming for documentation, does the ticket need altering?
14:39:01 <dalley> should we convert to a docs issue or is there a possibility of a better way?
14:39:15 <dkliban> let's do docs for now
14:39:24 <bmbouter> I was also proposing a feature
14:39:44 <bmbouter> ignore_unseen_types
14:39:52 <bmbouter> kind of a weird name
14:40:07 <dawalker> hehe, ignore those things in the dark you can't see...
14:40:12 <dawalker> but you can hear them. :D
14:40:21 <dawalker> so...accept?
14:40:30 <dkliban> accept
14:40:48 <dawalker> #idea Proposed for #3961: Leave the issue as-is, accepting its current state.
14:40:48 <dawalker> !propose accept
14:40:49 <pulpbot> dawalker: Proposed for #3961: Leave the issue as-is, accepting its current state.
14:40:53 <dkliban> +1
14:41:11 <dawalker> !accept
14:41:11 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:41:11 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:41:13 <dawalker> #topic Create a test fixture for Ansible - http://pulp.plan.io/issues/3967
14:41:13 <pulpbot> dawalker: 9 issues left to triage: 3967, 3973, 3975, 3978, 3980, 3981, 3982, 3983, 3984
14:41:14 <pulpbot> Issue #3967 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:41:15 <pulpbot> Create a test fixture for Ansible - http://pulp.plan.io/issues/3967
14:41:29 <dalley> +1 accept
14:41:59 <dawalker> #idea Proposed for #3967: Leave the issue as-is, accepting its current state.
14:41:59 <dawalker> !propose accept
14:41:59 <pulpbot> dawalker: Proposed for #3967: Leave the issue as-is, accepting its current state.
14:42:17 <bmbouter> +1
14:42:36 <dawalker> !accept
14:42:36 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:42:36 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:42:37 <dawalker> #topic As a pulp3 role user, production installs of pulpcore are handled by dependency resolution - http://pulp.plan.io/issues/3973
14:42:38 <pulpbot> dawalker: 8 issues left to triage: 3973, 3975, 3978, 3980, 3981, 3982, 3983, 3984
14:42:39 <pulpbot> Issue #3973 [ASSIGNED] (amacdona@redhat.com) - Priority: Normal | Severity: Medium
14:42:40 <pulpbot> As a pulp3 role user, production installs of pulpcore are handled by dependency resolution - http://pulp.plan.io/issues/3973
14:43:53 <bmbouter> I think accept, it's part of the greater epic
14:44:07 <dawalker> #idea Proposed for #3973: Leave the issue as-is, accepting its current state.
14:44:07 <dawalker> !propose accept
14:44:07 <pulpbot> dawalker: Proposed for #3973: Leave the issue as-is, accepting its current state.
14:44:50 <dkliban> +1
14:44:57 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:44:57 <dawalker> !accept
14:44:57 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:44:59 <pulpbot> dawalker: 7 issues left to triage: 3975, 3978, 3980, 3981, 3982, 3983, 3984
14:44:59 <dawalker> #topic pulp3-workers role should not install RQ - http://pulp.plan.io/issues/3975
14:45:00 <pulpbot> Issue #3975 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:45:01 <pulpbot> pulp3-workers role should not install RQ - http://pulp.plan.io/issues/3975
14:45:34 <dawalker> same logic
14:45:37 <dawalker> #idea Proposed for #3975: Leave the issue as-is, accepting its current state.
14:45:37 <dawalker> !propose accept
14:45:38 <pulpbot> dawalker: Proposed for #3975: Leave the issue as-is, accepting its current state.
14:45:41 <bmbouter> +1
14:45:43 <bmbouter> :)
14:45:45 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:45:45 <dawalker> !accept
14:45:45 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:45:47 <dawalker> #topic Operation postponed response contains too much information - http://pulp.plan.io/issues/3978
14:45:47 <pulpbot> dawalker: 6 issues left to triage: 3978, 3980, 3981, 3982, 3983, 3984
14:45:49 <pulpbot> Issue #3978 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:45:50 <pulpbot> Operation postponed response contains too much information - http://pulp.plan.io/issues/3978
14:46:29 <dkliban> accept ... but i filed it
14:46:44 <dawalker> #idea Proposed for #3978: Leave the issue as-is, accepting its current state.
14:46:44 <dawalker> !propose accept
14:46:44 <pulpbot> dawalker: Proposed for #3978: Leave the issue as-is, accepting its current state.
14:46:49 <dawalker> :)
14:47:42 <dawalker> *crickets*
14:47:55 <bmbouter> +1
14:48:04 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:48:04 <dawalker> !accept
14:48:04 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:48:05 <pulpbot> dawalker: 5 issues left to triage: 3980, 3981, 3982, 3983, 3984
14:48:06 <dawalker> #topic Redis only works on localhost - http://pulp.plan.io/issues/3980
14:48:06 <pulpbot> Issue #3980 [NEW] (unassigned) - Priority: Normal | Severity: High
14:48:08 <pulpbot> Redis only works on localhost - http://pulp.plan.io/issues/3980
14:48:21 <bmbouter> accept, it's part of the epic when we switch to dynaconf
14:48:25 <dalley> +1
14:48:27 <bmbouter> dyynaconfffffff
14:48:30 <dkliban> +1
14:48:35 <dawalker> hahaha
14:48:39 <dawalker> #idea Proposed for #3980: Leave the issue as-is, accepting its current state.
14:48:39 <dawalker> !propose accept
14:48:39 <pulpbot> dawalker: Proposed for #3980: Leave the issue as-is, accepting its current state.
14:48:44 <dawalker> !accept
14:48:44 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:48:44 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:48:45 <dawalker> #topic Switch Pulp3 settings to Dynaconf - http://pulp.plan.io/issues/3981
14:48:46 <pulpbot> dawalker: 4 issues left to triage: 3981, 3982, 3983, 3984
14:48:47 <pulpbot> Issue #3981 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:48:48 <pulpbot> Switch Pulp3 settings to Dynaconf - http://pulp.plan.io/issues/3981
14:48:56 <dawalker> I saw those emails
14:48:59 <dkliban> accept
14:49:12 <dawalker> #idea Proposed for #3981: Leave the issue as-is, accepting its current state.
14:49:12 <dawalker> !propose accept
14:49:12 <pulpbot> dawalker: Proposed for #3981: Leave the issue as-is, accepting its current state.
14:49:16 * bmbouter chants dynaconf
14:49:18 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:49:18 <dawalker> !accept
14:49:20 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:49:21 <dawalker> #topic Need api for Module md artifact -> rpm associations - http://pulp.plan.io/issues/3982
14:49:21 <pulpbot> dawalker: 3 issues left to triage: 3982, 3983, 3984
14:49:22 <pulpbot> Issue #3982 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:49:23 <pulpbot> Need api for Module md artifact -> rpm associations - http://pulp.plan.io/issues/3982
14:49:34 <dkliban> this ia story
14:50:01 <ipanova> which if accepted will imply a migration
14:50:27 <dkliban> it's not a bug, so we should discuss it outside of triage
14:50:31 <ipanova> +1
14:50:40 <dawalker> #idea Proposed for #3982: Skip this issue for this triage session.
14:50:40 <dawalker> !propose skip
14:50:40 <pulpbot> dawalker: Proposed for #3982: Skip this issue for this triage session.
14:50:47 <ipanova> let's convert to story and bring up on rpm meeting
14:50:58 <dawalker> Who wants to take point on converting to a story?
14:51:13 <dawalker> #idea Proposed for #3982: convert to story
14:51:13 <dawalker> !propose other convert to story
14:51:14 <pulpbot> dawalker: Proposed for #3982: convert to story
14:51:28 <dkliban> i will
14:51:52 <dawalker> #agreed convert to story
14:51:52 <dawalker> !accept
14:51:52 <pulpbot> dawalker: Current proposal accepted: convert to story
14:51:53 <dawalker> thank you
14:51:53 <pulpbot> dawalker: 2 issues left to triage: 3983, 3984
14:51:53 <dawalker> #topic Still seeing lots of docker images when specifying --tags - http://pulp.plan.io/issues/3983
14:51:54 <pulpbot> Issue #3983 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:51:55 <pulpbot> Still seeing lots of docker images when specifying --tags - http://pulp.plan.io/issues/3983
14:52:13 <dkliban> accept and add to sprint
14:52:23 <ipanova> i take as we can close it
14:52:28 <ipanova> as not a bug :)
14:52:33 <dkliban> oh
14:52:34 <dawalker> Thank you
14:52:43 <dawalker> #idea Proposed for #3983: close as not a bug
14:52:43 <dawalker> !propose other close as not a bug
14:52:44 <pulpbot> dawalker: Proposed for #3983: close as not a bug
14:52:50 <ipanova> dkliban: wants to assign all the bugs in the world on himself :-P
14:52:55 <dawalker> hehe
14:53:04 <dkliban> +1
14:53:07 <dawalker> #agreed close as not a bug
14:53:07 <dawalker> !accept
14:53:08 <pulpbot> dawalker: Current proposal accepted: close as not a bug
14:53:09 <dawalker> #topic Remove Python 3.5 Support - http://pulp.plan.io/issues/3984
14:53:09 <pulpbot> dawalker: 1 issues left to triage: 3984
14:53:10 <pulpbot> Issue #3984 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:53:11 <pulpbot> Remove Python 3.5 Support - http://pulp.plan.io/issues/3984
14:53:29 <dkliban> not a bug
14:53:35 <dkliban> let's convert to a task
14:53:39 <dkliban> i'll do it
14:53:46 <dawalker> thank you
14:53:51 <dawalker> #idea Proposed for #3984: convert to task
14:53:51 <dawalker> !propose other convert to task
14:53:52 <pulpbot> dawalker: Proposed for #3984: convert to task
14:54:07 <dawalker> dkliban++
14:54:11 <pulpbot> dawalker: dkliban's karma is now 137
14:54:15 <dawalker> ipanova++
14:54:16 <pulpbot> dawalker: ipanova's karma is now 30
14:54:32 <dawalker> #agreed convert to task
14:54:32 <dawalker> !accept
14:54:32 <pulpbot> dawalker: Current proposal accepted: convert to task
14:54:33 <pulpbot> dawalker: No issues to triage.
14:54:41 <dawalker> #endmeeting
14:54:41 <dawalker> !end