14:29:59 <dawalker> #startmeeting Pulp Triage 2018-09-14
14:29:59 <dawalker> !start
14:29:59 <pulpbot> Meeting started Fri Sep 14 14:29:59 2018 UTC and is due to finish in 60 minutes.  The chair is dawalker. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:59 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:59 <pulpbot> The meeting name has been set to 'pulp_triage_2018_09_14'
14:29:59 <dawalker> #info dawalker has joined triage
14:30:00 <pulpbot> dawalker: dawalker has joined triage
14:31:03 <asmacdo> #info asmacdo has joined triage
14:31:03 <asmacdo> !here
14:31:04 <pulpbot> asmacdo: asmacdo has joined triage
14:31:43 <daviddavis> !here
14:31:43 <daviddavis> #info daviddavis has joined triage
14:31:44 <pulpbot> daviddavis: daviddavis has joined triage
14:32:10 <dalley> #info dalley has joined triage
14:32:10 <dalley> !here
14:32:11 <pulpbot> dalley: dalley has joined triage
14:32:20 <bmbouter> #info bmbouter has joined triage
14:32:20 <bmbouter> !here
14:32:20 <pulpbot> bmbouter: bmbouter has joined triage
14:32:55 <dawalker> !next
14:32:56 <pulpbot> dawalker: 5 issues left to triage: 3915, 3949, 3999, 4002, 4009
14:32:57 <dawalker> #topic The ArtifactFileField is deleting source files. - http://pulp.plan.io/issues/3915
14:32:57 <pulpbot> Issue #3915 [NEW] (unassigned) - Priority: High | Severity: High
14:32:58 <pulpbot> The ArtifactFileField is deleting source files. - http://pulp.plan.io/issues/3915
14:33:04 <dawalker> Are we still skipping this?
14:33:22 <dawalker> I know some discussion has happened/been requested on list since last time.
14:33:23 <daviddavis> no, there's new discussion
14:33:26 <daviddavis> yea
14:33:33 <daviddavis> so this is some validation + update our docs?
14:33:49 <bmbouter> yeah this should be triaged
14:33:52 <bmbouter> this is ready
14:33:58 <dawalker> cool
14:34:04 <dawalker> #idea Proposed for #3915: Leave the issue as-is, accepting its current state.
14:34:04 <dawalker> !propose accept
14:34:04 <pulpbot> dawalker: Proposed for #3915: Leave the issue as-is, accepting its current state.
14:34:04 <bmbouter> jortel was right to keep bringing this up
14:34:15 <dawalker> errr..
14:34:19 <dawalker> my brain today
14:34:34 <dawalker> should we add to sprint?
14:34:42 <dawalker> or are we just marking it triaged for now?
14:34:46 <daviddavis> I could go either way
14:34:51 <bmbouter> I think add to sprint
14:34:56 <bmbouter> it's like 20 min of work
14:34:59 <daviddavis> does it need to be high priority?
14:35:00 <dawalker> ah, ok then
14:35:05 <bmbouter> no
14:35:08 <bmbouter> I don't think so
14:35:11 <bmbouter> just something to be done
14:35:17 <daviddavis> +1
14:35:27 <dawalker> #idea Proposed for #3915: accept and add to sprint, change priority to normal
14:35:27 <dawalker> !propose other accept and add to sprint, change priority to normal
14:35:27 <pulpbot> dawalker: Proposed for #3915: accept and add to sprint, change priority to normal
14:35:33 <daviddavis> that works
14:35:35 <asmacdo> +add pulp3 tag
14:35:42 <bmbouter> +1
14:36:10 <dawalker> !accept
14:36:10 <dawalker> #agreed accept and add to sprint, change priority to normal
14:36:10 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint, change priority to normal
14:36:11 <dawalker> #topic Repositories can end up with RPMs with duplicate nevra after copy - http://pulp.plan.io/issues/3949
14:36:12 <pulpbot> dawalker: 4 issues left to triage: 3949, 3999, 4002, 4009
14:36:13 <pulpbot> Issue #3949 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:14 <pulpbot> Repositories can end up with RPMs with duplicate nevra after copy - http://pulp.plan.io/issues/3949
14:36:26 <dawalker> this also was skipped
14:36:29 <dawalker> daviddavis, status?
14:36:35 <daviddavis> I updated it
14:36:56 <daviddavis> basically, I reproduced it
14:36:58 <dawalker> ah ok cool
14:37:11 <dawalker> #idea Proposed for #3949: Leave the issue as-is, accepting its current state.
14:37:11 <dawalker> !propose accept
14:37:11 <pulpbot> dawalker: Proposed for #3949: Leave the issue as-is, accepting its current state.
14:37:34 <ttereshc> #info ttereshc has joined triage
14:37:34 <ttereshc> !here
14:37:35 <pulpbot> ttereshc: ttereshc has joined triage
14:37:50 <daviddavis> +1 from me. would be interested to hear others' thoughts.
14:39:02 <daviddavis> let's just accept it then
14:39:05 <ttereshc> +1, it seems you are right that duplicates are not removed after copy
14:39:12 <daviddavis> ok
14:39:21 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:39:21 <dawalker> !accept
14:39:21 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:39:22 <pulpbot> dawalker: 3 issues left to triage: 3999, 4002, 4009
14:39:23 <dawalker> #topic Publishing incorrect branch head. - http://pulp.plan.io/issues/3999
14:39:23 <pulpbot> Issue #3999 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:39:24 <pulpbot> Publishing incorrect branch head. - http://pulp.plan.io/issues/3999
14:39:44 <ttereshc> accept
14:40:11 <ttereshc> valid bug, we discussed it a lot and jortel is creating a PoC
14:40:15 <daviddavis> +1
14:40:24 <dawalker> #idea Proposed for #3999: Leave the issue as-is, accepting its current state.
14:40:24 <dawalker> !propose accept
14:40:24 <pulpbot> dawalker: Proposed for #3999: Leave the issue as-is, accepting its current state.
14:40:27 <daviddavis> looks nasty
14:40:34 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:40:34 <dawalker> !accept
14:40:34 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:40:36 <dawalker> #topic pulp-admin doesn't support uploading modular errata - http://pulp.plan.io/issues/4002
14:40:36 <pulpbot> dawalker: 2 issues left to triage: 4002, 4009
14:40:37 <pulpbot> Issue #4002 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:40:38 <pulpbot> pulp-admin doesn't support uploading modular errata - http://pulp.plan.io/issues/4002
14:40:57 <ipanova> !here
14:40:57 <ipanova> #info ipanova has joined triage
14:40:57 <pulpbot> ipanova: ipanova has joined triage
14:41:19 <dawalker> another for rpm support
14:41:22 <ipanova> accept
14:41:31 <ttereshc> I believe it accepts json right now
14:41:33 <dawalker> #idea Proposed for #4002: Leave the issue as-is, accepting its current state.
14:41:33 <dawalker> !propose accept
14:41:33 <pulpbot> dawalker: Proposed for #4002: Leave the issue as-is, accepting its current state.
14:41:40 <ttereshc> that's how rcm uploads it
14:41:49 <ipanova> looks like cli needs to be updated to handle modular changes?
14:41:52 <ttereshc> so JSON should work, we can test though
14:42:14 <ttereshc> +1 that it's not supported in cli
14:42:20 <bmbouter> shouldn't this be a story?
14:42:26 <ttereshc> I would set a priority to low
14:42:37 <ttereshc> no one uses cli to upload errata
14:42:47 <daviddavis> I do
14:42:49 <ipanova> bmbouter: no it gets broken once we merge the modular errata changes
14:42:50 <daviddavis> jk
14:43:00 <ttereshc> :)
14:43:01 <ipanova> lol
14:43:05 <bmbouter> oic
14:43:09 <ipanova> i would just accept this
14:43:37 <ttereshc> when daviddavis is in a depression and really wants to upload errata that way to avoid JSON, he can fix it ;)
14:43:38 <daviddavis> +1
14:43:45 <daviddavis> hehe
14:43:48 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:43:48 <dawalker> !accept
14:43:48 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:43:49 <pulpbot> dawalker: 1 issues left to triage: 4009
14:43:49 <dawalker> #topic Make a OidCertificateGuard that is ported from Pulp2 - http://pulp.plan.io/issues/4009
14:43:50 <pulpbot> Issue #4009 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:43:51 <pulpbot> Make a OidCertificateGuard that is ported from Pulp2 - http://pulp.plan.io/issues/4009
14:43:56 <daviddavis> story
14:43:58 <bmbouter> +1
14:44:00 <ttereshc> +1
14:44:01 <ipanova> ttereshc: is a badass today
14:44:02 * daviddavis shames bmbouter
14:44:36 <dawalker> #idea Proposed for #4009: convert to story
14:44:36 <dawalker> !propose other convert to story
14:44:37 <pulpbot> dawalker: Proposed for #4009: convert to story
14:44:40 <bmbouter> haha
14:44:42 <dawalker> who wants to take point on that?
14:45:04 <bmbouter> I will b/c it needs soome more details
14:45:11 <dawalker> bmbouter++
14:45:13 <pulpbot> dawalker: bmbouter's karma is now 82
14:45:36 <dawalker> !accept
14:45:36 <dawalker> #agreed convert to story
14:45:36 <pulpbot> dawalker: Current proposal accepted: convert to story
14:45:37 <pulpbot> dawalker: No issues to triage.
14:45:44 <dawalker> #endmeeting
14:45:44 <dawalker> !end