14:32:13 <dawalker> #startmeeting Pulp Triage 2018-10-19
14:32:13 <dawalker> !start
14:32:13 <dawalker> #info dawalker has joined triage
14:32:13 <pulpbot> Meeting started Fri Oct 19 14:32:13 2018 UTC and is due to finish in 60 minutes.  The chair is dawalker. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:32:13 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:32:13 <pulpbot> The meeting name has been set to 'pulp_triage_2018_10_19'
14:32:13 <pulpbot> dawalker: dawalker has joined triage
14:32:17 <daviddavis> #info daviddavis has joined triage
14:32:17 <daviddavis> !here
14:32:17 <pulpbot> daviddavis: daviddavis has joined triage
14:32:20 <daviddavis> first!
14:32:20 <asmacdo> #info asmacdo has joined triage
14:32:20 <asmacdo> !here
14:32:20 <pulpbot> asmacdo: asmacdo has joined triage
14:32:25 <asmacdo> dang
14:32:51 <asmacdo> daviddavis++
14:32:53 <pulpbot> asmacdo: daviddavis's karma is now 122
14:33:04 <dalley> #info dalley has joined triage
14:33:04 <dalley> !here
14:33:05 <pulpbot> dalley: dalley has joined triage
14:33:57 <dawalker> if that's the way we're gonna be...*I'm* first :D
14:34:04 <daviddavis> :(
14:34:21 <dawalker> lol, no you can keep the lead, daviddavis
14:34:25 <daviddavis> :D
14:34:29 <dawalker> !kirby
14:34:29 <pulpbot> (>'-')> <('-'<) ^('-')^ v('-')v(>'-')> (^-^)
14:34:43 <dawalker> Alright, let's do this
14:34:47 <dawalker> !next
14:34:48 <dawalker> #topic Licensing Options fo Plugin Writers - http://pulp.plan.io/issues/4080
14:34:49 <pulpbot> dawalker: 7 issues left to triage: 4080, 4081, 4083, 4084, 4085, 4086, 4092
14:34:50 <pulpbot> Issue #4080 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:34:51 <pulpbot> Licensing Options fo Plugin Writers - http://pulp.plan.io/issues/4080
14:35:05 <dawalker> We skipped this last week waiting on feedback from legal
14:35:12 <dawalker> bmbouter, update? ^
14:35:21 <daviddavis> we're still waiting on feedback from legal. is this maybe a task though?
14:35:36 <dawalker> Yeah, I think so
14:35:50 <asmacdo> +1 task
14:36:07 <dawalker> #idea Proposed for #4080: convert to task
14:36:07 <dawalker> !propose other convert to task
14:36:07 <pulpbot> dawalker: Proposed for #4080: convert to task
14:36:11 <asmacdo> Probably already overloaded, but also seems like a good pulpcon topic
14:36:47 <dawalker> Agreed, it's really interesting, bmbouter shared a little bit about it the other day.
14:37:04 <daviddavis> our schedule is full but if we can drop something else then +1 from me.
14:37:17 <milan> #info milan has joined triage
14:37:17 <milan> !here
14:37:17 <pulpbot> milan: milan has joined triage
14:37:35 <dawalker> probably won't need a full time slot, can probably fit it in with other discussions somewhere...
14:37:45 <dawalker> #agreed convert to task
14:37:45 <dawalker> !accept
14:37:45 <pulpbot> dawalker: Current proposal accepted: convert to task
14:37:46 <dawalker> #topic Recommend usage of pip-compile for production deployments of Pulp - http://pulp.plan.io/issues/4081
14:37:47 <pulpbot> dawalker: 6 issues left to triage: 4081, 4083, 4084, 4085, 4086, 4092
14:37:48 <pulpbot> Issue #4081 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:37:49 <pulpbot> Recommend usage of pip-compile for production deployments of Pulp - http://pulp.plan.io/issues/4081
14:38:13 <daviddavis> I'll put licensing on the planning pad
14:38:15 <daviddavis> at least
14:38:27 <dawalker> +1, thanks
14:38:53 <asmacdo> !propose accept
14:38:53 <asmacdo> #idea Proposed for #4081: Leave the issue as-is, accepting its current state.
14:38:54 <pulpbot> asmacdo: Proposed for #4081: Leave the issue as-is, accepting its current state.
14:39:08 <daviddavis> +1
14:39:13 <milan> +1
14:39:26 <dawalker> +1
14:39:29 <asmacdo> oh also, story or task
14:39:44 <dawalker> story?
14:39:47 <dawalker> i think
14:39:50 <asmacdo> sure.
14:40:21 <dawalker> #idea Proposed for #4081: accept and convert to story
14:40:21 <dawalker> !propose other accept and convert to story
14:40:21 <pulpbot> dawalker: Proposed for #4081: accept and convert to story
14:40:29 <asmacdo> FYI, I think we ought to consider pipenv instead. AFAICT it's the future of piptools
14:40:55 <daviddavis> asmacdo: want to leave a comment to that effect?
14:40:58 <dawalker> ok.  Do you want to help ensure this gets converted to story and that conversation is started in the comments?
14:41:09 <asmacdo> I'll comment on it, just suggesting that it's not ready to be groomed
14:41:15 <dawalker> ah
14:41:18 <daviddavis> cool
14:41:26 <dawalker> Ok, in that case, shall we skip for now?
14:41:42 <daviddavis> no, we should convert it at least to a story or task
14:41:48 <asmacdo> I think it's fine to accept as an ungroomed story
14:42:03 <daviddavis> asmacdo: can you convert it when you go to comment?
14:42:06 <dawalker> ok
14:42:19 <asmacdo> yup, I'll get this one
14:42:28 <dawalker> great
14:42:35 <dawalker> #agreed accept and convert to story
14:42:35 <dawalker> !accept
14:42:35 <pulpbot> dawalker: Current proposal accepted: accept and convert to story
14:42:37 <pulpbot> dawalker: 5 issues left to triage: 4083, 4084, 4085, 4086, 4092
14:42:37 <dawalker> #topic Non-sensitive information is not being displayed for last_override_config - http://pulp.plan.io/issues/4083
14:42:38 <pulpbot> Issue #4083 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:42:39 <pulpbot> Non-sensitive information is not being displayed for last_override_config - http://pulp.plan.io/issues/4083
14:42:51 <daviddavis> just accept this
14:43:22 <dawalker> #idea Proposed for #4083: Leave the issue as-is, accepting its current state.
14:43:22 <dawalker> !propose accept
14:43:23 <pulpbot> dawalker: Proposed for #4083: Leave the issue as-is, accepting its current state.
14:43:35 <asmacdo> isn't "non-sensitive" info going to carry plugin to plugin?
14:44:05 <daviddavis> not sure I understand?
14:44:08 <asmacdo> whitelist seems right, but plugins may also need a way to extend the whitelist
14:44:18 <daviddavis> yea
14:44:34 <dawalker> makes sense
14:44:41 <asmacdo> cool +1 accept, I'll add a comment
14:44:58 <dawalker> thanks again
14:45:01 <dawalker> asmacdo++
14:45:04 <pulpbot> dawalker: asmacdo's karma is now 62
14:45:08 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:45:08 <dawalker> !accept
14:45:09 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:45:10 <pulpbot> dawalker: 4 issues left to triage: 4084, 4085, 4086, 4092
14:45:10 <dawalker> #topic When Pulp checks for remote files, reword the log message to sound non-fatal - http://pulp.plan.io/issues/4084
14:45:11 <pulpbot> Issue #4084 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:45:12 <pulpbot> When Pulp checks for remote files, reword the log message to sound non-fatal - http://pulp.plan.io/issues/4084
14:45:59 <daviddavis> I vote accept
14:46:20 <milan> +1 I'd prefer debug level
14:46:32 <milan> * in case you know, have to debug stuff ;)
14:46:38 <daviddavis> hehe
14:46:41 <bherring> +1
14:46:42 <asmacdo> -0 I think I (as a user) would want to know when things didn't download
14:46:46 <dawalker> !propose accept
14:46:46 <dawalker> #idea Proposed for #4084: Leave the issue as-is, accepting its current state.
14:46:47 <pulpbot> dawalker: Proposed for #4084: Leave the issue as-is, accepting its current state.
14:47:09 <asmacdo> Info seems appropriate to me, rewording would be my preference
14:47:28 <milan> asmacdo, it would show in the debug level
14:47:48 <milan> or we could do both: debug level with codes and details
14:47:57 <milan> info level for user
14:48:04 <milan> overkill?
14:48:18 <asmacdo> maybe. Either way we can accept.
14:48:23 <bherring> well, the submitter didn't want "failed" and "404" in the output
14:48:37 <asmacdo> +1 that's totally reasonable
14:48:44 <dawalker> Also, if you'd contribute these thoughts to the comments for it to track the discussion, that'd be great
14:48:45 <milan> yeah OT +1 accept discuss on issue
14:49:04 * asmacdo has a lot of homework
14:49:11 <bherring> +1
14:49:17 <dawalker> And I think this sounds like once the discussion is done, maybe this would be a good candidate for vlada or ppicka ?
14:49:23 <daviddavis> lol asmacdo
14:49:31 <dawalker> or both since it's in multiple plugins as noted in the comments
14:49:32 <asmacdo> good call dawalker
14:49:45 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:49:45 <dawalker> !accept
14:49:45 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:49:47 <pulpbot> dawalker: 3 issues left to triage: 4085, 4086, 4092
14:49:47 <daviddavis> it's a hard change. I think nectar logs this
14:49:47 <dawalker> #topic ContentUnitSaver stage is vulnerable to race conditions. - http://pulp.plan.io/issues/4085
14:49:48 <pulpbot> Issue #4085 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:49:49 <pulpbot> ContentUnitSaver stage is vulnerable to race conditions. - http://pulp.plan.io/issues/4085
14:50:14 <dawalker> oh, ok, daviddavis I defer to you.  I am unfamiliar with nectar
14:50:22 <asmacdo> Oh that's a good point daviddavis. I've been spoiled by pulp3.
14:50:26 <daviddavis> hehe
14:50:52 <daviddavis> I vote accept on this
14:51:01 <asmacdo> +100
14:51:10 <asmacdo> maybe add to the Sprint too?
14:51:23 <dawalker> #idea Proposed for #4085: accept and add to sprint
14:51:23 <dawalker> !propose other accept and add to sprint
14:51:24 <pulpbot> dawalker: Proposed for #4085: accept and add to sprint
14:51:35 <daviddavis> +1
14:51:49 <dawalker> #agreed accept and add to sprint
14:51:49 <dawalker> !accept
14:51:49 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint
14:51:51 <dawalker> #topic ArtifactSaver stage is vulnerable to race conditions. - http://pulp.plan.io/issues/4086
14:51:51 <pulpbot> dawalker: 2 issues left to triage: 4086, 4092
14:51:53 <pulpbot> Issue #4086 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:51:54 <pulpbot> ArtifactSaver stage is vulnerable to race conditions. - http://pulp.plan.io/issues/4086
14:51:55 <milan> +1 tho sounds like a feature ;)
14:52:43 <dawalker> Same here?
14:52:57 <daviddavis> +1
14:53:05 <milan> +1 I guess
14:53:21 <dawalker> #idea Proposed for #4086: accept and add to sprint
14:53:21 <dawalker> !propose other accept and add to sprint
14:53:21 <pulpbot> dawalker: Proposed for #4086: accept and add to sprint
14:53:24 <milan> they might be manifestations of the same issue tho
14:53:25 <asmacdo> no, it's a bug in the existing stages imo
14:53:35 <dawalker> milan, a feature to have race conditions or a feature to save us from them/
14:53:36 <dawalker> ?
14:53:57 <milan> a feature as one instance might have passed ;)
14:54:19 <asmacdo> I'm fine with a story
14:54:48 <milan> jortel, is it the same issue or but in the existing stages?  http://pulp.plan.io/issues/4086 vs http://pulp.plan.io/issues/4085
14:54:58 <milan> *bug
14:55:00 <jortel> !here
14:55:00 <jortel> #info jortel has joined triage
14:55:01 <pulpbot> jortel: jortel has joined triage
14:55:17 <asmacdo> There's 2 existing stages, both have the same problem
14:55:33 <jortel> corect
14:55:48 <milan> cool, then probably it's going to be one patch fixing, no?
14:55:53 <jortel> This is a known problem in the 2 core stages.  I mainly wanted to document it.
14:55:53 <asmacdo> Well 4 stages if you consider query existing and save to work together
14:56:12 <milan> hmm
14:56:37 <asmacdo> They should be related, but I think separate is correct
14:56:37 <jortel> anything doing query-save logic is vulnerable to the same race condition.
14:57:29 <dawalker> so...accept and add to sprint?
14:57:36 <jortel> if any other stages than the 2 I identified are doing this we need bugs filed on them too.
14:58:16 <asmacdo> jortel, the race condition is between the query stage and the save stage, which are separate
14:58:52 <jortel> asmacdo: right, the issue is with the save stages
14:59:13 <asmacdo> how about we just convert to an ungroomed story
14:59:18 <jortel> mainly that save stages cannot rely on the query stage
14:59:23 <asmacdo> We can add to the Sprint after we groom
14:59:32 <asmacdo> +1 jortel
14:59:42 <jortel> I think it's an issue, not a story.
14:59:47 <milan> sounds more and more feature to me, how that would be fixed?
15:00:29 <asmacdo> jortel I agree it's an issue, but the story pipeline might be useful so we can groom it before someone starts on it
15:00:41 <jortel> milan: the typical pattern for concurrent systems is to try: insert; catch the dup key and query to get the existing one.
15:01:10 <jortel> asmacdo: agreed.  the fix wrt bulk_create() will require a bit of thought.
15:01:25 <jortel> solving for bulk_create() may be really hard.
15:02:04 <jortel> but the main problem is that users will see syncs fail with random integrety errors which will be concerning to them.
15:02:07 <milan> jortel, right, the second query is susceptible to the same race, no (removed after added)?
15:02:23 <asmacdo> Yeah. We could just leave these as is, and add SerialSave stages along side, and leave it to the plugin writer to know what they need to do
15:03:09 <jortel> how do folks feel about prio/sev?
15:03:19 <jortel> let's start there for triage
15:04:16 <jortel> given that users will see random IntegretyError ..
15:04:43 <milan> log.error -> log.debugg and call it a day ;)
15:04:57 <asmacdo> I think this should be high priority. It also makes plugin development a pain
15:05:07 <asmacdo> lol milan
15:05:17 <jortel> +1
15:05:20 <dawalker> shall we call for discussion on issue?
15:05:21 <jortel> milan: :)
15:05:55 <milan> dawalker, I think the discussion will emerge on its own ;)
15:06:02 <dawalker> So, accept and add to sprint?  Do we want to change this one and the previous one both to high priority?
15:06:09 <dawalker> milan, true
15:06:11 <jortel> suggest we set to high/med and triage.  we can design on the issue before putting on a sprint.  this should be marked as GA blocker.
15:06:25 <asmacdo> +1 jortel
15:06:29 <dawalker> +1
15:06:47 <milan> +1 , provided it can be treated as documentation issue any time
15:06:49 <milan> ;)
15:07:08 <dawalker> !propose other high/med, accept, mark as GA blocker
15:07:08 <dawalker> #idea Proposed for #4086: high/med, accept, mark as GA blocker
15:07:09 <pulpbot> dawalker: Proposed for #4086: high/med, accept, mark as GA blocker
15:07:55 <asmacdo> Also +tag "painintheass"
15:08:07 <milan> lol asmacdo +1 :D
15:08:10 <dawalker> lol
15:08:20 <jortel> fyi, this was noted on the stages pr with agreement to merge anyway.  these issues are a follow up.
15:08:32 <jortel> to be sure it
15:08:37 <jortel> it's corrected before ga
15:08:54 <milan> aaahhh, K makes sense now jortel
15:08:58 <dawalker> #agreed high/med, accept, mark as GA blocker
15:08:58 <dawalker> !accept
15:08:59 <pulpbot> dawalker: Current proposal accepted: high/med, accept, mark as GA blocker
15:09:00 <pulpbot> dawalker: 2 issues left to triage: 4077, 4092
15:09:00 <dawalker> #topic pulpcore can't be installed in a Django site that also ships a a custom User object - http://pulp.plan.io/issues/4077
15:09:01 <pulpbot> Issue #4077 [POST] (unassigned) - Priority: Normal | Severity: Medium
15:09:02 <pulpbot> pulpcore can't be installed in a Django site that also ships a a custom User object - http://pulp.plan.io/issues/4077
15:09:05 <dawalker> where do I mark as ga blocker?
15:09:19 <jortel> milan: yeah, that's what I meant by "known".
15:09:31 <asmacdo> POST accept
15:09:51 <dawalker> #idea Proposed for #4077: Leave the issue as-is, accepting its current state.
15:09:51 <dawalker> !propose accept
15:09:51 <pulpbot> dawalker: Proposed for #4077: Leave the issue as-is, accepting its current state.
15:10:11 <jortel> +1
15:10:28 <milan> +1
15:10:35 <dawalker> #agreed Leave the issue as-is, accepting its current state.
15:10:35 <dawalker> !accept
15:10:35 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:10:37 <dawalker> #topic redirect_host defaults to socket.getfqdn() instead of None - http://pulp.plan.io/issues/4092
15:10:37 <pulpbot> dawalker: 1 issues left to triage: 4092
15:10:39 <pulpbot> Issue #4092 [POST] (evgeni) - Priority: Normal | Severity: Medium
15:10:40 <pulpbot> redirect_host defaults to socket.getfqdn() instead of None - http://pulp.plan.io/issues/4092
15:10:49 <Zhenech> that's mine <3
15:11:25 <dawalker> thanks Zhenech
15:12:09 <asmacdo> nice bug report Zhenech
15:12:34 <dawalker> #idea Proposed for #4092: Leave the issue as-is, accepting its current state.
15:12:34 <dawalker> !propose accept
15:12:35 <pulpbot> dawalker: Proposed for #4092: Leave the issue as-is, accepting its current state.
15:12:35 <milan> Zhenech ++ I think it's legit
15:12:45 <milan> +1
15:13:42 <asmacdo> Yeah I think accept, and if necessary further discussion can be had on the PR.
15:14:04 <dawalker> #agreed Leave the issue as-is, accepting its current state.
15:14:04 <dawalker> !accept
15:14:04 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:14:05 <pulpbot> dawalker: No issues to triage.
15:14:11 <dawalker> #endmeeting
15:14:11 <dawalker> !end