15:30:41 <dawalker> #startmeeting Pulp Triage 2018-11-27
15:30:41 <dawalker> #info dawalker has joined triage
15:30:42 <pulpbot> Meeting started Tue Nov 27 15:30:41 2018 UTC and is due to finish in 60 minutes.  The chair is dawalker. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:42 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:42 <pulpbot> The meeting name has been set to 'pulp_triage_2018_11_27'
15:30:42 <pulpbot> dawalker: dawalker has joined triage
15:30:46 <asmacdo> #info asmacdo has joined triage
15:30:46 <asmacdo> !here
15:30:46 <pulpbot> asmacdo: asmacdo has joined triage
15:31:00 <bmbouter> #info bmbouter has joined triage
15:31:00 <bmbouter> !here
15:31:00 <pulpbot> bmbouter: bmbouter has joined triage
15:31:05 <daviddavis> #info daviddavis has joined triage
15:31:05 <daviddavis> !here
15:31:05 <pulpbot> daviddavis: daviddavis has joined triage
15:31:21 <dkliban> !here
15:31:21 <dkliban> #info dkliban has joined triage
15:31:22 <pulpbot> dkliban: dkliban has joined triage
15:32:14 <dawalker> !next
15:32:15 <pulpbot> dawalker: 5 issues left to triage: 4185, 4187, 4188, 4190, 4191
15:32:15 <dawalker> #topic Content summary returns un-qualified plugin type names and counts - http://pulp.plan.io/issues/4185
15:32:16 <pulpbot> Issue #4185 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:32:17 <pulpbot> Content summary returns un-qualified plugin type names and counts - http://pulp.plan.io/issues/4185
15:32:18 <ipanova> #info ipanova has joined triage
15:32:18 <ipanova> !here
15:32:18 <pulpbot> ipanova: ipanova has joined triage
15:32:19 <milan> #info milan has joined triage
15:32:19 <milan> !here
15:32:19 <pulpbot> milan: milan has joined triage
15:32:38 <jortel> #info jortel has joined triage
15:32:38 <jortel> !here
15:32:38 <pulpbot> jortel: jortel has joined triage
15:32:41 <dkliban> accept
15:32:49 <dawalker> !propose accept
15:32:49 <dawalker> #idea Proposed for #4185: Leave the issue as-is, accepting its current state.
15:32:49 <pulpbot> dawalker: Proposed for #4185: Leave the issue as-is, accepting its current state.
15:32:55 <dalley> #info dalley has joined triage
15:32:55 <dalley> !here
15:32:55 <pulpbot> dalley: dalley has joined triage
15:33:01 <ipanova> +1
15:33:12 <dawalker> +1
15:33:21 <asmacdo> +1, this is cool. it would be a bit awkward for 1 unit plugins. ie `pulp_file.file`, but thats fine with me
15:33:43 <dawalker> #agreed Leave the issue as-is, accepting its current state.
15:33:43 <dawalker> !accept
15:33:43 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:33:44 <pulpbot> dawalker: 4 issues left to triage: 4187, 4188, 4190, 4191
15:33:45 <dawalker> #topic Pulp3's systemd unit names should not conflict with Pulp2's systemd unit names - http://pulp.plan.io/issues/4187
15:33:45 <pulpbot> Issue #4187 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:33:46 <pulpbot> Pulp3's systemd unit names should not conflict with Pulp2's systemd unit names - http://pulp.plan.io/issues/4187
15:33:48 <dalley> can it also be marked groomed?
15:33:57 <dalley> the prior one
15:33:59 <jortel> aren't content types unique across plugins?
15:34:01 <dawalker> sure
15:34:02 <daviddavis> do we groom issues?
15:34:04 <daviddavis> jortel: no
15:34:07 <dkliban> no
15:34:08 <asmacdo> dawalker: i don't think we need issues to be groomed right?
15:34:23 <asmacdo> dalley, not dawalker  ^ (silly tab)
15:34:37 <dalley> asmacdo, it's a field on the issue
15:34:37 <dawalker> either way, not grooming?
15:35:05 <dkliban> accept and add to sprint is what i think dalley wanted
15:35:13 <dalley> we've got sprint planning tomorrow
15:35:13 <bmbouter> either add now or at sprint planning
15:35:21 <bmbouter> sprint planning tomorrow was my plan
15:35:23 <bmbouter> when I filed it
15:35:49 <daviddavis> we're still taking about #4185 I think
15:35:49 <dawalker> #idea Proposed for #4187: Leave the issue as-is, accepting its current state.
15:35:49 <dawalker> !propose accept
15:35:49 <pulpbot> dawalker: Proposed for #4187: Leave the issue as-is, accepting its current state.
15:35:51 <asmacdo> lets make that a point of order to discuss grooming of issues for sprint planning (later). go ahead and mark groomed for now?
15:35:52 <dalley> never mind :P sorry for dragging off topic
15:35:57 <ipanova> let's groom this at least
15:35:59 <bmbouter> oh whoops
15:36:04 <ipanova> so it's ready for the planning
15:36:18 <dawalker> ok, that's fine too.
15:36:34 <dalley> +1 accept 4187
15:36:37 <daviddavis> +1
15:36:41 <ipanova> +1
15:36:45 <dawalker> +1
15:36:50 <dawalker> #agreed Leave the issue as-is, accepting its current state.
15:36:50 <dawalker> !accept
15:36:51 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:36:52 <pulpbot> dawalker: 3 issues left to triage: 4188, 4190, 4191
15:36:52 <dawalker> #topic As a Pulp3 user, I have containers - http://pulp.plan.io/issues/4188
15:36:53 <pulpbot> Issue #4188 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:36:54 <pulpbot> As a Pulp3 user, I have containers - http://pulp.plan.io/issues/4188
15:36:59 <daviddavis> convert to story
15:37:09 <dkliban> +1
15:37:12 <jortel> +1
15:37:14 <bmbouter> +1
15:37:16 <asmacdo> +1
15:37:26 <dawalker> #idea Proposed for #4188: convert to story
15:37:26 <dawalker> !propose other convert to story
15:37:26 <pulpbot> dawalker: Proposed for #4188: convert to story
15:37:27 <bmbouter> this is getting more work from me today in prep for tomorrow anyway
15:37:35 <dawalker> perfect
15:37:37 <bmbouter> it's just the epic, it's really the subtasks that matter
15:37:41 <bmbouter> and those don't exist yet
15:37:46 <dawalker> ok
15:37:48 <dawalker> #agreed convert to story
15:37:48 <dawalker> !accept
15:37:49 <dawalker> #topic Tag names starting with `sha256:` could cause collisions - http://pulp.plan.io/issues/4190
15:37:50 <pulpbot> dawalker: Current proposal accepted: convert to story
15:37:51 <pulpbot> dawalker: 2 issues left to triage: 4190, 4191
15:37:52 <pulpbot> Issue #4190 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:37:53 <pulpbot> Tag names starting with `sha256:` could cause collisions - http://pulp.plan.io/issues/4190
15:38:01 <dkliban> accept
15:38:01 <asmacdo> silly docker issue. we should just accept
15:38:15 <dawalker> #idea Proposed for #4190: Leave the issue as-is, accepting its current state.
15:38:15 <dawalker> !propose accept
15:38:16 <pulpbot> dawalker: Proposed for #4190: Leave the issue as-is, accepting its current state.
15:38:36 <ipanova> tag which is tagged as sha? asmacdo
15:38:55 <dkliban> ipanova: yeah
15:39:06 <ipanova> that's masochism but ok :D
15:39:13 <asmacdo> ipanova: there isn't one. just noticed it is possible when looking at regex
15:39:23 <asmacdo> purely hypothetical
15:39:36 <ipanova> let's accept it and discuss on our meeting in more details
15:39:43 <dawalker> makes sense
15:39:48 <dawalker> #agreed Leave the issue as-is, accepting its current state.
15:39:48 <dawalker> !accept
15:39:48 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:39:49 <pulpbot> dawalker: 1 issues left to triage: 4191
15:39:50 <dawalker> #topic Pulp does not support all search query strings - only name works reliably - http://pulp.plan.io/issues/4191
15:39:50 <asmacdo> yeah, we can lower prio imo
15:39:51 <pulpbot> Issue #4191 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:39:52 <pulpbot> Pulp does not support all search query strings - only name works reliably - http://pulp.plan.io/issues/4191
15:39:58 <daviddavis> I think we can close this out
15:40:07 <ipanova> asmacdo: yeah i'm ok with that
15:40:26 <dawalker> !propose other close
15:40:26 <dawalker> #idea Proposed for #4191: close
15:40:26 <pulpbot> dawalker: Proposed for #4191: close
15:40:30 <jortel> +1
15:40:36 <asmacdo> +1 close. akofink, feel free to reopen if you have a particular filter request
15:40:37 <dkliban> daviddavis: what about filtering py publication
15:40:48 <akofink> asmacdo: will do, thanks
15:40:51 <daviddavis> dkliban: what do you mean?
15:41:01 <dkliban> filter distributions for a specific publication
15:41:31 <daviddavis> is that broken or does it not exist?
15:41:43 <daviddavis> if the latter, we can open a story
15:41:49 <dkliban> i am not sure
15:41:53 <dawalker> what are we closing as?
15:41:54 <dkliban> but it's not possible irght now
15:42:02 <dawalker> won't fix/not a bug/works for me/etc
15:42:08 <asmacdo> dkliban: i didnt see a distribution filter in that issue?
15:42:31 <daviddavis> asmacdo: akofink at one point tries to filter publication by distribution
15:42:35 <daviddavis> or that's backwards
15:42:41 <daviddavis> oh no wait
15:42:45 <asmacdo> GET /pulp/api/v3/publications/ publisher==/pulp/api/v3/publishers/file/2/
15:42:46 <akofink> filter publication by publisher
15:42:55 <daviddavis> yea
15:43:08 <dalley> we only set up filters for a subset of the fields thus far
15:43:13 <akofink> or, more useful, filter publication by repo version
15:44:13 <ipanova> i suggest to skip this for now and convert to story based on usecases from akofink
15:44:15 <daviddavis> there are no filters on publications
15:44:36 <daviddavis> I vote we close out and open stories for any specific filter(s) that are needed
15:44:45 <akofink> I'll submit separate issues for each filter I need
15:44:46 <dawalker> #idea Proposed for #4191: Skip this issue for this triage session.
15:44:46 <dawalker> !propose skip
15:44:46 <pulpbot> dawalker: Proposed for #4191: Skip this issue for this triage session.
15:44:46 <asmacdo> ipanova, daviddavis +1
15:45:08 <daviddavis> akofink: great, do you know how to check what filters exist on an endpoint? it's in the api docs
15:45:15 <dawalker> !propose other close and open specific stories for needed filters
15:45:15 <dawalker> #idea Proposed for #4191: close and open specific stories for needed filters
15:45:15 <pulpbot> dawalker: Proposed for #4191: close and open specific stories for needed filters
15:45:26 <dalley> +1
15:45:36 <daviddavis> akofink: here's publications for example https://docs.pulpproject.org/en/3.0/nightly/integration-guide/rest-api/index.html#get--pulp-api-v3-publications-
15:45:47 <akofink> daviddavis: the ?format=api ?
15:45:52 <akofink> oh, thanks
15:46:37 <dawalker> so closing as...?
15:46:45 <daviddavis> +1
15:46:59 <asmacdo> notabug
15:47:11 <dkliban> sure
15:47:17 <dawalker> close enough
15:47:20 <dawalker> #agreed close and open specific stories for needed filters
15:47:20 <dawalker> !accept
15:47:22 <pulpbot> dawalker: Current proposal accepted: close and open specific stories for needed filters
15:47:23 <pulpbot> dawalker: No issues to triage.
15:47:28 <dawalker> #endmeeting
15:47:28 <dawalker> !end