15:30:01 <dawalker> #startmeeting Pulp Triage 2018-11-30
15:30:01 <dawalker> !start
15:30:01 <dawalker> #info dawalker has joined triage
15:30:01 <pulpbot> Meeting started Fri Nov 30 15:30:01 2018 UTC and is due to finish in 60 minutes.  The chair is dawalker. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:01 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:01 <pulpbot> The meeting name has been set to 'pulp_triage_2018_11_30'
15:30:02 <pulpbot> dawalker: dawalker has joined triage
15:30:05 <dkliban> #info dkliban has joined triage
15:30:05 <dkliban> !here
15:30:05 <pulpbot> dkliban: dkliban has joined triage
15:30:35 <bmbouter> #info bmbouter has joined triage
15:30:35 <bmbouter> !here
15:30:36 <pulpbot> bmbouter: bmbouter has joined triage
15:31:02 <dalley> !here
15:31:02 <dalley> #info dalley has joined triage
15:31:04 <pulpbot> dalley: dalley has joined triage
15:31:47 <dawalker> !next
15:31:48 <pulpbot> dawalker: 3 issues left to triage: 2598, 4214, 4215
15:31:49 <dawalker> #topic postgresql 9.3+ has  --data-checksums - http://pulp.plan.io/issues/2598
15:31:49 <pulpbot> Issue #2598 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:31:50 <pulpbot> postgresql 9.3+ has  --data-checksums - http://pulp.plan.io/issues/2598
15:32:09 <dawalker> so this is an old one asmacdo found and changed from task to issue to get attention
15:32:39 <dawalker> (drawn to it, not for him to get attention, me and words this morning oy)
15:34:13 <dkliban> asmacdo: i think this is outside of Pulp
15:34:48 <dkliban> perhaps the installer could do sometihng here ... but i am not sure that we should be in the business of controlling how the database starts up
15:35:07 <dkliban> or am i not understanding the suggestion here
15:35:10 <dkliban> ?
15:35:20 <dawalker> so...skip or close?
15:35:41 <dkliban> i would say close
15:36:07 <dawalker> not a bug or won't fix?
15:36:11 <dawalker> !propose close
15:36:11 <pulpbot> dawalker: Error: "propose" is not a valid command.
15:36:18 <dawalker> #idea Proposed for #2598: close
15:36:18 <dawalker> !propose other close
15:36:19 <pulpbot> dawalker: Proposed for #2598: close
15:36:29 <asmacdo> if i had a nickel for missing "other"...
15:36:39 <dawalker> yeppppp
15:36:49 <asmacdo> +1 close, maybe wontfix is best
15:37:21 <asmacdo> but leave a note, if this is still useful please reopen and clarify
15:38:03 <dawalker> agreed.
15:38:31 <dkliban> +1
15:38:39 <asmacdo> #info asmacdo has joined triage
15:38:39 <asmacdo> !here
15:38:39 <pulpbot> asmacdo: asmacdo has joined triage
15:39:01 <dawalker> #agreed close
15:39:01 <dawalker> !accept
15:39:01 <pulpbot> dawalker: Current proposal accepted: close
15:39:02 <pulpbot> dawalker: 2 issues left to triage: 4214, 4215
15:39:03 <dawalker> #topic Request body exceeded settings.DATA_UPLOAD_MAX_MEMORY_SIZE - http://pulp.plan.io/issues/4214
15:39:03 <pulpbot> Issue #4214 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:39:05 <pulpbot> Request body exceeded settings.DATA_UPLOAD_MAX_MEMORY_SIZE - http://pulp.plan.io/issues/4214
15:40:23 <dawalker> #idea Proposed for #4214: Leave the issue as-is, accepting its current state.
15:40:23 <dawalker> !propose accept
15:40:24 <pulpbot> dawalker: Proposed for #4214: Leave the issue as-is, accepting its current state.
15:40:48 <dkliban> +1
15:40:49 <dawalker> Do we want to disable the size, bump it up, or add a config option?
15:40:50 <bmbouter> +1
15:40:58 <dawalker> guess that can be discussed on the issue
15:41:01 <dawalker> or once someone takes it on
15:41:09 <dawalker> #agreed Leave the issue as-is, accepting its current state.
15:41:09 <dawalker> !accept
15:41:09 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:41:10 <dawalker> #topic Pulp does not support upload of non utf8 RPM - http://pulp.plan.io/issues/4215
15:41:11 <pulpbot> dawalker: 1 issues left to triage: 4215
15:41:12 <pulpbot> Issue #4215 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:41:13 <pulpbot> Pulp does not support upload of non utf8 RPM - http://pulp.plan.io/issues/4215
15:42:40 <bmbouter> so this interesting
15:42:50 <bmbouter> I did a lot of our utf8 stuff in pulp2
15:43:35 <bmbouter> the pulp2 behavior was to 'replace' those invalid characters with a utf-8 space for example
15:43:50 <bmbouter> after we worked the bugs out that was the final behavior
15:44:08 <bmbouter> buuuuut it's not really right because rpms per the spec are supposed to be utf8 encoded
15:44:21 <bmbouter> so pulp3 rejecting them is not incorrect
15:44:32 <bmbouter> and mutating the data (like we did in pulp2) probably is incorrect
15:44:34 <dawalker> interesting
15:44:40 <bmbouter> I can write all this on the issue
15:44:42 <bmbouter> want to skip?
15:44:50 <dawalker> Sure
15:44:54 <dawalker> #idea Proposed for #4215: Skip this issue for this triage session.
15:44:54 <dawalker> !propose skip
15:44:54 <pulpbot> dawalker: Proposed for #4215: Skip this issue for this triage session.
15:45:11 <bmbouter> +1
15:45:55 <dkliban> +1
15:46:04 <dawalker> my general tendency is to support all the things(!) but if RPMs specifically are supposed to be utf8 to be valid, then it seems proper to follow suit and reject
15:46:11 <dawalker> #agreed Skip this issue for this triage session.
15:46:11 <dawalker> !accept
15:46:11 <pulpbot> dawalker: Current proposal accepted: Skip this issue for this triage session.
15:46:12 <pulpbot> dawalker: No issues to triage.
15:46:19 <dawalker> #endmeeting