15:32:23 <dawalker> #startmeeting Pulp Triage 2018-12-04
15:32:23 <dawalker> #info dawalker has joined triage
15:32:23 <dawalker> !start
15:32:23 <pulpbot> Meeting started Tue Dec  4 15:32:23 2018 UTC and is due to finish in 60 minutes.  The chair is dawalker. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:32:23 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:32:23 <pulpbot> The meeting name has been set to 'pulp_triage_2018_12_04'
15:32:23 <pulpbot> dawalker: dawalker has joined triage
15:32:25 <dalley> #info dalley has joined triage
15:32:25 <dalley> !here
15:32:25 <pulpbot> dalley: dalley has joined triage
15:32:27 <ttereshc> #info ttereshc has joined triage
15:32:27 <ttereshc> !here
15:32:27 <pulpbot> ttereshc: ttereshc has joined triage
15:32:31 <dkliban> #info dkliban has joined triage
15:32:31 <dkliban> !here
15:32:31 <pulpbot> dkliban: dkliban has joined triage
15:33:16 <dawalker> !next
15:33:17 <pulpbot> dawalker: 2 issues left to triage: 4215, 4219
15:33:18 <dawalker> #topic Pulp does not support upload of non utf8 RPM - http://pulp.plan.io/issues/4215
15:33:18 <pulpbot> Issue #4215 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:33:20 <pulpbot> Pulp does not support upload of non utf8 RPM - http://pulp.plan.io/issues/4215
15:33:20 <daviddavis> #info daviddavis has joined triage
15:33:20 <daviddavis> !here
15:33:21 <pulpbot> daviddavis: daviddavis has joined triage
15:33:28 <jortel> #info jortel has joined triage
15:33:28 <jortel> !here
15:33:28 <pulpbot> jortel: jortel has joined triage
15:33:33 <daviddavis> accept and maybe to sprint?
15:33:51 <misa> ipanova: sent you and dkliban an email, share with others please, if you find value
15:33:52 <ttereshc> I also think it's a problem
15:34:01 <ttereshc> daviddavis, bmbouter suggested to close it
15:34:07 <dawalker> we skipped this last time but it was not a proper formatted rpm
15:34:07 <daviddavis> ah, reading it now
15:34:29 <ttereshc> the question is how many of them are in the wild
15:34:48 <bmbouter> I was hoping the bug reports against pulp3 could help let us know
15:34:58 <ttereshc> I think we handled those in pulp2 due to many reports
15:34:59 <bmbouter> since this was artifically created test data
15:35:11 <bmbouter> true
15:35:20 <bmbouter> still I don't think mutating the field is acceptable to users either
15:35:28 <dawalker> #idea Proposed for #4215: close
15:35:28 <dawalker> !propose other close
15:35:28 <pulpbot> dawalker: Proposed for #4215: close
15:35:28 <bmbouter> and that's why createrepo_c is emitting the exception (not pulp)
15:35:37 <jortel> agreed with bmbouter
15:35:50 <dkliban> i think that we should jsut tell the user what the problem is and have them fix it
15:36:14 <daviddavis> +1 to closing I think
15:36:22 <ttereshc> no objections
15:36:24 <kersom> I will write a negative test for this one
15:36:37 <asmacdo> we could modify to a "handle this error gracefully" issue
15:36:39 <kersom> since an exception has to be raised in this case
15:37:28 <ttereshc> asmacdo, actually +1
15:37:33 <ttereshc> it should not be 500
15:37:36 <kersom> yeah
15:37:43 <kersom> agree with you ttereshc
15:37:52 <daviddavis> +1. modify to be more graceful and accept.
15:37:59 <ttereshc> bmbouter, jortel,  dkliban ^
15:38:10 <bmbouter> that sounds good to me
15:38:11 <dawalker> #idea Proposed for #4215: modify to more graceful error handling and accept
15:38:11 <dawalker> !propose other modify to more graceful error handling and accept
15:38:12 <pulpbot> dawalker: Proposed for #4215: modify to more graceful error handling and accept
15:38:13 <dkliban> sounds good to me
15:38:20 <ttereshc> +1
15:38:26 <dkliban> +1
15:38:26 <dawalker> who would like to modify the issue?
15:38:28 <daviddavis> I can
15:38:32 <dawalker> thanks
15:38:36 <dawalker> #agreed modify to more graceful error handling and accept
15:38:36 <dawalker> !accept
15:38:37 <pulpbot> dawalker: Current proposal accepted: modify to more graceful error handling and accept
15:38:38 <pulpbot> dawalker: 2 issues left to triage: 4219, 4222
15:38:38 <dawalker> #topic Lazy syncing a repo with different metadata checksum types fails - http://pulp.plan.io/issues/4219
15:38:39 <pulpbot> Issue #4219 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:38:40 <pulpbot> Lazy syncing a repo with different metadata checksum types fails - http://pulp.plan.io/issues/4219
15:39:35 <ttereshc> daviddavis, how did you find it? is there any customer case?
15:39:42 <daviddavis> ttereshc: yea, see the BZ
15:40:00 <daviddavis> a number of RH repos had different checksum types in different repo md files
15:40:43 <daviddavis> for now they are working around it by republishing repos using the same checksum type for all repos but katello asked that we fix this
15:40:50 <dawalker> why do they have different types in different files to begin with?
15:40:54 <daviddavis> s/for all repos/all repo files/
15:40:59 <daviddavis> who knows
15:41:00 <ttereshc> ah I see, that's why no customer cases
15:41:24 <dawalker> #idea Proposed for #4219: Leave the issue as-is, accepting its current state.
15:41:24 <dawalker> !propose accept
15:41:25 <pulpbot> dawalker: Proposed for #4219: Leave the issue as-is, accepting its current state.
15:41:33 <asmacdo> so, would you have to publish all files to all checksum types?
15:41:49 <daviddavis> asmacdo: are you talking about pulp?
15:42:03 <asmacdo> oh thats upstream repos
15:42:05 <asmacdo> nevermind
15:42:16 <ttereshc> daviddavis, asmacdo, I *think* it was a request from CDT to have ability to configure checksum type for repomd specifically
15:42:33 * asmacdo has no business speculating here :)
15:42:33 <daviddavis> I see
15:42:37 <daviddavis> haha
15:42:54 <ttereshc> we should look into redmine issues, maybe we'll find the reason
15:43:12 <ttereshc> +1 to accept
15:43:22 <ttereshc> daviddavis, what's the priority?
15:43:31 <daviddavis> I can double check
15:43:36 <daviddavis> +1 to accept from me though
15:43:55 <ttereshc> #idea Proposed for #4219: Leave the issue as-is, accepting its current state.
15:43:55 <ttereshc> !propose accept
15:43:55 <pulpbot> ttereshc: Proposed for #4219: Leave the issue as-is, accepting its current state.
15:44:03 <dkliban> +1
15:44:06 <dawalker> #agreed Leave the issue as-is, accepting its current state.
15:44:06 <dawalker> !accept
15:44:06 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:44:07 <pulpbot> dawalker: 1 issues left to triage: 4222
15:44:08 <dawalker> #topic Remove "Notes" from Pulp - http://pulp.plan.io/issues/4222
15:44:08 <pulpbot> Issue #4222 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:44:10 <pulpbot> Remove "Notes" from Pulp - http://pulp.plan.io/issues/4222
15:44:24 <dalley> we can skip it if it needs more mailing list discussion
15:44:31 <dalley> but so far everyone is +1
15:44:45 <asmacdo> seems like we are all in agreement +1 accept
15:44:51 <dawalker> #idea Proposed for #4222: Leave the issue as-is, accepting its current state.
15:44:51 <dawalker> !propose accept
15:44:51 <pulpbot> dawalker: Proposed for #4222: Leave the issue as-is, accepting its current state.
15:44:52 <daviddavis> +1
15:44:57 <asmacdo> add to sprint?
15:45:06 <daviddavis> sure, it's an RC blocker
15:45:11 <asmacdo> IMO, seems like all RC blockers should be on sprint
15:45:15 <dawalker> #idea Proposed for #4222: accept and add to sprint
15:45:15 <dawalker> !propose other accept and add to sprint
15:45:16 <pulpbot> dawalker: Proposed for #4222: accept and add to sprint
15:45:20 <daviddavis> asmacdo: agreed
15:45:23 <asmacdo> dalley++
15:45:26 <pulpbot> asmacdo: dalley's karma is now 113
15:45:29 <asmacdo> im so glad you noticed this
15:45:34 <dawalker> #agreed accept and add to sprint
15:45:34 <dawalker> !accept
15:45:34 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint
15:45:35 <pulpbot> dawalker: No issues to triage.
15:45:38 <dawalker> #endmeeting
15:45:38 <dawalker> !end