15:34:39 <dawalker> #startmeeting Pulp Triage 2019-02-12
15:34:39 <dawalker> #info dawalker has joined triage
15:34:40 <pulpbot> Meeting started Tue Feb 12 15:34:39 2019 UTC and is due to finish in 60 minutes.  The chair is dawalker. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:34:40 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:34:40 <pulpbot> The meeting name has been set to 'pulp_triage_2019_02_12'
15:34:40 <pulpbot> dawalker: dawalker has joined triage
15:34:42 <daviddavis> #info daviddavis has joined triage
15:34:42 <daviddavis> !here
15:34:42 <pulpbot> daviddavis: daviddavis has joined triage
15:34:46 <ttereshc> !here
15:34:46 <ttereshc> #info ttereshc has joined triage
15:34:48 <pulpbot> ttereshc: ttereshc has joined triage
15:34:48 <ipanova> #info ipanova has joined triage
15:34:48 <ipanova> !here
15:34:49 <dkliban> #info dkliban has joined triage
15:34:49 <dkliban> !here
15:34:49 <pulpbot> ipanova: ipanova has joined triage
15:34:50 <pulpbot> dkliban: dkliban has joined triage
15:35:09 <dawalker> !next
15:35:10 <pulpbot> dawalker: 3 issues left to triage: 4387, 4404, 4405
15:35:11 <dawalker> #topic Epel is shipping a new version of celery which doesn't work with Pulp - http://pulp.plan.io/issues/4387
15:35:11 <pulpbot> Issue #4387 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:35:12 <asmacdo> #info asmacdo has joined triage
15:35:12 <asmacdo> !here
15:35:13 <pulpbot> Epel is shipping a new version of celery which doesn't work with Pulp - http://pulp.plan.io/issues/4387
15:35:14 <pulpbot> asmacdo: asmacdo has joined triage
15:35:18 <daviddavis> accept
15:35:26 <daviddavis> maybe add to sprint too?
15:35:36 <dkliban> yes
15:35:37 <ipanova> +1
15:36:07 <ttereshc> and what is the solution? to carry our own package?
15:36:20 <daviddavis> we already carry our own package but it's outdated by epel's version
15:36:28 <daviddavis> I think we have to look at upgrading to celery 4.2
15:36:32 <daviddavis> we're on celery 4.0
15:36:48 <dalley> 4.3
15:36:54 <daviddavis> 4.3 isn't out
15:37:04 <dawalker> !propose other accept and add to sprint
15:37:04 <dawalker> #idea Proposed for #4387: accept and add to sprint
15:37:04 <pulpbot> dawalker: Proposed for #4387: accept and add to sprint
15:37:12 <dalley> it is now according to what I saw?  maybe it's in beta
15:37:16 <bmbouter> #info bmbouter has joined triage
15:37:16 <bmbouter> !here
15:37:16 <pulpbot> bmbouter: bmbouter has joined triage
15:37:26 <ttereshc> there are so many issues around celery issues and upgrade, so I wonder if we can close some
15:37:26 <daviddavis> yea, it might be dropping soon
15:37:35 <jortel> #info jortel has joined triage
15:37:35 <jortel> !here
15:37:35 <pulpbot> jortel: jortel has joined triage
15:37:48 <bmbouter> my advice is to downgrade our users back to stable
15:38:00 <bmbouter> upgrading is going to be an endless "oh now this is broken let's invest many hours"
15:38:05 <dalley> ah, they're not done yet https://github.com/celery/celery/issues/5180#issuecomment-461094046
15:38:11 <dalley> kombu 4.3 is out but celery is not
15:38:16 <daviddavis> bmbouter: I'm fine with that
15:38:16 <ttereshc> +1 to add to sprint and discuss there
15:38:20 <dawalker> bmbouter, is that an option longterm though when they refused to downgrade epel/
15:38:22 <dawalker> ?
15:38:26 <bmbouter> celery isn't able to produce working builds that are stable
15:38:31 <daviddavis> ha
15:38:33 <bmbouter> dawalker: yes we would workaround by adjusting the repo priorities
15:38:40 <dawalker> Alright, discuss on ticket
15:38:40 <dawalker> !accept
15:38:40 <dawalker> #agreed accept and add to sprint
15:38:40 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint
15:38:41 <pulpbot> dawalker: 2 issues left to triage: 4404, 4405
15:38:42 <dawalker> #topic Sync performance degradation with RemoteArtifactSaver stage - http://pulp.plan.io/issues/4404
15:38:42 <pulpbot> Issue #4404 [POST] (gmbnomis) - Priority: Normal | Severity: Medium
15:38:43 <pulpbot> Sync performance degradation with RemoteArtifactSaver stage - http://pulp.plan.io/issues/4404
15:38:50 <ttereshc> gmbnomis++
15:38:50 <pulpbot> ttereshc: gmbnomis's karma is now 14
15:39:01 <ttereshc> rc blcoker?
15:39:04 <daviddavis> move to post and add to sprint
15:39:12 <ipanova> it is post
15:39:15 <ttereshc> I moved it to post  :)
15:39:18 <ttereshc> before triage
15:39:22 <daviddavis> ah
15:39:26 <daviddavis> +1 to rc blocker
15:39:27 <ttereshc> old tab daviddavis
15:39:27 <ipanova> sneaky ttereshc
15:39:31 <ttereshc> :P
15:39:36 <dawalker> #idea Proposed for #4404: accept and add to sprint
15:39:36 <dawalker> !propose other accept and add to sprint
15:39:37 <pulpbot> dawalker: Proposed for #4404: accept and add to sprint
15:39:40 <asmacdo> +1 to all that
15:39:48 <asmacdo> (including rc blocker
15:39:49 <asmacdo> )
15:40:04 <dawalker> #agreed accept and add to sprint
15:40:04 <dawalker> !accept
15:40:04 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint
15:40:05 <ttereshc> !propose other accept and add to sprint and add rc blocker tag
15:40:05 <dawalker> #topic Pulp 2.19master nightly ci regression at test_modularity.py - http://pulp.plan.io/issues/4405
15:40:05 <ttereshc> #idea Proposed for #4405: accept and add to sprint and add rc blocker tag
15:40:06 <pulpbot> dawalker: 1 issues left to triage: 4405
15:40:07 <pulpbot> Issue #4405 [ASSIGNED] (dalley) - Priority: Normal | Severity: Medium
15:40:08 <pulpbot> Pulp 2.19master nightly ci regression at test_modularity.py - http://pulp.plan.io/issues/4405
15:40:09 <pulpbot> ttereshc: Proposed for #4405: accept and add to sprint and add rc blocker tag
15:40:17 <ttereshc> too late
15:40:22 <ttereshc> it was for the other one, sorry
15:40:31 <ttereshc> race condition
15:40:33 <dawalker> no worries ttereshc I added rc blocker as well
15:40:44 <asmacdo> well, i think the current proposal is probably still appropriate :)
15:40:46 <dalley> accept, add to sprint. 2.19 blocker probably
15:40:54 <dalley> currently discussing with Patrick
15:40:54 <daviddavis> +1
15:40:58 <bmbouter> +1
15:40:59 <ttereshc> +1
15:41:15 <dawalker> #agreed accept and add to sprint and add rc blocker tag
15:41:15 <dawalker> !accept
15:41:15 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint and add rc blocker tag
15:41:16 <asmacdo> !propose other add to sprint 2.19 blocker
15:41:17 <pulpbot> dawalker: No issues to triage.
15:41:18 <pulpbot> asmacdo: Error: No current issue, proposal ignored.
15:41:36 <ttereshc> heh, yet another race condition
15:42:16 <asmacdo> it stings doesnt it ttereshc
15:42:28 <dawalker> Ok, I'm not sure how to put 2.19 blocker
15:42:31 <ipanova> asmacdo: x9c4 https://pulp.plan.io/issues/4406
15:42:39 <dawalker> it's not one of the dropdown options for blocks release nor a tag
15:42:51 <dawalker> other than that, ready to end triage
15:43:00 <dalley> dawalker, yeah, we should fix that
15:43:28 <dawalker> dalley, do you know how to edit those options?
15:43:40 <dalley> nope. and I don't think I have the ability to do so either
15:43:48 <daviddavis> I can add 2.19.z
15:43:53 <dawalker> thanks daviddavis
15:44:01 <dawalker> #endmeeting
15:44:01 <dawalker> !end