15:32:01 <dawalker> #startmeeting Pulp Triage 2019-02-22
15:32:01 <dawalker> #info dawalker has joined triage
15:32:02 <pulpbot> Meeting started Fri Feb 22 15:32:01 2019 UTC and is due to finish in 60 minutes.  The chair is dawalker. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:32:02 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:32:02 <pulpbot> The meeting name has been set to 'pulp_triage_2019_02_22'
15:32:02 <pulpbot> dawalker: dawalker has joined triage
15:32:19 <ttereshc> #info ttereshc has joined triage
15:32:19 <ttereshc> !here
15:32:19 <pulpbot> ttereshc: ttereshc has joined triage
15:32:29 <asmacdo> False Start, on the offence. 5 yrd penalty first down
15:32:30 <ipanova> !here
15:32:30 <ipanova> #info ipanova has joined triage
15:32:31 <pulpbot> ipanova: ipanova has joined triage
15:32:31 <asmacdo> #info asmacdo has joined triage
15:32:31 <asmacdo> !here
15:32:32 <pulpbot> asmacdo: asmacdo has joined triage
15:32:36 <dalley> #info dalley has joined triage
15:32:36 <dalley> !here
15:32:36 <pulpbot> dalley: dalley has joined triage
15:33:27 <jortel> !here
15:33:27 <jortel> #info jortel has joined triage
15:33:28 <pulpbot> jortel: jortel has joined triage
15:33:28 <bmbouter> x9c4: oh awesome
15:33:45 <bmbouter> x9c4: I can review just ping me. I won't write them since you started on them
15:34:01 <dawalker> !next
15:34:02 <dawalker> #topic Not possible delete duplicate login - http://pulp.plan.io/issues/4425
15:34:03 <pulpbot> dawalker: 11 issues left to triage: 4425, 4432, 4434, 4437, 4439, 4440, 4441, 4443, 4447, 4449, 4450
15:34:04 <pulpbot> Issue #4425 [NEW] (unassigned) - Priority: Normal | Severity: High
15:34:05 <pulpbot> Not possible delete duplicate login - http://pulp.plan.io/issues/4425
15:34:53 <asmacdo> nice job ina
15:34:55 <ttereshc> #idea Proposed for #4425: Leave the issue as-is, accepting its current state.
15:34:55 <ttereshc> !propose accept
15:34:55 <pulpbot> ttereshc: Proposed for #4425: Leave the issue as-is, accepting its current state.
15:35:16 <asmacdo> i think this needs to be changed actually
15:35:30 <asmacdo> the *real* issue is that duplicate users can be created
15:35:43 <ttereshc> +1
15:35:51 <dawalker> +1
15:35:54 <ipanova> yeah
15:36:06 <jortel> +1
15:36:25 <daviddavis> !here
15:36:25 <daviddavis> #info daviddavis has joined triage
15:36:25 <ttereshc> #idea Proposed for #4425: accept + update the title + leave instructions to unblock reporter
15:36:25 <ttereshc> !propose other accept + update the title + leave instructions to unblock reporter
15:36:25 <pulpbot> daviddavis: daviddavis has joined triage
15:36:26 <pulpbot> ttereshc: Proposed for #4425: accept + update the title + leave instructions to unblock reporter
15:36:30 <dawalker> do we have a volunteer?
15:36:31 <dkliban> #info dkliban has joined triage
15:36:31 <dkliban> !here
15:36:31 <pulpbot> dkliban: dkliban has joined triage
15:36:40 <asmacdo> +1
15:36:52 <dkliban> +1
15:37:12 <ttereshc> dawalker, I can do it
15:37:17 <dawalker> ttereshc++
15:37:17 <pulpbot> dawalker: ttereshc's karma is now 68
15:37:18 <dawalker> ty
15:37:25 <dawalker> !accept
15:37:25 <dawalker> #agreed accept + update the title + leave instructions to unblock reporter
15:37:25 <pulpbot> dawalker: Current proposal accepted: accept + update the title + leave instructions to unblock reporter
15:37:27 <dawalker> #topic Pulp upgrade from 2.7 to 2.18 logs  says Database initialization failed. - http://pulp.plan.io/issues/4432
15:37:27 <pulpbot> dawalker: 10 issues left to triage: 4432, 4434, 4437, 4439, 4440, 4441, 4443, 4447, 4449, 4450
15:37:28 <pulpbot> Issue #4432 [NEW] (unassigned) - Priority: Normal | Severity: High
15:37:29 <pulpbot> Pulp upgrade from 2.7 to 2.18 logs  says Database initialization failed. - http://pulp.plan.io/issues/4432
15:37:46 <ipanova> ttereshc: https://github.com/pulp/pulp/blob/2-master/server/pulp/server/db/model/__init__.py#L1184
15:37:52 <asmacdo> #idea Proposed for #4432: Skip this issue for this triage session.
15:37:52 <asmacdo> !propose skip
15:37:52 <pulpbot> asmacdo: Proposed for #4432: Skip this issue for this triage session.
15:38:29 <ipanova> +1
15:38:34 <daviddavis> +1 I can follow up
15:38:36 <dkliban> +1
15:38:43 <dawalker> +1, gives the person time to report if that worked
15:38:51 <ttereshc> +1
15:38:54 <dawalker> #agreed Skip this issue for this triage session.
15:38:54 <dawalker> !accept
15:38:54 <pulpbot> dawalker: Current proposal accepted: Skip this issue for this triage session.
15:38:56 <dawalker> #topic Some ClientResponseError can't try additional Remotes - http://pulp.plan.io/issues/4434
15:38:56 <pulpbot> dawalker: 9 issues left to triage: 4434, 4437, 4439, 4440, 4441, 4443, 4447, 4449, 4450
15:38:57 <pulpbot> Issue #4434 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:38:58 <pulpbot> Some ClientResponseError can't try additional Remotes - http://pulp.plan.io/issues/4434
15:39:34 <ttereshc> should we skip for now? bmbouter
15:39:46 <bmbouter> we shoiuld accept this is a legit issue
15:39:50 <dkliban> yeah
15:39:54 <jortel> yep
15:39:57 <dawalker> !propose accept
15:39:57 <dawalker> #idea Proposed for #4434: Leave the issue as-is, accepting its current state.
15:39:57 <pulpbot> dawalker: Proposed for #4434: Leave the issue as-is, accepting its current state.
15:40:00 <daviddavis> +1
15:40:18 <asmacdo> +1
15:40:20 <ipanova> +1
15:40:24 <asmacdo> bmbouter: does this need to be an rc blocker?
15:40:25 <ttereshc> ok, just didn't see clear way to reproduce it
15:40:33 <dawalker> !accept
15:40:33 <dawalker> #agreed Leave the issue as-is, accepting its current state.
15:40:33 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:40:33 <ttereshc> maybe missed it
15:40:35 <dawalker> #topic Cannot adapt BaseUrl when serving Content at a custom URL using a custom aiohttp handler - http://pulp.plan.io/issues/4437
15:40:35 <pulpbot> dawalker: 8 issues left to triage: 4437, 4439, 4440, 4441, 4443, 4447, 4449, 4450
15:40:36 <pulpbot> Issue #4437 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:40:37 <pulpbot> Cannot adapt BaseUrl when serving Content at a custom URL using a custom aiohttp handler - http://pulp.plan.io/issues/4437
15:41:03 <asmacdo> #idea Proposed for #4437: Skip this issue for this triage session.
15:41:03 <asmacdo> !propose skip
15:41:03 <pulpbot> asmacdo: Proposed for #4437: Skip this issue for this triage session.
15:41:38 <asmacdo> needs investigation, as discussed in RC blocker meeting
15:41:45 <dawalker> ^ agreed
15:41:52 <jortel> agreed
15:41:59 <dawalker> !accept
15:41:59 <dawalker> #agreed Skip this issue for this triage session.
15:41:59 <pulpbot> dawalker: Current proposal accepted: Skip this issue for this triage session.
15:42:00 <dawalker> #topic Our test suite times out in Travis after redis 3.2 was released to pypi - http://pulp.plan.io/issues/4439
15:42:01 <pulpbot> dawalker: 7 issues left to triage: 4439, 4440, 4441, 4443, 4447, 4449, 4450
15:42:02 <pulpbot> Issue #4439 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:42:03 <pulpbot> Our test suite times out in Travis after redis 3.2 was released to pypi - http://pulp.plan.io/issues/4439
15:42:33 <bmbouter> we likely need to stay pinned < 3.2 until RQ releases a fix upstream
15:42:37 <asmacdo> I guess this one could be changed to stop pinning redis after they fix upstream
15:42:44 <daviddavis> +1
15:42:51 <bmbouter> so I would say accept because several devs are watching the upstream issue so we will see the change of state
15:42:59 <dkliban> +1
15:43:00 <dawalker> #idea Proposed for #4439: Leave the issue as-is, accepting its current state.
15:43:00 <dawalker> !propose accept
15:43:01 <asmacdo> !propose accept
15:43:01 <pulpbot> dawalker: Proposed for #4439: Leave the issue as-is, accepting its current state.
15:43:14 <asmacdo> k fine. +1
15:43:18 <dawalker> !accept
15:43:18 <dawalker> #agreed Leave the issue as-is, accepting its current state.
15:43:18 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:43:18 <jortel> +1
15:43:19 <dawalker> lol
15:43:19 <dawalker> #topic Improve the CI/CD pipeline for pulp_python - http://pulp.plan.io/issues/4440
15:43:20 <pulpbot> dawalker: 6 issues left to triage: 4440, 4441, 4443, 4447, 4449, 4450
15:43:21 <pulpbot> Issue #4440 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:43:22 <pulpbot> Improve the CI/CD pipeline for pulp_python - http://pulp.plan.io/issues/4440
15:43:33 <ttereshc> story?
15:43:38 <dkliban> task
15:43:45 <asmacdo> either way, defer to pulp_python
15:43:45 <ttereshc> k
15:43:49 <daviddavis> +1
15:43:49 <ipanova> defer to python team
15:43:51 <dawalker> defer
15:43:54 <dawalker> #idea Proposed for #4440: Skip this issue for this triage session.
15:43:54 <dawalker> !propose skip
15:43:55 <pulpbot> dawalker: Proposed for #4440: Skip this issue for this triage session.
15:44:06 <ttereshc> I just prefer it to be moved out of un-triaged items
15:44:16 <ipanova> yeah
15:44:32 <daviddavis> I wonder if we should start skipping plugin issue during triage?
15:44:34 <asmacdo> ttereshc: we'll mark it triaged before next time
15:44:47 <ttereshc> daviddavis, +1
15:44:49 <ttereshc> asmacdo, +1
15:44:55 <ttereshc> daviddavis, +1
15:45:02 <daviddavis> is that +2
15:45:04 <ttereshc> oops, dawalker +1
15:45:04 <asmacdo> ttereshc, +1
15:45:06 <daviddavis> oh ha
15:45:07 <ttereshc> :)
15:45:10 <dawalker> !accept
15:45:10 <dawalker> #agreed Skip this issue for this triage session.
15:45:10 <pulpbot> dawalker: Current proposal accepted: Skip this issue for this triage session.
15:45:11 <dawalker> #topic Our "Required PR" syntax is munged by Github and causes confusion - http://pulp.plan.io/issues/4441
15:45:12 <pulpbot> dawalker: 5 issues left to triage: 4441, 4443, 4447, 4449, 4450
15:45:13 <pulpbot> Issue #4441 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:45:14 <pulpbot> Our "Required PR" syntax is munged by Github and causes confusion - http://pulp.plan.io/issues/4441
15:45:22 <dawalker> +1's all around!
15:45:27 <ipanova> yes please
15:45:33 <ttereshc> it's ipanova's favourite
15:45:34 <asmacdo> oooooof
15:45:43 <asmacdo> this one bites hard
15:45:59 <asmacdo> #idea Proposed for #4441: Leave the issue as-is, accepting its current state.
15:45:59 <asmacdo> !propose accept
15:46:01 <pulpbot> asmacdo: Proposed for #4441: Leave the issue as-is, accepting its current state.
15:46:04 <ipanova> asmacdo: especially when you need to re-push to 10 PRs :)
15:46:15 <dawalker> eek
15:46:15 <daviddavis> we need some suggestions for a solution on the issue
15:46:17 <asmacdo> not sure what to do, but its clearly not good the way it is
15:46:23 <daviddavis> yea
15:46:25 <dawalker> #idea Proposed for #4441: accept and add to sprint
15:46:25 <dawalker> !propose other accept and add to sprint
15:46:25 <pulpbot> dawalker: Proposed for #4441: accept and add to sprint
15:46:31 <asmacdo> we don't need a solution to triage
15:46:48 <daviddavis> agreed, just calling it out for visibility
15:46:52 <asmacdo> ah yeah
15:47:35 <asmacdo> i dont think this should be on the sprint
15:47:41 <daviddavis> yea
15:47:48 <dawalker> #idea Proposed for #4441: Leave the issue as-is, accepting its current state.
15:47:48 <dawalker> !propose accept
15:47:48 <pulpbot> dawalker: Proposed for #4441: Leave the issue as-is, accepting its current state.
15:47:51 <asmacdo> as annoying as it is, we are already in deep :)
15:47:51 <dkliban> +1
15:47:57 <bmbouter> yup
15:48:00 <dawalker> fair enough
15:48:10 <dawalker> !accept
15:48:10 <dawalker> #agreed Leave the issue as-is, accepting its current state.
15:48:10 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:48:11 <pulpbot> dawalker: 4 issues left to triage: 4443, 4447, 4449, 4450
15:48:11 <dawalker> #topic Add travis tests to pulplift - http://pulp.plan.io/issues/4443
15:48:12 <pulpbot> Issue #4443 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:48:13 <pulpbot> Add travis tests to pulplift - http://pulp.plan.io/issues/4443
15:49:46 <asmacdo> oh right
15:49:46 <ttereshc> task?
15:49:49 <bmbouter> +1
15:49:50 <asmacdo> +1
15:49:57 <dawalker> !propose other convert to task
15:49:57 <dawalker> #idea Proposed for #4443: convert to task
15:49:57 <pulpbot> dawalker: Proposed for #4443: convert to task
15:50:05 <ttereshc> +1
15:50:07 <asmacdo> i completely forgot this one was mine :)
15:50:14 <dkliban> +1
15:50:20 <dawalker> #agreed convert to task
15:50:20 <dawalker> !accept
15:50:20 <pulpbot> dawalker: Current proposal accepted: convert to task
15:50:21 <pulpbot> dawalker: 3 issues left to triage: 4447, 4449, 4450
15:50:21 <dawalker> #topic version create api seems to take repository id instead of href - http://pulp.plan.io/issues/4447
15:50:22 <pulpbot> Issue #4447 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:50:23 <pulpbot> version create api seems to take repository id instead of href - http://pulp.plan.io/issues/4447
15:50:32 <asmacdo> if anyone likes 4443 and wants to groom, id like to see it on next sprint
15:50:40 <daviddavis> accept and add to sprint
15:51:01 <daviddavis> also add api bindings, pulp 3, and pulp 3 blocker tags
15:51:01 <dkliban> daviddavis: +1
15:51:14 <ttereshc> +1
15:51:18 <bmbouter> +1
15:51:20 <asmacdo> i think this is bigger
15:51:30 <asmacdo> not a bindings problem, but a API problem
15:51:35 <dkliban> agreed
15:51:38 <daviddavis> ugg
15:51:51 <daviddavis> priority to high?
15:51:54 <dkliban> yes
15:51:58 <dawalker> #idea Proposed for #4447: accept and add to sprint, add tags for api, pulp3, pulp3 blocker, high priority
15:51:58 <dawalker> !propose other accept and add to sprint, add tags for api, pulp3, pulp3 blocker, high priority
15:51:58 <pulpbot> dawalker: Proposed for #4447: accept and add to sprint, add tags for api, pulp3, pulp3 blocker, high priority
15:52:09 <asmacdo> pulp3 blocker, does that mean RC or GA
15:52:13 <daviddavis> rc
15:52:16 <daviddavis> there is no ga tag
15:52:26 <asmacdo> k just making sure
15:52:30 <daviddavis> +1
15:52:35 <bmbouter> we're using the 3.0 milestone for GA blockers
15:52:36 <asmacdo> +1
15:53:05 <asmacdo> does this need a katello P{x} tag too
15:53:06 <dawalker> #agreed accept and add to sprint, add tags for api, pulp3, pulp3 blocker, high priority
15:53:06 <dawalker> !accept
15:53:06 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint, add tags for api, pulp3, pulp3 blocker, high priority
15:53:08 <dawalker> #topic Default to mirror = False - http://pulp.plan.io/issues/4449
15:53:08 <pulpbot> dawalker: 2 issues left to triage: 4449, 4450
15:53:10 <pulpbot> Issue #4449 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:53:11 <pulpbot> Default to mirror = False - http://pulp.plan.io/issues/4449
15:53:14 <ttereshc> this e-mail is one of the lost ones bmbouter
15:53:16 <daviddavis> asmacdo: yea good call. katello P1 tag too
15:53:28 <dawalker> thanks asmacdo, will add that too
15:53:39 <asmacdo> dalley++
15:53:39 <pulpbot> asmacdo: dalley's karma is now 138
15:53:48 <asmacdo> this is a really nice catch
15:53:49 <ipanova> +1
15:53:58 <daviddavis> +1
15:54:00 <jortel> +1
15:54:04 <asmacdo> RC blocker for sure
15:54:06 <ttereshc> add to sprint
15:54:10 <daviddavis> +1
15:54:12 <asmacdo> (backwards incompatible)
15:54:12 <dalley> +1
15:54:26 <ttereshc> we had to have our rc meeting before triage :)
15:54:31 <asmacdo> !propose other accept and add RC blocker
15:54:31 <asmacdo> #idea Proposed for #4449: accept and add RC blocker
15:54:32 <pulpbot> asmacdo: Proposed for #4449: accept and add RC blocker
15:54:38 <bmbouter> +1
15:54:42 <asmacdo> at least this one wont take 5 minutes :)
15:54:42 <jortel> +1
15:54:52 <ipanova> +1
15:55:03 <jortel> may impact smash tests ..
15:55:11 <asmacdo> buzzkill
15:55:18 <daviddavis> :[]
15:55:20 <jortel> heh
15:55:32 <dawalker> #agreed accept and add RC blocker
15:55:32 <dawalker> !accept
15:55:32 <pulpbot> dawalker: Current proposal accepted: accept and add RC blocker
15:55:33 <pulpbot> dawalker: 1 issues left to triage: 4450
15:55:33 <dawalker> #topic pulp-manager autocomplete doesn't work - http://pulp.plan.io/issues/4450
15:55:34 <pulpbot> Issue #4450 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:55:35 <pulpbot> pulp-manager autocomplete doesn't work - http://pulp.plan.io/issues/4450
15:55:42 <kersom> jortel, it will
15:55:45 <daviddavis> accept, add to sprint, rc blocker
15:55:52 <asmacdo> wait
15:56:03 <asmacdo> bmbouter: what installation are you using?
15:56:13 <bmbouter> pulplift or devel
15:56:25 <asmacdo> the pulp3-devel role installs django-extensions
15:56:34 <asmacdo> i think that should fix this.
15:56:38 <bmbouter> regardless it doesn't create value
15:56:42 <asmacdo> perhaps that should be added to user install as well?
15:57:00 <asmacdo> bmbouter: pulp-manager does add other commands
15:57:01 <bmbouter> we didn't have good reasoning to make pulp-manager so fixing it seems wrong
15:57:11 <asmacdo> we were even talking about adding stuff to it
15:57:15 <bmbouter> it does exactly the commands of django-admin no more
15:57:34 <ipanova> bmbouter: do we remember the reason we actually created pulp-manager?
15:57:42 <daviddavis> yea, if there's a possibility of us adding commands, we should keep it
15:57:51 <bmbouter> django-admin gets the same commands
15:58:00 <daviddavis> oh
15:58:04 <dawalker> discuss on ticket between the two solutions, but either way accept/sprint/rc blocker?
15:58:04 <bmbouter> pulp-manager is like an 8 line wrapper around django-admin
15:58:05 <ipanova> bmbouter: i do not like throw away stuff, without reasoning
15:58:20 <dkliban> yeah ... i created pulp-manager when i added the reset-admin-user django command
15:58:20 <bmbouter> I agree
15:58:24 <asmacdo> bmbouter: what about if pulp-manager restarts workers and stuff
15:58:26 <bmbouter> it just kind of happened
15:58:37 <bmbouter> we can introduce it when we have a reason to
15:58:51 <bmbouter> we can also discuss on the ticket that makes sense for triage
15:58:57 <dawalker> ^^
15:58:59 <dkliban> let's discuss on the ticket
15:59:02 <dawalker> discuss on ticket
15:59:02 <daviddavis> +1
15:59:13 <asmacdo> +1. lets make this a task or something though
15:59:13 <dawalker> want to skip for discussion then?
15:59:17 <daviddavis> +1
15:59:21 <dawalker> fine with that too
15:59:24 <asmacdo> change the title to "remove pulp-manager"
15:59:35 <asmacdo> id be fine to accept autocomplete doesnt work
15:59:39 <asmacdo> but not removing it
15:59:44 <ipanova> dkliban:  i see
15:59:53 <bmbouter> let's rename to be what it is 'remove pulp-manager'
16:00:02 <bmbouter> the autocomplete is just what caught my attention
16:00:20 <dawalker> !propose skip
16:00:20 <dawalker> #idea Proposed for #4450: Skip this issue for this triage session.
16:00:20 <pulpbot> dawalker: Proposed for #4450: Skip this issue for this triage session.
16:00:30 <asmacdo> !propose other change to task, rename to remove pulp-manager
16:00:30 <asmacdo> #idea Proposed for #4450: change to task, rename to remove pulp-manager
16:00:31 <pulpbot> asmacdo: Proposed for #4450: change to task, rename to remove pulp-manager
16:00:34 <dawalker> that's better
16:00:37 <dawalker> ^
16:00:48 <bmbouter> +1
16:00:49 <dawalker> +1
16:01:17 <dawalker> !accept
16:01:17 <dawalker> #agreed change to task, rename to remove pulp-manager
16:01:17 <pulpbot> dawalker: Current proposal accepted: change to task, rename to remove pulp-manager
16:01:18 <pulpbot> dawalker: No issues to triage.
16:01:23 <dawalker> !end
16:01:23 <dawalker> #endmeeting