15:49:15 <dawalker> #startmeeting Pulp Triage 2019-02-26
15:49:15 <dawalker> !start
15:49:15 <dawalker> #info dawalker has joined triage
15:49:16 <pulpbot> Meeting started Tue Feb 26 15:49:15 2019 UTC and is due to finish in 60 minutes.  The chair is dawalker. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:49:16 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:49:16 <pulpbot> The meeting name has been set to 'pulp_triage_2019_02_26'
15:49:16 <pulpbot> dawalker: dawalker has joined triage
15:49:28 <dkliban> ttereshc: yes
15:49:34 <dkliban> #info dkliban has joined triage
15:49:34 <dkliban> !here
15:49:34 <pulpbot> dkliban: dkliban has joined triage
15:49:47 <asmacdo> its sort of double nested for no reason
15:50:08 <asmacdo> #info asmacdo has joined triage
15:50:08 <asmacdo> !here
15:50:08 <pulpbot> asmacdo: asmacdo has joined triage
15:50:32 <ttereshc> dkliban, asmacdo, just the description is not descriptive enough, I think ppicka struggled to see what it is about
15:50:35 <ttereshc> !here
15:50:35 <ttereshc> #info ttereshc has joined triage
15:50:35 <pulpbot> ttereshc: ttereshc has joined triage
15:50:51 <ttereshc> I'm add the link
15:50:55 <dkliban> ttereshc: thanks
15:50:56 <ttereshc> *I'll
15:50:57 <dawalker> !next
15:50:58 <pulpbot> dawalker: 8 issues left to triage: 4432, 4437, 4452, 4455, 4471, 4473, 4474, 4475
15:50:58 <dawalker> #topic Pulp upgrade from 2.7 to 2.18 logs  says Database initialization failed. - http://pulp.plan.io/issues/4432
15:50:59 <pulpbot> Issue #4432 [NEW] (unassigned) - Priority: Normal | Severity: High
15:51:00 <pulpbot> Pulp upgrade from 2.7 to 2.18 logs  says Database initialization failed. - http://pulp.plan.io/issues/4432
15:51:01 <daviddavis> #info daviddavis has joined triage
15:51:01 <daviddavis> !here
15:51:02 <pulpbot> daviddavis: daviddavis has joined triage
15:51:13 <daviddavis> close this out and point user to irc/mailing list
15:51:19 <ttereshc> it feels like a support ticket
15:51:20 <ttereshc> yeah
15:51:22 <ttereshc> +1
15:51:27 <ttereshc> close as worksforme
15:51:31 <ttereshc> or not a bug
15:51:49 <dawalker> #idea Proposed for #4432: close as not a bug and offer support on list
15:51:49 <dawalker> !propose other close as not a bug and offer support on list
15:51:50 <pulpbot> dawalker: Proposed for #4432: close as not a bug and offer support on list
15:52:01 <ttereshc> +!
15:52:02 <ttereshc> +1
15:52:25 <dkliban> +1
15:52:27 <asmacdo> +1
15:52:46 <dawalker> #agreed close as not a bug and offer support on list
15:52:46 <dawalker> !accept
15:52:46 <pulpbot> dawalker: Current proposal accepted: close as not a bug and offer support on list
15:52:47 <pulpbot> dawalker: 7 issues left to triage: 4437, 4452, 4455, 4471, 4473, 4474, 4475
15:52:47 <dawalker> #topic Cannot adapt BaseUrl when serving Content at a custom URL using a custom aiohttp handler - http://pulp.plan.io/issues/4437
15:52:48 <pulpbot> Issue #4437 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:52:49 <pulpbot> Cannot adapt BaseUrl when serving Content at a custom URL using a custom aiohttp handler - http://pulp.plan.io/issues/4437
15:53:40 <dkliban> let's accept but not add to sprint
15:53:52 <dawalker> !propose accept
15:53:52 <dawalker> #idea Proposed for #4437: Leave the issue as-is, accepting its current state.
15:53:53 <pulpbot> dawalker: Proposed for #4437: Leave the issue as-is, accepting its current state.
15:54:41 <ttereshc> sounds more like a story to me
15:54:52 <dkliban> i think this is more of a docs story
15:54:58 <asmacdo> i'm unclear what we need to do based on this issue
15:54:59 <dkliban> we already have this in the plugin API
15:55:18 <asmacdo> i think i understand the problem, but its not clear at all how to proceed based on whats in the issue
15:55:44 <dawalker> #idea Proposed for #4437: convert to story
15:55:44 <dawalker> !propose other convert to story
15:55:44 <pulpbot> dawalker: Proposed for #4437: convert to story
15:55:48 <daviddavis> maybe skip today and get bmbouter to weigh in next triage?
15:55:54 <bmbouter> wow I can talk!
15:55:57 <daviddavis> :D
15:56:02 <ttereshc> should we add documentation tag then? I don't read it as docs only but I don't have enough insight into the topic
15:56:02 <bmbouter> I've been trying to talk for like 10 min but the channel wouldn't letme geez
15:56:04 <dawalker> o/
15:56:08 <daviddavis> haha
15:56:08 <ttereshc> heh
15:56:08 <bmbouter> !here
15:56:08 <bmbouter> #info bmbouter has joined triage
15:56:09 <asmacdo> lol
15:56:09 <pulpbot> bmbouter: bmbouter has joined triage
15:56:15 <bmbouter> I was bmbouter1 not a registered nick
15:56:22 <dawalker> ah
15:56:26 <bmbouter> so what we learned on this is that we don't have all the imports available in the plugin API
15:56:28 <dalley> #info dalley has joined triage
15:56:28 <dalley> !here
15:56:28 <pulpbot> dalley: dalley has joined triage
15:56:29 <bmbouter> iirc
15:56:44 <bmbouter> and we can accept and ifgure it out later
15:57:09 <dkliban> the docker plugin already makes use of this
15:57:12 <bmbouter> b/c docker I think fully rebuilds its serializers
15:57:21 <dkliban> ah yes
15:57:22 <bmbouter> and doesn't receive things it could from the plugin API (is my understanding)
15:57:23 <asmacdo> thats ok-- just be aware that if we accept this i don't think that anyone who isnt already familiar can work on it
15:57:30 <ttereshc> bmbouter, so it's an additive change but it's safer to do it before RC?
15:57:57 <bmbouter> I believe so and yes
15:58:01 <ttereshc> more will be available in the plugin api - this is how I read your other comment
15:58:04 <ttereshc> ok
15:58:07 <bmbouter> yes
15:58:09 <dkliban> yes
15:58:15 <ttereshc> yes yes
15:58:16 <dawalker> so, accept as is or convert to story?
15:58:18 <bmbouter> it's going to be like a 2-line import addition
15:58:33 <dkliban> bmbouter: not quite ... but i'll comment about that on the ticket
15:59:30 <dkliban> let's accept and go on to the next issue
15:59:33 <ttereshc> +1
15:59:38 <dawalker> #idea Proposed for #4437: Leave the issue as-is, accepting its current state.
15:59:38 <dawalker> !propose accept
15:59:38 <pulpbot> dawalker: Proposed for #4437: Leave the issue as-is, accepting its current state.
15:59:40 <dawalker> !accept
15:59:40 <dawalker> #agreed Leave the issue as-is, accepting its current state.
15:59:40 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:59:42 <pulpbot> dawalker: 6 issues left to triage: 4452, 4455, 4471, 4473, 4474, 4475
15:59:42 <dawalker> #topic fetching PULP_MANIFEST throws a 404 if file repo version contains no units - http://pulp.plan.io/issues/4452
15:59:43 <pulpbot> Issue #4452 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:59:44 <pulpbot> fetching PULP_MANIFEST throws a 404 if file repo version contains no units - http://pulp.plan.io/issues/4452
15:59:51 <daviddavis> accept and maybe add to sprint
15:59:54 <bmbouter> +1
16:00:03 <ttereshc> +1
16:00:04 <dkliban> +1
16:00:22 <dawalker> !propose other accept and add to sprint
16:00:22 <dawalker> #idea Proposed for #4452: accept and add to sprint
16:00:22 <pulpbot> dawalker: Proposed for #4452: accept and add to sprint
16:00:34 <asmacdo> +1
16:00:38 <dawalker> #agreed accept and add to sprint
16:00:38 <dawalker> !accept
16:00:38 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint
16:00:40 <pulpbot> dawalker: 5 issues left to triage: 4455, 4471, 4473, 4474, 4475
16:00:40 <dawalker> #topic S3 doesn't work if you follow the guide in our docs - http://pulp.plan.io/issues/4455
16:00:41 <pulpbot> Issue #4455 [NEW] (unassigned) - Priority: Normal | Severity: Medium
16:00:42 <pulpbot> S3 doesn't work if you follow the guide in our docs - http://pulp.plan.io/issues/4455
16:00:51 <daviddavis> this is a small doc fix
16:01:00 <dawalker> #idea Proposed for #4455: Leave the issue as-is, accepting its current state.
16:01:00 <dawalker> !propose accept
16:01:00 <pulpbot> dawalker: Proposed for #4455: Leave the issue as-is, accepting its current state.
16:01:18 <ttereshc> +1
16:01:36 <dawalker> #agreed Leave the issue as-is, accepting its current state.
16:01:36 <dawalker> !accept
16:01:36 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
16:01:38 <pulpbot> dawalker: 4 issues left to triage: 4471, 4473, 4474, 4475
16:01:39 <dawalker> #topic Pulp returns 200 when it fails to create rpm content - http://pulp.plan.io/issues/4471
16:01:39 <pulpbot> Issue #4471 [NEW] (unassigned) - Priority: Normal | Severity: Medium
16:01:41 <pulpbot> Pulp returns 200 when it fails to create rpm content - http://pulp.plan.io/issues/4471
16:01:50 <dawalker> rpm
16:01:51 <daviddavis> skip, rpm issue
16:01:57 <dawalker> !propse skip
16:01:57 <pulpbot> dawalker: Error: "propse" is not a valid command.
16:02:01 <dawalker> #idea Proposed for #4471: Skip this issue for this triage session.
16:02:01 <dawalker> !propose skip
16:02:01 <pulpbot> dawalker: Proposed for #4471: Skip this issue for this triage session.
16:02:03 <jortel> !here
16:02:03 <jortel> #info jortel has joined triage
16:02:04 <pulpbot> jortel: jortel has joined triage
16:02:09 <dawalker> #agreed Skip this issue for this triage session.
16:02:09 <dawalker> !accept
16:02:09 <pulpbot> dawalker: Current proposal accepted: Skip this issue for this triage session.
16:02:10 <pulpbot> dawalker: 3 issues left to triage: 4473, 4474, 4475
16:02:10 <dawalker> #topic RPM upload: filename parameter is not documented in the api docs, is redundant - http://pulp.plan.io/issues/4473
16:02:11 <pulpbot> Issue #4473 [NEW] (unassigned) - Priority: Normal | Severity: Medium
16:02:12 <pulpbot> RPM upload: filename parameter is not documented in the api docs, is redundant - http://pulp.plan.io/issues/4473
16:02:13 <daviddavis> another rpm issue
16:02:17 <dawalker> !propose skip
16:02:17 <dawalker> #idea Proposed for #4473: Skip this issue for this triage session.
16:02:17 <daviddavis> skip
16:02:17 <pulpbot> dawalker: Proposed for #4473: Skip this issue for this triage session.
16:02:19 <ttereshc> +1
16:02:20 <dawalker> #agreed Skip this issue for this triage session.
16:02:20 <dawalker> !accept
16:02:20 <pulpbot> dawalker: Current proposal accepted: Skip this issue for this triage session.
16:02:21 <pulpbot> dawalker: 2 issues left to triage: 4474, 4475
16:02:22 <dawalker> #topic One shot uploader doesn't populate 'created_resource' on task - http://pulp.plan.io/issues/4474
16:02:22 <pulpbot> Issue #4474 [NEW] (unassigned) - Priority: Normal | Severity: Medium
16:02:23 <pulpbot> One shot uploader doesn't populate 'created_resource' on task - http://pulp.plan.io/issues/4474
16:02:26 <dawalker> #idea Proposed for #4474: Skip this issue for this triage session.
16:02:26 <dawalker> !propose skip
16:02:26 <pulpbot> dawalker: Proposed for #4474: Skip this issue for this triage session.
16:02:29 <daviddavis> :)
16:02:32 <dawalker> another rpm...
16:02:38 <dawalker> !accept
16:02:38 <dawalker> #agreed Skip this issue for this triage session.
16:02:38 <pulpbot> dawalker: Current proposal accepted: Skip this issue for this triage session.
16:02:39 <pulpbot> dawalker: 1 issues left to triage: 4475
16:02:39 <dawalker> #topic pulp_file unit tests are failing - http://pulp.plan.io/issues/4475
16:02:40 <pulpbot> Issue #4475 [NEW] (unassigned) - Priority: Normal | Severity: Medium
16:02:41 <pulpbot> pulp_file unit tests are failing - http://pulp.plan.io/issues/4475
16:02:42 <daviddavis> accept, add to sprint, high priority
16:02:47 <ttereshc> we should filter out all plugins except the file one
16:02:53 <daviddavis> ttereshc: +1
16:02:54 <ttereshc> from triage
16:02:58 <dawalker> !propose other accept and add to sprint, priority high
16:02:58 <dawalker> #idea Proposed for #4475: accept and add to sprint, priority high
16:02:59 <pulpbot> dawalker: Proposed for #4475: accept and add to sprint, priority high
16:03:04 <dawalker> agreed ttereshc
16:03:35 <dawalker> !accept
16:03:35 <dawalker> #agreed accept and add to sprint, priority high
16:03:35 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint, priority high
16:03:36 <pulpbot> dawalker: No issues to triage.
16:03:41 <ttereshc> heh, daviddavis I guess it's due to my recent changes
16:03:43 <dawalker> #endmeeting
16:03:43 <dawalker> !end