14:30:20 <dawalker> #startmeeting Pulp Triage 2019-03-29
14:30:20 <dawalker> #info dawalker has joined triage
14:30:21 <pulpbot> Meeting started Fri Mar 29 14:30:20 2019 UTC and is due to finish in 60 minutes.  The chair is dawalker. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:21 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:21 <pulpbot> The meeting name has been set to 'pulp_triage_2019_03_29'
14:30:21 <pulpbot> dawalker: dawalker has joined triage
14:30:21 * bmbouter calls upon the lorax
14:30:52 <dawalker> lol
14:30:57 <daviddavis> !here
14:30:57 <daviddavis> #info daviddavis has joined triage
14:30:58 <pulpbot> daviddavis: daviddavis has joined triage
14:31:04 <ipanova> #info ipanova has joined triage
14:31:04 <ipanova> !here
14:31:04 <pulpbot> ipanova: ipanova has joined triage
14:31:09 <asmacdo> !care 4585
14:31:21 <ttereshc> #info ttereshc has joined triage
14:31:21 <ttereshc> !here
14:31:21 <pulpbot> ttereshc: ttereshc has joined triage
14:31:56 <dawalker> !next
14:31:57 <dawalker> #topic Task Cancellation doesn't interrupt/cancel a running task with Celery 4+ - http://pulp.plan.io/issues/4581
14:31:58 <pulpbot> dawalker: 10 issues left to triage: 4581, 4585, 4588, 4589, 4590, 4597, 4600, 4602, 4603, 4604
14:31:59 <pulpbot> Issue #4581 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:32:00 <pulpbot> Task Cancellation doesn't interrupt/cancel a running task with Celery 4+ - http://pulp.plan.io/issues/4581
14:32:09 <daviddavis> accept and add to sprint
14:32:18 <dawalker> #idea Proposed for #4581: accept and add to sprint
14:32:18 <dawalker> !propose other accept and add to sprint
14:32:18 <pulpbot> dawalker: Proposed for #4581: accept and add to sprint
14:32:37 <ppicka> #info ppicka has joined triage
14:32:37 <ppicka> !here
14:32:37 <pulpbot> ppicka: ppicka has joined triage
14:32:39 <dkliban> #info dkliban has joined triage
14:32:39 <dkliban> !here
14:32:39 <pulpbot> dkliban: dkliban has joined triage
14:33:03 <dawalker> #agreed accept and add to sprint
14:33:03 <dawalker> !accept
14:33:03 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint
14:33:05 <dawalker> #topic `make` should be installed by the pulp-devel role - http://pulp.plan.io/issues/4585
14:33:05 <pulpbot> dawalker: 9 issues left to triage: 4585, 4588, 4589, 4590, 4597, 4600, 4602, 4603, 4604
14:33:06 <pulpbot> Issue #4585 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:33:07 <pulpbot> `make` should be installed by the pulp-devel role - http://pulp.plan.io/issues/4585
14:33:08 <pulpbot> dawalker: asmacdo: Issue 4585 is currently being discussed.
14:33:23 <asmacdo> #idea Proposed for #4585: accept and add to the sprint
14:33:23 <asmacdo> #info asmacdo has joined triage
14:33:23 <asmacdo> !propose other accept and add to the sprint
14:33:24 <pulpbot> asmacdo: asmacdo has joined triage
14:33:24 <dkliban> accept and add to sprint
14:33:25 <pulpbot> asmacdo: Proposed for #4585: accept and add to the sprint
14:33:31 <dawalker> +1
14:33:32 <ppicka> +1
14:33:37 <ipanova> +1
14:33:52 <asmacdo> !care 4600
14:34:15 <dawalker> #agreed accept and add to the sprint
14:34:15 <dawalker> !accept
14:34:15 <pulpbot> dawalker: Current proposal accepted: accept and add to the sprint
14:34:17 <dawalker> #topic Ostree repo sync fails - http://pulp.plan.io/issues/4588
14:34:17 <pulpbot> dawalker: 8 issues left to triage: 4588, 4589, 4590, 4597, 4600, 4602, 4603, 4604
14:34:18 <pulpbot> Issue #4588 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:34:19 <pulpbot> Ostree repo sync fails - http://pulp.plan.io/issues/4588
14:34:28 <daviddavis> skip, ostree bug
14:34:32 <ipanova> !care ttereshc
14:34:32 <pulpbot> ipanova: Error: 'ttereshc' is not a valid positive integer.
14:34:36 <ipanova> dammit
14:34:36 <dawalker> !skip
14:34:38 <dawalker> #topic No published metadata is available on a Pubication via REST API - http://pulp.plan.io/issues/4589
14:34:38 <pulpbot> dawalker: 7 issues left to triage: 4589, 4590, 4597, 4600, 4602, 4603, 4604
14:34:39 <pulpbot> Issue #4589 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:34:40 <pulpbot> No published metadata is available on a Pubication via REST API - http://pulp.plan.io/issues/4589
14:34:47 <daviddavis> accept and add 3.0 milestone?
14:35:04 <ttereshc> +1
14:35:08 <dawalker> #idea Proposed for #4589: accept and add 3.0 milestone
14:35:08 <dawalker> !propose other accept and add 3.0 milestone
14:35:09 <pulpbot> dawalker: Proposed for #4589: accept and add 3.0 milestone
14:35:22 <ipanova> +1
14:35:28 <dkliban> +1
14:35:31 <dawalker> !accept
14:35:31 <dawalker> #agreed accept and add 3.0 milestone
14:35:31 <pulpbot> dawalker: Current proposal accepted: accept and add 3.0 milestone
14:35:32 <dawalker> #topic Return relative URI for distributions - http://pulp.plan.io/issues/4590
14:35:33 <pulpbot> dawalker: 6 issues left to triage: 4590, 4597, 4600, 4602, 4603, 4604
14:35:34 <pulpbot> Issue #4590 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:35:35 <pulpbot> Return relative URI for distributions - http://pulp.plan.io/issues/4590
14:35:37 <daviddavis> I think there's a pr for this?
14:35:40 <dkliban> yeah
14:35:50 <dawalker> !propose accept
14:35:50 <dawalker> #idea Proposed for #4590: Leave the issue as-is, accepting its current state.
14:35:51 <pulpbot> dawalker: Proposed for #4590: Leave the issue as-is, accepting its current state.
14:36:12 <daviddavis> accept and add to sprint. also remind dkliban to update issue.
14:36:19 <ipanova> +1
14:36:21 <ppicka> +1
14:36:23 <ttereshc> +1
14:36:26 <dawalker> should we add to 50 or 51 if there's a pr already up?
14:36:44 <ipanova> 51 i think
14:36:53 <ppicka> I think when 50 is done its done so 51
14:37:07 <dawalker> #idea Proposed for #4590: accept and add to sprint
14:37:07 <dawalker> !propose other accept and add to sprint
14:37:08 <pulpbot> dawalker: Proposed for #4590: accept and add to sprint
14:37:11 <ttereshc> doesn't matter
14:37:15 <dawalker> !accept
14:37:15 <dawalker> #agreed accept and add to sprint
14:37:15 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint
14:37:16 <dawalker> #topic Deprecate docker v1 support - http://pulp.plan.io/issues/4597
14:37:17 <pulpbot> dawalker: 5 issues left to triage: 4597, 4600, 4602, 4603, 4604
14:37:18 <pulpbot> Issue #4597 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:37:19 <pulpbot> Deprecate docker v1 support - http://pulp.plan.io/issues/4597
14:37:19 <ttereshc> rchan, will move everything on Monday anyway
14:37:26 <ipanova> rchan: will move all items to the next sprint i.e 51 so it does not really matter
14:37:32 <ipanova> dawalker: ^
14:37:39 <ipanova> skip docker issue
14:37:40 <daviddavis> skip, docker issue
14:37:41 <dawalker> ah, good point, thanks
14:37:44 <dawalker> !skip
14:37:46 <dawalker> #topic DockerDistributions are not validated correctly - http://pulp.plan.io/issues/4600
14:37:46 <pulpbot> dawalker: 4 issues left to triage: 4600, 4602, 4603, 4604
14:37:47 <pulpbot> Issue #4600 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:37:48 <pulpbot> DockerDistributions are not validated correctly - http://pulp.plan.io/issues/4600
14:37:49 <pulpbot> dawalker: asmacdo: Issue 4600 is currently being discussed.
14:37:58 <daviddavis> skip docker issue
14:38:01 <dawalker> !skip
14:38:03 <dawalker> #topic /var/lib/pulp/tmp/ seems to violate the FHS - http://pulp.plan.io/issues/4602
14:38:03 <pulpbot> dawalker: 3 issues left to triage: 4602, 4603, 4604
14:38:04 <pulpbot> Issue #4602 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:05 <pulpbot> /var/lib/pulp/tmp/ seems to violate the FHS - http://pulp.plan.io/issues/4602
14:38:25 <bmbouter> dkliban: we need to comment on ^ about it crossing the filesystem
14:38:31 <dkliban> yeah
14:38:34 <dkliban> i'll leave a comment
14:38:34 <daviddavis> skip for now
14:38:38 <bmbouter> we don't want the downloads and final storage to cross the filesystem volume
14:38:39 <bmbouter> +1
14:38:49 <ttereshc> +1
14:39:05 <dawalker> !skip
14:39:06 <pulpbot> dawalker: 2 issues left to triage: 4603, 4604
14:39:07 <dawalker> #topic pulp_streamer fails to properly stream response - http://pulp.plan.io/issues/4603
14:39:08 <pulpbot> Issue #4603 [ASSIGNED] (dkliban@redhat.com) - Priority: Normal | Severity: Medium
14:39:09 <pulpbot> pulp_streamer fails to properly stream response - http://pulp.plan.io/issues/4603
14:39:13 <daviddavis> accept and add to sprint
14:39:17 <bmbouter> +1
14:39:18 <daviddavis> ?
14:39:24 <ttereshc> +1
14:39:26 <ipanova> +1
14:39:35 <dawalker> #idea Proposed for #4603: accept and add to sprint
14:39:35 <dawalker> !propose other accept and add to sprint
14:39:35 <pulpbot> dawalker: Proposed for #4603: accept and add to sprint
14:39:38 <dawalker> !accept
14:39:38 <dawalker> #agreed accept and add to sprint
14:39:38 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint
14:39:39 <pulpbot> dawalker: 1 issues left to triage: 4604
14:39:40 <dawalker> #topic Remove duplicates does not work properly if there is multiple content types in the repo - http://pulp.plan.io/issues/4604
14:39:40 <pulpbot> Issue #4604 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:39:41 <pulpbot> Remove duplicates does not work properly if there is multiple content types in the repo - http://pulp.plan.io/issues/4604
14:39:50 <daviddavis> ugg
14:40:01 <ipanova> i will a pr later
14:40:04 <ipanova> submit
14:40:12 <daviddavis> accept and add to sprint?
14:40:12 <ttereshc> add to sprint
14:40:15 <dawalker> #idea Proposed for #4604: accept and add to sprint
14:40:15 <dawalker> !propose other accept and add to sprint
14:40:15 <pulpbot> dawalker: Proposed for #4604: accept and add to sprint
14:40:24 <ipanova> +1
14:40:35 <dkliban> _1
14:40:35 <dawalker> !accept
14:40:35 <dawalker> #agreed accept and add to sprint
14:40:35 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint
14:40:37 <pulpbot> dawalker: No issues to triage.
14:40:39 <daviddavis> !dance
14:40:39 <pulpbot> ♪┏(°.°)┛┗(°.°)┓┗(°.°)┛┏(°.°)┓ ♪
14:40:48 <daviddavis> !end
14:40:55 <daviddavis> oh no wait
14:40:57 <dawalker> Anyone have any issues to bring up?
14:41:01 <daviddavis> don't listen to me!
14:41:18 <ttereshc> ipanova, I suggest to rename 4604- "...if there is multiple content types in a batch"
14:41:24 <daviddavis> I have issues but they're not pulp related
14:41:24 <dawalker> We received an email a few hours ago re: documentation on ansible-pulp of systemd settings?
14:41:29 <ppicka> daviddavis: not sure if you can explain it to bot :)
14:41:39 <daviddavis> hehe
14:42:17 <dawalker> ttereshc, +1 on the rename for clarity
14:42:52 <daviddavis> dawalker: I saw that email and agree we need to fix the docs
14:42:59 <dawalker> +1
14:43:03 <dkliban> looks like travis is still not working for the pulp_file repo
14:43:15 <dawalker> *sigh*
14:43:27 <daviddavis> dkliban: yup, I think we should just merge your pr. it seems like the cron job last night did run though
14:43:39 <dawalker> dkliban, reminder to update the issue 4590
14:43:55 <ipanova> ttereshc: it happens also when there is a 1 dc in a batch, just different one from the RemoveD model
14:44:42 <dkliban> dawalker: already did
14:44:48 <dawalker> dkliban, thanks!
14:44:53 <ttereshc> I see
14:44:59 <dawalker> wasn't sure you were around earlier
14:45:05 <bmbouter> travis buids seem to run well for me
14:45:27 <bmbouter> I'm trying to figure out why there is a shadow one for pulp-cerguard though. (dkliban the new pr and new branch gave the same result) https://github.com/pulp/pulp-certguard/pull/15
14:45:30 <daviddavis> bmbouter: me as well except for pulp_file
14:46:02 <dawalker> Do we want to end triage and continue this discussion after?
14:46:33 <bmbouter> and I think I figured it out!
14:46:43 <bmbouter> +1 to ending triage
14:46:56 <bmbouter> so in the branch protection github is still thinking that the 'Travis CI' is a required check
14:47:04 <bmbouter> so I think githu is adding it and expecting travis will keep up
14:47:06 <bmbouter> but something changed
14:47:07 <dawalker> #endmeeting