14:30:51 <asmacdo> #startmeeting Pulp Triage 2019-04-05
14:30:51 <asmacdo> #info asmacdo has joined triage
14:30:52 <pulpbot> Meeting started Fri Apr  5 14:30:51 2019 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:52 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:52 <pulpbot> The meeting name has been set to 'pulp_triage_2019_04_05'
14:30:52 <pulpbot> asmacdo: asmacdo has joined triage
14:31:22 <daviddavis> #info daviddavis has joined triage
14:31:22 <daviddavis> !here
14:31:22 <pulpbot> daviddavis: daviddavis has joined triage
14:31:30 <ppicka> #info ppicka has joined triage
14:31:30 <ppicka> !here
14:31:30 <pulpbot> ppicka: ppicka has joined triage
14:31:38 <ttereshc> #info ttereshc has joined triage
14:31:38 <ttereshc> !here
14:31:38 <pulpbot> ttereshc: ttereshc has joined triage
14:31:43 <ipanova> !руку
14:31:43 <pulpbot> ipanova: Error: "руку" is not a valid command.
14:31:48 <ipanova> #info ipanova has joined triage
14:31:48 <ipanova> !here
14:31:48 <pulpbot> ipanova: ipanova has joined triage
14:31:52 <ttereshc> !ногу
14:31:52 <pulpbot> ttereshc: Error: "ногу" is not a valid command.
14:31:55 <bmbouter> !here
14:31:55 <bmbouter> #info bmbouter has joined triage
14:31:56 <pulpbot> bmbouter: bmbouter has joined triage
14:32:00 <ipanova> !friday
14:32:00 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
14:32:04 <asmacdo> Привет ipanova!
14:32:15 <asmacdo> !start
14:32:15 <asmacdo> #info asmacdo has joined triage
14:32:15 <pulpbot> asmacdo: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
14:32:16 <pulpbot> asmacdo: asmacdo has joined triage
14:32:20 <asmacdo> !next
14:32:21 <pulpbot> asmacdo: 4 issues left to triage: 4602, 4638, 4641, 4642
14:32:21 <asmacdo> #topic /var/lib/pulp/tmp/ seems to violate the FHS - http://pulp.plan.io/issues/4602
14:32:22 <pulpbot> Issue #4602 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:32:23 <pulpbot> /var/lib/pulp/tmp/ seems to violate the FHS - http://pulp.plan.io/issues/4602
14:32:35 <daviddavis> skip?
14:32:38 <ipanova> asmacdo: добрый день товарищ Остин!
14:32:39 <mikedep333> So my understanding is that this is not so much a temp directory as a staging directory.
14:32:53 <mikedep333> The files always get deleted or moved to their permanent location from it.
14:32:57 <bmbouter> yes but it uses Django's temporary dir facilities
14:33:01 <mikedep333> Correct?
14:33:04 <mikedep333> hmm
14:33:17 <bmbouter> so we need to refer to it with that language for that reason (I think)
14:33:39 <bmbouter> we should collaab post triage on the issue
14:33:47 <bmbouter> it's a bit more than we can talk through this second I think
14:33:48 <asmacdo> how about we skip, let convo continue on the issue. however, when those of you who are involved decide its good, feel free to mark triaged
14:33:55 <bmbouter> +1
14:33:57 <ttereshc> +1
14:34:01 <asmacdo> !skip
14:34:02 <mikedep333> +1
14:34:03 <pulpbot> asmacdo: 3 issues left to triage: 4638, 4641, 4642
14:34:03 <asmacdo> #topic Delete distriution REST API method description incorrect - http://pulp.plan.io/issues/4638
14:34:04 <ppicka> sounds good
14:34:04 <pulpbot> Issue #4638 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:34:04 <daviddavis> +1
14:34:05 <pulpbot> Delete distriution REST API method description incorrect - http://pulp.plan.io/issues/4638
14:34:16 <dawalker> #info dawalker has joined triage
14:34:16 <dawalker> !here
14:34:16 <pulpbot> dawalker: dawalker has joined triage
14:34:16 <daviddavis> accept and add to sprint?
14:34:41 <bmbouter> +1
14:34:55 <asmacdo> #idea Proposed for #4638: accept and add to sprint
14:34:55 <asmacdo> !propose other accept and add to sprint
14:34:56 <pulpbot> asmacdo: Proposed for #4638: accept and add to sprint
14:35:05 <dawalker> +1
14:35:11 <ppicka> +1
14:35:19 <asmacdo> #agreed accept and add to sprint
14:35:19 <asmacdo> !accept
14:35:19 <pulpbot> asmacdo: Current proposal accepted: accept and add to sprint
14:35:20 <pulpbot> asmacdo: 2 issues left to triage: 4641, 4642
14:35:20 <asmacdo> #topic Delete the 'master' branch and make 2-master to main branch - http://pulp.plan.io/issues/4641
14:35:21 <pulpbot> Issue #4641 [ASSIGNED] (bmbouter) - Priority: Normal | Severity: Medium
14:35:22 <pulpbot> Delete the 'master' branch and make 2-master to main branch - http://pulp.plan.io/issues/4641
14:35:39 <daviddavis> convert to task
14:35:39 <ttereshc> task
14:35:40 <dawalker> accept and add to sprint
14:35:44 <dawalker> or that
14:35:48 <dawalker> I wasn't sure which it was
14:35:49 <ttereshc> both
14:35:54 <ipanova> +1
14:36:01 <ttereshc> task and add to the sprint
14:36:04 <mikedep333> +1
14:36:05 <dawalker> +1
14:36:10 <ppicka> +1
14:36:16 <bmbouter> +1
14:36:17 <ttereshc> ah it's already there
14:36:27 <asmacdo> that sounds fine to me, but this is a puppet bug
14:36:55 <asmacdo> #idea Proposed for #4641: Skip this issue for this triage session.
14:36:55 <asmacdo> !propose skip
14:36:55 <pulpbot> asmacdo: Proposed for #4641: Skip this issue for this triage session.
14:37:19 <asmacdo> i guess i could just click triaged too, nbd
14:37:32 <dawalker> !shrug
14:37:32 <pulpbot> ¯\_(ツ)_/¯
14:37:35 <asmacdo> #idea Proposed for #4641: Leave the issue as-is, accepting its current state.
14:37:35 <asmacdo> !propose accept
14:37:35 <pulpbot> asmacdo: Proposed for #4641: Leave the issue as-is, accepting its current state.
14:37:38 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:37:38 <asmacdo> !accept
14:37:38 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:37:39 <pulpbot> asmacdo: 1 issues left to triage: 4642
14:37:40 <asmacdo> #topic Delete the 'master' branch and make 2-master to main branch - http://pulp.plan.io/issues/4642
14:37:40 <pulpbot> Issue #4642 [ASSIGNED] (bmbouter) - Priority: Normal | Severity: Medium
14:37:41 <pulpbot> Delete the 'master' branch and make 2-master to main branch - http://pulp.plan.io/issues/4642
14:37:57 <asmacdo> #idea Proposed for #4642: Leave the issue as-is, accepting its current state.
14:37:57 <asmacdo> !propose accept
14:37:58 <pulpbot> asmacdo: Proposed for #4642: Leave the issue as-is, accepting its current state.
14:38:00 <dawalker> same
14:38:06 <daviddavis> convert to task
14:38:09 <dawalker> ostree
14:38:15 <ppicka> as is already assigned accept
14:38:35 <daviddavis> convert to task and add to sprint
14:38:47 <asmacdo> #idea Proposed for #4642: convert to task
14:38:47 <asmacdo> !propose other convert to task
14:38:47 <pulpbot> asmacdo: Proposed for #4642: convert to task
14:38:53 <asmacdo> (already added to sprint)
14:38:53 <ttereshc> +1
14:39:01 <asmacdo> !accept
14:39:01 <asmacdo> #agreed convert to task
14:39:01 <pulpbot> asmacdo: Current proposal accepted: convert to task
14:39:02 <pulpbot> asmacdo: No issues to triage.
14:39:07 <ttereshc> yay
14:39:14 <asmacdo> open floor, anyone
14:39:26 <daviddavis> I wanted to suggest #4630 but someone deleted it
14:39:42 <daviddavis> !friday
14:39:42 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
14:40:06 <asmacdo> !832
14:40:06 <pulpbot> asmacdo: Error: "832" is not a valid command.
14:40:07 <kersom> asmacdo, open floor is nice initiative.
14:40:14 <rchan> poor pulpbot
14:40:18 <asmacdo> !issue 832
14:40:18 <asmacdo> #topic As a user, I can cancel all running tasks using API - http://pulp.plan.io/issues/832
14:40:19 <pulpbot> Story #832 [NEW] (unassigned) - Priority: Normal
14:40:19 <dawalker> I think you wre going to revisit discussing 4602 after
14:40:20 <pulpbot> As a user, I can cancel all running tasks using API - http://pulp.plan.io/issues/832
14:40:29 <asmacdo> heres an old one from the backlog
14:40:48 <asmacdo> thought it might be nice to make into a pulp3 issue, and avoid the mass close
14:41:13 <bmbouter> for this the user could use a scrpit to do this pretty easily (I think)
14:41:46 <asmacdo> ie, GET all tasks, then cancel each one, yeah
14:42:31 <bmbouter> this may also be fine to accept to the backlog anyway though
14:42:38 <bmbouter> we could convert to story, tag as Pulp3 and leave it there?
14:42:45 <asmacdo> +1
14:42:52 <bmbouter> that's where all the features will go anyway in prep for 3.1 planning
14:43:49 <asmacdo> cool, added pulp3 tag
14:44:09 <asmacdo> !issue 147
14:44:09 <kersom> this is an example of what I think what we will loose if we bulk close without a better evaluation of issues.
14:44:10 <asmacdo> #topic As a pulp user, I would like to publish to an rsync target - http://pulp.plan.io/issues/147
14:44:10 <pulpbot> Story #147 [NEW] (unassigned) - Priority: Normal
14:44:11 <pulpbot> As a pulp user, I would like to publish to an rsync target - http://pulp.plan.io/issues/147
14:44:31 <asmacdo> kersom: i'm still going through the backlog, and collecting these
14:44:48 <asmacdo> the idea is that ill hopefully spot some of them before closing
14:44:54 <kersom> asmacdo, I will reply the email thread as well.
14:45:12 <asmacdo> so for this one, AFAIK, there are no plugins that implement an exporter
14:45:29 <asmacdo> i think we need to implement at least one of them to "prove" the plugin api for exporters
14:46:13 <asmacdo> i'm thinking we add the pulp3 tag to it and add to backlog
14:46:16 <bmbouter> +1 I agree
14:46:33 <bmbouter> we need at least a dummy exporter to prove those mechanisms work
14:46:59 <asmacdo> one more from the backlog and lets call it a triage
14:47:34 <bmbouter> these all seem like stories though
14:47:41 <asmacdo> !issue 203
14:47:41 <asmacdo> #topic [RFE] Add 'diff' command to pulp-admin - http://pulp.plan.io/issues/203
14:47:42 <pulpbot> Story #203 [NEW] (unassigned) - Priority: Normal
14:47:43 <pulpbot> [RFE] Add 'diff' command to pulp-admin - http://pulp.plan.io/issues/203
14:48:34 <asmacdo> so, given our repository versions, i think this one would be a really slick feature for pulp3
14:48:48 <ttereshc> off topic. For how long do we have open floor? any time limits?
14:48:51 <asmacdo> bmbouter: i hadn't planned on limiting open floor to issues vs stories
14:49:07 <bmbouter> I missed that we transitioned to open floor this makes more sense now
14:49:22 <asmacdo> ttereshc: nothing is in place, but i figure "just not too long"
14:49:48 <bmbouter> generally we should all be thinking about 3.1 features and preparing any ideas in that area like you are doing here
14:50:03 <bmbouter> but putting them into redmine, labeling as Pulp3 and marking as a story
14:50:05 <ttereshc> asmacdo, ok, just because we started revisiting old issues/rfes and they have 3 digit numbers, I was worried that it can take a while :)
14:50:06 <ppicka> this story sound reasonable as rfe for pulp3 so +1 to add pulp3 tag
14:50:20 <bmbouter> and we should make a query for 3.1 feature ideas that shows that category of things for core
14:51:12 <asmacdo> dk, added pulp3 tag
14:51:16 <asmacdo> ok*
14:51:26 <asmacdo> thats it from me today :)
14:51:37 <asmacdo> anyone want to mention anything or are we good to end?
14:52:35 <asmacdo> #endmeeting
14:52:35 <asmacdo> !end