14:30:24 <asmacdo> #startmeeting Pulp Triage 2019-04-09
14:30:24 <asmacdo> #info asmacdo has joined triage
14:30:24 <asmacdo> !start
14:30:24 <pulpbot> Meeting started Tue Apr  9 14:30:24 2019 UTC.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:24 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:24 <pulpbot> The meeting name has been set to 'pulp_triage_2019-04-09'
14:30:24 <pulpbot> asmacdo: asmacdo has joined triage
14:30:35 <ipanova> #info ipanova has joined triage
14:30:35 <ipanova> !here
14:30:36 <pulpbot> ipanova: ipanova has joined triage
14:30:36 <daviddavis> #info daviddavis has joined triage
14:30:36 <daviddavis> !here
14:30:37 <pulpbot> daviddavis: daviddavis has joined triage
14:30:41 <dkliban> #info dkliban has joined triage
14:30:41 <dkliban> !here
14:30:41 <pulpbot> dkliban: dkliban has joined triage
14:30:43 <bmbouter> #info bmbouter has joined triage
14:30:43 <bmbouter> !here
14:30:43 <pulpbot> bmbouter: bmbouter has joined triage
14:30:54 <mikedep333> #info mikedep333 has joined triage
14:30:54 <mikedep333> !here
14:30:54 <pulpbot> mikedep333: mikedep333 has joined triage
14:30:56 <asmacdo> !next
14:30:57 <pulpbot> asmacdo: 10 issues left to triage: 4602, 4644, 4646, 4648, 4649, 4651, 4653, 4654, 4655, 4656
14:30:57 <asmacdo> #topic https://pulp.plan.io/issues/4602
14:30:58 <pulpbot> RM 4602 - mdepaulo@redhat.com - NEW - /var/lib/pulp/tmp/ seems to violate the FHS
14:30:59 <pulpbot> https://pulp.plan.io/issues/4602
14:31:06 <ppicka> #info ppicka has joined triage
14:31:06 <ppicka> !here
14:31:06 <pulpbot> ppicka: ppicka has joined triage
14:31:10 <dkliban> skip again
14:31:18 <dkliban> there has been some discussion
14:31:23 <dkliban> but we need to finish it up still
14:31:24 <daviddavis> +1
14:31:28 <bmbouter> we do
14:31:30 <mikedep333> +1
14:31:35 <asmacdo> can someone take an action item to cmment?
14:31:40 <bmbouter> I'm on the fence about maybe adjusting it
14:31:45 <mikedep333> dkliban: exactly. And it will be updated docs anyway I'm leaning towards.
14:31:53 <bmbouter> I did comment from last time but even my thoughts are unconclusive
14:31:59 <mikedep333> Because it is more of a staging directory than a pure temp directory
14:32:05 <asmacdo> k, ill skip, yall just keep on discussing :)
14:32:07 <asmacdo> !skip
14:32:08 <pulpbot> asmacdo: 9 issues left to triage: 4644, 4646, 4648, 4649, 4651, 4653, 4654, 4655, 4656
14:32:09 <asmacdo> #topic https://pulp.plan.io/issues/4644
14:32:09 <pulpbot> RM 4644 - bherring - NEW - Modular and RPM Errata Copy Documentation can be misleading of intended expected behavior
14:32:11 <pulpbot> https://pulp.plan.io/issues/4644
14:32:11 <bmbouter> haha ok
14:32:13 <daviddavis> skip
14:32:30 <bmbouter> mikedep333: we can try to work that last one out some on the issue today (or I can help somehow maybe)
14:32:33 <asmacdo> !skip
14:32:34 <pulpbot> asmacdo: 8 issues left to triage: 4646, 4648, 4649, 4651, 4653, 4654, 4655, 4656
14:32:34 <asmacdo> #topic https://pulp.plan.io/issues/4646
14:32:35 <pulpbot> RM 4646 - dkliban@redhat.com - NEW - 'docker-content-digest' header is not returned with requests for a tag
14:32:36 <pulpbot> https://pulp.plan.io/issues/4646
14:32:39 <daviddavis> skip
14:32:42 <asmacdo> !skip
14:32:43 <pulpbot> asmacdo: 7 issues left to triage: 4648, 4649, 4651, 4653, 4654, 4655, 4656
14:32:43 <asmacdo> #topic https://pulp.plan.io/issues/4648
14:32:44 <pulpbot> RM 4648 - dkliban@redhat.com - NEW - 'reset-admin-password' django-admin command is listed under 'app' section of help text
14:32:45 <pulpbot> https://pulp.plan.io/issues/4648
14:32:55 <dalley> #info dalley has joined triage
14:32:55 <dalley> !here
14:32:55 <pulpbot> dalley: dalley has joined triage
14:33:05 <bherring> #info bherring has joined triage
14:33:05 <bherring> !here
14:33:05 <pulpbot> bherring: bherring has joined triage
14:33:08 <dkliban> accept
14:33:08 <daviddavis> accept?
14:33:12 <asmacdo> i think this issue needs some more info
14:33:12 <dalley> accept
14:33:23 <asmacdo> where should it be? why is being under app a problem, etc
14:33:27 <ppicka> +1 more info
14:33:41 <dkliban> ill add more info
14:33:50 <asmacdo> dkliban: feel free to mark triaged when you do IMO
14:33:51 <daviddavis> ok skip then?
14:33:54 <daviddavis> +1
14:33:58 <asmacdo> !skip
14:33:58 <dkliban> sure
14:33:59 <pulpbot> asmacdo: 6 issues left to triage: 4649, 4651, 4653, 4654, 4655, 4656
14:33:59 <asmacdo> #topic https://pulp.plan.io/issues/4649
14:34:00 <pulpbot> RM 4649 - bherring - NEW - Pulp 2 Nightly fails test_package_paths and test_download_policies
14:34:01 <pulpbot> https://pulp.plan.io/issues/4649
14:34:14 <dkliban> we already figured out the problem
14:34:17 <bherring> That was a nectar problem
14:34:26 <bherring> I believe this already resolved and passed last night.
14:34:27 <dkliban> new version of nectar had not been built
14:34:41 <dkliban> let's close as modified
14:34:41 <bherring> I will be closing it out.
14:34:45 <bherring> ack
14:34:45 <daviddavis> +1
14:34:46 <asmacdo> is there a related issue?
14:34:55 <bherring> +1
14:35:32 <bherring> asmacdo: is that directed at me?
14:35:34 <asmacdo> #idea Proposed for #4649: bherring will mark as MODIFIED and associate related (if there is one)
14:35:34 <asmacdo> !propose other bherring will mark as MODIFIED and associate related (if there is one)
14:35:34 <pulpbot> asmacdo: Proposed for #4649: bherring will mark as MODIFIED and associate related (if there is one)
14:35:36 <dkliban> asmacdo: it was the result of that streamer bug i fixed. new version of nectar was needed
14:35:56 <daviddavis> ok maybe set the streamer issue as related
14:36:05 <asmacdo> thats what i was thinking
14:36:12 <bherring> ack. I will get with dkliban on that
14:36:17 <daviddavis> ty
14:36:24 <asmacdo> #agreed bherring will mark as MODIFIED and associate related (if there is one)
14:36:24 <asmacdo> !accept
14:36:24 <pulpbot> asmacdo: Current proposal accepted: bherring will mark as MODIFIED and associate related (if there is one)
14:36:25 <asmacdo> #topic https://pulp.plan.io/issues/4651
14:36:25 <pulpbot> asmacdo: 5 issues left to triage: 4651, 4653, 4654, 4655, 4656
14:36:26 <pulpbot> RM 4651 - kersom - NEW - As a user, I can install pulp 3 on a RHEL host
14:36:27 <pulpbot> https://pulp.plan.io/issues/4651
14:36:50 <asmacdo> #idea Proposed for #4651: change to story
14:36:50 <asmacdo> !propose other change to story
14:36:50 <pulpbot> asmacdo: Proposed for #4651: change to story
14:36:53 <daviddavis> is pulp 3 expected to work on rhel ?
14:37:03 <mikedep333> new enough components? Absolutely.
14:37:12 <dkliban> yeah
14:37:12 <mikedep333> *packages
14:37:17 <mikedep333> Are all the packages available? Probably not.
14:37:18 <daviddavis> I guess my point is: is this a story or bug?
14:37:24 <mikedep333> EPEL8 does not exist yet.
14:37:29 <dkliban> it's a story
14:37:32 <mikedep333> It's worth trying.
14:37:34 <asmacdo> story for sure
14:37:34 <mikedep333> I have a RHEL8 VM.
14:37:50 <dkliban> we are talking about rhel 7 now
14:37:50 <asmacdo> this story isnt just that pulp can be instaleld on rhel
14:37:59 <asmacdo> its also to add that option to the ansible installer
14:38:06 <daviddavis> I see
14:38:14 <daviddavis> +1 to story
14:38:14 <mikedep333> Oh, RHEL in general. I thought it said "RHEL8".
14:38:27 <daviddavis> yea rhel in general
14:38:32 <asmacdo> im sure ^ is rhel8ed
14:38:36 <mikedep333> I think we need to decide how to handle the optional repo. That's required, isn't it?
14:38:54 <daviddavis> optional repo = epel?
14:39:05 <bmbouter> this kind of falls in the area of user responsibility (I think)
14:39:09 <mikedep333> No. Optional is a repo within RHEL itself.
14:39:14 <mikedep333> We could make it that, yeah.
14:39:19 <daviddavis> I see
14:39:22 <asmacdo> so the proposal is to make this a story
14:39:22 <mikedep333> It's just a common pain point among novice admins.
14:39:24 <dkliban> can we go to the next issue?
14:39:27 <mikedep333> yes
14:39:27 <asmacdo> it needs to be groomed
14:39:32 <asmacdo> but that can be done async
14:39:36 <daviddavis> +1
14:39:40 <asmacdo> #agreed change to story
14:39:40 <asmacdo> !accept
14:39:41 <pulpbot> asmacdo: Current proposal accepted: change to story
14:39:41 <asmacdo> #topic https://pulp.plan.io/issues/4653
14:39:42 <pulpbot> asmacdo: 4 issues left to triage: 4653, 4654, 4655, 4656
14:39:42 <mikedep333> +1
14:39:43 <pulpbot> RM 4653 - bmbouter - NEW - Orphan cleanup fails for some model types due to database cascade PROTECTED options
14:39:44 <pulpbot> https://pulp.plan.io/issues/4653
14:39:56 <daviddavis> this is kinda a core problem
14:40:05 <dawalker> asmacdo, appreciated the pun
14:40:13 <daviddavis> but I can open a separate issue against pulpcore
14:40:17 <daviddavis> so let's skip
14:40:18 <asmacdo> it was rhely bad, but thanks
14:40:22 <daviddavis> lol
14:40:24 <bmbouter> I think this is forthe core issue
14:40:25 <dawalker> :P
14:40:45 <daviddavis> bmbouter: oh I moved it to the ansible plugin
14:41:01 <daviddavis> I can move it back though
14:41:07 <asmacdo> #idea Proposed for #4653: move to pulp and accept
14:41:07 <asmacdo> !propose other move to pulp and accept
14:41:07 <pulpbot> asmacdo: Proposed for #4653: move to pulp and accept
14:41:12 <bmbouter> let's move it back and then 3818 will be the ansible one
14:41:13 <asmacdo> daviddavis: will you handle that?
14:41:17 <daviddavis> sure
14:41:25 <bmbouter> I'm hoping to accpet and add ot sprint as docs
14:41:27 <bmbouter> https://pulp.plan.io/issues/4653#note-7
14:41:36 <dkliban> let's accept
14:41:41 <asmacdo> #agreed move to pulp and accept
14:41:41 <asmacdo> !accept
14:41:41 <pulpbot> asmacdo: Current proposal accepted: move to pulp and accept
14:41:43 <dkliban> and add to sprint
14:41:43 <pulpbot> asmacdo: 3 issues left to triage: 4654, 4655, 4656
14:41:43 <asmacdo> #topic https://pulp.plan.io/issues/4654
14:41:44 <pulpbot> RM 4654 - paji@redhat.com - NEW - Modulemd profiles not getting removed from the consumer
14:41:45 <pulpbot> https://pulp.plan.io/issues/4654
14:41:50 <daviddavis> skip
14:41:54 <dkliban> skip
14:41:57 <bmbouter> skippppp
14:42:03 * daviddavis screams SKIP
14:42:06 <asmacdo> !skip
14:42:07 <asmacdo> #topic https://pulp.plan.io/issues/4655
14:42:08 <pulpbot> asmacdo: 2 issues left to triage: 4655, 4656
14:42:09 <pulpbot> RM 4655 - rmcgover - NEW - updateinfo_checksum_type should be "preferred", not "mandatory" checksum type
14:42:10 <pulpbot> https://pulp.plan.io/issues/4655
14:42:11 <daviddavis> skip
14:42:14 * daviddavis screams SKIP
14:42:14 <asmacdo> !skip
14:42:16 <asmacdo> #topic https://pulp.plan.io/issues/4656
14:42:16 <pulpbot> asmacdo: 1 issues left to triage: 4656
14:42:17 <pulpbot> RM 4656 - ppicka - POST - One shot uploader assign wrong locatication_href
14:42:18 <pulpbot> https://pulp.plan.io/issues/4656
14:42:26 <daviddavis> skip
14:42:50 <ppicka> it is post and fast review enough
14:43:10 <asmacdo> ppicka: im gonna skip, the rpm team can accept
14:43:12 <asmacdo> !skip
14:43:13 <pulpbot> asmacdo: No issues to triage.
14:43:33 <asmacdo> **OPEN FLOOR**
14:44:51 <asmacdo> !issue 19
14:44:52 <asmacdo> #topic https://pulp.plan.io/issues/19
14:44:52 <pulpbot> RM 19 - Anonymous - NEW - As a user, I can scale down my Celery workers without cancelling tasks
14:44:54 <pulpbot> https://pulp.plan.io/issues/19
14:45:12 <asmacdo> i think this would be interesting for Pulp3, obviously not celery works though
14:45:18 <asmacdo> bmbouter: ^
14:46:46 * bmbouter reads
14:47:16 <dalley> well, the timeouts are 30 seconds now, so it's not 5 minutes even w/ pulp 2
14:47:40 <bmbouter> regardless of how workers are scaled down (or lost) we should have tasks never cancel
14:47:49 <asmacdo> oh nice
14:47:53 <asmacdo> then im going to close
14:48:04 <bmbouter> and I have an engineering proposal to resolve it but I need to write it in detail
14:48:27 <asmacdo> bmbouter: do you want me to leave that issue open or would you rather start a new one
14:48:29 <bmbouter> if you close this I will take a todo to write that story and post it back when its done
14:48:41 <bmbouter> let's make a new one
14:48:47 <bmbouter> this already has commits on it
14:48:49 <dkliban> +1 to new
14:48:52 <dawalker> +1
14:48:53 <bmbouter> from 4 years ago
14:49:00 <asmacdo> lol yeah
14:49:01 <bmbouter> but this is very helpful in that now it's not lost
14:49:06 * bmbouter takes the todo
14:49:18 <asmacdo> thats it from me for today, anyone else?
14:49:43 <bmbouter> I wanted to get some clarity on the ansible for rhel ticket
14:50:00 <asmacdo> !issue 4653
14:50:01 <asmacdo> #topic https://pulp.plan.io/issues/4653
14:50:01 <pulpbot> RM 4653 - bmbouter - NEW - Orphan cleanup fails for some model types due to database cascade PROTECTED options
14:50:02 <pulpbot> https://pulp.plan.io/issues/4653
14:50:16 <asmacdo> is that the right one?
14:50:16 <bmbouter> is it a story or a testing activity? I wrote some here https://pulp.plan.io/issues/4651#note-2
14:50:23 <bmbouter> ja :)
14:50:25 <asmacdo> !issue 4651
14:50:26 <asmacdo> #topic https://pulp.plan.io/issues/4651
14:50:26 <pulpbot> RM 4651 - kersom - NEW - As a user, I can install pulp 3 on a RHEL host
14:50:28 <pulpbot> https://pulp.plan.io/issues/4651
14:50:45 <daviddavis> kersom: you around?
14:50:47 <asmacdo> bmbouter: now im confused :)
14:50:50 <kersom> yeah
14:51:11 <kersom> reading the discussion
14:52:11 <bmbouter> kersom: ty
14:52:22 <asmacdo> bmbouter: https://pulp.plan.io/issues/4651#note-3
14:52:34 <kersom> I just read it
14:52:47 <kersom> the installer does not claim rhel in the docs
14:53:12 <kersom> and there are differences btw centos and rhel
14:53:17 <asmacdo> i'm pretty sure the installer would just fail
14:53:22 <kersom> yeap
14:53:35 <asmacdo> it will try to load an os var called vars/rhel.yml or similar
14:53:44 <asmacdo> and it won't be there, and the whole thing will blow up
14:53:58 <asmacdo> (this will happen in multiple roles)
14:54:27 <bmbouter> this makes and we want that to not fail
14:54:40 <bmbouter> how do we assure our centOS compatability today?
14:54:45 <dawalker> didn't someone say yesterday that there needed to be a check up front for a box with access to updates for RHEL to ensure it has a subscription?
14:54:47 <bmbouter> for the intsaller that is
14:55:03 <asmacdo> bmbouter: we use centos containers and run ansible against them in travis
14:55:09 <asmacdo> (using molecule)
14:55:50 <bmbouter> I think that is where this easy ticket gets hard
14:56:15 <bmbouter> if its just a text/fix ticket then we don't claim format support but it does work (best effort)
14:56:23 <bmbouter> work on rhel that is
14:56:52 <bmbouter> if we want to label it with formal support we probably need to do the ci on that other os when we do and I'm not sure how to do that
14:57:06 <asmacdo> that seems reasonable to me
14:57:18 <asmacdo> lets modify this ticket to allow installation (best effort)
14:57:31 <asmacdo> and not officially claim support and add to ci yet
14:57:33 <kersom> we do need pulp 3 being able to install o a rhel box
14:57:52 <kersom> we already discussed this so many times...
14:58:08 <asmacdo> incremental steps :)
14:58:14 <kersom> and this will allow us to test fips
14:58:26 <mikedep333> dawalker, bmbouter: It's not so much updates as access to additional packages. But require being subscribed.
14:58:30 <asmacdo> lets make installation work first before we try to figure out subscriptions in the CI
14:58:42 <mikedep333> *both require
14:58:43 <bmbouter> yeah it's kind of a baby steps approach
14:58:49 <kersom> we do have sucbsciprtion roles for pulp 2
14:58:51 <bmbouter> step 1 let's get it actually working
14:58:53 <kersom> we could reuse them
14:59:02 <bmbouter> oh yes this is the other aspect
14:59:16 <bmbouter> I don't feel the pulp installer should deal w/ subscription aspects
14:59:25 <kersom> https://github.com/pulp/pulp-ci/blob/master/ci/ansible/roles/subscription-manager/tasks/main.yaml
14:59:26 <asmacdo> +1
14:59:29 <bmbouter> that is way outside of its responsibility
14:59:37 <mikedep333> bmbouter: I think we should do it in as separate role needed for our testing.
14:59:49 <bherring> So, assume that is already done before the installer starts working?
14:59:56 <dkliban> yeah
14:59:59 <bherring> i.e. something Satellite would have already done?
15:00:01 <asmacdo> +1 bherring
15:00:15 <bherring> Sure, we can wrap the pulp installer with our own test setup
15:00:17 <bmbouter> mikedep333: agreed but we need it in a separate repo so pulp users don't use them
15:00:41 <mikedep333> bmbouter: That's OK with me.
15:00:48 <bherring> Meaning, I can't argue with that as I think that is the customer's use case.
15:00:53 <kersom> if the ansible installer works in a rhel with subscription we could add this step before to run the installer
15:01:04 <bherring> kersom +1 for internal use
15:01:06 <bmbouter> it's kind of similar to how we also don't ship scripts that manage people's certs anymor ebecause we had CVE's and then we were liable
15:01:18 <kersom> that is how we do for pulp 2
15:01:23 <bherring> bmbouter: ack
15:01:27 <kersom> I just shared the link
15:01:34 <kersom> https://github.com/pulp/pulp-ci/blob/master/ci/ansible/roles/subscription-manager/tasks/main.yaml
15:01:36 <kersom> again
15:01:48 <bherring> Right. They don't want to be liable.
15:01:59 <bherring> I think the downstream case is other software would manage this outside of pulp.
15:02:12 * bherring realizes where he is
15:02:33 <bmbouter> yeah like other paid OSes for example, another distro that needs some other sort of cert/validation/update workflow
15:02:39 <bmbouter> that's all outside of Pulp
15:03:26 <bherring> bmbouter: do we state these assumptions anywhere for consumers?
15:03:45 <bherring> Meaning, it is fine to draw lines of demarcation, but it should be understood by both parties, no?
15:03:54 <asmacdo> does it need to be?
15:04:05 <bherring> Why would it not?
15:04:18 <asmacdo> "you can install pulp an whatever operating system you want" does not imply that we will set up that operating system for you
15:04:27 <bmbouter> I agree
15:04:28 <bherring> Ah. Understood.
15:04:42 <bmbouter> we keep it general because that's actually where our compatability is (which is pretty awesome)
15:04:58 <bherring> Thanks for walking through that, asmacdo
15:05:10 <asmacdo> no worries, its tricky business
15:05:18 <asmacdo> so #4651...
15:05:47 <asmacdo> consensus seems to be, that this issue is to add whatever is necessary for the ansible installer to work on rhel7
15:05:55 <bmbouter> I think it needs scope clarity (no registration) and also that it's to test that it works on rhel7
15:05:56 <asmacdo> this issue will exclude CI work
15:05:57 <bmbouter> yes
15:05:59 <bmbouter> yes
15:06:23 <asmacdo> lets file a separate issue for testing, since that will require CI
15:06:51 <asmacdo> maybe once rhel install is working, QE can set up the subscription stuff
15:06:53 <kersom> sound good, we can improve and modify as needed.
15:07:13 <kersom> asmacdo, yes. we can add the subscription part of it.
15:07:16 <asmacdo> i think I would be comfortable not including rhel in the ansible-pulp CI provided that it was used regularly by qe
15:07:35 <kersom> what do you mean?
15:07:43 <kersom> not running using molecule?
15:07:49 <asmacdo> yeah
15:08:08 <bmbouter> my hope is that we figure out how to CI on rhel in a public way
15:08:09 <kersom> it does make sense, how are you going to test that is working on rhel?
15:08:24 <bmbouter> the community can't have any assurance without having access to the test results and systems
15:08:51 <asmacdo> we can certainly include it in the CI, but not immediately
15:08:58 <kersom> gotcha
15:09:14 <dawalker> \o/ a successful use of open floor post-triage! Now don't forget to end triage at some point...
15:09:35 <asmacdo> ok so, we update 4651 to limit the scope, and file a new related issue to figure out RHEL CI for ansible-pulp
15:09:48 <asmacdo> sound right?
15:10:00 <kersom> +1
15:10:45 <kersom> thanks for this discussion. It is nice to understand different views.
15:10:54 <kersom> point of views
15:12:42 <asmacdo> #endmeeting