14:30:58 <asmacdo> #startmeeting Pulp Triage 2019-04-12
14:30:58 <asmacdo> #info asmacdo has joined triage
14:30:58 <asmacdo> !start
14:30:58 <pulpbot> Meeting started Fri Apr 12 14:30:58 2019 UTC.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:58 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:58 <pulpbot> The meeting name has been set to 'pulp_triage_2019-04-12'
14:30:58 <pulpbot> asmacdo: asmacdo has joined triage
14:31:12 <daviddavis> #info daviddavis has joined triage
14:31:12 <daviddavis> !here
14:31:12 <pulpbot> daviddavis: daviddavis has joined triage
14:31:18 <dkliban> #info dkliban has joined triage
14:31:18 <dkliban> !here
14:31:18 <pulpbot> dkliban: dkliban has joined triage
14:31:29 <asmacdo> daviddavis++
14:31:29 <pulpbot> asmacdo: daviddavis's karma is now 184
14:31:31 <bmbouter> #info bmbouter has joined triage
14:31:31 <bmbouter> !here
14:31:31 <pulpbot> bmbouter: bmbouter has joined triage
14:31:35 <asmacdo> so  frequently first in :)
14:31:41 <ppicka> #info ppicka has joined triage
14:31:41 <ppicka> !here
14:31:41 <pulpbot> ppicka: ppicka has joined triage
14:31:42 <asmacdo> !next
14:31:43 <pulpbot> asmacdo: 7 issues left to triage: 4602, 4648, 4662, 4665, 4672, 4676, 4679
14:31:43 <asmacdo> #topic https://pulp.plan.io/issues/4602
14:31:44 <pulpbot> RM 4602 - mdepaulo@redhat.com - NEW - /var/lib/pulp/tmp/ seems to violate the FHS
14:31:45 <pulpbot> https://pulp.plan.io/issues/4602
14:31:52 <dkliban> skip?
14:32:02 <daviddavis> yea, who is this waiting on?
14:32:11 <bmbouter> I think we can accept now
14:32:14 <dkliban> ok
14:32:15 <daviddavis> ok
14:32:16 <bmbouter> it'll be a docs thing
14:32:20 <dkliban> accept
14:32:23 <bmbouter> and I can try to work on it today and get mike to review
14:32:26 <daviddavis> +1
14:32:39 <asmacdo> #idea Proposed for #4602: Leave the issue as-is, accepting its current state.
14:32:39 <asmacdo> !propose accept
14:32:39 <pulpbot> asmacdo: Proposed for #4602: Leave the issue as-is, accepting its current state.
14:32:40 <dkliban> accept and add to sprint
14:32:42 <dawalker> #info dawalker has joined triage
14:32:42 <dawalker> !here
14:32:42 <pulpbot> dawalker: dawalker has joined triage
14:32:44 <mikedep333> !here (a wizard arrives precisely when he means to)
14:32:44 <pulpbot> mikedep333: (here mark yourself present for triage) -- Records a note in the meeting minutes that you are present for this triage session. The meeting chair and anyone participating using triage bot commands should be automatically added.
14:32:49 <asmacdo> #idea Proposed for #4602: accept and add to the sprint
14:32:49 <asmacdo> !propose other accept and add to the sprint
14:32:49 <pulpbot> asmacdo: Proposed for #4602: accept and add to the sprint
14:32:55 <mikedep333> #info mikedep333 has joined triage
14:32:55 <mikedep333> !here
14:32:55 <pulpbot> mikedep333: mikedep333 has joined triage
14:33:11 <asmacdo> lol, glad to have a wizard in here
14:33:17 <ttereshc> #info ttereshc has joined triage
14:33:17 <ttereshc> !here
14:33:17 <pulpbot> ttereshc: ttereshc has joined triage
14:33:21 <bmbouter> me too
14:33:23 <asmacdo> mikedep333: all good to accept this?
14:34:10 <mikedep333> 4602? Yes, on the docs update.
14:34:18 <asmacdo> #agreed accept and add to the sprint
14:34:18 <asmacdo> !accept
14:34:18 <pulpbot> asmacdo: Current proposal accepted: accept and add to the sprint
14:34:19 <pulpbot> asmacdo: 6 issues left to triage: 4648, 4662, 4665, 4672, 4676, 4679
14:34:19 <asmacdo> #topic https://pulp.plan.io/issues/4648
14:34:20 <pulpbot> RM 4648 - dkliban@redhat.com - NEW - 'reset-admin-password' django-admin command is listed under 'app' section of help text
14:34:21 <pulpbot> https://pulp.plan.io/issues/4648
14:35:25 <dkliban> i updated the description
14:35:32 <dkliban> i think we should accept
14:35:47 <asmacdo> #idea Proposed for #4648: Leave the issue as-is, accepting its current state.
14:35:47 <asmacdo> !propose accept
14:35:47 <pulpbot> asmacdo: Proposed for #4648: Leave the issue as-is, accepting its current state.
14:35:51 <bmbouter> +1
14:35:53 <ppicka> +1
14:36:12 <bmbouter> tag as 3.0
14:36:25 <bmbouter> sprint/milestone = 3.0
14:36:29 <asmacdo> +1
14:37:01 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:37:01 <asmacdo> !accept
14:37:01 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:37:02 <pulpbot> asmacdo: 5 issues left to triage: 4662, 4665, 4672, 4676, 4679
14:37:02 <dalley> !here
14:37:02 <asmacdo> #topic https://pulp.plan.io/issues/4662
14:37:02 <dalley> #info dalley has joined triage
14:37:03 <pulpbot> RM 4662 - kersom - NEW - Few fields returned by task reported by orphans endpoint set as None
14:37:04 <pulpbot> https://pulp.plan.io/issues/4662
14:37:05 <pulpbot> dalley: dalley has joined triage
14:37:16 <bmbouter> I think this is a legit issue
14:37:24 <bmbouter> and we should put onto sprint + accept
14:37:28 <dkliban> yp ... accept and add to sprint
14:37:31 <ttereshc> +1
14:37:31 <dalley> +1
14:37:36 <daviddavis> +1
14:37:56 <asmacdo> #idea Proposed for #4662: accept and add to sprint
14:37:56 <asmacdo> !propose other accept and add to sprint
14:37:56 <pulpbot> asmacdo: Proposed for #4662: accept and add to sprint
14:38:22 <asmacdo> ill also add 3.0 milestone
14:38:34 <daviddavis> great
14:38:47 <asmacdo> #agreed accept and add to sprint
14:38:47 <asmacdo> !accept
14:38:47 <pulpbot> asmacdo: Current proposal accepted: accept and add to sprint
14:38:48 <bmbouter> +1
14:38:48 <asmacdo> #topic https://pulp.plan.io/issues/4665
14:38:49 <pulpbot> asmacdo: 4 issues left to triage: 4665, 4672, 4676, 4679
14:38:50 <pulpbot> RM 4665 - kersom - NEW - Field base_version set as none even when repo has multiple versions
14:38:51 <pulpbot> https://pulp.plan.io/issues/4665
14:39:13 <daviddavis> accept
14:39:15 <ttereshc> +1 to accept
14:39:15 <bmbouter> +1
14:39:17 <asmacdo> im not sure if this does make sense for mirror=True
14:39:33 <asmacdo> this feature only makes sense if the version was created from another version right?
14:39:46 <bmbouter> every version (except the first) is made from another version
14:39:48 <dkliban> but every version except 1 is
14:39:50 <kersom> yeap
14:39:56 <ppicka> +1
14:39:58 <bmbouter> the packages could change significantly version to version
14:40:11 <asmacdo> ok thats cool
14:40:19 <asmacdo> #idea Proposed for #4665: Leave the issue as-is, accepting its current state.
14:40:19 <asmacdo> !propose accept
14:40:19 <pulpbot> asmacdo: Proposed for #4665: Leave the issue as-is, accepting its current state.
14:40:23 <daviddavis> wait
14:40:24 <asmacdo> 3.0?
14:40:28 <bmbouter> +1 3.0
14:40:28 <daviddavis> should we add the 3.0 milestone
14:40:30 <dkliban> yes
14:40:30 <daviddavis> yea ok
14:40:34 <daviddavis> will be a pain to migrate
14:40:54 <asmacdo> lol right
14:41:02 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:41:02 <asmacdo> !accept
14:41:02 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:41:04 <pulpbot> asmacdo: 3 issues left to triage: 4672, 4676, 4679
14:41:04 <asmacdo> #topic https://pulp.plan.io/issues/4672
14:41:05 <pulpbot> RM 4672 - kersom - NEW - Actions over task system missing documentation
14:41:06 <pulpbot> https://pulp.plan.io/issues/4672
14:41:27 <daviddavis> I also wonder if we should be showing a user error message
14:41:31 <daviddavis> 409 could mean anything
14:41:36 <kersom> the issue #4665 does not make sense to me. Later if someone can explain to me, I appreciate it.
14:42:14 <asmacdo> kersom: sure, ping me after
14:42:19 <dkliban> we should add docs
14:42:26 <kersom> asmacdo, thanks.
14:42:28 <dkliban> daviddavis: this is a docs issue
14:42:34 <asmacdo> daviddavis: I think if we include 409 in the REST docs, that should be fine
14:42:38 <kersom> yeap
14:42:49 <daviddavis> I think we could do both tho?
14:42:49 <dkliban> asmacdo: add documentation tag on this
14:42:54 <bmbouter> +1 docs tag
14:43:03 <daviddavis> it already has a docs tag
14:43:08 <asmacdo> #idea Proposed for #4672: accept +documentation +3.0milestone and add to sprint
14:43:08 <asmacdo> !propose other accept +documentation +3.0milestone and add to sprint
14:43:08 <pulpbot> asmacdo: Proposed for #4672: accept +documentation +3.0milestone and add to sprint
14:43:12 <dkliban> +1
14:43:18 <ttereshc> I agree with daviddavis , "reason" can be better
14:43:23 <ttereshc> than just Conflict
14:43:24 <bmbouter> agreed also
14:43:28 <bmbouter> conflict does not seem right
14:43:34 <daviddavis> I'll file a separate issue
14:43:41 <kersom> related to http status code, do you have standards around them?
14:43:45 <kersom> we*
14:43:55 <bmbouter> generally we try to follow the standard
14:44:01 <asmacdo> daviddavis: can we do it on the same issue? it would be not ideal to add docs for 409 and then change it
14:44:03 <daviddavis> yes it's called rfc2616
14:44:06 <kersom> this is the only 209 that I recorded seen
14:44:09 <daviddavis> asmacdo: +1
14:44:12 <bmbouter> there is a bit of interpretation here and there, but generally we let drf do the work
14:44:13 <kersom> I mean for pulp endpoints
14:44:22 <kersom> ah I see
14:44:31 <ttereshc> bmbouter, I think 409 is our addition
14:44:36 <kersom> delete always produces 204, for instance?
14:44:40 <bmbouter> strange
14:45:01 <asmacdo> daviddavis: i'm going to accept, any concerns, please comment on the issue
14:45:06 <ttereshc> bmbouter, we specifically added 409 instead of general 400 for specific cases
14:45:11 <daviddavis> asmacdo: ok
14:45:12 <kersom> I was trying to compare and I could not find a doc explained this for pulp 3
14:45:21 <bmbouter> ttereshc: where does this happen?
14:45:35 <ttereshc> bmbouter, I'll try to find an issue
14:45:36 <bmbouter> we can answer later also
14:45:38 <bmbouter> ty
14:45:46 <asmacdo> #agreed accept +documentation +3.0milestone and add to sprint
14:45:46 <asmacdo> !accept
14:45:46 <pulpbot> asmacdo: Current proposal accepted: accept +documentation +3.0milestone and add to sprint
14:45:47 <asmacdo> #topic https://pulp.plan.io/issues/4676
14:45:47 <pulpbot> asmacdo: 2 issues left to triage: 4676, 4679
14:45:48 <pulpbot> RM 4676 - jdjeffers - NEW - Documentation for PATCH /pulp/api/v3/remotes/file/file/:ref doesn't match behavior
14:45:49 <pulpbot> https://pulp.plan.io/issues/4676
14:45:59 <asmacdo> we can come back to that one during open floor if anyone is interested
14:46:14 <dkliban> this is a problem iwth the bindings
14:46:21 <bmbouter> agreed
14:46:21 <dkliban> let's accept and add to sprint
14:46:23 <bmbouter> +1
14:46:27 <ttereshc> +1
14:46:29 <bmbouter> 3.0 milestone
14:46:48 <asmacdo> #idea Proposed for #4676: accept +add to sprint +3.0milestone
14:46:48 <asmacdo> !propose other accept +add to sprint +3.0milestone
14:46:48 <pulpbot> asmacdo: Proposed for #4676: accept +add to sprint +3.0milestone
14:47:06 <asmacdo> do we want to change this to "File Support" or should this be treated as a pulpcore issue
14:47:28 <daviddavis> I'm a bit confused by this issue
14:47:33 <daviddavis> I tried to reproduce but couldn't
14:47:37 <daviddavis> see my comment
14:47:43 <daviddavis> is it a bindings issue?
14:47:45 <kersom> I talked with rochacbruno about bindings testing, more than use a diff to compare json files, it will require a drastic change in the way that we are currently writing tests. Not sure if we are going to be able to do this now.
14:47:46 <dkliban> yes
14:47:54 <daviddavis> ok we should add the bindings tag then
14:48:18 <daviddavis> I think this could be pulpcore since the serializer and fields exist in core
14:48:23 <dkliban> yeah
14:48:27 <bmbouter> makes sense
14:49:08 <asmacdo> #agreed accept +add to sprint +3.0milestone
14:49:08 <asmacdo> !accept
14:49:08 <pulpbot> asmacdo: Current proposal accepted: accept +add to sprint +3.0milestone
14:49:09 <asmacdo> #topic https://pulp.plan.io/issues/4679
14:49:09 <pulpbot> asmacdo: 1 issues left to triage: 4679
14:49:10 <pulpbot> RM 4679 - tustvold - NEW - Custom settings not propogating
14:49:11 <pulpbot> https://pulp.plan.io/issues/4679
14:49:43 <dkliban> we already hav ea PR that's going to fix it
14:49:58 <dkliban> rochacbruno made a PR for the latest version of DynaConf integration
14:50:06 <dkliban> so let's accept and add to sprint
14:50:14 <bmbouter> +1
14:50:23 <asmacdo> #idea Proposed for #4679: accept, add to sprint, rochacbruno to take as assigned
14:50:23 <asmacdo> !propose other accept, add to sprint, rochacbruno to take as assigned
14:50:23 <pulpbot> asmacdo: Proposed for #4679: accept, add to sprint, rochacbruno to take as assigned
14:50:25 <ttereshc> +1
14:50:51 <asmacdo> #agreed accept, add to sprint, rochacbruno to take as assigned
14:50:51 <asmacdo> !accept
14:50:52 <pulpbot> asmacdo: Current proposal accepted: accept, add to sprint, rochacbruno to take as assigned
14:50:53 <pulpbot> asmacdo: No issues to triage.
14:51:13 <asmacdo> rochacbruno: i went ahead and assigned you. feel free to correct that if you disagree
14:51:19 <asmacdo> Open floor!
14:51:22 <ttereshc> bmbouter, re 409 code, I remember a lot of discussion about it next to my desk :), it turned out the PR was not merged and issues was closed https://pulp.plan.io/issues/3846
14:51:29 <kersom> https://pulp.plan.io/issues/3527 that is the issue that introduced the 409
14:51:43 <asmacdo> !issue 4672
14:51:43 <asmacdo> #topic https://pulp.plan.io/issues/4672
14:51:44 <pulpbot> RM 4672 - kersom - NEW - Actions over task system missing documentation
14:51:45 <pulpbot> https://pulp.plan.io/issues/4672
14:51:57 <daviddavis> I just responded to this btw
14:52:22 <bmbouter> I think 400 is right and 409 is not what I expected
14:52:41 <rochacbruno> asmacdo: cool, I'll try to reproduce that problem and if needed I update my opened PR
14:52:56 <asmacdo> 409:   The request could not be completed due to a conflict with the current
14:52:57 <asmacdo> state of the resource.
14:53:14 <asmacdo> that sounds correct to me, the task state prevents it from getting deleted
14:53:33 <kersom> and a error message explaining why would be great as well
14:53:35 <bmbouter> so the delete works if it's in completed?
14:53:45 * bmbouter rereads
14:53:48 <daviddavis> correct
14:53:54 <kersom> that is another part of the documentation missing
14:54:16 <bmbouter> ic
14:54:27 <bmbouter> asmacdo: I think you're right then about the 409
14:54:37 <bmbouter> and kersom you are right about the missing docs
14:54:39 <daviddavis> I just want to point out that rfc2616 says "The response body SHOULD include enough information for the user to recognize the source of the conflict."
14:54:41 <bmbouter> and perhaps the error message too
14:54:51 <bmbouter> yeah we are not doing that part
14:54:55 <bmbouter> let's do that part
14:54:55 <kersom> daviddavis, +1
14:55:15 <asmacdo> +1. if the error message is clear, then the other part is also true :This code is only allowed in situations where
14:55:15 <asmacdo> it is expected that the user might be able to resolve the conflict
14:55:15 <asmacdo> and resubmit the request.
14:55:26 <daviddavis> ok, I am fine with 409
14:55:35 <asmacdo> if the user sees a descriptive 409, they can cancel the task, and then delete it
14:55:41 <daviddavis> +1
14:55:47 <kersom> I wrote tests for the task system covering those topics
14:55:49 <kersom> https://github.com/pulp/pulpcore/pull/80
14:55:57 <kersom> I can update them later
14:56:07 <asmacdo> anyone want to update this issue with what we discussed here?
14:57:00 <asmacdo> ill grab do it then
14:57:16 <asmacdo> anyone else got an issue they'd like to discuss?
14:57:23 <bmbouter> I do
14:57:25 <daviddavis> does it have to be a bug?
14:57:33 <bmbouter> https://pulp.plan.io/issues/4678
14:57:36 <asmacdo> daviddavis: na, i think it can be anything
14:57:41 <asmacdo> !issue 4678
14:57:42 <asmacdo> #topic https://pulp.plan.io/issues/4678
14:57:42 <pulpbot> RM 4678 - bmbouter - NEW - As a plugin writer, I have Master/Detail Publications
14:57:43 <pulpbot> https://pulp.plan.io/issues/4678
14:57:50 <asmacdo> oh, yes
14:58:23 <asmacdo> bmbouter: ive been wondering about this one, and whether we actually should delete the publishers
14:58:36 <asmacdo> IMO many plugins should for sure delete the publishers
14:58:45 <bmbouter> they only create a 2-step workflow I've realized
14:58:53 <asmacdo> but some plugins might have values that they want to repeat
14:59:03 <daviddavis> I need to read this I suppose
14:59:10 * daviddavis just saw we're removing publishers
14:59:13 <asmacdo> it would be irritating to have to enter them in for every POST  Publication  request
14:59:22 <bmbouter> asmacdo: I see your point
14:59:34 <asmacdo> I think pulpcore should leave in Publisher for any plugins that it helps
14:59:34 <daviddavis> would it be possible for a plugin to create a publisher?
14:59:38 <daviddavis> without it being in core?
14:59:58 <daviddavis> I guess we can leave it core as well if it helps plugins
15:00:00 <bmbouter> asmacdo: I can see the use case you are talking about
15:00:13 <bmbouter> we can revise this to leave publishers as-is
15:00:19 <asmacdo> awesome
15:00:22 <bmbouter> which also makes this a simpler change
15:00:28 <asmacdo> generally, I really like this
15:00:50 <bmbouter> hopefully those who use publishers will record the actual options used on the publication but that is up to them
15:00:51 <daviddavis> does GET /pulp/api/v3/publications/ go away?
15:00:57 <asmacdo> yes
15:01:04 <daviddavis> I see
15:01:05 <asmacdo> so this won't be backwards compatible
15:01:11 <bmbouter> that's true
15:01:17 <asmacdo> bmbouter: IIRC you said it could be done backwards compatible somehwere?
15:01:28 <bmbouter> I was focusing on the plugin interface mainly
15:01:33 <asmacdo> ah ok
15:01:48 <asmacdo> so this will be a little bit awkward
15:02:02 <daviddavis> can we bring this up next week? I'd like time to review it more.
15:02:09 <bmbouter> yes this is not decision time
15:02:15 <daviddavis> ok cool
15:02:15 <bmbouter> it's advertisement and discussion time
15:02:24 <bmbouter> please comment w/ ideas/concerns etc
15:02:44 <bmbouter> next?
15:02:46 <daviddavis> I like this change but I hate master detail
15:02:54 <daviddavis> #4487
15:03:02 <asmacdo> !issue 4487
15:03:03 <asmacdo> #topic https://pulp.plan.io/issues/4487
15:03:03 <pulpbot> RM 4487 - daviddavis - NEW - As a user, I can spin up Pulp in a FIPS enabled environment with pulplift
15:03:04 <pulpbot> https://pulp.plan.io/issues/4487
15:03:20 <daviddavis> I just wanted to advertise this issue because there's a lot of FIPS work slated for 3.0 and this is blocking it
15:03:34 <asmacdo> btw, it is 11:03, so we can keep going, but people may drop off
15:04:14 <asmacdo> daviddavis: is this blocked by installing on RHEL?
15:04:16 <bmbouter> we should put this onto the sprint
15:04:27 <bmbouter> CentOS has fips right?
15:04:35 <daviddavis> asmacdo: no, we can use centos. there's a centos-fips box in forklift as well.
15:04:38 <daviddavis> yea
15:04:44 <asmacdo> sweet
15:04:50 <bmbouter> let's get this onto the sprint we should do this
15:04:52 <asmacdo> #idea Proposed for #4487: add to sprint
15:04:52 <asmacdo> !propose other add to sprint
15:04:53 <pulpbot> asmacdo: Proposed for #4487: add to sprint
15:04:57 <daviddavis> +1
15:05:14 <asmacdo> I'd love to help with this, but im super ignorant with FIPs
15:05:31 <asmacdo> so whoever picks up, feel free to discuss with me
15:05:44 <asmacdo> #agreed add to sprint
15:05:44 <asmacdo> !accept
15:05:44 <pulpbot> asmacdo: Current proposal accepted: add to sprint
15:05:45 <pulpbot> asmacdo: No issues to triage.
15:06:05 <daviddavis> +1
15:06:06 <asmacdo> thats our time, so im going to end
15:06:08 <asmacdo> #endmeeting
15:06:08 <asmacdo> !end