14:30:58 <asmacdo> #startmeeting Pulp Triage 2019-04-16
14:30:58 <asmacdo> #info asmacdo has joined triage
14:30:58 <asmacdo> !start
14:30:58 <pulpbot> Meeting started Tue Apr 16 14:30:58 2019 UTC.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:58 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:58 <pulpbot> The meeting name has been set to 'pulp_triage_2019-04-16'
14:30:58 <pulpbot> asmacdo: asmacdo has joined triage
14:31:11 <dkliban> #info dkliban has joined triage
14:31:11 <dkliban> !here
14:31:11 <pulpbot> dkliban: dkliban has joined triage
14:31:22 <ppicka> #info ppicka has joined triage
14:31:22 <ppicka> !here
14:31:23 <pulpbot> ppicka: ppicka has joined triage
14:31:27 <dalley> #info dalley has joined triage
14:31:27 <dalley> !here
14:31:27 <pulpbot> dalley: dalley has joined triage
14:31:30 <asmacdo> hope i didn't screw this up by starting it in #pulp also ...
14:31:32 <asmacdo> !next
14:31:44 <asmacdo> apparently i did
14:31:46 <asmacdo> !end
14:31:46 <ipanova> #info ipanova has joined triage
14:31:46 <ipanova> !here
14:31:47 <pulpbot> ipanova: ipanova has joined triage
14:31:49 <asmacdo> #info asmacdo has joined triage
14:31:49 <asmacdo> !start
14:31:49 <pulpbot> asmacdo: Error: Can't start another meeting, one is in progress.
14:31:50 <pulpbot> asmacdo: asmacdo has joined triage
14:32:01 <asmacdo> oh no. it says i'm not the meeting chair
14:32:07 <asmacdo> !next
14:32:08 <pulpbot> asmacdo: 6 issues left to triage: 4561, 4680, 4681, 4684, 4693, 4700
14:32:08 <asmacdo> #topic https://pulp.plan.io/issues/4561
14:32:09 <pulpbot> RM 4561 - siberijah - NEW - E11000 duplicate key error during pulp-manage-db command
14:32:10 <pulpbot> https://pulp.plan.io/issues/4561
14:32:20 <dkliban> this is not a bug
14:32:28 <dkliban> user is trying to learn how to migrate mongo dbs
14:32:30 <bmbouter> #info bmbouter has joined triage
14:32:30 <bmbouter> !here
14:32:30 <pulpbot> bmbouter: bmbouter has joined triage
14:32:35 <dkliban> not really our problem
14:32:41 <daviddavis> #info daviddavis has joined triage
14:32:41 <daviddavis> !here
14:32:41 <pulpbot> daviddavis: daviddavis has joined triage
14:33:03 <asmacdo> dkliban: would you mind closing it and pointing them at mongo docs?
14:33:23 <dkliban> i don't mind ... i'll even tell them to reach out on the mailing list
14:33:28 <dkliban> others may have advice
14:33:36 <asmacdo> +1, thats a better venue for that
14:33:41 <ipanova> +1
14:33:45 <daviddavis> +1
14:33:47 <asmacdo> #idea Proposed for #4561: dkliban will close and suggest better venue
14:33:47 <asmacdo> !propose other dkliban will close and suggest better venue
14:33:47 <pulpbot> asmacdo: Proposed for #4561: dkliban will close and suggest better venue
14:33:54 <dalley> +1
14:33:55 <asmacdo> #agreed dkliban will close and suggest better venue
14:33:55 <asmacdo> !accept
14:33:55 <pulpbot> asmacdo: Current proposal accepted: dkliban will close and suggest better venue
14:33:56 <pulpbot> asmacdo: 5 issues left to triage: 4680, 4681, 4684, 4693, 4700
14:33:56 <asmacdo> #topic https://pulp.plan.io/issues/4680
14:33:57 <pulpbot> RM 4680 - kersom - NEW - Document use cases to use repository base_version
14:33:58 <pulpbot> https://pulp.plan.io/issues/4680
14:34:04 <daviddavis> accept
14:34:07 <asmacdo> kersom: i was unclear about this one
14:34:22 <asmacdo> we don't often include "why " someone would want to use a feature
14:34:33 <kersom> It was based on the discussion with daviddavis
14:34:33 <asmacdo> especially not in our REST API docs
14:34:41 <bmbouter> we could have a rollback workflow
14:34:59 <kersom> well, those features have to be added in docs, besides REST API docs
14:35:09 <bmbouter> https://docs.pulpproject.org/en/3.0/nightly/workflows/index.html
14:35:13 <bmbouter> we could have a rollback
14:35:14 <kersom> they will complement each other
14:35:16 <bmbouter> section
14:35:20 <daviddavis> bmbouter: +1
14:35:28 <dkliban> yeah ... let's add a section to the workflows
14:35:34 <kersom> rest api docs is great, but does not describe what pulp does clear
14:35:42 <dkliban> kersom: i agree
14:35:48 <dkliban> let's accept and add to sprint
14:36:00 <daviddavis> I don't think rest api docs are for workflows
14:36:08 <asmacdo> #idea Proposed for #4680: accept and add to the sprint, update to move docs to workflow
14:36:08 <asmacdo> !propose other accept and add to the sprint, update to move docs to workflow
14:36:08 <pulpbot> asmacdo: Proposed for #4680: accept and add to the sprint, update to move docs to workflow
14:36:16 <asmacdo> yes, rest api docs are reference docs
14:36:26 <asmacdo> you should understand what it does, and all your options
14:36:26 <kersom> asmacdo, agree
14:36:26 <dkliban> workflows link to REST API docs for reference
14:36:36 <daviddavis> sure
14:36:38 <kersom> dkliban, +1
14:36:41 <asmacdo> workflows tie many REST calls together and give you a "why"
14:36:46 <dkliban> yep
14:36:51 <kersom> that is missing
14:37:08 <kersom> there are many other cases
14:37:24 <kersom> should I file an issue for every case that I see?
14:37:26 <asmacdo> kersom: could you make a list and ping me later
14:37:31 <kersom> sure
14:37:35 <asmacdo> perfect
14:37:38 <asmacdo> #agreed accept and add to the sprint, update to move docs to workflow
14:37:38 <asmacdo> !accept
14:37:39 <pulpbot> asmacdo: Current proposal accepted: accept and add to the sprint, update to move docs to workflow
14:37:39 <mikedep333> !here
14:37:39 <asmacdo> #topic https://pulp.plan.io/issues/4681
14:37:39 <mikedep333> #info mikedep333 has joined triage
14:37:40 <pulpbot> asmacdo: 4 issues left to triage: 4681, 4684, 4693, 4700
14:37:41 <pulpbot> RM 4681 - tustvold - NEW - pulpcore.app.models.Content is not abstract
14:37:42 <pulpbot> https://pulp.plan.io/issues/4681
14:37:43 <pulpbot> mikedep333: mikedep333 has joined triage
14:37:49 <bherring> #info bherring has joined triage
14:37:49 <bherring> !here
14:37:49 <pulpbot> bherring: bherring has joined triage
14:37:57 <asmacdo> the title of this one needs to change
14:37:59 <asmacdo> at least.
14:38:20 <asmacdo> my guess is that they are trying to install 2 incompatible versions
14:38:42 <asmacdo> pulp_deb requiring a different version of pulpcore-plugin than pulp_rpm
14:38:42 <dkliban> i think we need to accept and have someone try to reproduce
14:38:49 <dkliban> and then provide advice for the reporter
14:39:14 <bmbouter> iirc this is a problem we hit before
14:39:31 <asmacdo> when we hit this problem, its not a bug, its an env issue
14:39:31 <bmbouter> accept and investigate is fine w/ me
14:39:37 <daviddavis> both plugins have a Package model which extends Content
14:39:40 <daviddavis> I think that's the problem
14:39:50 <bmbouter> oic
14:39:52 <dkliban> oh ok
14:39:54 <dkliban> that makes sense
14:39:54 <asmacdo> oh ok that changes things for me
14:39:55 <bmbouter> but they are namespaced?
14:39:56 <daviddavis> it's trying to create the reverse association
14:39:58 <asmacdo> +1 accept
14:40:05 <dkliban> accept and add to sprint
14:40:06 <ipanova> +1 and add to the sprint
14:40:08 <bmbouter> +1
14:40:10 <daviddavis> +1
14:40:16 <bmbouter> we need to investigate/support anyway
14:40:17 <asmacdo> #idea Proposed for #4681: accept and add to sprint
14:40:17 <asmacdo> !propose other accept and add to sprint
14:40:17 <pulpbot> asmacdo: Proposed for #4681: accept and add to sprint
14:40:32 <asmacdo> daviddavis: could you please handle this one and comment?
14:40:46 <daviddavis> sure
14:40:56 <daviddavis> I think the priority should be high on this
14:41:03 <daviddavis> I'm worried we have a serious problem
14:41:14 <dkliban> i agre
14:41:19 <asmacdo> #idea Proposed for #4681: accept and add to sprint high/high
14:41:19 <asmacdo> !propose other accept and add to sprint high/high
14:41:19 <pulpbot> asmacdo: Proposed for #4681: accept and add to sprint high/high
14:41:20 <bmbouter> I agree
14:41:23 <daviddavis> cool
14:41:29 <asmacdo> #agreed accept and add to sprint high/high
14:41:29 <asmacdo> !accept
14:41:29 <pulpbot> asmacdo: Current proposal accepted: accept and add to sprint high/high
14:41:31 <asmacdo> #topic https://pulp.plan.io/issues/4684
14:41:31 <pulpbot> asmacdo: 3 issues left to triage: 4684, 4693, 4700
14:41:32 <pulpbot> RM 4684 - dkliban@redhat.com - NEW - pulp_ostree 1.4.0 doesn't store all info when sync has depth of 1
14:41:33 <pulpbot> https://pulp.plan.io/issues/4684
14:41:51 <asmacdo> !skip
14:41:52 <asmacdo> #topic https://pulp.plan.io/issues/4693
14:41:52 <pulpbot> asmacdo: 2 issues left to triage: 4693, 4700
14:41:54 <pulpbot> RM 4693 - paji@redhat.com - NEW - Module Streams not copying correctly with recursive and recursive_conservative
14:41:55 <pulpbot> https://pulp.plan.io/issues/4693
14:42:10 <asmacdo> !skip
14:42:11 <pulpbot> asmacdo: 1 issues left to triage: 4700
14:42:11 <asmacdo> #topic https://pulp.plan.io/issues/4700
14:42:12 <pulpbot> RM 4700 - dkliban@redhat.com - NEW - validation error for 'base_path' of Distribution is not clear
14:42:13 <pulpbot> https://pulp.plan.io/issues/4700
14:42:29 <daviddavis> accept
14:42:38 <asmacdo> #idea Proposed for #4700: Leave the issue as-is, accepting its current state.
14:42:38 <asmacdo> !propose accept
14:42:38 <pulpbot> asmacdo: Proposed for #4700: Leave the issue as-is, accepting its current state.
14:42:53 <ipanova> +1
14:43:01 <asmacdo> dkliban: should we add to sprint? looks like you might be working on it?
14:43:11 <dkliban> i am not working on it. it was not an easy fix
14:43:43 <asmacdo> k ill just accept then
14:43:46 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:43:46 <asmacdo> !accept
14:43:46 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:43:47 <pulpbot> asmacdo: No issues to triage.
14:43:59 <asmacdo> Open floor! Go!
14:44:04 <kersom> why we skipped the #4684?
14:44:22 <asmacdo> plugin issue
14:44:32 <kersom> triage per plugin team?
14:44:36 <asmacdo> yes
14:44:40 <kersom> ok
14:44:44 <dkliban> kersom: but if you want to discuss we can
14:44:48 <dkliban> asmacdo: pull it up
14:44:56 <asmacdo> !issue 4684
14:44:56 <asmacdo> #topic https://pulp.plan.io/issues/4684
14:44:57 <pulpbot> RM 4684 - dkliban@redhat.com - NEW - pulp_ostree 1.4.0 doesn't store all info when sync has depth of 1
14:44:58 <kersom> I am reading the issue
14:44:59 <pulpbot> https://pulp.plan.io/issues/4684
14:45:05 <kersom> my query did not get this one
14:45:26 <dkliban> kersom: this is a problem with the 1.4.0 release ... i don't think we are going to prioritize it at this time
14:45:48 <kersom> let me read the bz
14:46:58 <kersom> I read it quickly, I think we should add to the sprint, and evaluate it
14:47:07 <kersom> at least accept it
14:47:20 <dkliban> kersom: we don't have any pulp_ostree users upstream
14:47:38 <kersom> but we do have downstream
14:48:12 <dkliban> kersom: it's true, but 1.4.0 has not been released downstream
14:48:19 <kersom> ah I see
14:48:34 <bmbouter> matrix is baaaack!
14:48:36 <asmacdo> sounds like this is wrapping up. does anyone else have an issue to bring up?
14:48:47 <bmbouter> yes I wanted to shop this one again  https://pulp.plan.io/issues/4678
14:49:10 <bmbouter> it's been revised with an example and groomed
14:49:16 <bmbouter> feedback has all been positive so far
14:49:25 <dkliban> i am all for this change
14:49:38 <dkliban> i am currently removing publications all together from pulp_docker
14:49:49 <asmacdo> bmbouter: big +1
14:49:49 <bmbouter> also plugins should consider filing stories to remove their publishers if their users don't benefit from them
14:50:05 <asmacdo> bmbouter: i did that for python yesterday
14:50:07 <bmbouter> dkliban: see the stories we filed for pulp_ansible and pulp_python
14:50:17 <bmbouter> asmacdo: your python one inspired me to do the same for pulp_ansible
14:50:38 <bmbouter> so the question is, is there more feedback and when can we add to the sprint?
14:51:08 <asmacdo> seems mostly straightforward to me
14:51:10 <daviddavis> sprint planning?
14:51:27 <bmbouter> oh that is soon
14:51:31 <daviddavis> thursday
14:51:32 <bmbouter> I can't make that time tho
14:51:39 <daviddavis> I can represent it
14:51:45 <bmbouter> that works for me
14:51:45 <dkliban> why wait?
14:51:59 <asmacdo> +1 dkliban i'd like to add this now
14:52:12 <asmacdo> this is a *backwrads incompatible change* for ****all plugins****
14:52:13 <daviddavis> is anyone going to work on it before thursday?
14:52:23 <daviddavis> I feel like this is a smaller crowd
14:52:29 <daviddavis> than sprint planning
14:52:44 <bmbouter> doing it at sprint planning on thurs is fine w/ me also
14:52:56 <daviddavis> if someone wants to pick it up before thursday, then I am fine with adding it now
14:52:56 <bmbouter> I want to point out though that we're in an open forum here and that is a closed one
14:53:09 <bmbouter> mainly that this irc meeting should be the future of sprint planning
14:53:31 <daviddavis> the only hesitation I have is that this is a really small quorum
14:53:35 <daviddavis> only 3-4 people
14:53:47 <bmbouter> yeah it's new and waiting is ok w/ me
14:54:09 <dkliban> daviddavis: sounds good. we'll wait till thursday
14:54:19 <daviddavis> ok
14:54:36 <asmacdo> okiedockie
14:54:46 <asmacdo> anyone else got one?
14:55:09 <dkliban> i hope that one day we will do sprint planning on IRC also
14:55:51 <asmacdo> i like that idea-- though we have a lot of groundwork before we can get there
14:56:15 <asmacdo> ie, what sprints are, etc
14:56:49 <asmacdo> ok, i guess thats it
14:56:51 <asmacdo> #endmeeting