14:30:16 <asmacdo> #startmeeting Pulp Triage 2019-04-23
14:30:16 <asmacdo> #info asmacdo has joined triage
14:30:16 <asmacdo> !start
14:30:16 <pulpbot> Meeting started Tue Apr 23 14:30:16 2019 UTC.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:16 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:16 <pulpbot> The meeting name has been set to 'pulp_triage_2019-04-23'
14:30:16 <pulpbot> asmacdo: asmacdo has joined triage
14:30:17 <daviddavis> #info daviddavis has joined triage
14:30:17 <daviddavis> !here
14:30:17 <pulpbot> daviddavis: daviddavis has joined triage
14:30:22 <mikedep333> #info mikedep333 has joined triage
14:30:22 <mikedep333> !here
14:30:22 <pulpbot> mikedep333: mikedep333 has joined triage
14:30:42 <dkliban> #info dkliban has joined triage
14:30:42 <dkliban> !here
14:30:42 <pulpbot> dkliban: dkliban has joined triage
14:31:24 <ttereshc> #info ttereshc has joined triage
14:31:24 <ttereshc> !here
14:31:24 <pulpbot> ttereshc: ttereshc has joined triage
14:32:06 <asmacdo> !next
14:32:07 <pulpbot> asmacdo: 6 issues left to triage: 4680, 4693, 4708, 4718, 4720, 4722
14:32:07 <asmacdo> #topic https://pulp.plan.io/issues/4680
14:32:08 <pulpbot> RM 4680 - kersom - NEW - Document use cases to use repository base_version
14:32:09 <pulpbot> https://pulp.plan.io/issues/4680
14:32:55 <asmacdo> #idea Proposed for #4680: accept and add to sprint
14:32:55 <asmacdo> !propose other accept and add to sprint
14:32:55 <pulpbot> asmacdo: Proposed for #4680: accept and add to sprint
14:33:05 <daviddavis> add docs tag
14:33:10 <asmacdo> +1
14:33:18 <daviddavis> oops its there
14:33:30 <daviddavis> +1 to accept and add to sprint
14:33:38 <asmacdo> :)
14:33:44 <asmacdo> #agreed accept and add to sprint
14:33:44 <asmacdo> !accept
14:33:44 <pulpbot> asmacdo: Current proposal accepted: accept and add to sprint
14:33:45 <pulpbot> asmacdo: 5 issues left to triage: 4693, 4708, 4718, 4720, 4722
14:33:45 <asmacdo> #topic https://pulp.plan.io/issues/4693
14:33:46 <pulpbot> RM 4693 - paji@redhat.com - NEW - Module Streams not copying correctly with recursive and recursive_conservative
14:33:47 <pulpbot> https://pulp.plan.io/issues/4693
14:33:51 <daviddavis> skip
14:34:13 <asmacdo> !skip
14:34:14 <pulpbot> asmacdo: 4 issues left to triage: 4708, 4718, 4720, 4722
14:34:15 <asmacdo> #topic https://pulp.plan.io/issues/4708
14:34:15 <pulpbot> RM 4708 - Zhiming - POST - Improve performance of publishing files with iso_distributor via the way of fast-forward
14:34:17 <pulpbot> https://pulp.plan.io/issues/4708
14:34:33 <ttereshc> asmacdo, if you are still on 4680, you can remove the spam comment :)
14:34:43 <daviddavis> accept and add to sprint?
14:35:20 <ttereshc> daviddavis, did you look at it? do you know if it affects iso only or not?
14:35:36 <ttereshc> PR is against pulp, not pulp_rpm
14:35:39 <ttereshc> so I wonder
14:35:41 <asmacdo> ttereshc: nice catch spam deleted
14:35:50 <ttereshc> ty
14:36:03 <dkliban> let's accept
14:36:40 <ttereshc> ok, let's accept, it's cdt anyway
14:36:46 <asmacdo> !accept
14:36:46 <pulpbot> asmacdo: No action proposed, nothing to accept.
14:36:48 <dalley> it can be moved once we figure out where the problem is
14:37:15 <asmacdo> dalley: should we accept?
14:37:22 <asmacdo> #idea Proposed for #4708: Leave the issue as-is, accepting its current state.
14:37:22 <asmacdo> !propose accept
14:37:22 <pulpbot> asmacdo: Proposed for #4708: Leave the issue as-is, accepting its current state.
14:37:49 <dalley> yeah accept
14:37:51 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:37:51 <asmacdo> !accept
14:37:51 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:37:52 <pulpbot> asmacdo: 3 issues left to triage: 4718, 4720, 4722
14:37:52 <asmacdo> #topic https://pulp.plan.io/issues/4718
14:37:53 <pulpbot> RM 4718 - paji@redhat.com - NEW - Need a module copy --with-modular-rpms options
14:37:54 <pulpbot> https://pulp.plan.io/issues/4718
14:38:04 <ttereshc> rpm
14:38:04 <dkliban> convert to story
14:38:08 <ttereshc> skip
14:38:10 <daviddavis> skip
14:38:12 <dkliban> +1 to skip
14:38:16 <dalley> @daviddavis why skip 4693?
14:38:16 <ttereshc> +1 dkliban, we can do it later
14:38:35 <asmacdo> !skip
14:38:37 <pulpbot> asmacdo: 2 issues left to triage: 4720, 4722
14:38:37 <asmacdo> #topic https://pulp.plan.io/issues/4720
14:38:38 <pulpbot> RM 4720 - daviddavis - NEW - Remove publishers from pulp_file
14:38:39 <pulpbot> https://pulp.plan.io/issues/4720
14:38:40 <daviddavis> dalley: because it's rpm?
14:38:48 <ttereshc> yeah
14:38:50 <daviddavis> convert to task
14:38:53 <dkliban> +1
14:38:55 <dalley> ah, yeah
14:38:58 <ttereshc> +1
14:39:06 <dalley> +1
14:39:22 <ttereshc> #idea Proposed for #4720: convert to task
14:39:22 <ttereshc> !propose other convert to task
14:39:22 <pulpbot> ttereshc: Proposed for #4720: convert to task
14:39:27 <daviddavis> some feedback would be great on 4720
14:39:51 <daviddavis> !accept
14:39:56 <daviddavis> :D
14:39:58 <asmacdo> #idea Proposed for #4720: Leave the issue as-is, accepting its current state.
14:39:58 <asmacdo> !propose accept
14:39:58 <pulpbot> asmacdo: Proposed for #4720: Leave the issue as-is, accepting its current state.
14:40:09 <asmacdo> #idea Proposed for #4720: convert to task and accept
14:40:09 <asmacdo> !propose other convert to task and accept
14:40:09 <pulpbot> asmacdo: Proposed for #4720: convert to task and accept
14:40:13 <daviddavis> +1
14:40:22 <asmacdo> #agreed convert to task and accept
14:40:22 <asmacdo> !accept
14:40:23 <pulpbot> asmacdo: Current proposal accepted: convert to task and accept
14:40:24 <pulpbot> asmacdo: 1 issues left to triage: 4722
14:40:24 <asmacdo> #topic https://pulp.plan.io/issues/4722
14:40:25 <pulpbot> RM 4722 - dalley - NEW - Using the "fields=" feature has strange behavior with "created_resources"
14:40:26 <pulpbot> https://pulp.plan.io/issues/4722
14:40:44 <daviddavis> we should accept and either add to sprint or to 3.0 GA
14:41:00 <dalley> accept + 3.0 GA, IMO
14:41:04 <asmacdo> i wonder if this is a problem for other "non-id" fields
14:41:10 <daviddavis> me too
14:41:17 <asmacdo> so im inclined to put it on the sprint
14:42:00 <asmacdo> i guess its not really urgent. a 3.0 GA blocker is probably sufficient
14:42:21 <asmacdo> #idea Proposed for #4722: accept +3.0 GA
14:42:21 <asmacdo> !propose other accept +3.0 GA
14:42:21 <pulpbot> asmacdo: Proposed for #4722: accept +3.0 GA
14:42:26 <ttereshc> +1
14:42:27 <dalley> +1
14:42:31 <asmacdo> #agreed accept +3.0 GA
14:42:31 <asmacdo> !accept
14:42:31 <pulpbot> asmacdo: Current proposal accepted: accept +3.0 GA
14:42:32 <pulpbot> asmacdo: No issues to triage.
14:42:53 <asmacdo> open floor anyone?
14:42:59 <daviddavis> 4681
14:43:04 <asmacdo> !4681
14:43:04 <pulpbot> asmacdo: Error: "4681" is not a valid command.
14:43:11 <asmacdo> !issue 4681
14:43:12 <asmacdo> #topic https://pulp.plan.io/issues/4681
14:43:13 <pulpbot> RM 4681 - tustvold - NEW - Error caused by non-unique Master-Detail model names
14:43:14 <pulpbot> https://pulp.plan.io/issues/4681
14:43:22 <daviddavis> so we need a solution here
14:43:27 <daviddavis> I emailed out pulp-dev
14:43:31 <daviddavis> we need feedback ASAP
14:43:35 <daviddavis> this is a huge problem
14:43:45 <daviddavis> just wanted to call that out
14:44:18 <asmacdo> IIRC we talked about this problem when it was only hypothetical during our MVP calls
14:44:54 <daviddavis> ah ok, did we come up with a good solution?
14:45:03 <asmacdo> and the conclusion we came to was that plugins should just be cool
14:45:54 <daviddavis> that seems like a terrible idea
14:46:06 <asmacdo> heh, yeah
14:46:18 <daviddavis> at the very least we should have some sort of requirement/docs
14:46:38 <asmacdo> what "layer" is this namespace broken?
14:46:52 <asmacdo> is this the db table names?
14:47:01 <daviddavis> it's in my email but basically django defines a reverse accessor based on the class name
14:47:16 <daviddavis> and it blows up if two subclass names are the same
14:47:29 <asmacdo> ah, hadnt seen it yet
14:48:18 <asmacdo> daviddavis: option 1 is definitely the easiest, but it would be uncool IMO
14:48:19 <daviddavis> anyway, responses on the issue or email are appreciated
14:48:24 <daviddavis> yea
14:48:45 <asmacdo> content/rpm/rpm/rpmpackage/ <----lol
14:49:05 <dkliban> i think we can just use full names for the relations
14:49:24 <dkliban> i think you can specify the relationg as <app_label>.<modelname>
14:49:39 <asmacdo> dkliban: i was hoping that was possible, i wasnt sure
14:49:46 <daviddavis> yea the only downside is we have to define them all
14:50:01 <asmacdo> daviddavis: can you elaborate?
14:50:13 <dkliban> can we accept and discuss more after triage?
14:50:20 <daviddavis> +1
14:50:25 <daviddavis> it's already accepted
14:50:28 <daviddavis> and on the sprint
14:50:38 <daviddavis> just wanted to point out that it needed discussion
14:50:40 <daviddavis> sorry
14:51:13 <dkliban> oh ok
14:51:38 <asmacdo> thanks for highlighting that one daviddavis
14:52:07 <asmacdo> anyone else got one?
14:52:30 <asmacdo> the end is near ...
14:52:51 <asmacdo> #endmeeting
14:52:51 <asmacdo> !end