14:30:29 <asmacdo> #startmeeting Pulp Triage 2019-04-30
14:30:29 <asmacdo> !start
14:30:29 <asmacdo> #info asmacdo has joined triage
14:30:29 <pulpbot> Meeting started Tue Apr 30 14:30:29 2019 UTC.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:29 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:29 <pulpbot> The meeting name has been set to 'pulp_triage_2019-04-30'
14:30:29 <pulpbot> asmacdo: asmacdo has joined triage
14:30:29 <dkliban> !here
14:30:30 <dkliban> #info dkliban has joined triage
14:30:30 <pulpbot> dkliban: dkliban has joined triage
14:30:32 <ppicka> #info ppicka has joined triage
14:30:32 <ppicka> !here
14:30:33 <pulpbot> ppicka: ppicka has joined triage
14:30:45 <asmacdo> wow dkliban was waiting to pounce on that one
14:31:00 <dalley> #info dalley has joined triage
14:31:00 <dalley> !here
14:31:00 <pulpbot> dalley: dalley has joined triage
14:31:04 <asmacdo> !next
14:31:04 <dawalker> !here
14:31:05 <pulpbot> asmacdo: 1 issues left to triage: 4746
14:31:06 <asmacdo> #topic https://pulp.plan.io/issues/4746
14:31:06 <dawalker> #info dawalker has joined triage
14:31:06 <pulpbot> RM 4746 - gmbnomis - NEW - Do not query saved content QueryExistingContents stage
14:31:06 <dkliban> this one issue is already has a PR
14:31:07 <pulpbot> https://pulp.plan.io/issues/4746
14:31:08 <pulpbot> dawalker: dawalker has joined triage
14:31:13 <dkliban> it should be at POST
14:31:28 <ttereshc> #info ttereshc has joined triage
14:31:28 <ttereshc> !here
14:31:28 <pulpbot> ttereshc: ttereshc has joined triage
14:31:38 <dawalker> well accept and add to sprint then I 'spose
14:31:39 <asmacdo> #idea Proposed for #4746: triage and POST
14:31:39 <asmacdo> !propose other triage and POST
14:31:39 <pulpbot> asmacdo: Proposed for #4746: triage and POST
14:31:46 <dkliban> yep
14:31:47 <ttereshc> +1
14:31:48 <dawalker> that works too
14:31:52 <asmacdo> + sprint
14:31:56 <asmacdo> #agreed triage and POST
14:31:56 <asmacdo> !accept
14:31:56 <pulpbot> asmacdo: Current proposal accepted: triage and POST
14:31:57 <pulpbot> asmacdo: No issues to triage.
14:32:01 <dawalker> \o/
14:32:09 <asmacdo> open floor
14:32:10 <ttereshc> that was quick
14:32:19 <dalley> lol yup
14:32:24 <dalley> !dance
14:32:24 <pulpbot> ♪┏(°.°)┛┗(°.°)┓┗(°.°)┛┏(°.°)┓ ♪
14:32:29 <asmacdo> i wanted to show off a change to pulp-python docs
14:32:30 <asmacdo> https://pulp-python.readthedocs.io/en/latest/workflows/sync.html
14:32:47 <asmacdo> instead of hardcoding the walkthroughs, we've now got scripts
14:33:01 <asmacdo> which will make the docs testable
14:33:17 <asmacdo> just wanted to make sure the other plugin teams saw that
14:33:19 <daviddavis> #info daviddavis has joined triage
14:33:19 <daviddavis> !here
14:33:19 <pulpbot> daviddavis: daviddavis has joined triage
14:33:38 <bmbouter> #info bmbouter has joined triage
14:33:38 <bmbouter> !here
14:33:38 <pulpbot> bmbouter: bmbouter has joined triage
14:33:44 <asmacdo> thats all for me, anyone else have an issue for open floor?
14:34:05 <dkliban> asmacdo: that looks great! and i encourage others to have such scripts in their docs
14:34:16 <kersom> +1
14:34:27 <bmbouter> very nice!
14:34:31 <ttereshc> +1
14:34:45 <bmbouter> yes I wanted to highlight the one daviddavis filed yesterday
14:35:05 <bmbouter> https://pulp.plan.io/issues/4745
14:35:27 <asmacdo> !issue 4745
14:35:27 <asmacdo> #topic https://pulp.plan.io/issues/4745
14:35:29 <pulpbot> RM 4745 - daviddavis - NEW - As a plugin writer, I can create distributions for repository versions
14:35:30 <pulpbot> https://pulp.plan.io/issues/4745
14:35:50 <asmacdo> oh yes, i think this could use some brainstorming here before we comment on it
14:36:05 <bmbouter> yes and we don't need any decisions here
14:36:05 <asmacdo> i like the idea, but ive got some concerns
14:36:11 <bmbouter> mainly just advertisement and ideas
14:36:35 <asmacdo> i don't think it will add much plugin work, so thats a minimal concern for me
14:36:50 <asmacdo> but will this screw up kickstart trees?
14:37:54 <asmacdo> it will also mean that pulpcore should get out of the business of documenting lifecycles, which is too bad because almost all of the plugins will do this the same way
14:38:30 <bmbouter> there are still lifecycles, they just flow repo1 -> repo2 -> repo3
14:38:48 <bmbouter> with distribution1, distribution2, distribution3 paired with each repo respectively
14:38:55 <bmbouter> is how I imagined it at least
14:39:29 <asmacdo> ohhh my fault, i was thinking of a different thread... disregard all those comments, they are meant for master/detail distributions
14:39:39 <bmbouter> ah
14:39:48 <asmacdo> though that discussion could be relevant here also
14:40:33 <jjeffers> Is this expected? https://pastebin.com/vAA7MYz0 I am attemping to publish with a file repository, using the publication URI, but the POST comes back with 404.
14:41:11 <dkliban> jjeffers: we changed this yesterday
14:41:37 <jjeffers> dkliban: I figured, since you mentioned a new version of the pulp_file client gem.
14:41:38 <daviddavis> this is strange:
14:41:40 <daviddavis> POST /pulp/api/v3/publishers/file/file/d1aecf00-dd5b-4313-92db-0f1cb79a0cb0/publish/
14:41:43 <asmacdo> looks like the docs didnt get udated though
14:42:05 <dkliban> daviddavis: what is strange?
14:42:08 <asmacdo> jjeffers: check out the pulp-python docs, they should be very similar https://pulp-python.readthedocs.io/en/latest/workflows/publish-host.html
14:42:46 <daviddavis> what docs?
14:42:52 <daviddavis> https://github.com/pulp/pulp_file#create-a-publication
14:43:05 <dkliban> jjeffers: give me 5 mins and i'll push a new version of the ruby gem for pulp_file_client
14:43:14 <dkliban> jjeffers: and then we can talk about how to use it
14:43:17 <dkliban> jjeffers: sound good/
14:43:19 <dkliban> ?
14:43:22 <jjeffers> dkliban: ok, no problem, ty
14:43:30 <asmacdo> oh thats right daviddavis, i forgot you didnt remove the publisher
14:43:31 <bmbouter> I'm proposing an adjustemnt to how autodistribution works
14:43:46 <asmacdo> bmbouter: i think that adjustment is correct
14:43:47 * daviddavis waits with bated breath
14:44:12 <bmbouter> there would be two kinds effectively, I propose it here  https://pulp.plan.io/issues/4745#note-5
14:44:45 <bmbouter> one driven by a publisher (any time it publishes) and the other by repository and any time there is a new repo version
14:45:05 <daviddavis> will that be confusing to users having two different ways to set up auto distribute?
14:45:22 <bmbouter> I think it's just more functionality
14:45:34 <asmacdo> bmbouter: what if we just do 1 way to start off (by repository)
14:45:49 <bmbouter> that would be fine with me
14:45:55 <bmbouter> the repository one I think is the main one
14:45:56 <asmacdo> i think a lot of plugins are going to remove the publisher
14:46:01 <bmbouter> exactly!
14:46:12 <daviddavis> I see
14:46:22 <bmbouter> but won't those other plugins also want auto-distribution?
14:46:36 <asmacdo> they will, but it can only be done by repository
14:46:54 <bmbouter> but the repository woon't have the metadata only the publications as PublishedMetadata
14:47:18 <asmacdo> oh, you are talking about plugins that dont have publications either
14:47:34 <bmbouter> I'm talking about plugins that have metadata like pulp_file for example
14:48:26 <bmbouter> let's go back to whta was proposed earlier
14:48:52 <bmbouter> let's just have auto distribute be done with the 'repository' field which will auto-distribute any repository version that is created in that repo
14:49:07 <asmacdo> +1
14:49:08 <bmbouter> and we would remove the 'publisher' option from the Distribution
14:49:31 <asmacdo> +1 :)
14:49:58 <bmbouter> any other feedback?
14:49:58 <asmacdo> what about the other questions Do we still need pass_through publications anymore?
14:50:09 <bmbouter> oh I wrote about that in a comment
14:50:42 <bmbouter> https://pulp.plan.io/issues/4745#note-2
14:50:50 <bmbouter> there are use cases where we need them (I think)
14:51:07 <asmacdo> i didnt quite follow the comment
14:52:51 <asmacdo> thats ok though, we can keep moving: How (if at all) do we prevent users from associating distributions to repo versions for plugins like pulp_file?
14:53:19 <asmacdo> i guess that could be solved by master/detail distributions if we go that way
14:53:43 <bmbouter> agreed
14:54:16 <bmbouter> that actually would be a good resolution
14:54:47 <asmacdo> thats the only mechanism i can think of. a pulpcore repo version and a pulpcore distribution couldnt know about the plugin restrictions
14:54:50 <bmbouter> but even if we don't users will be following the plugin docs and they will be clear on how it should be used
14:55:15 <asmacdo> yeah. not really a bug, just a "your own fault" hole
14:55:37 <bmbouter> and we want to avoid those usability problems
14:56:21 <bmbouter> I'm going to revise the issue some from this convo
14:56:27 <asmacdo> thanks bmbouter
14:56:35 <asmacdo> do we have any other issues to discuss?
14:56:36 <bmbouter> I'd like to try to do this before rc2
14:56:54 <asmacdo> are we tracking rc2 in redmine?
14:56:56 <bmbouter> so I'll email pulp-dev to seek maybe some grooming+sprint-adding there
14:57:04 <bmbouter> we're about to start
14:57:11 <bmbouter> we're going to have like a 1-week mini burndown
14:57:11 <asmacdo> ack
14:57:24 <bmbouter> it'll be pulp-dev coordinated
14:57:41 <asmacdo> #endmeeting
14:57:41 <asmacdo> !end