14:37:35 <asmacdo> #startmeeting Pulp Triage 2019-05-07
14:37:35 <asmacdo> #info asmacdo has joined triage
14:37:35 <asmacdo> !start
14:37:35 <pulpbot> Meeting started Tue May  7 14:37:35 2019 UTC.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:37:35 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:37:35 <pulpbot> The meeting name has been set to 'pulp_triage_2019-05-07'
14:37:35 <pulpbot> asmacdo: asmacdo has joined triage
14:37:47 <dawalker> #info dawalker has joined triage
14:37:47 <dawalker> !here
14:37:47 <pulpbot> dawalker: dawalker has joined triage
14:37:49 <asmacdo> (sorry yall)
14:37:55 <mikedep333> #info mikedep333 has joined triage
14:37:55 <mikedep333> !here
14:37:55 <pulpbot> mikedep333: mikedep333 has joined triage
14:38:14 <asmacdo> summit has mucked my calendar
14:38:16 <asmacdo> !next
14:38:17 <pulpbot> asmacdo: 6 issues left to triage: 4780, 4783, 4786, 4788, 4789, 4790
14:38:17 <asmacdo> #topic https://pulp.plan.io/issues/4780
14:38:18 <pulpbot> RM 4780 - rochacbruno - NEW - Task search by invalid field should raise meaningful error
14:38:19 <pulpbot> https://pulp.plan.io/issues/4780
14:39:17 <dawalker> I remember seeing this one friday
14:39:24 <dawalker> accept?
14:39:41 <dkliban> #info dkliban has joined triage
14:39:41 <dkliban> !here
14:39:41 <pulpbot> dkliban: dkliban has joined triage
14:39:45 <dkliban> accept
14:40:29 <ppicka> #info ppicka has joined triage
14:40:29 <ppicka> !here
14:40:29 <pulpbot> ppicka: ppicka has joined triage
14:40:30 <asmacdo> we should accept, but IMO this should maybe be 3.1+
14:41:07 <asmacdo> if we can easily configure DRF to do this, +1, if we have to get fancy, I don't think it should be in 3.0
14:41:22 <asmacdo> I can add that as a comment on the issue and accept?
14:41:34 <dkliban> sure
14:41:49 <dkliban> there is a project that DRF recommends that we use for doing the query param validation
14:42:10 <bmbouter> #info bmbouter has joined triage
14:42:10 <bmbouter> !here
14:42:10 <pulpbot> bmbouter: bmbouter has joined triage
14:42:28 <bmbouter> that sounds ok to me also
14:42:39 <bmbouter> I think we can configure a dep but otherwise 3.1
14:43:04 <asmacdo> #idea Proposed for #4780: accept and comment on priority
14:43:04 <asmacdo> !propose other accept and comment on priority
14:43:04 <pulpbot> asmacdo: Proposed for #4780: accept and comment on priority
14:43:04 <ppicka> +1 for 3.1
14:43:13 <dawalker> +1
14:43:29 <asmacdo> #agreed accept and comment on priority
14:43:29 <asmacdo> !accept
14:43:29 <pulpbot> asmacdo: Current proposal accepted: accept and comment on priority
14:43:30 <pulpbot> asmacdo: 5 issues left to triage: 4783, 4786, 4788, 4789, 4790
14:43:30 <asmacdo> #topic https://pulp.plan.io/issues/4783
14:43:31 <pulpbot> RM 4783 - dkliban@redhat.com - NEW - plugin_template bootstrap script creates scripts with wrong permissions
14:43:32 <pulpbot> https://pulp.plan.io/issues/4783
14:43:39 <asmacdo> (heres the comment https://pulp.plan.io/issues/4780)
14:44:12 <asmacdo> #idea Proposed for #4783: accept and add to sprint
14:44:12 <asmacdo> !propose other accept and add to sprint
14:44:12 <pulpbot> asmacdo: Proposed for #4783: accept and add to sprint
14:44:15 <dkliban> +1
14:45:18 <asmacdo> #agreed accept and add to sprint
14:45:18 <asmacdo> !accept
14:45:18 <pulpbot> asmacdo: Current proposal accepted: accept and add to sprint
14:45:19 <asmacdo> #topic https://pulp.plan.io/issues/4786
14:45:19 <pulpbot> asmacdo: 4 issues left to triage: 4786, 4788, 4789, 4790
14:45:20 <pulpbot> RM 4786 - gmbnomis - NEW - Pulp does not accept empty atifacts
14:45:21 <pulpbot> https://pulp.plan.io/issues/4786
14:46:05 <asmacdo> we need to switch this to pulp_file
14:46:18 <dkliban> it's a bug in pulpcore
14:46:22 <dkliban> the PR is for pulpcore
14:47:00 <dkliban> accept
14:47:04 <asmacdo> #idea Proposed for #4786: switch to POST accept and add to sprint
14:47:04 <asmacdo> !propose other switch to POST accept and add to sprint
14:47:04 <pulpbot> asmacdo: Proposed for #4786: switch to POST accept and add to sprint
14:47:57 <asmacdo> (can i get a +-1?)
14:48:00 <dawalker> +1
14:48:14 <asmacdo> #agreed switch to POST accept and add to sprint
14:48:14 <asmacdo> !accept
14:48:14 <pulpbot> asmacdo: Current proposal accepted: switch to POST accept and add to sprint
14:48:15 <pulpbot> asmacdo: 3 issues left to triage: 4788, 4789, 4790
14:48:15 <asmacdo> #topic https://pulp.plan.io/issues/4788
14:48:16 <pulpbot> RM 4788 - elliehilton - NEW - Get Super Essay Help
14:48:17 <pulpbot> https://pulp.plan.io/issues/4788
14:48:29 <bmbouter> nice
14:48:31 <dkliban> lol
14:48:33 <dkliban> damn it
14:48:34 <asmacdo> !spam
14:48:34 <pulpbot> asmacdo: Error: "spam" is not a valid command.
14:48:39 <bmbouter> I'll delete
14:49:09 <dawalker> lol
14:49:16 <dawalker> we need a valid spam command
14:49:23 <asmacdo> ty bmbouter. btw, could we establish a protocol for dealing with these? ie, delete (block?) the user and delete the issue?
14:49:44 <dawalker> I think that's what daviddavis was doing previously
14:49:57 <asmacdo> #idea Proposed for #4788: SPAM
14:49:57 <asmacdo> !propose other SPAM
14:49:57 <pulpbot> asmacdo: Proposed for #4788: SPAM
14:50:00 <asmacdo> #agreed SPAM
14:50:00 <asmacdo> !accept
14:50:00 <pulpbot> asmacdo: Current proposal accepted: SPAM
14:50:01 <pulpbot> asmacdo: 1 issues left to triage: 4790
14:50:01 <asmacdo> #topic https://pulp.plan.io/issues/4790
14:50:01 <dawalker> but we don't have it documented afaik
14:50:02 <pulpbot> RM 4790 - amacdona@redhat.com - POST - As an installer user, pulp-api service is enabled and works after machine reboot
14:50:03 <pulpbot> https://pulp.plan.io/issues/4790
14:50:18 <bmbouter> asmacdo: yeah I have a process I should write it up
14:50:23 <asmacdo> #idea Proposed for #4790: Leave the issue as-is, accepting its current state.
14:50:23 <asmacdo> !propose accept
14:50:23 <pulpbot> asmacdo: Proposed for #4790: Leave the issue as-is, accepting its current state.
14:50:29 <ppicka> accept
14:50:32 <bmbouter> asmacdo: I was going to write a little scrpit do to it also at some point
14:50:37 <dawalker> +1
14:50:41 <bmbouter> we shoiuld fix/merge this soon
14:50:43 <bmbouter> +1
14:50:57 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:50:57 <asmacdo> !accept
14:50:58 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:50:59 <pulpbot> asmacdo: No issues to triage.
14:51:13 <asmacdo> open floor?
14:51:59 <bmbouter> so it seems master/detail Distributions have arrived
14:52:08 <bmbouter> I'm going to test later today it comes with like 6 PRs
14:52:45 <bmbouter> asmacdo: I think this is going to resolve our shared concerns around docs since these will isolate the right fields onto the right types
14:52:55 <asmacdo> \o/
14:53:08 <bmbouter> and also limit plugins users from doing weird things like wiring a Distribution to a RepoVersion that contains units that require metadata
14:53:23 <bmbouter> s/weird things/weird things that won't work/
14:53:24 <asmacdo> that makes me so happy -- i was struggling to figure out how to explain the alternative
14:53:52 <asmacdo> bmbouter: do you need any issues or PRs reviewed yet?
14:54:14 <bmbouter> asmacdo: I do not I'm wrapping up my test changes and then I'll remove the WIP
14:54:22 <bmbouter> soon tho and I'll ping on this channel
14:54:33 <asmacdo> bmbouter++
14:54:33 <pulpbot> asmacdo: bmbouter's karma is now 139
14:54:39 <bmbouter> that is for the distribution's getting the repository_version and removing the publisher fields
14:54:43 <bmbouter> \o/
14:54:54 <bmbouter> so those are the main core items I had to bring up
14:55:10 <bmbouter> we should merge these open PRs in these various repos (for these non large efforts)
14:55:55 <asmacdo> time to clean the house +1
14:57:22 <asmacdo> ive got one thing, but its more of a brainstorm at this point, so ill end and anyone interested in docs scripts should hang
14:57:35 <asmacdo> #endmeeting
14:57:35 <asmacdo> !end