14:29:16 <asmacdo> #startmeeting Pulp Triage 2019-05-10
14:29:16 <asmacdo> !start
14:29:16 <asmacdo> #info asmacdo has joined triage
14:29:16 <pulpbot> Meeting started Fri May 10 14:29:16 2019 UTC.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:16 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:29:16 <pulpbot> The meeting name has been set to 'pulp_triage_2019-05-10'
14:29:16 <pulpbot> asmacdo: asmacdo has joined triage
14:29:53 <mikedep333> #info mikedep333 has joined triage
14:29:53 <mikedep333> !here
14:29:53 <pulpbot> mikedep333: mikedep333 has joined triage
14:31:14 <dkliban> #info dkliban has joined triage
14:31:14 <dkliban> !here
14:31:14 <pulpbot> dkliban: dkliban has joined triage
14:31:17 <asmacdo> !next
14:31:18 <asmacdo> #topic https://pulp.plan.io/issues/4792
14:31:19 <pulpbot> asmacdo: 12 issues left to triage: 4792, 4793, 4794, 4795, 4796, 4797, 4798, 4799, 4807, 4808, 4809, 4810
14:31:20 <pulpbot> RM 4792 - dalley - ASSIGNED - Serialization bug on Publications
14:31:21 <pulpbot> https://pulp.plan.io/issues/4792
14:31:31 <dkliban> accept and add to sprint
14:31:41 <daviddavis> #info daviddavis has joined triage
14:31:41 <daviddavis> !here
14:31:41 <pulpbot> daviddavis: daviddavis has joined triage
14:31:44 <dkliban> looks like dalley is already working on it
14:31:54 <daviddavis> yea I think he fixed it
14:31:56 <asmacdo> #idea Proposed for #4792: Leave the issue as-is, accepting its current state.
14:31:56 <asmacdo> !propose accept
14:31:56 <pulpbot> asmacdo: Proposed for #4792: Leave the issue as-is, accepting its current state.
14:32:42 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:32:42 <asmacdo> !accept
14:32:42 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:32:43 <pulpbot> asmacdo: 11 issues left to triage: 4793, 4794, 4795, 4796, 4797, 4798, 4799, 4807, 4808, 4809, 4810
14:32:43 <asmacdo> #topic https://pulp.plan.io/issues/4793
14:32:44 <pulpbot> RM 4793 - dalley - NEW - Locking does not work as expected with Publications
14:32:45 <pulpbot> https://pulp.plan.io/issues/4793
14:33:13 <daviddavis> accept and add to sprint
14:34:07 <dawalker> #info dawalker has joined triage
14:34:07 <dawalker> !here
14:34:07 <pulpbot> dawalker: dawalker has joined triage
14:34:07 <bmbouter> #info bmbouter has joined triage
14:34:07 <bmbouter> !here
14:34:08 <pulpbot> bmbouter: bmbouter has joined triage
14:34:22 <bmbouter> +1
14:35:21 <daviddavis> this may not be a bug now that I think about it
14:35:32 <bmbouter> I agree but I figured I could look at it
14:35:34 <bmbouter> or someone
14:35:38 <daviddavis> ok
14:35:55 <asmacdo> sounds good to me. current behavior is what i expect, but proposed behavior would be nice
14:36:07 <asmacdo> !accept
14:36:07 <pulpbot> asmacdo: No action proposed, nothing to accept.
14:36:17 <asmacdo> #idea Proposed for #4793: accept and add to sprint
14:36:17 <asmacdo> !propose other accept and add to sprint
14:36:17 <pulpbot> asmacdo: Proposed for #4793: accept and add to sprint
14:36:21 <asmacdo> #agreed accept and add to sprint
14:36:21 <asmacdo> !accept
14:36:21 <pulpbot> asmacdo: Current proposal accepted: accept and add to sprint
14:36:22 <asmacdo> #topic https://pulp.plan.io/issues/4794
14:36:22 <pulpbot> asmacdo: 10 issues left to triage: 4794, 4795, 4796, 4797, 4798, 4799, 4807, 4808, 4809, 4810
14:36:23 <pulpbot> RM 4794 - mdepaulo@redhat.com - NEW - Pulp handles incompatible plugins poorly
14:36:24 <pulpbot> https://pulp.plan.io/issues/4794
14:37:16 <bmbouter> this is a great issue in spirit but it doesn't lead me towards a resolution
14:37:23 <daviddavis> agreed
14:37:41 <bmbouter> we can skip for triage purposes and discuss on the issue?
14:37:53 <bmbouter> we should make some improvements in this area but I'm hesitant to accept until we at least have some idea
14:38:21 <asmacdo> yeah +1. im not sure what we can do, but agree we should do something
14:38:31 <daviddavis> +1
14:38:34 <asmacdo> !skip
14:38:35 <asmacdo> #topic https://pulp.plan.io/issues/4795
14:38:35 <pulpbot> asmacdo: 9 issues left to triage: 4795, 4796, 4797, 4798, 4799, 4807, 4808, 4809, 4810
14:38:36 <pulpbot> RM 4795 - bherring - NEW - Pulp 2 Nightly Regression in second-sync testing behavior
14:38:37 <pulpbot> https://pulp.plan.io/issues/4795
14:38:39 <bmbouter> asmacdo: we should relate to the issues on adding some "checking" to the ansible installer
14:38:48 <daviddavis> skip, rpm
14:38:53 <bmbouter> if you know of those issues pointing them to mikedep would be good
14:39:01 <bmbouter> +1 skip rpm
14:39:15 <bmbouter> unless rpm folks are here (since it's pulp2 and important)
14:39:21 <asmacdo> !skip
14:39:22 <asmacdo> #topic https://pulp.plan.io/issues/4796
14:39:23 <pulpbot> asmacdo: 8 issues left to triage: 4796, 4797, 4798, 4799, 4807, 4808, 4809, 4810
14:39:24 <pulpbot> RM 4796 - dkliban@redhat.com - NEW - README missing from pulpcore-client on PyPI
14:39:25 <pulpbot> https://pulp.plan.io/issues/4796
14:39:30 <asmacdo> we can come back if rpm folks want
14:39:35 <bmbouter> +1 at the end
14:39:41 <asmacdo> bmbouter: i related 4794 to https://pulp.plan.io/issues/4562
14:39:48 <bmbouter> asmacdo: ty!
14:39:54 <daviddavis> convert to task
14:40:04 <daviddavis> err nm
14:40:14 <asmacdo> #idea Proposed for #4796: accept and add to sprint
14:40:14 <asmacdo> !propose other accept and add to sprint
14:40:14 <pulpbot> asmacdo: Proposed for #4796: accept and add to sprint
14:40:16 <bmbouter> add to sprint?
14:40:19 <bmbouter> +1 add to sprint
14:40:27 <bmbouter> I know we have a lot but this is clear work and it's high value
14:40:53 <daviddavis> +1
14:40:57 <asmacdo> the wrath of kanban
14:41:07 <asmacdo> #agreed accept and add to sprint
14:41:07 <asmacdo> !accept
14:41:07 <pulpbot> asmacdo: Current proposal accepted: accept and add to sprint
14:41:09 <asmacdo> #topic https://pulp.plan.io/issues/4797
14:41:09 <pulpbot> asmacdo: 7 issues left to triage: 4797, 4798, 4799, 4807, 4808, 4809, 4810
14:41:11 <pulpbot> RM 4797 - amacdona@redhat.com - ASSIGNED - Add support for Master/Detail Distributions
14:41:12 <pulpbot> https://pulp.plan.io/issues/4797
14:41:22 <daviddavis> skip
14:41:30 <bmbouter> skip
14:41:30 <asmacdo> !skip
14:41:31 <pulpbot> asmacdo: 6 issues left to triage: 4798, 4799, 4807, 4808, 4809, 4810
14:41:31 <asmacdo> #topic https://pulp.plan.io/issues/4798
14:41:32 <pulpbot> RM 4798 - kravir - NEW - Rpm file uploaded/published successfully but not accessible
14:41:33 <pulpbot> https://pulp.plan.io/issues/4798
14:41:36 <bmbouter> it would be nice to remove plugin issues from the query
14:42:12 <bmbouter> this needs the pulp 2 tag I think
14:42:25 <daviddavis> +1
14:42:28 <daviddavis> then skip
14:42:46 <daviddavis> agreed also on removing plugin issues
14:42:53 <asmacdo> #idea Proposed for #4798: add pulp2 tag and skip
14:42:53 <asmacdo> !propose other add pulp2 tag and skip
14:42:53 <pulpbot> asmacdo: Proposed for #4798: add pulp2 tag and skip
14:42:56 <asmacdo> #agreed add pulp2 tag and skip
14:42:56 <asmacdo> !accept
14:42:56 <pulpbot> asmacdo: Current proposal accepted: add pulp2 tag and skip
14:42:57 <asmacdo> #topic https://pulp.plan.io/issues/4799
14:42:57 <pulpbot> asmacdo: 5 issues left to triage: 4799, 4807, 4808, 4809, 4810
14:42:58 <pulpbot> RM 4799 - Zhiming - POST - Replace option "skip_fast_forward" with "force_full" for FileDistributor
14:42:59 <pulpbot> https://pulp.plan.io/issues/4799
14:43:09 <asmacdo> i write up an issue for skipping
14:43:17 <daviddavis> +1
14:43:22 <bmbouter> asmacdo: I think it's just a query adjustment but yeah
14:43:22 <daviddavis> add 4799 to sprint
14:44:09 <bmbouter> +1
14:44:12 <asmacdo> i switched this to modified for a second, but i wasnt totally sure it was completely finished
14:44:20 <asmacdo> the PR has been merged though
14:44:28 <bmbouter> I think it should be MODIFIED
14:44:32 <bmbouter> if not they can re-raise
14:44:52 <daviddavis> there's a comment on the PR though after it got merged
14:45:05 <bmbouter> oh I didn't see that
14:45:05 <asmacdo> #idea Proposed for #4799: MODIFIED, add to sprint
14:45:05 <asmacdo> !propose other MODIFIED, add to sprint
14:45:06 <pulpbot> asmacdo: Proposed for #4799: MODIFIED, add to sprint
14:45:28 <daviddavis> https://github.com/pulp/pulp/pull/3917#discussion_r282712978
14:45:29 <asmacdo> theres another issue about this
14:45:37 <asmacdo> https://pulp.plan.io/issues/4810
14:45:55 <bmbouter> dkliban: ^?
14:46:17 <bmbouter> how about skip for now?
14:46:31 <daviddavis> +1
14:47:08 <asmacdo> !skip
14:47:09 <pulpbot> asmacdo: 4 issues left to triage: 4807, 4808, 4809, 4810
14:47:09 <asmacdo> #topic https://pulp.plan.io/issues/4807
14:47:10 <pulpbot> RM 4807 - mdellweg - ASSIGNED - The container boxes in pulplift are broken
14:47:11 <pulpbot> https://pulp.plan.io/issues/4807
14:47:20 <bmbouter> add to sprint, it's assigned
14:47:28 <daviddavis> it's already on the sprint
14:47:29 <asmacdo> we just talked about this in planning
14:47:33 <dawalker> yep
14:47:37 <bmbouter> then accept
14:47:41 <daviddavis> +1
14:47:43 <asmacdo> #idea Proposed for #4807: Leave the issue as-is, accepting its current state.
14:47:43 <asmacdo> !propose accept
14:47:43 <pulpbot> asmacdo: Proposed for #4807: Leave the issue as-is, accepting its current state.
14:47:45 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:47:45 <asmacdo> !accept
14:47:45 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:47:46 <pulpbot> asmacdo: 3 issues left to triage: 4808, 4809, 4810
14:47:46 <asmacdo> #topic https://pulp.plan.io/issues/4808
14:47:47 <pulpbot> RM 4808 - ipanova@redhat.com - NEW - Problem: 'library' as a namespace is used for all the registries.
14:47:48 <pulpbot> https://pulp.plan.io/issues/4808
14:47:56 <daviddavis> skip
14:48:04 <bmbouter> +1
14:48:05 <asmacdo> !skip
14:48:06 <pulpbot> asmacdo: 2 issues left to triage: 4809, 4810
14:48:06 <asmacdo> #topic https://pulp.plan.io/issues/4809
14:48:07 <pulpbot> RM 4809 - bmbouter - NEW - Custom Distributions cannot be disabled from being served by the content app
14:48:08 <pulpbot> https://pulp.plan.io/issues/4809
14:48:27 <bmbouter> I think send this to the pulp3 backlog (no milestone but accepted)
14:48:35 <asmacdo> i could have sworn this was a dupe of a issue that gmbnomis filed a while back
14:48:38 <bherring> #info bherring has joined triage
14:48:38 <bherring> !here
14:48:38 <pulpbot> bherring: bherring has joined triage
14:48:39 <bmbouter> we're still talking about options w/ gmbnomis
14:48:39 <asmacdo> but i couldnt find it
14:48:53 <asmacdo> #idea Proposed for #4809: Leave the issue as-is, accepting its current state.
14:48:53 <asmacdo> !propose accept
14:48:53 <pulpbot> asmacdo: Proposed for #4809: Leave the issue as-is, accepting its current state.
14:49:33 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:49:33 <asmacdo> !accept
14:49:33 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:49:35 <asmacdo> #topic https://pulp.plan.io/issues/4810
14:49:35 <pulpbot> asmacdo: 1 issues left to triage: 4810
14:49:36 <pulpbot> RM 4810 - Zhiming - NEW - "force_full" should disable fast-forward instead of enabling
14:49:37 <pulpbot> https://pulp.plan.io/issues/4810
14:49:52 <asmacdo> i guess we want to skip this one too
14:49:55 <bmbouter> here is that other issue, we should skip this one too
14:49:57 <bmbouter> yup
14:50:00 <asmacdo> !skip
14:50:01 <pulpbot> asmacdo: No issues to triage.
14:50:24 <bmbouter> I don't think we have the right rpm folks here to go back
14:50:24 <asmacdo> do we need to go back to some rpm issues?
14:50:28 <bherring> Open Floor: Who do I need to talk about 4795 with?
14:50:39 <bmbouter> yes open floor!
14:51:24 <asmacdo> bherring: someone on rpm is the best i can do :)
14:51:39 <bmbouter> bherring: so this is against source?
14:51:46 <bmbouter> a source install that is? or is it against released bits?
14:51:51 <bherring> Ack. Want to know if the expected failure is due to new behavior so I can either remove or block the failing nightly on that ticket.
14:52:21 <bherring> bmbouter: sorry. Don't follow. This is pulp2 2-master nightly. I am not sure that addresses your query
14:52:36 <bmbouter> yes 2-master is source ty
14:53:00 * bherring remembers this word association for the future
14:54:27 <bmbouter> I think it's from this recent commit on 2-master  https://github.com/pulp/pulp/commit/89a0453b9e41390d9303d7fd0c278d65605002f8  ?
14:54:49 <gmbnomis> asmacdo, re issue 4809: you are right the duplicate issue is 4435
14:55:16 <asmacdo> gmbnomis: thank you! i thought i had gone crazy
14:55:36 <bmbouter> bherring: so check this out this person made a reversion commit that is unmerged  https://github.com/pulp/pulp/pull/3918/files
14:56:11 <bherring> bmbouter: the failure is previous to 1-day ago, however.
14:56:33 <bmbouter> ic
14:56:36 <bmbouter> when did it start
14:56:57 <bherring> bmbouter: great question. I have tested this enough that, whomever leads this, I need a 1v1
14:57:08 <bherring> i.e. outside the scope of this meeting, I believe
14:57:30 <bmbouter> bherring: come to the next rpm meeting and we can find someone to help w/ that?
14:57:41 <bherring> bmbouter: not a problem. Will do.
14:57:58 * bherring looks this up so he knows when this `rpm meeting` is
14:58:05 <asmacdo> bmbouter: do you need anything for the rc2 work?
14:58:34 <bmbouter> bherring: yeah it's not on the meetings list but it probably should be
14:59:17 <bherring> bmbouter: ack. Will get details in PM. Thanks, sir.
14:59:27 <daviddavis> bherring: I invited you
14:59:32 <daviddavis> to the next one
14:59:49 <bherring> daviddavis++ thank you. Accepted.
15:00:00 <asmacdo> unless anyone has another issue, ill close
15:00:08 <asmacdo> s/close/end/
15:00:11 <daviddavis> !friday
15:00:11 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
15:00:14 <bmbouter> !friday
15:00:14 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
15:00:16 <bmbouter> !dance
15:00:16 <pulpbot> ♪┏(°.°)┛┗(°.°)┓┗(°.°)┛┏(°.°)┓ ♪
15:00:43 <bmbouter> everytime I do that I move my arms like that
15:00:48 <daviddavis> lool
15:01:32 <asmacdo> #endmeeting
15:01:32 <asmacdo> !end