15:39:28 <asmacdo> #startmeeting Pulp Triage 2019-05-14
15:39:28 <asmacdo> #info asmacdo has joined triage
15:39:28 <asmacdo> !start
15:39:28 <pulpbot> Meeting started Tue May 14 15:39:28 2019 UTC.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:39:28 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:39:28 <pulpbot> The meeting name has been set to 'pulp_triage_2019-05-14'
15:39:28 <pulpbot> asmacdo: asmacdo has joined triage
15:39:35 <dkliban> !here
15:39:35 <dkliban> #info dkliban has joined triage
15:39:37 <pulpbot> dkliban: dkliban has joined triage
15:40:13 <ttereshc> #info ttereshc has joined triage
15:40:13 <ttereshc> !here
15:40:13 <pulpbot> ttereshc: ttereshc has joined triage
15:40:24 <daviddavis> #info daviddavis has joined triage
15:40:24 <daviddavis> !here
15:40:24 <pulpbot> daviddavis: daviddavis has joined triage
15:40:34 <asmacdo> !next
15:40:35 <asmacdo> #topic https://pulp.plan.io/issues/4794
15:40:35 <pulpbot> asmacdo: 7 issues left to triage: 4794, 4795, 4798, 4799, 4810, 4814, 4816
15:40:36 <pulpbot> RM 4794 - mdepaulo@redhat.com - NEW - Pulp handles incompatible plugins poorly
15:40:37 <pulpbot> https://pulp.plan.io/issues/4794
15:41:30 <asmacdo> we skipped this last time, dkliban are you intentionally assigned to this?
15:42:27 <dawalker> #info dawalker has joined triage
15:42:27 <dawalker> !here
15:42:27 <pulpbot> dawalker: dawalker has joined triage
15:42:54 <ppicka> #info ppicka has joined triage
15:42:54 <ppicka> !here
15:42:54 <pulpbot> ppicka: ppicka has joined triage
15:44:43 <asmacdo> i guess we can skip again but i'm not clear what this needs to move forward
15:44:49 <ttereshc> yeah
15:44:57 <ttereshc> I think it's a known issue in general
15:45:13 <ttereshc> we haven't tackeled the problem of incompatible plugins
15:45:40 <dkliban> asmacdo: yeah ... let's accept it
15:45:43 <dkliban> and i am going to fix it
15:45:45 <asmacdo> #idea Proposed for #4794: Leave the issue as-is, accepting its current state.
15:45:45 <asmacdo> !propose accept
15:45:45 <pulpbot> asmacdo: Proposed for #4794: Leave the issue as-is, accepting its current state.
15:46:01 <dkliban> it's a problem with pulp_ansible ... i need to install it and see what's going on
15:46:02 <asmacdo> dkliban: could you comment on the issue how you are planning to address this?
15:46:21 <asmacdo> oh, thats not what i was expecting
15:46:50 <dkliban> yeah ... they are doing things different than any other plugin so i need to investigate how to generate the openapi schema for them
15:47:02 <asmacdo> ok, accepting
15:47:35 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
15:47:35 <asmacdo> !accept
15:47:36 <asmacdo> #topic https://pulp.plan.io/issues/4795
15:47:37 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:47:38 <pulpbot> asmacdo: 6 issues left to triage: 4795, 4798, 4799, 4810, 4814, 4816
15:47:39 <pulpbot> RM 4795 - bherring - NEW - Pulp 2 Nightly Regression in second-sync testing behavior
15:47:40 <pulpbot> https://pulp.plan.io/issues/4795
15:48:11 <bherring> ~here
15:48:13 <bherring> #info bherring has joined triage
15:48:13 <bherring> !here
15:48:13 <pulpbot> bherring: bherring has joined triage
15:48:24 <asmacdo> !skip
15:48:25 <pulpbot> asmacdo: 5 issues left to triage: 4798, 4799, 4810, 4814, 4816
15:48:25 <asmacdo> #topic https://pulp.plan.io/issues/4798
15:48:27 <pulpbot> RM 4798 - kravir - NEW - Rpm file uploaded/published successfully but not accessible
15:48:28 <pulpbot> https://pulp.plan.io/issues/4798
15:48:39 <asmacdo> !skip
15:48:40 <asmacdo> #topic https://pulp.plan.io/issues/4799
15:48:40 <pulpbot> asmacdo: 4 issues left to triage: 4799, 4810, 4814, 4816
15:48:41 <pulpbot> RM 4799 - Zhiming - POST - Replace option "skip_fast_forward" with "force_full" for FileDistributor
15:48:42 <pulpbot> https://pulp.plan.io/issues/4799
15:48:45 <asmacdo> *both were rpm
15:49:06 <dkliban> i'll triage them after this
15:49:20 <ttereshc> yeah, we'll handle it
15:49:41 <ttereshc> my bad, I was not good at the end of last week, no rpm meeting, no triage :)
15:49:47 <dkliban> lol
15:50:39 <asmacdo> this one is related to https://pulp.plan.io/issues/4810, which (i think) is why we skipped on friday
15:50:55 <asmacdo> we can skip again, but i'd like to have some path to move them forward
15:51:26 <dkliban> accept it
15:51:33 <dkliban> there is a PR and it makes sense
15:51:57 <dkliban> i kicked off the unit tests for it earlier this morning. will finish reviewing later today.
15:52:02 <ttereshc> dkliban, is it in pulp?
15:52:06 <ttereshc> sounds like rpm
15:52:40 <dkliban> pulp
15:52:46 <asmacdo> #idea Proposed for #4799: Leave the issue as-is, accepting its current state.
15:52:46 <asmacdo> !propose accept
15:52:46 <pulpbot> asmacdo: Proposed for #4799: Leave the issue as-is, accepting its current state.
15:52:57 <dkliban> ttereshc: ironically it's in Pulp
15:53:15 <ttereshc> heh ok
15:53:19 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
15:53:19 <asmacdo> !accept
15:53:19 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:53:20 <asmacdo> #topic https://pulp.plan.io/issues/4810
15:53:21 <pulpbot> asmacdo: 3 issues left to triage: 4810, 4814, 4816
15:53:22 <pulpbot> RM 4810 - Zhiming - NEW - "force_full" should disable fast-forward instead of enabling
15:53:23 <pulpbot> https://pulp.plan.io/issues/4810
15:53:36 <asmacdo> same deal dkliban?
15:54:11 <dkliban> yeah ... they are related
15:54:17 <dkliban> same issue actually
15:54:21 <ttereshc> yeah, dkliban, we should be very careful with those changes, I believe they are a part of all the complicated workflows we just discssed
15:54:54 <dkliban> yeah
15:55:29 <ttereshc> accept?
15:55:36 <asmacdo> dkliban: i marked 4799 as triaged, do you mind handling this one? maybe close as dupe or relate them, etc
15:56:10 <asmacdo> #idea Proposed for #4810: dkliban will align with 4799
15:56:10 <asmacdo> !propose other dkliban will align with 4799
15:56:10 <pulpbot> asmacdo: Proposed for #4810: dkliban will align with 4799
15:56:17 <dkliban> yep
15:56:25 <asmacdo> #agreed dkliban will align with 4799
15:56:25 <asmacdo> !accept
15:56:25 <pulpbot> asmacdo: Current proposal accepted: dkliban will align with 4799
15:56:26 <asmacdo> #topic https://pulp.plan.io/issues/4814
15:56:26 <pulpbot> asmacdo: 2 issues left to triage: 4814, 4816
15:56:27 <pulpbot> RM 4814 - kersom - NEW - Filter by repository_version not working for artifacts endpoint
15:56:28 <pulpbot> https://pulp.plan.io/issues/4814
15:56:45 <dkliban> accept and add to sprint
15:56:49 <daviddavis> +1
15:57:06 <ttereshc> +1
15:57:57 <dawalker> +1
15:58:02 <asmacdo> this call doesnt look right to me http GET http://localhost:24817/pulp/api/v3/artifacts/ repository_version=$REPO_VERSION
15:58:16 <asmacdo> should it not be http GET http://localhost:24817/pulp/api/v3/artifacts/?repository_version=$REPO_VERSION
15:58:34 <dkliban> oh
15:59:04 <kersom> I tried using pulp_smash as well
15:59:09 <ttereshc> I thought httpie does it for you
15:59:13 <ttereshc> but I'm not sure
15:59:17 <ttereshc> asmacdo, ^
15:59:18 <dkliban> no ... not the get parameters
15:59:22 <ttereshc> ok
15:59:26 <kersom> it fails, but I did spend sometime with httpie just to file the issue
15:59:26 <dkliban> accept for now
16:00:12 <kersom> asmacdo, I will try again
16:00:22 <asmacdo> dkliban: thats what i thought too, but i think ttereshc  is right https://httpie.org/doc#querystring-parameters
16:00:26 <asmacdo> #idea Proposed for #4814: Leave the issue as-is, accepting its current state.
16:00:26 <asmacdo> !propose accept
16:00:26 <pulpbot> asmacdo: Proposed for #4814: Leave the issue as-is, accepting its current state.
16:01:30 <dkliban> +1
16:01:51 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
16:01:51 <asmacdo> !accept
16:01:51 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
16:01:52 <asmacdo> #topic https://pulp.plan.io/issues/4816
16:01:52 <pulpbot> asmacdo: 1 issues left to triage: 4816
16:01:53 <pulpbot> RM 4816 - ppicka - POST - Add RPM distribution to match Master-detail
16:01:54 <pulpbot> https://pulp.plan.io/issues/4816
16:02:09 <ppicka> already in post
16:02:17 <daviddavis> convert to task and skip
16:02:29 <ppicka> oh should be task right
16:02:51 <ppicka> +1
16:03:01 <asmacdo> #idea Proposed for #4816: convert to task and skip
16:03:01 <asmacdo> !propose other convert to task and skip
16:03:03 <pulpbot> asmacdo: Proposed for #4816: convert to task and skip
16:03:03 <asmacdo> #agreed convert to task and skip
16:03:03 <asmacdo> !accept
16:03:04 <pulpbot> asmacdo: Current proposal accepted: convert to task and skip
16:03:05 <pulpbot> asmacdo: No issues to triage.
16:03:38 <asmacdo> since we are at an unusual time, lets skip open floor for today (unless anyone is burning)
16:04:14 <asmacdo> #endmeeting
16:04:14 <asmacdo> !end