14:30:19 <asmacdo> #startmeeting Pulp Triage 2019-05-21
14:30:19 <asmacdo> !start
14:30:19 <asmacdo> #info asmacdo has joined triage
14:30:19 <pulpbot> Meeting started Tue May 21 14:30:19 2019 UTC.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:19 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:19 <pulpbot> The meeting name has been set to 'pulp_triage_2019-05-21'
14:30:19 <pulpbot> asmacdo: asmacdo has joined triage
14:30:31 <ttereshc> #info ttereshc has joined triage
14:30:31 <ttereshc> !here
14:30:31 <pulpbot> ttereshc: ttereshc has joined triage
14:30:35 <asmacdo> almost all of these are rpm, so we just have 1
14:30:43 <ipanova> #info ipanova has joined triage
14:30:43 <ipanova> !here
14:30:43 <pulpbot> ipanova: ipanova has joined triage
14:30:45 <dkliban> #info dkliban has joined triage
14:30:45 <dkliban> !here
14:30:45 <pulpbot> dkliban: dkliban has joined triage
14:31:14 <asmacdo> !next
14:31:15 <pulpbot> asmacdo: 5 issues left to triage: 4835, 4850, 4856, 4857, 4858
14:31:15 <asmacdo> #topic https://pulp.plan.io/issues/4835
14:31:16 <pulpbot> RM 4835 - dkliban@redhat.com - NEW - RPM package can be created without specifying the 'relative_path'
14:31:17 <pulpbot> https://pulp.plan.io/issues/4835
14:31:19 <asmacdo> !skip
14:31:20 <pulpbot> asmacdo: 4 issues left to triage: 4850, 4856, 4857, 4858
14:31:20 <asmacdo> #topic https://pulp.plan.io/issues/4850
14:31:21 <pulpbot> RM 4850 - ppicka - POST - Update autogenerated titles in API docs
14:31:22 <daviddavis> #info daviddavis has joined triage
14:31:22 <daviddavis> !here
14:31:23 <pulpbot> https://pulp.plan.io/issues/4850
14:31:23 <ppicka> #info ppicka has joined triage
14:31:23 <ppicka> !here
14:31:24 <pulpbot> daviddavis: daviddavis has joined triage
14:31:26 <pulpbot> ppicka: ppicka has joined triage
14:31:28 <asmacdo> !skp
14:31:28 <pulpbot> asmacdo: Error: "skp" is not a valid command.
14:31:32 <asmacdo> !skip
14:31:33 <pulpbot> asmacdo: 3 issues left to triage: 4856, 4857, 4858
14:31:33 <asmacdo> #topic https://pulp.plan.io/issues/4856
14:31:34 <pulpbot> RM 4856 - rmcgover - NEW - Uploading ISOs of same name to a repo creates duplicates, makes repo unusable
14:31:35 <pulpbot> https://pulp.plan.io/issues/4856
14:31:44 <daviddavis> skip
14:31:47 <asmacdo> !skip
14:31:48 <pulpbot> asmacdo: 2 issues left to triage: 4857, 4858
14:31:49 <asmacdo> #topic https://pulp.plan.io/issues/4857
14:31:49 <pulpbot> RM 4857 - bherring - NEW - Pulp 2 Nightly Regression in test_iso_crud.ISOUpdateTestCase.test_all
14:31:51 <pulpbot> https://pulp.plan.io/issues/4857
14:31:55 <asmacdo> !skip
14:31:57 <pulpbot> asmacdo: 1 issues left to triage: 4858
14:31:57 <asmacdo> #topic https://pulp.plan.io/issues/4858
14:31:58 <pulpbot> RM 4858 - lmayorga1980 - NEW - Running Pulp Inside a Container
14:31:59 <pulpbot> https://pulp.plan.io/issues/4858
14:32:09 <bmbouter> !here
14:32:09 <bmbouter> #info bmbouter has joined triage
14:32:10 <pulpbot> bmbouter: bmbouter has joined triage
14:33:19 <ttereshc> asmacdo is a skip master
14:33:29 <asmacdo> is pulp/pulp-ci still supported?
14:33:29 <dawalker> #info dawalker has joined triage
14:33:29 <dawalker> !here
14:33:29 <pulpbot> dawalker: dawalker has joined triage
14:33:43 <dkliban> asmacdo: we use it on Jenkins
14:33:55 <ppicka> may pulp2 tag?
14:33:56 <dkliban> but i don't think we do anything with containers with it
14:33:59 <kersom> asmacdo, that is what we used to do ci for pulp 2 on jenkins
14:34:11 <asmacdo> but its not intended to be user-facing right?
14:34:21 <dkliban> i'll comment on the issue
14:34:25 <dkliban> i think we can close it
14:34:34 <dkliban> as won't fix
14:34:39 <kersom> asmacdo, no
14:34:41 <asmacdo> #idea Proposed for #4858: dkliban will comment and close
14:34:41 <asmacdo> !propose other dkliban will comment and close
14:34:41 <pulpbot> asmacdo: Proposed for #4858: dkliban will comment and close
14:34:56 <asmacdo> do we have pulp2 docker instructions anywhere?
14:35:13 <ttereshc> add Pulp2 tag as ppicka suggested
14:35:23 <ttereshc> and remove 2.19.0 milestone please
14:35:29 <ttereshc> dkliban, ^
14:35:34 <daviddavis> pulp 2 docker instructions: use pulp 3 :)
14:36:08 <ttereshc> asmacdo, +1
14:36:09 <asmacdo> :)
14:36:12 <asmacdo> #agreed dkliban will comment and close
14:36:12 <asmacdo> !accept
14:36:12 <pulpbot> asmacdo: Current proposal accepted: dkliban will comment and close
14:36:13 <pulpbot> asmacdo: No issues to triage.
14:36:19 <asmacdo> open floor!
14:36:23 <daviddavis> https://pulp.plan.io/issues/4591
14:36:29 <asmacdo> !issue 4591
14:36:29 <asmacdo> #topic https://pulp.plan.io/issues/4591
14:36:30 <pulpbot> RM 4591 - ttereshc - POST - Publish of a mid-size repo is slow
14:36:31 <pulpbot> https://pulp.plan.io/issues/4591
14:36:37 <daviddavis> oops wrong one
14:36:39 <daviddavis> wait
14:36:52 <daviddavis> https://pulp.plan.io/issues/4428
14:37:10 <daviddavis> !issue 4428
14:37:32 <asmacdo> !issue 4428
14:37:32 <asmacdo> #topic https://pulp.plan.io/issues/4428
14:37:33 <pulpbot> RM 4428 - daviddavis - ASSIGNED - Upsert query raises NotUniqueError
14:37:34 <pulpbot> https://pulp.plan.io/issues/4428
14:37:38 <ttereshc> daviddavis daviddavis , you are not the open floor master :P
14:37:43 <daviddavis> lol
14:37:49 <asmacdo> (you can !propose, but you cant !issue)
14:38:08 <daviddavis> it sounds like repo applicability regen is failing so we're going to try to add sleep statements
14:38:12 <daviddavis> would like to add to sprint
14:38:27 <daviddavis> this affects deferred downloads too
14:38:42 <dkliban> +1 to adding to sprint
14:39:47 <ttereshc> +1
14:40:18 <bmbouter> +1
14:40:21 <asmacdo> seems reasonable to me, sleep is ugly but not risky
14:40:24 <ipanova> +1
14:40:27 <daviddavis> yea
14:40:27 <ttereshc> daviddavis, I'm not worried about deferred donload
14:40:44 <ttereshc> where do you see that applicability fails
14:40:51 <daviddavis> the only concern I have is that users see these errors 3-4+ times per day
14:41:11 <daviddavis> dkliban reported the applicability failures https://pulp.plan.io/issues/4428#note-16
14:41:14 <dkliban> ttereshc: on dogfood satellite there are no consumers being managed
14:41:28 <dkliban> so each time a repo is synced there the regen applicability task fails
14:41:38 <dkliban> and it marks the sync task is katello with a warning
14:41:43 <ttereshc> weird
14:42:09 <ttereshc> I'm still +1 :) just curious
14:42:55 <daviddavis> so I'll add it to the sprint if there are no objections
14:43:42 * daviddavis falls asleep
14:43:58 <dkliban> lol
14:44:02 <dkliban> daviddavis: please do
14:44:13 <ttereshc> go for it, dkliban and I, we've got your back
14:44:37 <asmacdo> fyi, https://pulp.plan.io/issues?query_id=30 has been updated to exclude all plugins except for pulp_file
14:44:58 * asmacdo was annoyed by skipping today
14:45:15 <asmacdo> any other issues?
14:45:22 <ttereshc> that's a shame :(
14:45:41 <ttereshc> can we make a separate query either for triage or for all untriaged bugs?
14:45:50 <ttereshc> so we can filter it by plugin as before?
14:45:53 <ttereshc> asmacdo, ^
14:45:54 <daviddavis> yea https://pulp.plan.io/projects/pulp_rpm/issues?query_id=30 no longer works
14:47:00 <asmacdo> hmm
14:47:05 <daviddavis> make a new Un-Triaged query and rename query 30 to "Issues to Triage" ?
14:48:17 <ttereshc> I would do it the other way around, just because many people know what query 30 is, but this ^ works as well
14:48:37 <ttereshc> daviddavis, I can make one if you want
14:49:14 <daviddavis> yea, let's create a new "Issues for Triage" and revert query 30
14:49:36 <asmacdo> i did it this way to avoid having to change pulpbot
14:49:48 <asmacdo> but its probably not a big deal to update the query in there
14:50:11 <daviddavis> !pirate
14:50:11 <pulpbot> daviddavis: Error: "pirate" is not a valid command.
14:50:26 * daviddavis wasn't sure what to expect
14:50:36 <asmacdo> aha, yeah, this should be easy https://github.com/pulp/supybot-pulptriage/blob/master/config.py#L63
14:50:45 <daviddavis> nice find asmacdo
14:50:52 <ttereshc> daviddavis, asmacdo, I'll create/update queries and let you know
14:51:08 <daviddavis> ttereshc: so to confirm, we're reverting query 30?
14:51:16 <asmacdo> +1
14:51:20 <ttereshc> yes, I'm in favour of doing it
14:51:23 <daviddavis> +1
14:51:29 <daviddavis> ttereshc++
14:51:29 <pulpbot> daviddavis: ttereshc's karma is now 90
14:51:45 <daviddavis> !dance
14:51:45 <pulpbot> ♪┏(°.°)┛┗(°.°)┓┗(°.°)┛┏(°.°)┓ ♪
14:52:03 <asmacdo> sorry to jump the gun
14:52:14 <asmacdo> thanks ttereshc
14:52:24 <ttereshc> asmacdo, daviddavis, we are ignoring debian only, right?
14:52:28 <bmbouter> this all sounds good
14:52:32 <asmacdo> actually
14:52:37 <asmacdo> lets not filter by project
14:53:16 <asmacdo> then the query will be filterable for all projects using the /projects/<name>/issues?query_id=30
14:54:13 <ttereshc> there are a bunch of issues shown under Infrastructure and Pulp CLI
14:54:51 <bmbouter> we sitll have Pulp CLI?
14:55:28 <asmacdo> ttereshc: IMO, the query is right, it just exposes some cleanup we need to do
14:55:35 <ttereshc> I agree
14:55:56 <asmacdo> ttereshc: let me know when you have a query_id, so i can make a PR to pulpbot
14:56:08 <asmacdo> oh right
14:56:10 <asmacdo> #endmeeting
14:56:10 <asmacdo> !end