15:00:15 <dawalker> #startmeeting Pulp Triage 2019-05-24
15:00:15 <dawalker> #info dawalker has joined triage
15:00:15 <dawalker> !start
15:00:15 <pulpbot> Meeting started Fri May 24 15:00:15 2019 UTC.  The chair is dawalker. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:15 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:15 <pulpbot> The meeting name has been set to 'pulp_triage_2019-05-24'
15:00:15 <pulpbot> dawalker: dawalker has joined triage
15:00:38 <ttereshc> this query include core and file supprot
15:00:39 <ttereshc> *this query includes core and file support
15:00:39 <ttereshc> and this is the one pulpbot should use
15:00:54 <dawalker> cool
15:00:56 <daviddavis> #info daviddavis has joined triage
15:00:56 <daviddavis> !here
15:00:56 <pulpbot> daviddavis: daviddavis has joined triage
15:02:05 <ipanova> #info ipanova has joined triage
15:02:05 <ipanova> !here
15:02:05 <pulpbot> ipanova: ipanova has joined triage
15:02:26 <ttereshc> #info ttereshc has joined triage
15:02:26 <ttereshc> !here
15:02:26 <pulpbot> ttereshc: ttereshc has joined triage
15:02:39 <dawalker> it's nice to see a variety of reporting authors on these issues today.  feels less like we're talking into a void ourselves.
15:02:51 <dawalker> !next
15:02:52 <pulpbot> dawalker: 20 issues left to triage: 3301, 3463, 3829, 3830, 3832, 3834, 3835, 3837, 3839, 4319, 4856, 4857, 4863, 4865, 4867, 4869, 4871, 4872, 4878, 4879
15:02:52 <dawalker> #topic https://pulp.plan.io/issues/3301
15:02:53 <pulpbot> RM 3301 - paji@redhat.com - NEW - Need API to fetch a subset of rpms in a Lazy Repo
15:02:53 <ppicka> #info ppicka has joined triage
15:02:53 <ppicka> !here
15:02:54 <pulpbot> https://pulp.plan.io/issues/3301
15:02:55 <pulpbot> ppicka: ppicka has joined triage
15:03:02 <daviddavis> accept, add to sprint, set to POST
15:03:30 <dawalker> #idea Proposed for #3301: accept and add to sprint, set as POST
15:03:30 <dawalker> !propose other accept and add to sprint, set as POST
15:03:30 <pulpbot> dawalker: Proposed for #3301: accept and add to sprint, set as POST
15:03:42 <ttereshc> dkliban, was pulpbot fixed?
15:03:49 <ttereshc> was query updated?
15:03:51 <dalley> #info dalley has joined triage
15:03:51 <dalley> !here
15:03:51 <pulpbot> dalley: dalley has joined triage
15:03:52 <ipanova> it was reported 1 year ago
15:03:55 <dawalker> evidently not
15:04:03 <ttereshc> I think asmacdo and bmbouter was working on it
15:04:22 <dawalker> I think they tried testing it but didn't see the change go through and thought it might need some time
15:04:37 <ipanova> do we use query 134 for triage?
15:04:41 <daviddavis> yes
15:04:42 <ttereshc> we should
15:04:48 <ttereshc> let's skip old ones
15:04:52 <dawalker> ok
15:05:01 <dawalker> !skip
15:05:03 <dawalker> #topic https://pulp.plan.io/issues/3463
15:05:03 <pulpbot> dawalker: 19 issues left to triage: 3463, 3829, 3830, 3832, 3834, 3835, 3837, 3839, 4319, 4856, 4857, 4863, 4865, 4867, 4869, 4871, 4872, 4878, 4879
15:05:05 <pulpbot> RM 3463 - pcreech - NEW - Add F28 development images to jenkins
15:05:06 <pulpbot> https://pulp.plan.io/issues/3463
15:05:06 <dawalker> !skip
15:05:07 <dawalker> #topic https://pulp.plan.io/issues/3829
15:05:08 <pulpbot> dawalker: 18 issues left to triage: 3829, 3830, 3832, 3834, 3835, 3837, 3839, 4319, 4856, 4857, 4863, 4865, 4867, 4869, 4871, 4872, 4878, 4879
15:05:09 <dawalker> !skip
15:05:09 <pulpbot> RM 3829 - daviddavis - NEW - Relationships should use id or name in lieu of href
15:05:10 <pulpbot> https://pulp.plan.io/issues/3829
15:05:10 <dawalker> #topic https://pulp.plan.io/issues/3830
15:05:11 <pulpbot> dawalker: 17 issues left to triage: 3830, 3832, 3834, 3835, 3837, 3839, 4319, 4856, 4857, 4863, 4865, 4867, 4869, 4871, 4872, 4878, 4879
15:05:12 <dawalker> !skip
15:05:13 <pulpbot> RM 3830 - daviddavis - NEW - As a user I can specify different formats for the responses
15:05:13 <dawalker> #topic https://pulp.plan.io/issues/3832
15:05:14 <dawalker> !skip
15:05:14 <pulpbot> https://pulp.plan.io/issues/3830
15:05:15 <pulpbot> dawalker: 16 issues left to triage: 3832, 3834, 3835, 3837, 3839, 4319, 4856, 4857, 4863, 4865, 4867, 4869, 4871, 4872, 4878, 4879
15:05:15 <dawalker> #topic https://pulp.plan.io/issues/3834
15:05:16 <pulpbot> RM 3832 - daviddavis - NEW - Properly handle json input
15:05:17 <pulpbot> https://pulp.plan.io/issues/3832
15:05:17 <dawalker> !skip
15:05:18 <pulpbot> dawalker: 15 issues left to triage: 3834, 3835, 3837, 3839, 4319, 4856, 4857, 4863, 4865, 4867, 4869, 4871, 4872, 4878, 4879
15:05:18 <dawalker> #topic https://pulp.plan.io/issues/3835
15:05:19 <pulpbot> RM 3834 - daviddavis - NEW - Conversion of name -> id fails on master/detail models
15:05:20 <pulpbot> https://pulp.plan.io/issues/3834
15:05:21 <dawalker> !skip
15:05:22 <pulpbot> dawalker: 14 issues left to triage: 3835, 3837, 3839, 4319, 4856, 4857, 4863, 4865, 4867, 4869, 4871, 4872, 4878, 4879
15:05:22 <dawalker> #topic https://pulp.plan.io/issues/3837
15:05:23 <pulpbot> RM 3835 - daviddavis - NEW - Pagination breaks when calling next on an object with no next page
15:05:24 <pulpbot> https://pulp.plan.io/issues/3835
15:05:25 <pulpbot> dawalker: 13 issues left to triage: 3837, 3839, 4319, 4856, 4857, 4863, 4865, 4867, 4869, 4871, 4872, 4878, 4879
15:05:25 <dawalker> !skip
15:05:26 <pulpbot> RM 3837 - daviddavis - NEW - Handle errors by showing user friendly messages
15:05:27 <dawalker> #topic https://pulp.plan.io/issues/3839
15:05:27 <pulpbot> https://pulp.plan.io/issues/3837
15:05:28 <pulpbot> dawalker: 12 issues left to triage: 3839, 4319, 4856, 4857, 4863, 4865, 4867, 4869, 4871, 4872, 4878, 4879
15:05:29 <pulpbot> RM 3839 - daviddavis - NEW - Handle file parameters
15:05:30 <pulpbot> https://pulp.plan.io/issues/3839
15:05:33 <dawalker> !skip
15:05:34 <pulpbot> dawalker: 11 issues left to triage: 4319, 4856, 4857, 4863, 4865, 4867, 4869, 4871, 4872, 4878, 4879
15:05:34 <dawalker> #topic https://pulp.plan.io/issues/4319
15:05:35 <pulpbot> RM 4319 - paji@redhat.com - NEW - Missing package in 2.18 repo
15:05:36 <pulpbot> https://pulp.plan.io/issues/4319
15:05:42 <dalley> incredible velocity :)
15:05:46 <dawalker> :)
15:05:51 <ipanova> skip
15:06:05 <ttereshc> +1 it's an old one as well
15:06:07 <dawalker> oh, a real skip :P
15:06:11 <dawalker> !skip
15:06:12 <pulpbot> dawalker: 10 issues left to triage: 4856, 4857, 4863, 4865, 4867, 4869, 4871, 4872, 4878, 4879
15:06:12 <dawalker> #topic https://pulp.plan.io/issues/4856
15:06:13 <pulpbot> RM 4856 - rmcgover - NEW - Uploading ISOs of same name to a repo creates duplicates, makes repo unusable
15:06:14 <pulpbot> https://pulp.plan.io/issues/4856
15:06:17 <dawalker> ahh, just not in the 3000's old
15:06:22 <daviddavis> skip
15:06:31 <ipanova> we forgot to triage on rpm team
15:06:34 <dawalker> !skip
15:06:35 <pulpbot> dawalker: 9 issues left to triage: 4857, 4863, 4865, 4867, 4869, 4871, 4872, 4878, 4879
15:06:35 <dawalker> #topic https://pulp.plan.io/issues/4857
15:06:36 <pulpbot> RM 4857 - bherring - NEW - Pulp 2 Nightly Regression in test_iso_crud.ISOUpdateTestCase.test_all
15:06:37 <pulpbot> https://pulp.plan.io/issues/4857
15:06:44 <daviddavis> skip
15:06:45 <dawalker> also rpm
15:06:47 <dawalker> !skip
15:06:48 <pulpbot> dawalker: 8 issues left to triage: 4863, 4865, 4867, 4869, 4871, 4872, 4878, 4879
15:06:48 <dawalker> #topic https://pulp.plan.io/issues/4863
15:06:49 <pulpbot> RM 4863 - dkliban@redhat.com - NEW - task status api returns task href with each progress report
15:06:50 <pulpbot> https://pulp.plan.io/issues/4863
15:07:06 <daviddavis> accept and add to sprint?
15:07:14 <ttereshc> +!
15:07:16 <ttereshc> +1
15:07:17 <dawalker> ttereshc, didn't you say this might not be a problem?
15:07:26 <dawalker> like there may be a subtask that might want this?
15:07:37 <dawalker> #idea Proposed for #4863: accept and add to sprint
15:07:37 <dawalker> !propose other accept and add to sprint
15:07:37 <pulpbot> dawalker: Proposed for #4863: accept and add to sprint
15:07:46 <ttereshc> I did say that it might be needed
15:08:00 <dawalker> so does it need more grooming/discussion on the ticket first?
15:08:01 <ttereshc> it's not a problem per se, just duplication of info  at the moment
15:08:13 <ttereshc> we agreed that we can add whenever we have a real need
15:08:19 <ttereshc> and the format might be different
15:08:30 <ttereshc> maybe multiple tasks in a step
15:08:30 <dawalker> ack
15:08:36 <dawalker> #agreed accept and add to sprint
15:08:36 <dawalker> !accept
15:08:36 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint
15:08:37 <pulpbot> dawalker: 7 issues left to triage: 4865, 4867, 4869, 4871, 4872, 4878, 4879
15:08:37 <dawalker> #topic https://pulp.plan.io/issues/4865
15:08:38 <pulpbot> RM 4865 - Zhiming - NEW - PULP_MANIFEST does not update correctly to publish files with iso_distributor via fast-forward when deleting an unit
15:08:39 <pulpbot> https://pulp.plan.io/issues/4865
15:08:50 <daviddavis> add pulp 2 tag and move to rpm
15:08:55 <ttereshc> +!
15:08:56 <ttereshc> +1
15:09:01 <ipanova> +1
15:09:01 <daviddavis> heh
15:09:08 <dawalker> #idea Proposed for #4865: add pulp 2 tag, move to rpm
15:09:08 <dawalker> !propose other add pulp 2 tag, move to rpm
15:09:08 <pulpbot> dawalker: Proposed for #4865: add pulp 2 tag, move to rpm
15:09:15 <ttereshc> same typo twice :/
15:09:32 <dawalker> #agreed add pulp 2 tag, move to rpm
15:09:32 <dawalker> !accept
15:09:33 <pulpbot> dawalker: Current proposal accepted: add pulp 2 tag, move to rpm
15:09:34 <pulpbot> dawalker: 6 issues left to triage: 4867, 4869, 4871, 4872, 4878, 4879
15:09:34 <dawalker> #topic https://pulp.plan.io/issues/4867
15:09:35 <pulpbot> RM 4867 - jcabrera - NEW - rpm distribution not deleted when deleting a repo with pulp3
15:09:36 <pulpbot> https://pulp.plan.io/issues/4867
15:09:39 <daviddavis> NOTABUG
15:10:13 <dawalker> #idea Proposed for #4867: NOTABUG
15:10:13 <dawalker> !propose other NOTABUG
15:10:13 <pulpbot> dawalker: Proposed for #4867: NOTABUG
15:10:59 <ttereshc> daviddavis, can you comment on it?
15:11:02 <dawalker> agreed?  any +1's?
15:11:02 <daviddavis> sure
15:11:03 <ipanova> so the distribution will be basically empty?
15:11:11 <ipanova> because publication will be null
15:11:14 <daviddavis> yea, you can create distributions without publications
15:11:27 <daviddavis> so they shouldn't be deleted when you delete the publication IMO
15:11:50 <dawalker> makes sense
15:11:54 <ppicka> +1
15:11:58 <ttereshc> daviddavis, they deleted a repo
15:12:01 <ttereshc> not a publication
15:12:10 <daviddavis> right, same thing though
15:12:52 <dawalker> ok, so daviddavis will comment and close as NOTABUG
15:12:53 <ttereshc> just clarifying, so your comment would refer to removed repo
15:12:55 <ttereshc> :)
15:13:04 <daviddavis> sure
15:13:04 <ttereshc> +1
15:13:05 <dawalker> #agreed NOTABUG
15:13:05 <dawalker> !accept
15:13:05 <pulpbot> dawalker: Current proposal accepted: NOTABUG
15:13:07 <dawalker> #topic https://pulp.plan.io/issues/4869
15:13:07 <pulpbot> dawalker: 5 issues left to triage: 4869, 4871, 4872, 4878, 4879
15:13:08 <pulpbot> RM 4869 - ttereshc - NEW - Use RPMTAG_MODULARITYLABEL to determine modular RPM
15:13:09 <pulpbot> https://pulp.plan.io/issues/4869
15:13:38 <ttereshc> skip
15:13:40 <dawalker> rpm so skip
15:13:41 <ttereshc> rpm
15:13:42 <dawalker> !skip
15:13:43 <pulpbot> dawalker: 4 issues left to triage: 4871, 4872, 4878, 4879
15:13:43 <dawalker> #topic https://pulp.plan.io/issues/4871
15:13:44 <pulpbot> RM 4871 - quba42 - NEW - When changing unit_key_fields, the relevant DB units may need to be prepared during migration BEFORE indexes are applied
15:13:45 <pulpbot> https://pulp.plan.io/issues/4871
15:13:59 <ttereshc> accept and add to the sprint
15:14:04 <ttereshc> and set pulp2 tag
15:14:10 <dawalker> #idea Proposed for #4871: accept and add to sprint
15:14:10 <dawalker> !propose other accept and add to sprint
15:14:10 <pulpbot> dawalker: Proposed for #4871: accept and add to sprint
15:14:18 <ttereshc> it's atix PR which I reviewed
15:14:19 <dawalker> #idea Proposed for #4871: accept and add to sprint and add pulp2 tag
15:14:19 <dawalker> !propose other accept and add to sprint and add pulp2 tag
15:14:19 <pulpbot> dawalker: Proposed for #4871: accept and add to sprint and add pulp2 tag
15:14:27 <ttereshc> and asked to create an issue
15:14:29 <ipanova> tag is set i think
15:14:32 <ttereshc> ok
15:14:38 <dawalker> yeah, it's set already
15:14:58 <dawalker> #idea Proposed for #4871: accept and add to sprint
15:14:58 <dawalker> !propose other accept and add to sprint
15:14:58 <pulpbot> dawalker: Proposed for #4871: accept and add to sprint
15:15:08 <ttereshc> +1
15:15:10 <ipanova> +1
15:15:14 <dawalker> #agreed accept and add to sprint
15:15:14 <dawalker> !accept
15:15:14 <pulpbot> dawalker: Current proposal accepted: accept and add to sprint
15:15:15 <pulpbot> dawalker: 3 issues left to triage: 4872, 4878, 4879
15:15:15 <dawalker> #topic https://pulp.plan.io/issues/4872
15:15:16 <pulpbot> RM 4872 - Johnclair - NEW - Assess the promise made to the study of essay
15:15:17 <pulpbot> https://pulp.plan.io/issues/4872
15:15:25 <daviddavis> ooo
15:15:29 <daviddavis> this sounds good
15:15:34 <dawalker> daviddavis, wanna handle this one?
15:15:38 <daviddavis> lol
15:15:39 <dawalker> and the next?
15:15:51 <ttereshc> daviddavis, it's all yours
15:15:56 <dalley> rm -rf 4872
15:15:58 <dawalker> I don't think I can blcok the people
15:16:02 <daviddavis> I'll do it
15:16:09 <dawalker> thank you
15:16:40 <daviddavis> done
15:16:45 <dawalker> thanks
15:16:50 <dawalker> !skip
15:16:51 <dawalker> #topic https://pulp.plan.io/issues/4878
15:16:51 <pulpbot> dawalker: 2 issues left to triage: 4878, 4879
15:16:52 <pulpbot> RM 4878 - mdellweg - NEW - Some servers deny answering to requests made with pyhon-requests
15:16:53 <pulpbot> https://pulp.plan.io/issues/4878
15:16:59 <daviddavis> move to post and add to sprint
15:17:02 <ipanova> +1
15:17:16 <daviddavis> also pulp 2 tag
15:17:18 <ttereshc> +1
15:17:21 <dawalker> #idea Proposed for #4878: move to POST and add to sprint and add pulp 2 tag
15:17:21 <dawalker> !propose other move to POST and add to sprint and add pulp 2 tag
15:17:21 <pulpbot> dawalker: Proposed for #4878: move to POST and add to sprint and add pulp 2 tag
15:17:29 <dalley> +1
15:17:54 <dawalker> #agreed move to POST and add to sprint and add pulp 2 tag
15:17:54 <dawalker> !accept
15:17:54 <pulpbot> dawalker: Current proposal accepted: move to POST and add to sprint and add pulp 2 tag
15:17:55 <pulpbot> dawalker: 1 issues left to triage: 4879
15:17:55 <dawalker> #topic https://pulp.plan.io/issues/4879
15:17:56 <pulpbot> RM 4879 - jcabrera - NEW - Allow users to filter on package name in /content/rpm/packages/ for pulp3
15:17:57 <pulpbot> https://pulp.plan.io/issues/4879
15:18:03 <daviddavis> skip
15:18:29 <dawalker> why skip? still discussing it on list?
15:18:36 <dawalker> oh wait, it's rpm isn't it
15:18:36 <dawalker> ok
15:18:38 <dawalker> !skip
15:18:39 <pulpbot> dawalker: No issues to triage.
15:18:42 <dawalker> #endmeeting