14:30:17 <asmacdo> #startmeeting Pulp Triage 2019-06-04
14:30:17 <asmacdo> !start
14:30:17 <asmacdo> #info asmacdo has joined triage
14:30:17 <pulpbot> Meeting started Tue Jun  4 14:30:17 2019 UTC.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:17 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:17 <pulpbot> The meeting name has been set to 'pulp_triage_2019-06-04'
14:30:17 <pulpbot> asmacdo: asmacdo has joined triage
14:30:22 <dkliban> #info dkliban has joined triage
14:30:22 <dkliban> !here
14:30:22 <pulpbot> dkliban: dkliban has joined triage
14:30:30 <ttereshc> #info ttereshc has joined triage
14:30:30 <ttereshc> !here
14:30:30 <pulpbot> ttereshc: ttereshc has joined triage
14:30:39 <ipanova> #info ipanova has joined triage
14:30:39 <ipanova> !here
14:30:39 <pulpbot> ipanova: ipanova has joined triage
14:30:40 <asmacdo> first issue should be 4904, so lets see if the pulpbot gets it
14:30:41 <ppicka> #info ppicka has joined triage
14:30:41 <ppicka> !here
14:30:41 <pulpbot> ppicka: ppicka has joined triage
14:30:42 <asmacdo> !next
14:30:43 <asmacdo> #topic https://pulp.plan.io/issues/4891
14:30:43 <pulpbot> asmacdo: 5 issues left to triage: 4891, 4900, 4901, 4903, 4904
14:30:44 <pulpbot> RM 4891 - Fah - NEW - The client side ssl cert for pulp should follow http header standards
14:30:45 <pulpbot> https://pulp.plan.io/issues/4891
14:30:48 <asmacdo> !issue 4904
14:30:49 <asmacdo> #topic https://pulp.plan.io/issues/4904
14:30:49 <pulpbot> RM 4904 - jdjeffers - NEW - pulp-file_client might be encoding request URLs incorrectly
14:30:51 <pulpbot> https://pulp.plan.io/issues/4904
14:30:56 <dkliban> it's a problem with the bindings
14:31:02 <dkliban> we need to accept and add to the sprint
14:31:05 <daviddavis> #info daviddavis has joined triage
14:31:05 <daviddavis> !here
14:31:05 <pulpbot> daviddavis: daviddavis has joined triage
14:31:09 <daviddavis> +1
14:31:15 <asmacdo> #idea Proposed for #4904: accept and add to sprint
14:31:15 <asmacdo> !propose other accept and add to sprint
14:31:15 <pulpbot> asmacdo: Proposed for #4904: accept and add to sprint
14:31:22 <ipanova> +1
14:31:29 <mikedep333> #info mikedep333 has joined triage
14:31:29 <mikedep333> !here
14:31:29 <pulpbot> mikedep333: mikedep333 has joined triage
14:31:31 <dkliban> +1
14:31:32 <ttereshc> +1
14:31:40 <ggainey> #info ggainey has joined triage
14:31:40 <ggainey> !here
14:31:40 <pulpbot> ggainey: ggainey has joined triage
14:31:46 <dawalker> #info dawalker has joined triage
14:31:46 <dawalker> !here
14:31:46 <pulpbot> dawalker: dawalker has joined triage
14:31:52 <asmacdo> hmm looks like we still dont have a sprint 34
14:31:58 <asmacdo> rchan? ^
14:32:01 <dkliban> 54
14:32:01 <asmacdo> #agreed accept and add to sprint
14:32:01 <asmacdo> !accept
14:32:01 <pulpbot> asmacdo: Current proposal accepted: accept and add to sprint
14:32:02 <pulpbot> asmacdo: 4 issues left to triage: 4891, 4900, 4901, 4903
14:32:03 <asmacdo> #topic https://pulp.plan.io/issues/4891
14:32:03 <pulpbot> RM 4891 - Fah - NEW - The client side ssl cert for pulp should follow http header standards
14:32:04 <pulpbot> https://pulp.plan.io/issues/4891
14:32:06 <bherring> #info bherring has joined triage
14:32:06 <bherring> !here
14:32:06 <pulpbot> bherring: bherring has joined triage
14:32:24 <asmacdo> !issue 4903
14:32:24 <asmacdo> #topic https://pulp.plan.io/issues/4903
14:32:25 <pulpbot> RM 4903 - mdellweg - NEW - python bindings are unable to nullify repository description
14:32:26 <pulpbot> https://pulp.plan.io/issues/4903
14:32:35 <dkliban> same as the last one
14:32:39 <dkliban> accept and add to sprint
14:32:40 <rchan> asmacdo: doh. i'll go create sprint now
14:32:43 <daviddavis> +1
14:32:46 <ttereshc> +1
14:32:49 <ipanova> +1
14:33:09 <asmacdo> dkliban: i think this call should work http --json PUT :24817/pulp/api/v3/repositories/cebe653e-f8ca-4b2f-acd0-93c5edf32b48/ name:=\"test_repo\"
14:33:10 <dalley> #info dalley has joined triage
14:33:10 <dalley> !here
14:33:10 <pulpbot> dalley: dalley has joined triage
14:33:34 <asmacdo> ^ is the same as the call in the issue, but the PUT simply omits the description rather than attempting to set it to null
14:33:52 <dkliban> asmacdo: what about other fields?
14:33:57 <rchan> Sprint 54 is live
14:34:00 <asmacdo> dkliban: should work for all fields
14:34:07 <dkliban> asmacdo: please comment on the issue
14:34:29 <asmacdo> will do, ill comment and ping x9c4, lets skip for today
14:34:32 <bmbouter> #info bmbouter has joined triage
14:34:32 <bmbouter> !here
14:34:34 <pulpbot> bmbouter: bmbouter has joined triage
14:35:12 <dkliban> asmacdo: sounds good
14:35:32 <asmacdo> !issue 4901
14:35:32 <asmacdo> #topic https://pulp.plan.io/issues/4901
14:35:33 <pulpbot> RM 4901 - jsherril@redhat.com - NEW - Repository Version creation api should provide an easy way to clear out all units when adding new units
14:35:34 <pulpbot> https://pulp.plan.io/issues/4901
14:35:51 <dkliban> this is a story
14:35:54 <daviddavis> agreed
14:36:03 <asmacdo> a good story too
14:36:25 <daviddavis> we need to get this groomed soon though
14:36:28 <daviddavis> it's a P2
14:36:44 <daviddavis> I can take it as an AI
14:36:50 <asmacdo> daviddavis++
14:36:50 <pulpbot> asmacdo: daviddavis's karma is now 194
14:36:57 <ttereshc> +1 to convert to story
14:37:06 <dkliban> +1
14:37:07 <ipanova> +1
14:37:11 <asmacdo> #idea Proposed for #4901: daviddavis wil change to story and shepherd it through grooming
14:37:11 <asmacdo> !propose other daviddavis wil change to story and shepherd it through grooming
14:37:11 <pulpbot> asmacdo: Proposed for #4901: daviddavis wil change to story and shepherd it through grooming
14:37:30 <asmacdo> #agreed daviddavis wil change to story and shepherd it through grooming
14:37:30 <asmacdo> !accept
14:37:30 <pulpbot> asmacdo: Current proposal accepted: daviddavis wil change to story and shepherd it through grooming
14:37:31 <asmacdo> #topic https://pulp.plan.io/issues/4891
14:37:31 <pulpbot> asmacdo: 3 issues left to triage: 4891, 4900, 4903
14:37:32 <pulpbot> RM 4891 - Fah - NEW - The client side ssl cert for pulp should follow http header standards
14:37:33 <pulpbot> https://pulp.plan.io/issues/4891
14:37:42 <asmacdo> !issue 4900
14:37:42 <asmacdo> #topic https://pulp.plan.io/issues/4900
14:37:43 <pulpbot> RM 4900 - Fah - NEW - As a user I would like to know how to make pulp work with yum
14:37:44 <pulpbot> https://pulp.plan.io/issues/4900
14:37:59 <daviddavis> this is completed. also needs to be under certguard I think.
14:38:05 <dkliban> yep ... agreed
14:38:12 <dkliban> yeah ... we already merged the PR for this
14:38:31 <asmacdo> someone on the rpm team wanna polish the paperwork?
14:38:43 <ttereshc> +1 move to certguard
14:38:47 <ttereshc> I can do that
14:38:51 <ipanova> i will put this into according state
14:38:54 <ipanova> ok ttereshc will do
14:38:56 <ipanova> :-P
14:39:03 <asmacdo> brno is motivated today
14:39:08 <ipanova> Brrrrno
14:39:20 <ipanova> it's finally summer here!
14:39:21 <asmacdo> !propose someone in brno will file the paperwork
14:39:21 <pulpbot> asmacdo: Error: "propose" is not a valid command.
14:39:29 <dkliban> wooooo!! summmer!!!
14:39:39 <asmacdo> #idea Proposed for #4900: tt<tab> will file the paperwork
14:39:39 <asmacdo> !propose other tt<tab> will file the paperwork
14:39:39 <pulpbot> asmacdo: Proposed for #4900: tt<tab> will file the paperwork
14:39:42 <daviddavis> wow, we just got spring weather
14:39:44 <asmacdo> #agreed tt<tab> will file the paperwork
14:39:44 <asmacdo> !accept
14:39:44 <pulpbot> asmacdo: Current proposal accepted: tt<tab> will file the paperwork
14:39:45 <asmacdo> #topic https://pulp.plan.io/issues/4891
14:39:45 <pulpbot> asmacdo: 2 issues left to triage: 4891, 4903
14:39:45 <ttereshc> daviddavis, dkliban, is all the work done there?
14:39:46 <pulpbot> RM 4891 - Fah - NEW - The client side ssl cert for pulp should follow http header standards
14:39:47 <pulpbot> https://pulp.plan.io/issues/4891
14:39:55 <ttereshc> can I change it to MODIFIED?
14:40:00 <ttereshc> 4900
14:40:00 <daviddavis> ttereshc: I believe so. there's an attached commit. maybe follow up with bmbouter.
14:40:04 <ipanova> ttereshc: yes
14:40:06 <ttereshc> ok
14:40:07 <ttereshc> done
14:40:11 <ttereshc> just checking
14:40:23 <asmacdo> ok the last 2  in in the queue aren't for triage
14:40:26 <dkliban> yes, it's modified
14:40:26 <asmacdo> open floor!
14:40:41 * dkliban moonwalks accross the open floor
14:40:58 * dkliban falls backwards on the floor
14:41:00 * bherring shakes his head
14:41:05 * ipanova catwalks accross the open florr
14:41:08 <dkliban> LOL
14:41:10 <asmacdo> rchan (or someone), could you move assigned/post/new issues from 53 to 54
14:42:45 <ttereshc> asmacdo, I guess someone who was present at the sprint planning and who knows what to move should do that
14:43:17 <bmbouter> we got this from katello andit's a feature so maybe comment on the issue? https://pulp.plan.io/issues/4901
14:43:27 <asmacdo> i thought we assigned everything we wanted on to 53, and anything not carrying forward was removed from 53
14:44:40 <dkliban> asmacdo: correct
14:45:17 <ttereshc> great
14:45:35 <asmacdo> anyway, ttereshc makes a decent point, ill take that as an action item. rchan, you're off the hook this morning|evening|weekend|whatever it feels like  ;)
14:46:40 <bmbouter> moving items during the sprint planning meeting would solve this too
14:46:46 <bmbouter> I don't think the data quality of waiting 72 hours is worth it
14:48:40 * rochacbruno googles what is a catwalk
14:49:38 <asmacdo> sprint 54 is now active https://pulp.plan.io/issues?query_id=127
14:50:15 <asmacdo> oh i forgot to end the thing
14:50:20 <asmacdo> #endmeeting
14:50:20 <asmacdo> !end