14:30:20 <asmacdo> #startmeeting Pulp Triage 2019-06-14
14:30:20 <asmacdo> !start
14:30:20 <asmacdo> #info asmacdo has joined triage
14:30:20 <pulpbot> Meeting started Fri Jun 14 14:30:20 2019 UTC.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:20 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:20 <pulpbot> The meeting name has been set to 'pulp_triage_2019-06-14'
14:30:20 <pulpbot> asmacdo: asmacdo has joined triage
14:30:26 <dkliban> #info dkliban has joined triage
14:30:26 <dkliban> !here
14:30:26 <pulpbot> dkliban: dkliban has joined triage
14:30:31 <daviddavis> #info daviddavis has joined triage
14:30:31 <daviddavis> !here
14:30:31 <pulpbot> daviddavis: daviddavis has joined triage
14:30:36 <ttereshc> #info ttereshc has joined triage
14:30:36 <ttereshc> !here
14:30:36 <pulpbot> ttereshc: ttereshc has joined triage
14:30:37 <ggainey> #info ggainey has joined triage
14:30:37 <ggainey> !here
14:30:38 <pulpbot> ggainey: ggainey has joined triage
14:30:39 <bmbouter> #info bmbouter has joined triage
14:30:39 <bmbouter> !here
14:30:40 <pulpbot> bmbouter: bmbouter has joined triage
14:31:02 <asmacdo> !next
14:31:04 <asmacdo> #topic https://pulp.plan.io/issues/4920
14:31:04 <pulpbot> asmacdo: 9 issues left to triage: 4920, 4939, 4947, 4958, 4959, 4966, 4967, 4970, 4971
14:31:05 <pulpbot> RM 4920 - kersom - ASSIGNED - Collection - Repository versions not being update after successive syncs
14:31:06 <pulpbot> https://pulp.plan.io/issues/4920
14:31:15 <asmacdo> !skip
14:31:16 <pulpbot> asmacdo: 8 issues left to triage: 4939, 4947, 4958, 4959, 4966, 4967, 4970, 4971
14:31:16 <asmacdo> #topic https://pulp.plan.io/issues/4939
14:31:17 <pulpbot> RM 4939 - kersom - NEW - Docs - Collections upload workflows is using role endpoints
14:31:18 <pulpbot> https://pulp.plan.io/issues/4939
14:31:25 <asmacdo> !skip
14:31:26 <pulpbot> asmacdo: 7 issues left to triage: 4947, 4958, 4959, 4966, 4967, 4970, 4971
14:31:26 <asmacdo> #topic https://pulp.plan.io/issues/4947
14:31:27 <pulpbot> RM 4947 - amacdona@redhat.com - NEW -  As a user I can add tags to a repository by name.
14:31:28 <pulpbot> https://pulp.plan.io/issues/4947
14:31:33 <dkliban> story
14:31:42 <daviddavis> +1
14:31:47 <asmacdo> docker story -- ill adjust it after
14:31:49 <asmacdo> !skip
14:31:50 <pulpbot> asmacdo: 6 issues left to triage: 4958, 4959, 4966, 4967, 4970, 4971
14:31:50 <asmacdo> #topic https://pulp.plan.io/issues/4958
14:31:51 <pulpbot> RM 4958 - amacdona@redhat.com - NEW - queue_download_deferred raises a duplicate key error
14:31:52 <pulpbot> https://pulp.plan.io/issues/4958
14:32:01 <dkliban> accept and add to sprint
14:32:05 <daviddavis> +1
14:32:18 <ppicka> #info ppicka has joined triage
14:32:18 <ppicka> !here
14:32:18 <pulpbot> ppicka: ppicka has joined triage
14:32:21 <ttereshc> +1
14:32:31 <asmacdo> #idea Proposed for #4958: accept and add to sprint
14:32:31 <asmacdo> !propose other accept and add to sprint
14:32:31 <pulpbot> asmacdo: Proposed for #4958: accept and add to sprint
14:33:01 <asmacdo> #agreed accept and add to sprint
14:33:01 <asmacdo> !accept
14:33:01 <pulpbot> asmacdo: Current proposal accepted: accept and add to sprint
14:33:02 <pulpbot> asmacdo: 5 issues left to triage: 4959, 4966, 4967, 4970, 4971
14:33:02 <asmacdo> #topic https://pulp.plan.io/issues/4959
14:33:03 <pulpbot> RM 4959 - amacdona@redhat.com - NEW - Do not log that a download fails with 401 (INFO) unless it fails again after token refresh
14:33:04 <pulpbot> https://pulp.plan.io/issues/4959
14:33:10 <ttereshc> skip
14:33:11 <asmacdo> !skip
14:33:12 <pulpbot> asmacdo: 4 issues left to triage: 4966, 4967, 4970, 4971
14:33:12 <asmacdo> #topic https://pulp.plan.io/issues/4966
14:33:13 <pulpbot> RM 4966 - bmbouter - NEW - Nginx needs to expose both pulp-api and pulp-content-app
14:33:14 <pulpbot> https://pulp.plan.io/issues/4966
14:33:25 <ttereshc> task?
14:33:43 <daviddavis> +1
14:33:46 <dkliban> +1
14:33:48 <bmbouter> +1
14:33:49 <ppicka> +1
14:34:01 <bmbouter> during open floor I was going to bring up the epic this is part of
14:34:02 <asmacdo> bmbouter: do you want to add this to the sprint?
14:34:14 <asmacdo> k lets do that during open floor +1
14:34:16 <bmbouter> can we do it during open floor
14:34:23 <bmbouter> b/c I want to add 1-2 but not all 8
14:34:28 <asmacdo> perfect
14:34:33 <asmacdo> #idea Proposed for #4966: convert to task
14:34:33 <asmacdo> !propose other convert to task
14:34:34 <pulpbot> asmacdo: Proposed for #4966: convert to task
14:34:48 <asmacdo> #agreed convert to task
14:34:48 <asmacdo> !accept
14:34:48 <pulpbot> asmacdo: Current proposal accepted: convert to task
14:34:49 <pulpbot> asmacdo: 3 issues left to triage: 4967, 4970, 4971
14:34:49 <asmacdo> #topic https://pulp.plan.io/issues/4967
14:34:50 <pulpbot> RM 4967 - bmbouter - NEW - Apache needs to expose both pulp-api and pulp-content-app
14:34:51 <pulpbot> https://pulp.plan.io/issues/4967
14:34:53 <bmbouter> same
14:34:56 <daviddavis> +1
14:35:01 <asmacdo> #idea Proposed for #4967: convert to task
14:35:01 <asmacdo> !propose other convert to task
14:35:01 <pulpbot> asmacdo: Proposed for #4967: convert to task
14:35:14 <asmacdo> #agreed convert to task
14:35:14 <asmacdo> !accept
14:35:14 <pulpbot> asmacdo: Current proposal accepted: convert to task
14:35:15 <asmacdo> #topic https://pulp.plan.io/issues/4970
14:35:15 <pulpbot> asmacdo: 2 issues left to triage: 4970, 4971
14:35:16 <pulpbot> RM 4970 - kersom - NEW - Collection - RepositoryDistribution does not provide url to consume to cosume content from Pulp
14:35:16 <ttereshc> +1
14:35:17 <pulpbot> https://pulp.plan.io/issues/4970
14:35:21 <daviddavis> skip
14:35:25 <asmacdo> !skip
14:35:26 <asmacdo> #topic https://pulp.plan.io/issues/4971
14:35:26 <pulpbot> asmacdo: 1 issues left to triage: 4971
14:35:27 <pulpbot> RM 4971 - Fixemails - NEW - Gmail Helpline number
14:35:28 <pulpbot> https://pulp.plan.io/issues/4971
14:35:36 <daviddavis> accept and add to sprint
14:35:40 <ttereshc> accept?
14:35:48 <daviddavis> lol
14:35:51 <dkliban> lol
14:35:51 <ttereshc> :)
14:35:54 <ggainey> ?!?
14:35:56 <asmacdo> #idea Proposed for #4971: forward to my family in case they need help
14:35:56 <asmacdo> !propose other forward to my family in case they need help
14:35:56 <pulpbot> asmacdo: Proposed for #4971: forward to my family in case they need help
14:35:57 <ttereshc> I was more modest daviddavis
14:36:02 <daviddavis> haha
14:36:07 <dkliban> LOL
14:36:09 <ggainey> heh
14:36:10 <daviddavis> it seems pretty urgent though
14:36:10 <bherring> #info bherring has joined triage
14:36:10 <bherring> !here
14:36:10 <pulpbot> bherring: bherring has joined triage
14:36:11 <ttereshc> +1
14:36:27 <asmacdo> !skip
14:36:28 <pulpbot> asmacdo: No issues to triage.
14:36:44 <asmacdo> bmbouter: all yours!
14:37:21 <bmbouter> so in collaboration w/ QE, mikedep333, and asmacdo I've written up an epic  https://pulp.plan.io/issues/4961
14:37:43 <dalley> #info dalley has joined triage
14:37:43 <dalley> !here
14:37:43 <pulpbot> dalley: dalley has joined triage
14:38:56 <kersom> yeah
14:39:14 <bmbouter> this epic brings together a variety of changes, somein the installer, some in pulp-smash, and some to our travis matrix to add nginx and apache to the matrix
14:39:24 <kersom> this will change how we are currently testing pulp
14:40:03 <sajha> pulp3 ansible collection has a single content type collection right?
14:40:18 <bmbouter> yes
14:40:40 <daviddavis> I'm concerned about adding more tests to our test matrix. Travis is already super slow
14:40:47 <daviddavis> sometimes we only have 2-3 concurrent jobs
14:41:07 <bmbouter> daviddavis: I hear that, it could be in nightly only I'd be ok w/ that
14:41:14 <sajha> bmbouter: Thanks!
14:41:27 <bmbouter> or a very limited set, but yes we don't want to make Travis much longer
14:41:31 <asmacdo> rather than a full matrix, we could perform specific tests with apache and nginx
14:41:37 <bmbouter> yeah exactly
14:41:46 <daviddavis> that's a good solution
14:41:53 <ggainey> +1
14:42:07 <bmbouter> capability-wise this would give us that place to put tests which actually test specific webserver integration
14:42:11 <bmbouter> and move the default testing of P
14:42:26 <kersom> yeah, we could use pytest to mark a specific tests to run
14:42:28 <bmbouter> ulp to disinclude a webserver at all and go straight to gunicorn hosting pulp-api and pulp-content-app
14:42:59 <ttereshc> +1
14:43:03 <asmacdo> just to get an idea, i think the main tests we'd want would be the REMOTE_USER, lazy. any other affected areas?
14:43:10 <bherring> daviddavis: you are always going to have more and more tests
14:43:29 <daviddavis> bherring: I get that. but we're limited by concurrency
14:43:30 <bmbouter> practically speaking if you have to go through the webserver testing the entire surface of pulp as an application is practically difficult
14:43:37 <bherring> I think there are intelligent ways to eark-mark tests that are relevant to run in push situations and other to run in regression or other test scenarios
14:43:40 <kersom> we will need to pick just a subset to run on travis
14:43:56 <bmbouter> I think it probably is time forus to get smarter about our Travis test selections
14:44:07 <bherring> That way we can run `high value` tests in CI and then run the whole she-bang in Jenkins or situations where quick turn around isn't as important
14:44:10 <bherring> Always write more tests
14:44:16 <daviddavis> agreed. we can't run all our tests against every PR.
14:44:24 <bmbouter> yeah we likely have reached that point
14:44:33 <bherring> And you will
14:44:35 <kersom> bmbouter, this has to be a collaboration btw QE and dev to pick the critical ones
14:44:36 <dalley> we could switch to a CI that doesn't limit you to 4 concurrent jobs :)
14:44:37 <daviddavis> also we need to get off Travis
14:44:42 <bherring> That is the conundrum with tests.
14:44:52 <bmbouter> kersom: agreed, we should try to assess it together
14:44:54 <asmacdo> kersom +1
14:44:59 <bmbouter> daviddavis: I'm not totally convinced
14:45:14 <bmbouter> just few days ago an article came out saying that Azure had many issues
14:45:16 <bherring> +1 to Google spreadsheet to get group understanding of `test phases` and what to run where
14:45:20 <bmbouter> and they were broken for over 7 days
14:45:51 <bherring> bmbouter: can you have multiple options and just not one?
14:45:52 <bmbouter> https://hynek.me/articles/simple-python-azure-pipelines/
14:46:30 <kersom> travis has stages as well, not sure how we could leverage those to help us
14:46:37 <bherring> kersom: +1
14:46:41 <bmbouter> bherring: project by project could pick, but we're starting to use this tooling to manage Travis's config so the cost of adding a second would be high (but not impossible)
14:46:52 <bherring> bmbouter: ack
14:47:08 <bmbouter> we wrote some about that Travis CI tooling here https://pulpproject.org/2019/05/29/travis-ci-cd-config-generator-for-pulp3-plugins/
14:47:18 <asmacdo> the good news is that the tooling can also be applied to making the switch once for all repos
14:47:26 <bmbouter> yeah exactly
14:47:50 <bmbouter> and I'm into switching I just want to be sure we're actually getting the benefits we think we're going to get
14:48:08 <bmbouter> and one of the main motivator's I've heard is travis' downtime is an issue and I agree
14:48:28 <bmbouter> but now there are Azure pipeline downtimes too, and all of this is beyond our control
14:48:37 <daviddavis> yea
14:48:38 <bherring> bmbouter: are there other smart alternatives we can mirror from downstream or other teams? (may have already been explored)
14:48:39 <kersom> we could migrate one repo and see what happens
14:48:51 <daviddavis> migrating one repo would help free travis resources
14:48:59 <daviddavis> we share executors across the entire pulp org
14:49:01 <bmbouter> bherring: we need something community based outside of Red Hat and I see mostly RH tooling used in downstreams
14:49:06 <daviddavis> so having different CIs might be a good move
14:49:17 <kersom> daviddavis, interesting.
14:49:35 <bmbouter> some diveresity would be good to me
14:49:38 <kersom> I was thinking to migrate one to azure and evaluate there, but your idea...
14:49:51 <bherring> _1 to failing fast
14:49:54 <bherring> +1
14:50:05 <bmbouter> my main thinking is to think of it as 'how can I do this at scale with X pipeline features for Y repos'
14:50:24 <asmacdo> we could actually use the diversity across plugins
14:50:25 <bmbouter> because it almost doesn't matter how much effort it takes as long as it can be recouped by easily applying it to all repos
14:50:34 <daviddavis> what is the priority of https://pulp.plan.io/issues/4961? are there no ways to test pulp-smash without nginx/apache?
14:50:42 <asmacdo> ie, the api smoke tests could run on travis, but the docs tests could run on another platform
14:50:44 <bmbouter> yeah back to the epic at hand
14:50:47 <daviddavis> asking because we have a ton of stakeholder work too
14:51:09 <bmbouter> ironically this came up through some stakeholder work
14:51:18 <bmbouter> and we should call that aspect out
14:51:43 <bmbouter> so in my dev environment mazer and pulp_ansible work great
14:51:50 <bmbouter> but something is up when testing through nginx
14:52:06 <bmbouter> and upon looking at nginx it hasn't really been maintained
14:52:52 <bmbouter> so to fix this up for katello we'll either have to quickly address nginx's (which is only a small piece of the problem) or have dev and QE align on what does it mean to have a feature working
14:53:05 <kersom> daviddavis, we can run smash without apache/nginx, there are ports to set up.
14:53:11 <bmbouter> and this epic shifts that to 'working as measures when interacting with gunicorn directly'
14:53:36 <kersom> one for the api, another for the content app
14:53:46 <bmbouter> earlier I said 'looking at nignx' I meant 'loogin at our nginx config in the ansible-pulp installer'
14:53:52 <bmbouter> loogin lol
14:54:27 <kersom> yeah, mazer is not only that shows this ngnix/ problem. all the others tests we were to use ngnix.
14:54:36 <kersom> is the only one*
14:54:59 <daviddavis> is there a bug for the mazer problem?
14:55:15 <bmbouter> there is a 'test' ticket and the test code developed isn't passing
14:55:22 <daviddavis> I see
14:55:41 <bmbouter> my proposal for this epic is actually the bare minimum for right now
14:55:54 <bmbouter> 4963, 4964, 4965 (which qe would do)
14:55:59 <bmbouter> dev would do the first 2
14:56:25 <bmbouter> to resolve the immediate need around the testing of mazer/pulp_ansible
14:56:49 <bmbouter> and we can fixup the nginx and apache installer options later, and maybe mikedep333 could help w/ that perhaps
14:56:56 <daviddavis> that makes sense to me
14:57:03 <bmbouter> 4968 can happen wheneer (not immediate)
14:57:35 <daviddavis> yea, I'm very hesitant to address 4968 anytime soon. until we sort out our CI woes.
14:57:42 <bmbouter> agreed
14:57:51 <bmbouter> so that's what I wanted to share
14:58:01 <daviddavis> +1 from me
14:58:04 <bmbouter> a request to add 4963, 4964, 4965 to sprint
14:58:04 <daviddavis> I gotta run to a meeting
14:58:07 <bmbouter> ty!
14:59:52 <asmacdo> bmbouter: +1 to adding all 3, and I've commented on 4964 that 4946 will also need to be done
15:00:21 <asmacdo> so proposal is 4963, 4964, 4965, and 4946 to be added to the sprint
15:01:47 <asmacdo> in short, the work is to switch the default to 127.0.0.1, and refactor the relevent variables for correctness and consistency
15:02:04 <bmbouter> yup
15:02:08 * bmbouter just read
15:02:10 <bmbouter> this makes sense
15:02:11 <asmacdo> bmbouter: I was waiting to mark as groomed until others had a chance to respond
15:02:19 <bmbouter> +1
15:02:39 <asmacdo> but i think they are ready now. ill groom and add to sprint
15:03:00 <asmacdo> does that wrap up?
15:03:12 <bmbouter> it does for me
15:03:14 <bmbouter> other topics?
15:03:28 <bmbouter> I kind of think a dedicated 1-hour chat meeting would be good
15:03:37 <bmbouter> for pulpcore topics
15:03:57 <asmacdo> so, we separate open floor from triage? sure seems reasonable
15:04:36 <bmbouter> just a thought
15:04:52 <bmbouter> my goal is increased participation really
15:05:02 <bmbouter> more discussion
15:05:52 <asmacdo> easy enough to give it a whirl
15:06:34 <bmbouter> anyway for now we can end?
15:06:38 <asmacdo> #endmeeting
15:06:38 <asmacdo> !end