14:31:12 <dalley> #startmeeting Pulp Triage 2019-07-12
14:31:12 <dalley> #info dalley has joined triage
14:31:12 <dalley> !start
14:31:12 <pulpbot> Meeting started Fri Jul 12 14:31:12 2019 UTC.  The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:12 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:31:12 <pulpbot> The meeting name has been set to 'pulp_triage_2019-07-12'
14:31:12 <pulpbot> dalley: dalley has joined triage
14:31:15 <daviddavis> !here
14:31:15 <daviddavis> #info daviddavis has joined triage
14:31:16 <pulpbot> daviddavis: daviddavis has joined triage
14:31:25 <mikedep333> morre: Totally understandable. Overcoming the limitation is on my to-do; probably via rook.
14:31:28 <mikedep333> #info mikedep333 has joined triage
14:31:28 <mikedep333> !here
14:31:28 <pulpbot> mikedep333: mikedep333 has joined triage
14:31:31 <ggainey> #info ggainey has joined triage
14:31:31 <ggainey> !here
14:31:31 <pulpbot> ggainey: ggainey has joined triage
14:31:56 <dalley> !next
14:31:56 <pulpbot> dalley: 4 issues left to triage: 5118, 5109, 5104, 5101
14:31:57 <dalley> #topic https://pulp.plan.io/issues/5118
14:31:57 <ppicka> #info ppicka has joined triage
14:31:57 <ppicka> !here
14:31:58 <pulpbot> RM 5118 - daviddavis - NEW - We're not running flake8 against pulp/pulp
14:31:59 <pulpbot> https://pulp.plan.io/issues/5118
14:32:00 <pulpbot> ppicka: ppicka has joined triage
14:32:04 <bmbouter> #info bmbouter has joined triage
14:32:04 <bmbouter> !here
14:32:04 <pulpbot> bmbouter: bmbouter has joined triage
14:32:37 <bmbouter> !friday
14:32:37 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
14:32:48 <ttereshc> #info ttereshc has joined triage
14:32:48 <ttereshc> !here
14:32:48 <pulpbot> ttereshc: ttereshc has joined triage
14:32:50 <daviddavis> \o/
14:33:08 <dkliban> #info dkliban has joined triage
14:33:08 <dkliban> !here
14:33:08 <pulpbot> dkliban: dkliban has joined triage
14:33:32 <dkliban> we are running flake8 on pulp/pulp but only on Jenkins
14:33:33 <dalley> accept?
14:33:49 <ppicka> +1
14:33:50 <dkliban> or at least i thought we were
14:33:53 <daviddavis> dkliban: are you sure? I see lines over 100 chars
14:33:54 <dkliban> anyway, let's accept
14:34:00 <daviddavis> k
14:34:01 <ttereshc> +1 to accept
14:34:03 <ggainey> +1
14:34:06 <dalley> !accept
14:34:06 <pulpbot> dalley: No action proposed, nothing to accept.
14:34:11 <dalley> #idea Proposed for #5118: Leave the issue as-is, accepting its current state.
14:34:11 <dalley> !propose accept
14:34:11 <pulpbot> dalley: Proposed for #5118: Leave the issue as-is, accepting its current state.
14:34:17 <dalley> #agreed Leave the issue as-is, accepting its current state.
14:34:17 <dalley> !accept
14:34:17 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:34:18 <pulpbot> dalley: 3 issues left to triage: 5109, 5104, 5101
14:34:18 <dalley> #topic https://pulp.plan.io/issues/5109
14:34:19 <pulpbot> RM 5109 - jokabo - NEW - 500 - illegal-argument: Value for replyText is too large(320)
14:34:20 <pulpbot> https://pulp.plan.io/issues/5109
14:34:53 <dkliban> i'll comment on this
14:34:58 <dkliban> there is not enough info at this time
14:35:10 <bmbouter> I agree
14:35:12 <dkliban> we need to know where he is syncing from at least
14:35:21 <bmbouter> we need a reproducer
14:35:32 <ipanova> #info ipanova has joined triage
14:35:32 <ipanova> !here
14:35:32 <pulpbot> ipanova: ipanova has joined triage
14:35:32 <ttereshc> it seems to be a qpid error
14:35:44 <dalley> #idea Proposed for #5109: Skip this issue for this triage session.
14:35:44 <dalley> !propose skip
14:35:44 <pulpbot> dalley: Proposed for #5109: Skip this issue for this triage session.
14:36:12 <dkliban> +1
14:36:14 <dkliban> i commented
14:36:21 <ttereshc> I mean it;'s likely not related to where he is syncing from
14:36:31 <ipanova> +1
14:36:34 <ttereshc> if he gets an error for every plugin
14:36:49 <ttereshc> or he said for every project, I read it as for every plugin
14:37:07 <ttereshc> I'm fine to skip though
14:37:39 <dalley> !skip
14:37:39 <dalley> #topic https://pulp.plan.io/issues/5104
14:37:40 <pulpbot> dalley: 2 issues left to triage: 5104, 5101
14:37:41 <pulpbot> RM 5104 - dkliban@redhat.com - NEW - Pulp 2 stops working after installing Pulp 3
14:37:42 <pulpbot> https://pulp.plan.io/issues/5104
14:38:33 <dalley> that's... strange
14:38:33 <dkliban> accept and add to sprint
14:38:33 <ttereshc> #idea Proposed for #5104: accept and add to the sprint
14:38:33 <ttereshc> !propose other accept and add to the sprint
14:38:33 <pulpbot> ttereshc: Proposed for #5104: accept and add to the sprint
14:38:57 <dalley> +1
14:39:34 <ipanova> +1
14:40:15 <bmbouter> +1
14:40:22 <dalley> #agreed accept and add to the sprint
14:40:22 <dalley> !accept
14:40:22 <pulpbot> dalley: Current proposal accepted: accept and add to the sprint
14:40:23 <dalley> #topic https://pulp.plan.io/issues/5101
14:40:23 <pulpbot> dalley: 1 issues left to triage: 5101
14:40:24 <pulpbot> RM 5101 - bmbouter - NEW - Content filters in DRF don't show correctly
14:40:25 <pulpbot> https://pulp.plan.io/issues/5101
14:41:04 <ttereshc> accept?
14:41:07 <ipanova> yes
14:41:29 <dalley> +1
14:41:33 <ggainey> +1
14:41:34 <dalley> #idea Proposed for #5101: Leave the issue as-is, accepting its current state.
14:41:34 <dalley> !propose accept
14:41:34 <pulpbot> dalley: Proposed for #5101: Leave the issue as-is, accepting its current state.
14:41:34 <ppicka> +1
14:42:15 <dalley> #agreed Leave the issue as-is, accepting its current state.
14:42:15 <dalley> !accept
14:42:15 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:42:16 <pulpbot> dalley: No issues to triage.
14:42:29 <dalley> open floor commence ->
14:44:26 <bmbouter> we have one issue that needs planning attention
14:45:48 <pcreech> dkliban: fixed bits are live
14:46:02 <ggainey> pcreech++
14:46:03 <pulpbot> ggainey: pcreech's karma is now 96
14:48:30 <rchan> pcreech++
14:48:30 <pulpbot> rchan: pcreech's karma is now 97
14:49:06 <dalley> bmbouter, what issue?
14:49:49 <bmbouter> I'm looking
14:49:54 <bmbouter> it's the one you commented on most recently
14:51:45 <dalley> do you mean at retro?
14:51:49 <dalley> or redmine comment
14:51:51 <bmbouter> https://pulp.plan.io/issues/4681#note-14
14:52:24 <bmbouter> this proposal is pretty major  https://pulp.plan.io/issues/4681#note-11
14:53:42 <bmbouter> or are you just saying break it from the overall inheritance
14:54:14 <dalley> what do you mean break it from the overall inheritance
14:55:03 <daviddavis> I think ditching model inheritance for the Content models
14:55:07 <bmbouter> from comment 11 I think I don't understand "we could just ditch model inheritance for the content models entirely"
14:55:47 <dalley> bmbouter, the proposal is basically to turn the Package is-a Content relationship into a Package has-a content relationship, which is the same way it's *actually* represented in the database
14:57:33 <dalley> and if we're at the point where the end user has to manually name the link back to Content anyways to avoid the issue --- that separation has already been exposed through the API regardless of our attempt to hide it
14:58:03 <dalley> the issue = 4861
14:58:09 <bmbouter> yup
14:59:15 <daviddavis> have we tried to look at renaming the link automatically for the plugin writer to include the app label?
15:00:01 <bmbouter> I'm ok w/ not having it be an automatic thing
15:00:18 <dalley> daviddavis, how would that work? it would have to be automatic at schema-generation time
15:00:36 <dalley> ie. when django is making the migrations, not when it's running
15:00:56 <daviddavis> it's only the reverse parent link which doesn't exist in the database
15:01:07 <bmbouter> agreed
15:01:11 <bmbouter> that's my understanding
15:01:47 <dalley> I'm not sure, the first 4 error messages look like that is the case, but the next 2:
15:01:48 <dalley> rpm.Package.release: (models.E006) The field 'release' clashes with the field 'release' from model 'core.content'.
15:01:48 <dalley> rpm.UpdateRecord.release: (models.E006) The field 'release' clashes with the field 'release' from model 'core.content'.
15:02:51 <dalley> that could still be true, I don't necessarily know how to parse the meaning of that, it just sounds lower-level than the runtime ORM
15:03:42 <bmbouter> I'm reading this and it sounds like it was maybe a 1-line thing? https://pulp.plan.io/issues/4681#note-8
15:05:59 <daviddavis> I think it possibly could be
15:06:42 <bmbouter> practically speaking I think we need to do that first before we consider a large change
15:08:08 <daviddavis> that's cool. I can try to take a look into it this sprint. if it fails, we can discuss other proposals like dalley's?
15:08:09 <dalley> we can and I'm fine w/ that. I just wanted to point out that we're leaking abstractions now and that by getting rid of them in this one specific place we could enable much better performance
15:08:49 <lmjachky> Hi guys! Do you use tmux in vagrant's VM?
15:08:56 <lmjachky> I am connected to the VM via ssh
15:09:18 <daviddavis> lmjachky: I go the other way around. tmux and then ssh into the VM.
15:09:30 <daviddavis> I edit files on my host os
15:09:32 <lmjachky> I start tmux, and when I type "pstop && pclean && pstart" I get a (pulp) venv within (pulp) venv
15:09:41 <lmjachky> Is it normal behavior?
15:09:59 <bmbouter> dalley: I hear you
15:10:36 <bmbouter> dalley: I don't think of it as a goeal to hide the machinery from plugin writers as much as to keep the complexity down
15:10:53 <bmbouter> if this few line solution doesn't pan out we may have to do what you're saying
15:11:01 <bmbouter> and the bulk_insert gains make sense also
15:11:19 <bmbouter> we should end open floor so we can go to rpm meeting
15:11:31 <dalley> it's a decision we have to make before GA though, FWIW
15:11:52 <bmbouter> dalley: if this issue resolves do you still want to consider it?
15:12:25 <dalley> we can wait until we start getting back performance data
15:12:27 <dalley> at least
15:12:50 <bmbouter> agreed
15:13:16 <bmbouter> speaking of which psuriset is it possible for us to start testing soon?
15:13:48 <ttereshc> dalley, bmbouter , can we call this openfloor closed and proceed with rpm meeting ?
15:13:55 <dalley> yes
15:13:56 <dalley> #endmeeting
15:13:56 <dalley> !end