14:31:11 <asmacdo> #startmeeting Pulp Triage 2019-08-02
14:31:11 <asmacdo> !start
14:31:11 <asmacdo> #info asmacdo has joined triage
14:31:11 <pulpbot> Meeting started Fri Aug  2 14:31:11 2019 UTC.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:11 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:31:11 <pulpbot> The meeting name has been set to 'pulp_triage_2019-08-02'
14:31:11 <pulpbot> asmacdo: asmacdo has joined triage
14:31:25 <ttereshc> #info ttereshc has joined triage
14:31:25 <ttereshc> !here
14:31:25 <pulpbot> ttereshc: ttereshc has joined triage
14:31:37 <daviddavis> #info daviddavis has joined triage
14:31:37 <daviddavis> !here
14:31:37 <pulpbot> daviddavis: daviddavis has joined triage
14:31:58 <fabricioo0> #info fabricioo0 has joined triage
14:31:58 <fabricioo0> !here
14:31:58 <pulpbot> fabricioo0: fabricioo0 has joined triage
14:32:20 <ggainey> #info ggainey has joined triage
14:32:20 <ggainey> !here
14:32:20 <pulpbot> ggainey: ggainey has joined triage
14:32:22 <asmacdo> !next
14:32:23 <asmacdo> #topic https://pulp.plan.io/issues/5210
14:32:23 <pulpbot> asmacdo: 3 issues left to triage: 5210, 5197, 5195
14:32:24 <pulpbot> RM 5210 - jsherril@redhat.com - NEW - pulp task status and version details returns 'serialized' ruby hashes in ruby bindings
14:32:25 <pulpbot> https://pulp.plan.io/issues/5210
14:32:40 <dkliban> accept and add to sprint
14:32:45 <daviddavis> +1
14:32:51 <mikedep333> #info mikedep333 has joined triage
14:32:51 <mikedep333> !here
14:32:51 <pulpbot> mikedep333: mikedep333 has joined triage
14:32:58 <ggainey> +1
14:33:00 <asmacdo> #idea Proposed for #5210: accept and add to sprint
14:33:00 <asmacdo> !propose other accept and add to sprint
14:33:01 <pulpbot> asmacdo: Proposed for #5210: accept and add to sprint
14:33:11 <ttereshc> bindings tag?
14:33:20 <dkliban> yes
14:33:31 <asmacdo> #agreed accept and add to sprint
14:33:31 <asmacdo> !accept
14:33:31 <pulpbot> asmacdo: Current proposal accepted: accept and add to sprint
14:33:32 <asmacdo> #topic https://pulp.plan.io/issues/5197
14:33:32 <pulpbot> asmacdo: 2 issues left to triage: 5197, 5195
14:33:33 <pulpbot> RM 5197 - dkliban@redhat.com - POST - As a user of Ruby bindings, I can specify custom ssl configs
14:33:34 <pulpbot> https://pulp.plan.io/issues/5197
14:33:52 <dkliban> it should be modified now ... the upstream PR is merged
14:33:57 <dalley> #info dalley has joined triage
14:33:57 <dalley> !here
14:33:57 <pulpbot> dalley: dalley has joined triage
14:34:05 <ttereshc> and probably a sroty
14:34:18 <dkliban> ttereshc: it was a bug
14:34:22 <dkliban> it used to work and then stopped
14:34:24 <asmacdo> dkliban: cool can you do the paperwork on this one? needs an associated commit also.
14:34:28 <dkliban> i am doing it now
14:34:51 <asmacdo> !propose dkliban will change to modified and add associated commit
14:34:51 <pulpbot> asmacdo: Error: "propose" is not a valid command.
14:35:00 <asmacdo> #idea Proposed for #5197: dkliban will change to modified and add associated commit
14:35:00 <asmacdo> !propose other dkliban will change to modified and add associated commit
14:35:00 <pulpbot> asmacdo: Proposed for #5197: dkliban will change to modified and add associated commit
14:35:01 <asmacdo> #agreed dkliban will change to modified and add associated commit
14:35:01 <asmacdo> !accept
14:35:02 <pulpbot> asmacdo: Current proposal accepted: dkliban will change to modified and add associated commit
14:35:02 <asmacdo> #topic https://pulp.plan.io/issues/5195
14:35:03 <pulpbot> asmacdo: 1 issues left to triage: 5195
14:35:03 <ttereshc> dkliban, ok, justr the way it's written, it looks like a story
14:35:04 <pulpbot> RM 5195 - chrobert@redhat.com - NEW - Removal of python2-celery-4.0.2-5.el7sat.noarch leave behind systemd files
14:35:05 <pulpbot> https://pulp.plan.io/issues/5195
14:35:42 <asmacdo> hmm- can we even fix this?
14:35:54 <dkliban> i don't want to
14:36:01 <dkliban> we do package it
14:36:09 <dkliban> so we could ... but i don't want to fix tihs
14:36:13 <daviddavis> why would removing celery remove the pulp systemd files?
14:36:38 <ttereshc> I think we add them at installation time, so we should be able to remove them
14:36:44 <ttereshc> dkliban, why not?
14:36:47 <asmacdo> but pulp would remove them
14:37:02 <asmacdo> OP removed python2-celery, which shouldnt know about pulp
14:37:08 <ttereshc> daviddavis, I read it as - when pulp is removed from the system
14:37:11 * dkliban has to go ... be back in 30
14:37:20 <ggainey> oic
14:37:34 <daviddavis> ttereshc: I think that makes sense but it says celery
14:37:35 <mikedep333> Are those /etc symlinks to files under /usr, or actual files under /etc?
14:37:48 <ttereshc> daviddavis, yeah, and then the last sentence
14:37:51 <mikedep333> I'm thinking we're not calling certain systemd RPM scriptlets.
14:37:57 <ttereshc> maybe we should ask for more info
14:38:07 <asmacdo> i see what you meant ttereshc
14:38:11 <ggainey> links - /home/vagrant/devel/pulp/server/usr/lib/systemd/system/
14:38:21 <mikedep333> https://docs.fedoraproject.org/en-US/packaging-guidelines/Scriptlets/#_systemd
14:38:23 <asmacdo> ttereshc or mikedep333 do you want to comment on the issue and skip maybe?
14:38:39 <ttereshc> asmacdo, I can comment
14:38:40 <bmbouter> #info bmbouter has joined triage
14:38:40 <bmbouter> !here
14:38:40 <pulpbot> bmbouter: bmbouter has joined triage
14:38:43 <mikedep333> Yeah, I'll comment. We need to investigate.
14:38:49 <ttereshc> I'll ask how the reporter removed pulp
14:38:50 <mikedep333> ttereshc: Thank you
14:38:59 <mikedep333> And ask if they are files or symlinks
14:39:12 <ttereshc> mikedep333, ack
14:39:17 <asmacdo> #idea Proposed for #5195: skip and ttereshc and/or mikedep333 will comment
14:39:17 <asmacdo> !propose other skip and ttereshc and/or mikedep333 will comment
14:39:17 <pulpbot> asmacdo: Proposed for #5195: skip and ttereshc and/or mikedep333 will comment
14:39:24 <ttereshc> +1
14:39:34 <asmacdo> #agreed skip and ttereshc and/or mikedep333 will comment
14:39:35 <asmacdo> !accept
14:39:35 <pulpbot> asmacdo: Current proposal accepted: skip and ttereshc and/or mikedep333 will comment
14:39:36 <pulpbot> asmacdo: No issues to triage.
14:39:40 <asmacdo> open floor!
14:39:55 <asmacdo> (now including PRs in need of review!)
14:40:00 <asmacdo> ggainey++
14:40:00 <pulpbot> asmacdo: ggainey's karma is now 6
14:40:16 <ggainey> :)
14:41:55 <ggainey> asmacdo: I got nuthin today
14:42:06 <asmacdo> apparently you arent alone
14:42:19 <asmacdo> the floor is open but nobody wants to dance...
14:42:21 <asmacdo> #endmeeting
14:42:21 <asmacdo> !end