14:30:30 <asmacdo> #startmeeting Pulp Triage 2019-08-20
14:30:30 <asmacdo> !start
14:30:30 <asmacdo> #info asmacdo has joined triage
14:30:30 <pulpbot> Meeting started Tue Aug 20 14:30:30 2019 UTC.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:30 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:30 <pulpbot> The meeting name has been set to 'pulp_triage_2019-08-20'
14:30:30 <pulpbot> asmacdo: asmacdo has joined triage
14:30:35 <ttereshc> #info ttereshc has joined triage
14:30:35 <ttereshc> !here
14:30:35 <pulpbot> ttereshc: ttereshc has joined triage
14:30:45 <dkliban> #info dkliban has joined triage
14:30:45 <dkliban> !here
14:30:45 <pulpbot> dkliban: dkliban has joined triage
14:30:48 <asmacdo> !next
14:30:49 <asmacdo> #topic https://pulp.plan.io/issues/5304
14:30:49 <pulpbot> asmacdo: 1 issues left to triage: 5304
14:30:50 <pulpbot> RM 5304 - dkliban@redhat.com - NEW - Pulp 3 can't publish metadata when installed together with Pulp 2
14:30:50 <daviddavis> #info daviddavis has joined triage
14:30:50 <daviddavis> !here
14:30:51 <pulpbot> https://pulp.plan.io/issues/5304
14:30:52 <pulpbot> daviddavis: daviddavis has joined triage
14:31:04 <dkliban> we should accept and add to sprint
14:31:11 <ppicka> #info ppicka has joined triage
14:31:11 <ppicka> !here
14:31:11 <pulpbot> ppicka: ppicka has joined triage
14:31:11 <ggainey> #info ggainey has joined triage
14:31:11 <ggainey> !here
14:31:12 <pulpbot> ggainey: ggainey has joined triage
14:31:23 <ttereshc> +1
14:31:31 <asmacdo> #idea Proposed for #5304: accept and add to sprint
14:31:31 <asmacdo> !propose other accept and add to sprint
14:31:32 <pulpbot> asmacdo: Proposed for #5304: accept and add to sprint
14:31:44 <asmacdo> do we know if this is going to be a change to pulp3 installer or pulp2?
14:32:12 <dkliban> it's a change in the spec file for pulp2 or change in how we publish in pulp 3
14:32:25 <asmacdo> gotcha
14:32:37 <asmacdo> #agreed accept and add to sprint
14:32:37 <asmacdo> !accept
14:32:37 <pulpbot> asmacdo: Current proposal accepted: accept and add to sprint
14:32:38 <ttereshc> if we decide to do it in pulp2, we need to set a tag on the issue
14:32:39 <pulpbot> asmacdo: No issues to triage.
14:32:48 <asmacdo> ttereshc: sorry, do you want to go back
14:32:49 <ttereshc> the tag :)
14:32:52 <ttereshc> no
14:32:53 <mikedep333> #info mikedep333 has joined triage
14:32:53 <mikedep333> !here
14:32:53 <pulpbot> mikedep333: mikedep333 has joined triage
14:32:53 <dkliban> ttereshc: i agree
14:33:05 <dkliban> ttereshc: but i was hoping we could discuss this here during open floor
14:33:08 <ttereshc> asmacdo, just reminding so more people remember about it
14:33:15 <asmacdo> there is a pulp2 tag on the issue already
14:33:23 <ttereshc> dkliban, sure let's do it
14:33:27 <ttereshc> asmacdo, ah thanks
14:33:44 <dkliban> yeah ... i put a couple of tags on it when i filed it
14:33:47 <dawalker> #info dawalker has joined triage
14:33:47 <dawalker> !here
14:33:47 <pulpbot> dawalker: dawalker has joined triage
14:34:03 <asmacdo> open floor. whats the topic dkliban?
14:34:17 <dkliban> do we want to change how Pulp 3 publishes metadata?
14:34:34 <dkliban> right now pulp_file publishes the PULP_MANIFEST file to /var/lib/pulp/published/
14:35:00 <dkliban> however, i think it should just be stored in /var/lib/pulp/artifacts/
14:35:37 <asmacdo> oh yeah. where a file lives has nothing to do with whether or not its published in pulp3
14:35:38 <dkliban> i am not sure what benefit is derived from keeping files generated during a publish in /var/lib/pulp/published/
14:36:02 <ttereshc> I'm +1 to store metadata somewhere outside of pulp2 location
14:36:34 <ttereshc> I don't know if it's good not to track metadata separately
14:36:53 <dkliban> i don't think it does
14:37:01 <bmbouter> #info bmbouter has joined triage
14:37:01 <bmbouter> !here
14:37:02 <pulpbot> bmbouter: bmbouter has joined triage
14:37:32 <ttereshc> dkliban, what about orphan clean up? if we add metadata file to the artifact storage, will those be removed?
14:37:32 <dkliban> ttereshc: do you know where pulp_rpm publishes the metadata files?
14:37:56 <ttereshc> dkliban, yes, within a published repo
14:37:58 <dkliban> idon't think so. those files still belong to a publication
14:38:11 <dalley> #info dalley has joined triage
14:38:11 <dalley> !here
14:38:11 <pulpbot> dalley: dalley has joined triage
14:38:25 <dkliban> ttereshc: where is that? is that in /var/lib/pulp/published?
14:38:48 <ttereshc> yes
14:39:49 <ttereshc> here /var/lib/pulp/published/https/isos/file-many/PULP_MANIFEST
14:39:56 <ttereshc> as an example
14:40:07 <ttereshc> file-many is a repo name
14:40:27 <ttereshc> it's not a symlink like content
14:40:53 <ttereshc> metadata is a part of a repo and not de-duplicated in any way
14:40:56 <dkliban> this is pulp 2
14:41:00 <ttereshc> yes
14:41:05 <dkliban> i am talking about pulp 3 right now
14:41:08 <asmacdo> pulp3 https://github.com/pulp/pulpcore/blob/ae6be0d89c5df26ac1cfdc876f3b131aa6e9bcf8/pulpcore/app/models/storage.py#L130
14:41:09 <ttereshc> oh
14:41:15 <ttereshc> I'm mixing those up today
14:41:38 <dkliban> asmacdo: thank you
14:41:45 <asmacdo> what do you think of namespacing this?
14:41:55 <asmacdo> to avoid this problem with pulp4?
14:42:15 <dkliban> asmacdo: what is the benefit of putting these in /var/lib/pulp/published/ vs /var/lib/pulp/artifact/
14:42:17 <dkliban> ?
14:42:33 <asmacdo> dkliban: i dont see one
14:43:05 <dkliban> yeah ... so i think we should get rid of this in pulp 3 and simply create the files in /var/lib/pulp/artifact/
14:43:21 <ttereshc> the name of directory is a bit confusing then
14:43:29 <dkliban> which name?
14:43:41 <ttereshc> right now it has a direct correlation with Artifact model
14:44:21 <ttereshc> dkliban,  this one /var/lib/pulp/artifact/
14:44:40 <ttereshc> I understand that any file can be called an artifact
14:44:57 <dkliban> every file in Pulp 3 is an artifact
14:45:28 <ttereshc> ok, doesn't matter
14:45:44 <ttereshc> I can't explain myself today :)
14:46:20 <asmacdo> i guess we are done with this one? anyone else got a topic?
14:46:23 <dkliban> i am going to comment on the issue
14:46:31 <dkliban> not from me
14:47:29 <asmacdo> #endmeeting
14:47:29 <asmacdo> !end