14:30:09 <asmacdo> #startmeeting Pulp Triage 2019-09-03
14:30:09 <asmacdo> #info asmacdo has joined triage
14:30:09 <asmacdo> !start
14:30:09 <pulpbot> Meeting started Tue Sep  3 14:30:09 2019 UTC.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:09 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:09 <pulpbot> The meeting name has been set to 'pulp_triage_2019-09-03'
14:30:09 <pulpbot> asmacdo: asmacdo has joined triage
14:30:15 <bmbouter> #info bmbouter has joined triage
14:30:15 <bmbouter> !here
14:30:15 <pulpbot> bmbouter: bmbouter has joined triage
14:30:15 <daviddavis> #info daviddavis has joined triage
14:30:15 <daviddavis> !here
14:30:17 <pulpbot> daviddavis: daviddavis has joined triage
14:30:18 <asmacdo> !next
14:30:19 <asmacdo> #topic https://pulp.plan.io/issues/5384
14:30:19 <pulpbot> asmacdo: 3 issues left to triage: 5384, 5383, 5378
14:30:20 <pulpbot> RM 5384 - jaymzh - NEW - from-source docs for pulpcore3 don't mention DJANGO_SETTINGS_MODULE=pulpcore.app.settings
14:30:21 <pulpbot> https://pulp.plan.io/issues/5384
14:30:33 <asmacdo> #idea Proposed for #5384: accept and add to sprint
14:30:33 <asmacdo> !propose other accept and add to sprint
14:30:33 <pulpbot> asmacdo: Proposed for #5384: accept and add to sprint
14:30:35 <bmbouter> +1
14:30:38 <daviddavis> +1
14:30:59 <asmacdo> #agreed accept and add to sprint
14:30:59 <asmacdo> !accept
14:31:00 <pulpbot> asmacdo: Current proposal accepted: accept and add to sprint
14:31:00 <asmacdo> #topic https://pulp.plan.io/issues/5383
14:31:01 <pulpbot> asmacdo: 2 issues left to triage: 5383, 5378
14:31:02 <pulpbot> RM 5383 - jaymzh - NEW - please allow double-slashes
14:31:03 <ppicka> #info ppicka has joined triage
14:31:03 <ppicka> !here
14:31:04 <pulpbot> https://pulp.plan.io/issues/5383
14:31:05 <pulpbot> ppicka: ppicka has joined triage
14:31:29 <dkliban> i am not sure if django supports this
14:32:01 <bmbouter> it could if drf's router's allowed it maybe
14:32:17 <dkliban> we should look into this ... but for now let's just accept
14:32:23 <dkliban> !other propose accept
14:32:23 <pulpbot> dkliban: Error: "other" is not a valid command.
14:32:23 <bmbouter> agreed, not ready for sprint
14:32:27 <asmacdo> assuming that we could configure drf to do this (im not sure it would be simple) i dont think there is a reason to do this
14:33:09 <asmacdo> seems to me to be work that allows 0 use cases. i think we ought to close
14:33:13 <daviddavis> probably not an issue but a story or task
14:33:41 <daviddavis> closing is fine with me
14:34:02 <asmacdo> bmbouter, dkliban?
14:34:21 <bmbouter> I'd rather ask him why he wants it than to close right now
14:34:30 <dkliban> +1
14:34:31 <bmbouter> I don't understand why he wants it
14:34:31 <asmacdo> +1
14:34:40 <mikedep333> #info mikedep333 has joined triage
14:34:40 <mikedep333> !here
14:34:40 <pulpbot> mikedep333: mikedep333 has joined triage
14:34:44 <asmacdo> #idea Proposed for #5383: skip and comment asking for use case
14:34:44 <asmacdo> !propose other skip and comment asking for use case
14:34:44 <pulpbot> asmacdo: Proposed for #5383: skip and comment asking for use case
14:34:44 <daviddavis> I know why he wants it
14:35:00 <daviddavis> it's because he's probably copying the server url + the href he gets back from our api
14:35:26 <bmbouter> yup that does make sense
14:35:28 <asmacdo> ah
14:35:44 <asmacdo> that is slightly awkward
14:36:17 <asmacdo> so, accept or skip?
14:36:41 <dkliban> let's accept
14:36:51 <daviddavis> maybe convert it to a story too
14:37:01 <dkliban> ok ... i'll convert to a story
14:37:13 <asmacdo> #idea Proposed for #5383: dkliban will accept and convert to story
14:37:13 <asmacdo> !propose other dkliban will accept and convert to story
14:37:13 <pulpbot> asmacdo: Proposed for #5383: dkliban will accept and convert to story
14:37:21 <asmacdo> #agreed dkliban will accept and convert to story
14:37:21 <asmacdo> !accept
14:37:21 <pulpbot> asmacdo: Current proposal accepted: dkliban will accept and convert to story
14:37:22 <asmacdo> #topic https://pulp.plan.io/issues/5378
14:37:23 <pulpbot> asmacdo: 1 issues left to triage: 5378
14:37:24 <pulpbot> RM 5378 - jaymzh - NEW - Index pages on content server
14:37:25 <pulpbot> https://pulp.plan.io/issues/5378
14:37:33 <daviddavis> did we do this in pulp 2?
14:38:21 <dkliban> this is 2 issues in 1
14:38:33 <dkliban> we do list directories in pulp 2
14:38:55 <dkliban> but we don't serve any special index pages that say that pulp is running
14:39:47 <daviddavis> maybe split into two stories?
14:40:03 <asmacdo> v3/status/ is what they were looking for-- maybe we should add that to the install docs
14:40:28 <dkliban> daviddavis: we have a ticket for the listing of directories in the content app
14:40:57 <dkliban> asmacdo: no ... not v3/status ... he wants to actually ping the content app and see it return something
14:41:28 <asmacdo> ack
14:42:18 <asmacdo> first bullet seems reasonable then.
14:43:09 <asmacdo> dkliban: does the ticket you are talking about cover the second bullet?
14:43:14 <bmbouter> this is a common user desire I think
14:43:30 <dkliban> yeah
14:43:32 <bmbouter> even the second one moreso than the first (to me)
14:43:36 <dkliban> it does ... i'll add it as related
14:43:40 <dkliban> yep
14:43:49 <daviddavis> great
14:44:21 <bmbouter> users want to browse content like a normal webserver and the only reason they can't is because pulp doesn't use filesystem layouts
14:44:43 <daviddavis> yea, we'll have to think of a good way to do this
14:44:45 <bmbouter> but users don't know that and so pulp seems frustrating in this aspect
14:44:50 <mikedep333> as a Satellite/Katello SysAdmin at my last job, I loved the index pages.
14:45:01 <daviddavis> the problem I foresee is how to generate them quickly
14:45:06 <daviddavis> maybe cache them somehow
14:45:06 <mikedep333> Including the fact that I could browse the available versions with it and compare them.
14:45:19 <dkliban> daviddavis: definitely cache them
14:45:38 <bmbouter> or put varnish in fron tof pulp-content (we don't have to write a caching feature necessarily)
14:45:38 <mikedep333> daviddavis: Personally, I didn't use them all the time, so speed was not a strict requirement. But the cache would still be appreciated.
14:46:35 <bmbouter> I'd like to write on the stories some whatever issue numers these become can someone link me to them
14:47:14 <dkliban> ok ... i'll post them here bmbouter
14:47:17 <dkliban> later
14:47:27 <bmbouter> ty, drop my nick on it if you can
14:47:33 <dkliban> will do
14:48:08 <asmacdo> in the meantime, skip to make sure this gets organized properly before next triage?
14:48:31 <bmbouter> +1 skip
14:48:36 <asmacdo> #idea Proposed for #5378: Skip this issue for this triage session.
14:48:36 <asmacdo> !propose skip
14:48:36 <pulpbot> asmacdo: Proposed for #5378: Skip this issue for this triage session.
14:49:33 <asmacdo> !skip
14:49:34 <pulpbot> asmacdo: 1 issues left to triage: 5392
14:49:34 <asmacdo> #topic https://pulp.plan.io/issues/5392
14:49:35 <pulpbot> RM 5392 - ppicka - NEW - Sync stages documentation mentions artifactsave twice
14:49:36 <pulpbot> https://pulp.plan.io/issues/5392
14:49:51 <asmacdo> #idea Proposed for #5392: accept, add to sprint, +easyfix
14:49:51 <asmacdo> !propose other accept, add to sprint, +easyfix
14:49:51 <pulpbot> asmacdo: Proposed for #5392: accept, add to sprint, +easyfix
14:50:09 <ppicka> it has easy fix even docs
14:50:12 <daviddavis> +1
14:50:14 <bmbouter> +1
14:50:18 <dalley> +1
14:50:23 <asmacdo> #agreed accept, add to sprint, +easyfix
14:50:23 <asmacdo> !accept
14:50:23 <pulpbot> asmacdo: Current proposal accepted: accept, add to sprint, +easyfix
14:50:24 <pulpbot> asmacdo: No issues to triage.
14:50:37 <asmacdo> anyone have a topic for open floor?
14:51:07 <mikedep333> How is the container CI working for pulpcore & pulp_rpm?
14:51:09 <bmbouter> FYI: today is the breaking change in the installer to stop "makemigrations"
14:51:19 <mikedep333> I've been looking at PRs for any Travis failures due to it.
14:51:38 <daviddavis> bmbouter: is there a PR open for that
14:51:49 <bmbouter> not yet but one needs to be made
14:53:10 <asmacdo> mikedep333: i guess if nobody noticed a problem its working well?
14:53:19 <mikedep333> :)
14:53:31 <bmbouter> yup, that was my conclusion too
14:53:46 <mikedep333> I'm also concerned about performance too.
14:54:02 <mikedep333> I have made some performance improvements lately. More to come.
14:54:20 <daviddavis> great
14:54:37 <bmbouter> excellentay
14:54:59 <asmacdo> i've got one: if anyone is interested in driving triage lmk
14:55:12 <asmacdo> any other topics?
14:55:38 <asmacdo> #endmeeting