14:30:28 <fabricioo0> #startmeeting Pulp Triage 2019-09-17
14:30:28 <fabricioo0> !start
14:30:28 <fabricioo0> #info fabricioo0 has joined triage
14:30:28 <pulpbot> Meeting started Tue Sep 17 14:30:28 2019 UTC.  The chair is fabricioo0. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:28 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:28 <pulpbot> The meeting name has been set to 'pulp_triage_2019-09-17'
14:30:28 <pulpbot> fabricioo0: fabricioo0 has joined triage
14:30:32 <asmacdo> #info asmacdo has joined triage
14:30:32 <asmacdo> !here
14:30:33 <pulpbot> asmacdo: asmacdo has joined triage
14:30:36 <misa> asmacdo: dkliban: for pulp 2, is there a script somewhere that would let me remove all content from mongo, but not users?
14:30:56 <daviddavis> #info daviddavis has joined triage
14:30:56 <daviddavis> !here
14:30:56 <pulpbot> daviddavis: daviddavis has joined triage
14:31:14 <misa> asmacdo: trying to reset an instance but would like to not lose the auth info
14:31:18 <dkliban> #info dkliban has joined triage
14:31:18 <dkliban> !here
14:31:18 <pulpbot> dkliban: dkliban has joined triage
14:31:21 <fabricioo0> !next
14:31:22 <fabricioo0> #topic https://pulp.plan.io/issues/5451
14:31:22 <pulpbot> fabricioo0: 1 issues left to triage: 5451
14:31:22 <asmacdo> misa: im not aware of one.
14:31:23 <pulpbot> RM 5451 - lbausch - NEW - openapi-generator: attribute info.logo is unexpected
14:31:24 <pulpbot> https://pulp.plan.io/issues/5451
14:31:55 <asmacdo> whatever we do, lets delete the spam comment
14:31:58 <daviddavis> done
14:32:12 <ttereshc> #info ttereshc has joined triage
14:32:12 <ttereshc> !here
14:32:12 <pulpbot> ttereshc: ttereshc has joined triage
14:32:17 <dawalker> #info dawalker has joined triage
14:32:17 <dawalker> !here
14:32:17 <pulpbot> dawalker: dawalker has joined triage
14:32:17 <dkliban> let's accept the issue
14:32:18 <ppicka> #info ppicka has joined triage
14:32:18 <ppicka> !here
14:32:19 <pulpbot> ppicka: ppicka has joined triage
14:32:21 <daviddavis> +1
14:32:29 <dkliban> i don't think we are going to fix this, but i want to keep it open for now
14:32:34 <fabricioo0> #idea Proposed for #5451: accept the issue
14:32:34 <fabricioo0> !propose other accept the issue
14:32:34 <pulpbot> fabricioo0: Proposed for #5451: accept the issue
14:32:43 <dkliban> +1
14:32:47 <ttereshc> +1
14:32:50 <asmacdo> +1
14:32:50 <dalley> #info dalley has joined triage
14:32:50 <dalley> !here
14:32:50 <pulpbot> dalley: dalley has joined triage
14:33:02 <fabricioo0> #agreed accept the issue
14:33:02 <fabricioo0> !accept
14:33:02 <pulpbot> fabricioo0: Current proposal accepted: accept the issue
14:33:03 <pulpbot> fabricioo0: No issues to triage.
14:33:07 <ttereshc> fabricioo0, there is just !propose accept :), jfyi
14:33:19 <fabricioo0> thanks
14:33:26 <fabricioo0> Open floor!
14:33:33 <daviddavis> !propose accept
14:33:33 <pulpbot> daviddavis: Error: No current issue, proposal ignored.
14:33:37 <daviddavis> oh
14:33:42 <bmbouter> #info bmbouter has joined triage
14:33:42 <bmbouter> !here
14:33:42 <pulpbot> bmbouter: bmbouter has joined triage
14:33:45 <daviddavis> I have an issue
14:33:47 <daviddavis> 5403
14:33:52 <bmbouter> I also 5444
14:34:01 <ttereshc> fight
14:34:04 <dkliban> lol
14:34:06 * bmbouter runs away
14:34:07 <dkliban> LOL
14:34:08 <fabricioo0> !issue 5403
14:34:08 <fabricioo0> #topic https://pulp.plan.io/issues/5403
14:34:09 <pulpbot> RM 5403 - bmbouter - NEW - As a plugin writer, I have a Serializer I can use for Content creation via upload that accepts either file or an existing Artifact but not both
14:34:10 <pulpbot> https://pulp.plan.io/issues/5403
14:34:16 <mikedep333> #info mikedep333 has joined triage
14:34:16 <mikedep333> !here
14:34:16 <pulpbot> mikedep333: mikedep333 has joined triage
14:34:20 <daviddavis> I'd like to get this and its subissues on the sprint
14:34:30 <bmbouter> I agree, I share that goal
14:34:30 <dkliban> what do we need to finish discussing on this?
14:34:48 <daviddavis> did we need a follow up from dalley ?
14:34:54 <dalley> no
14:34:56 <fabricioo0> #idea Proposed for #5403: add this and its issues to the sprint
14:34:56 <fabricioo0> !propose other add this and its issues to the sprint
14:34:56 <pulpbot> fabricioo0: Proposed for #5403: add this and its issues to the sprint
14:35:02 <dalley> I think it just needs to be groomed
14:35:13 <dalley> discussion folded back into the description
14:35:20 <bmbouter> there are some details on the PR but I think we could handle those there (if you agree)
14:35:27 <daviddavis> ok great, mind if I groom it and it to the sprint?
14:35:33 <dkliban> don't mind at all
14:35:38 <dkliban> anyone else mind?
14:35:49 <daviddavis> *crickets*
14:35:52 <dkliban> sweet
14:35:57 <fabricioo0> #agreed add this and its issues to the sprint
14:35:57 <fabricioo0> !accept
14:35:57 <pulpbot> fabricioo0: Current proposal accepted: add this and its issues to the sprint
14:35:58 <pulpbot> fabricioo0: No issues to triage.
14:36:07 <fabricioo0> !issue 5444
14:36:07 <fabricioo0> #topic https://pulp.plan.io/issues/5444
14:36:08 <pulpbot> RM 5444 - bmbouter - NEW - Consolidate ProgressReporting into a single model so it's simpler for plugin writers
14:36:09 <pulpbot> https://pulp.plan.io/issues/5444
14:37:01 <dkliban> yes, let's add this to the sprint also ... i think fabricio has even started on some of this
14:37:06 <bmbouter> there is a PR almost halfway doing this already
14:37:22 <dawalker> +1
14:37:26 <daviddavis> just out of curiousity, how painful will this be for plugin writers
14:37:30 <daviddavis> this is backwards incompatible?
14:37:35 <fabricioo0> #idea Proposed for #5444: add to the sprint
14:37:35 <fabricioo0> !propose other add to the sprint
14:37:35 <pulpbot> fabricioo0: Proposed for #5444: add to the sprint
14:37:35 <ttereshc> was there a reason to create 3 models initially?
14:37:46 <bmbouter> it is backwards incompatible
14:37:51 <ttereshc> I mean we choose to have multiple models for some reason
14:37:54 <dkliban> ttereshc: not really ... over planning
14:37:58 <bmbouter> yup over planning
14:37:58 <daviddavis> we like lots of models
14:38:09 <bmbouter> I implemented this area originally 3+ years ago
14:38:24 <asmacdo> i remember an exciting pulpcon presentation
14:38:39 <ttereshc> daviddavis, we like lots of repos as well :) so merge everything into one repo
14:38:43 <bmbouter> all of the plugins use 1 of the 3, so we should just make it as simple for them as it is in the db
14:39:01 <bmbouter> I hope fabricio could also make PRs against all the plugins too
14:39:12 <ttereshc> no objections
14:39:23 <ttereshc> just wanted to know the original reasons
14:40:08 <fabricioo0> plugins don't use progressspinner, so I think I won't need to create PRs for them
14:40:25 <fabricioo0> #agreed add to the sprint
14:40:25 <fabricioo0> !accept
14:40:25 <pulpbot> fabricioo0: Current proposal accepted: add to the sprint
14:40:26 <pulpbot> fabricioo0: No issues to triage.
14:41:12 <fabricioo0> Open floor!
14:42:09 <bmbouter> fabricioo0: the model surviving would be called ProgressReport and that is not the one used by eveyrone (in name)
14:42:25 <fabricioo0> oh, I see!
14:42:53 <fabricioo0> no more issues?
14:44:01 <asmacdo> none from me
14:44:02 <ttereshc> bulgarian noding
14:44:08 <fabricioo0> #endmeeting