14:30:19 <fabricioo0> #startmeeting Pulp Triage 2019-09-20
14:30:19 <fabricioo0> !start
14:30:19 <fabricioo0> #info fabricioo0 has joined triage
14:30:19 <pulpbot> Meeting started Fri Sep 20 14:30:19 2019 UTC.  The chair is fabricioo0. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:19 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:19 <pulpbot> The meeting name has been set to 'pulp_triage_2019-09-20'
14:30:19 <pulpbot> fabricioo0: fabricioo0 has joined triage
14:30:28 <dkliban> #info dkliban has joined triage
14:30:28 <dkliban> !here
14:30:28 <pulpbot> dkliban: dkliban has joined triage
14:31:15 <fabricioo0> !next
14:31:16 <pulpbot> fabricioo0: 4 issues left to triage: 5485, 5484, 5474, 5456
14:31:16 <fabricioo0> #topic https://pulp.plan.io/issues/5485
14:31:17 <pulpbot> RM 5485 - ipanova@redhat.com - NEW - Migration plugin should filter only those repo types that belong to the plugin that is being migrated
14:31:18 <pulpbot> https://pulp.plan.io/issues/5485
14:31:23 <daviddavis> #info daviddavis has joined triage
14:31:23 <daviddavis> !here
14:31:23 <pulpbot> daviddavis: daviddavis has joined triage
14:31:50 <ipanova> #info ipanova has joined triage
14:31:50 <ipanova> !here
14:31:51 <pulpbot> ipanova: ipanova has joined triage
14:32:04 <dalley> #info dalley has joined triage
14:32:04 <dalley> !here
14:32:04 <pulpbot> dalley: dalley has joined triage
14:32:11 <bmbouter> #info bmbouter has joined triage
14:32:11 <bmbouter> !here
14:32:12 <pulpbot> bmbouter: bmbouter has joined triage
14:32:12 <ipanova> we should accept it
14:32:21 <bmbouter> +1
14:32:26 <dkliban> +1
14:32:26 <fabricioo0> #idea Proposed for #5485: Leave the issue as-is, accepting its current state.
14:32:26 <fabricioo0> !propose accept
14:32:26 <pulpbot> fabricioo0: Proposed for #5485: Leave the issue as-is, accepting its current state.
14:32:41 <mikedep333> #info mikedep333 has joined triage
14:32:41 <mikedep333> !here
14:32:41 <pulpbot> mikedep333: mikedep333 has joined triage
14:32:56 <fabricioo0> #agreed Leave the issue as-is, accepting its current state.
14:32:56 <fabricioo0> !accept
14:32:56 <pulpbot> fabricioo0: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:32:57 <fabricioo0> #topic https://pulp.plan.io/issues/5484
14:32:57 <pulpbot> fabricioo0: 3 issues left to triage: 5484, 5474, 5456
14:32:58 <pulpbot> RM 5484 - mdellweg - NEW - plugin templates bootstrap section contains publisher code
14:32:59 <pulpbot> https://pulp.plan.io/issues/5484
14:33:09 <dkliban> we should also accept
14:33:12 <daviddavis> +1
14:33:18 <fabricioo0> #idea Proposed for #5484: Leave the issue as-is, accepting its current state.
14:33:18 <fabricioo0> !propose accept
14:33:18 <pulpbot> fabricioo0: Proposed for #5484: Leave the issue as-is, accepting its current state.
14:33:33 <ttereshc> #info ttereshc has joined triage
14:33:33 <ttereshc> !here
14:33:33 <pulpbot> ttereshc: ttereshc has joined triage
14:34:03 <ttereshc> +1
14:34:05 <ipanova> +1
14:34:05 <fabricioo0> #agreed Leave the issue as-is, accepting its current state.
14:34:05 <fabricioo0> !accept
14:34:05 <pulpbot> fabricioo0: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:34:06 <pulpbot> fabricioo0: 2 issues left to triage: 5474, 5456
14:34:07 <fabricioo0> #topic https://pulp.plan.io/issues/5474
14:34:07 <pulpbot> RM 5474 - bmbouter - POST - For all processes launched by systemd ensure the PATH includes the virtualenv if installed in a virtualenv
14:34:09 <pulpbot> https://pulp.plan.io/issues/5474
14:34:38 <dkliban> thi sis already in POST
14:34:41 <dkliban> let's accept
14:34:54 <ipanova> agreed
14:34:54 <ttereshc> +1
14:34:55 <bmbouter> this POST is waiting on the installer CI to merge (it was an ansiblefest blocker)
14:35:07 <fabricioo0> #idea Proposed for #5474: Leave the issue as-is, accepting its current state.
14:35:07 <fabricioo0> !propose accept
14:35:07 <pulpbot> fabricioo0: Proposed for #5474: Leave the issue as-is, accepting its current state.
14:35:12 <fabricioo0> #agreed Leave the issue as-is, accepting its current state.
14:35:12 <fabricioo0> !accept
14:35:13 <fabricioo0> #topic https://pulp.plan.io/issues/5456
14:35:13 <pulpbot> fabricioo0: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:35:13 <mikedep333> bmbouter: I agree. We just need to figure out how to properly set it. I left a comment.
14:35:14 <pulpbot> fabricioo0: 1 issues left to triage: 5456
14:35:15 <pulpbot> RM 5456 - mdellweg - NEW - The current CI implementation makes it hard to discuss small changes to a bigger PR
14:35:16 <pulpbot> https://pulp.plan.io/issues/5456
14:35:17 <mikedep333> +1
14:36:00 <daviddavis> for this one, are we talking about not failing fast?
14:36:12 <mikedep333> I agree with mdellweg, but all those later squashed commits I address by just adding [noissue].
14:36:15 <daviddavis> or running the commit validation as a separate job (it says "separate test")
14:36:17 <dkliban> x9c4: ^
14:36:29 <mikedep333> In fact, I often put [noissue] on all my commits, then put the issue # when I squash.
14:36:44 <mikedep333> daviddavis: That's a good idea.
14:36:56 <mikedep333> The overall test suite would show up as failed, but the individual tests would work.
14:37:16 <fabricioo0> from the issue: "If commit message validation was extracted as a separate test, one could use for example the git commit --fixup aabbccdd"
14:37:20 <daviddavis> if we turn off failing fast, then we could still see the test results
14:37:48 <bmbouter> daviddavis: that's a good idea
14:37:58 <daviddavis> that would be easy but it would tax our resources
14:38:03 <bmbouter> want to comment on the issue w/ that workaround
14:38:27 <bmbouter> he mentioned it on chat and I asked him to file
14:38:33 <daviddavis> ok
14:39:08 <daviddavis> I'm more worried ATM about our resources in Travis and any solution to this issue would add to that problem
14:39:43 <bmbouter> let's send to parking log for now
14:39:54 <bmbouter> backlog I guess is the right term for that
14:39:59 <dkliban> yep
14:40:13 <daviddavis> I propose we accept and I'll comment
14:40:17 <dkliban> +1
14:40:25 <fabricioo0> #idea Proposed for #5456: Leave the issue as-is, accepting its current state.
14:40:25 <fabricioo0> !propose accept
14:40:25 <pulpbot> fabricioo0: Proposed for #5456: Leave the issue as-is, accepting its current state.
14:41:13 <fabricioo0> #idea Proposed for #5456: accept and daviddavis comments on this
14:41:13 <fabricioo0> !propose other accept and daviddavis comments on this
14:41:14 <pulpbot> fabricioo0: Proposed for #5456: accept and daviddavis comments on this
14:41:25 <dkliban> +1
14:41:48 <bmbouter> +1
14:41:51 <fabricioo0> #agreed accept and daviddavis comments on this
14:41:51 <fabricioo0> !accept
14:41:51 <pulpbot> fabricioo0: Current proposal accepted: accept and daviddavis comments on this
14:41:53 <pulpbot> fabricioo0: No issues to triage.
14:42:05 <fabricioo0> Open floor!
14:42:26 <bmbouter> dalley: can you tell me more about the migration squashing?
14:44:10 <fabricioo0> any issues?
14:45:10 <fabricioo0> #endmeeting
14:45:10 <fabricioo0> !end