14:30:08 <fabricioo0> #startmeeting Pulp Triage 2019-09-27
14:30:08 <fabricioo0> !start
14:30:08 <fabricioo0> #info fabricioo0 has joined triage
14:30:08 <pulpbot> Meeting started Fri Sep 27 14:30:08 2019 UTC.  The chair is fabricioo0. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:08 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:08 <pulpbot> The meeting name has been set to 'pulp_triage_2019-09-27'
14:30:08 <pulpbot> fabricioo0: fabricioo0 has joined triage
14:30:31 <daviddavis> #info daviddavis has joined triage
14:30:31 <daviddavis> !here
14:30:31 <pulpbot> daviddavis: daviddavis has joined triage
14:31:07 <fabricioo0> !next
14:31:08 <fabricioo0> #topic https://pulp.plan.io/issues/5510
14:31:08 <pulpbot> fabricioo0: 3 issues left to triage: 5510, 5507, 5502
14:31:09 <pulpbot> RM 5510 - Skullman - NEW - I would like to have an option to associate key-value pair to repository - former "Notes" field in Pulp 2
14:31:10 <pulpbot> https://pulp.plan.io/issues/5510
14:31:10 <bmbouter> #info bmbouter has joined triage
14:31:10 <bmbouter> !here
14:31:11 <pulpbot> bmbouter: bmbouter has joined triage
14:31:17 <dkliban> #info dkliban has joined triage
14:31:17 <dkliban> !here
14:31:17 <pulpbot> dkliban: dkliban has joined triage
14:31:33 <dkliban> this is a story
14:31:51 <fabricioo0> #idea Proposed for #5510: change to story
14:31:51 <fabricioo0> !propose other change to story
14:31:51 <pulpbot> fabricioo0: Proposed for #5510: change to story
14:31:56 <bmbouter> we also need to remove 3.0
14:32:02 <daviddavis> +1
14:32:04 <dkliban> +1
14:32:16 <fabricioo0> #idea Proposed for #5510: change to story and remove 3.0
14:32:16 <fabricioo0> !propose other change to story and remove 3.0
14:32:16 <pulpbot> fabricioo0: Proposed for #5510: change to story and remove 3.0
14:32:24 <fabricioo0> #agreed change to story and remove 3.0
14:32:24 <fabricioo0> !accept
14:32:24 <pulpbot> fabricioo0: Current proposal accepted: change to story and remove 3.0
14:32:25 <pulpbot> fabricioo0: 2 issues left to triage: 5507, 5502
14:32:25 <fabricioo0> #topic https://pulp.plan.io/issues/5507
14:32:26 <pulpbot> RM 5507 - dkliban@redhat.com - NEW - content-app always sets Content-Type header to 'application/octet-stream'
14:32:27 <bmbouter> does rpm want to do this in its plugin "first"?
14:32:28 <pulpbot> https://pulp.plan.io/issues/5507
14:32:40 <dkliban> accept
14:32:49 <dkliban> it's already in POST ... should be at least
14:32:51 <daviddavis> bmbouter: sure, or pulp_file
14:32:52 <dkliban> i'll update it
14:33:48 <dkliban> fabricioo0: i updated this issue ... we can go to the next
14:33:56 <dkliban> #idea Proposed for #5507: Leave the issue as-is, accepting its current state.
14:33:56 <dkliban> !propose accept
14:33:56 <pulpbot> dkliban: Proposed for #5507: Leave the issue as-is, accepting its current state.
14:34:13 <ggainey> #info ggainey has joined triage
14:34:13 <ggainey> !here
14:34:13 <pulpbot> ggainey: ggainey has joined triage
14:35:04 <dkliban> fabricioo0_: i updated the issue and it's ready to be accepted
14:35:15 <fabricioo0_> I had some connectivity issue
14:35:37 <fabricioo0_> #idea Proposed for #5507: Leave the issue as-is, accepting its current state.
14:35:37 <fabricioo0_> #info fabricioo0_ has joined triage
14:35:37 <fabricioo0_> !propose accept
14:35:37 <pulpbot> fabricioo0_: fabricioo0_ has joined triage
14:35:38 <pulpbot> fabricioo0_: Proposed for #5507: Leave the issue as-is, accepting its current state.
14:36:36 <fabricioo0> #idea Proposed for #5507: Leave the issue as-is, accepting its current state.
14:36:36 <fabricioo0> !propose accept
14:36:36 <pulpbot> fabricioo0: Proposed for #5507: Leave the issue as-is, accepting its current state.
14:36:46 <fabricioo0> #agreed Leave the issue as-is, accepting its current state.
14:36:46 <fabricioo0> !accept
14:36:46 <pulpbot> fabricioo0: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:36:46 <fabricioo0> #topic https://pulp.plan.io/issues/5502
14:36:47 <pulpbot> fabricioo0: 1 issues left to triage: 5502
14:36:48 <pulpbot> RM 5502 - mihai.ibanescu@gmail.com - NEW - worker fails to mark a task as failed when critical conditions are encountered
14:36:49 <pulpbot> https://pulp.plan.io/issues/5502
14:37:23 <bmbouter> this needs Pulp 2 label
14:37:29 <ggainey> yeah
14:37:37 <dkliban> yeah ... and we should accept
14:37:41 <daviddavis> +1
14:37:43 <ggainey> concur
14:37:52 <bmbouter> can we ask him for a patch... maybe?
14:38:02 <daviddavis> yea, if not we should maybe close out
14:38:07 <fabricioo0> #idea Proposed for #5502: add pulp2 label and accept
14:38:07 <fabricioo0> !propose other add pulp2 label and accept
14:38:07 <pulpbot> fabricioo0: Proposed for #5502: add pulp2 label and accept
14:38:25 <dkliban> bmbouter: we can always aask
14:39:42 <fabricioo0> #agreed add pulp2 label and accept
14:39:42 <fabricioo0> !accept
14:39:42 <pulpbot> fabricioo0: Current proposal accepted: add pulp2 label and accept
14:39:43 <pulpbot> fabricioo0: No issues to triage.
14:39:51 <fabricioo0> Open floor!
14:40:06 <daviddavis> I got one
14:40:11 <daviddavis> https://pulp.plan.io/issues/5509
14:40:42 <fabricioo0> !issue 5509
14:40:43 <fabricioo0> #topic https://pulp.plan.io/issues/5509
14:40:43 <pulpbot> RM 5509 - daviddavis - NEW - Can't sync with 3.0.0b5 release of pulp_rpm
14:40:44 <pulpbot> https://pulp.plan.io/issues/5509
14:41:45 <daviddavis> I think we should release a new core
14:41:52 <dkliban> yes
14:41:56 <daviddavis> that will mean releasing new plugins too
14:41:57 <dkliban> let's release a new core
14:42:17 <daviddavis> I can work on it monday unless someone has time today
14:42:29 <daviddavis> bmbouter: any objection?
14:43:18 <dawalker> #info dawalker has joined triage
14:43:18 <dawalker> !here
14:43:18 <pulpbot> dawalker: dawalker has joined triage
14:43:21 <fabricioo0> #idea Proposed for #5509: Leave the issue as-is, accepting its current state.
14:43:21 <fabricioo0> !propose accept
14:43:21 <pulpbot> fabricioo0: Proposed for #5509: Leave the issue as-is, accepting its current state.
14:44:07 <daviddavis> #idea Proposed for #5509: accept and add to sprint
14:44:07 <daviddavis> !propose other accept and add to sprint
14:44:08 <pulpbot> daviddavis: Proposed for #5509: accept and add to sprint
14:44:27 <daviddavis> well bmbouter can object when he gets back
14:44:28 <fabricioo0> #agreed accept and add to sprint
14:44:28 <fabricioo0> !accept
14:44:28 <pulpbot> fabricioo0: Current proposal accepted: accept and add to sprint
14:44:29 <pulpbot> fabricioo0: No issues to triage.
14:44:47 <bmbouter> sorry back
14:44:55 <bmbouter> +1
14:45:08 <fabricioo0> Open floor!
14:46:34 <bmbouter> daviddavis: we doing core issue stuff here?
14:47:10 <daviddavis> bmbouter: sure
14:48:57 <bmbouter> here's one https://pulp.plan.io/issues/5442
14:49:07 <bmbouter> Replace pulpcore.plugin.models Task with the actual Task from pulpcore
14:49:12 <fabricioo0> !issue 5442
14:49:12 <fabricioo0> #topic https://pulp.plan.io/issues/5442
14:49:13 <pulpbot> RM 5442 - bmbouter - NEW - Replace pulpcore.plugin.models Task with the actual Task from pulpcore
14:49:14 <pulpbot> https://pulp.plan.io/issues/5442
14:49:17 <bmbouter> !friday
14:49:17 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
14:49:21 <daviddavis> lgtm
14:49:26 <daviddavis> let's accept + add to sprint
14:49:28 <bmbouter> +1
14:49:41 <fabricioo0> #idea Proposed for #5442: accept and to sprint
14:49:41 <fabricioo0> !propose other accept and to sprint
14:49:41 <pulpbot> fabricioo0: Proposed for #5442: accept and to sprint
14:49:48 <fabricioo0> #agreed accept and to sprint
14:49:48 <fabricioo0> !accept
14:49:48 <pulpbot> fabricioo0: Current proposal accepted: accept and to sprint
14:49:49 <pulpbot> fabricioo0: No issues to triage.
14:50:07 <bmbouter> https://pulp.plan.io/issues/5086
14:50:14 <bmbouter> that's another one I think is ready
14:50:20 <daviddavis> +1
14:50:23 <bmbouter> I'm not sure if these are in your six
14:51:23 <dawalker> I may have found a bug, but not sure if it's filed already?  Whenever a task completes successfully, you can see the results, but if it fails, I get a 500 error: https://paste.fedoraproject.org/paste/0zkweANxTGxL4j77NC2Zlg
14:51:28 <dawalker> Anyone run into this before?
14:51:42 <daviddavis> bmbouter: I didn't have a list of actual issues. just said we would probably put on ~6 issues.
14:51:49 <bmbouter> cool
14:51:56 <dalley> daviddavis, does this look good? https://pulp.plan.io/issues/5502#note-2
14:52:45 <misa> dalley: I won't be able to work on it any time soon
14:53:17 <misa> dalley: and I don't have enough knowledge of celery to even know how to fix it
14:53:26 <fabricioo0> any more bugs or should i end this triage?
14:53:26 <dalley> ok
14:53:36 <gmbnomis> re https://pulp.plan.io/issues/5509: shameless plug https://pulp.plan.io/issues/4386 :-)
14:53:39 <ttereshc> dalley, thank you for your comments, I'll answer after all my meetings
14:53:42 <daviddavis> dalley: +1
14:54:10 <bmbouter> daviddavis: this is a blocker currently but it's a P3?  https://pulp.plan.io/issues/3809#note-11
14:54:27 <misa> dalley: I *think* one needs to create a function-scope task class and decorate it with current_app, or something like that
14:54:41 <misa> dalley: but I don't know if there's a better way to do it
14:54:53 <daviddavis> bmbouter: it probably never got bumped to P1 or P2. cc jsherrill
14:55:06 <daviddavis> once we got rid of P4
14:55:24 <daviddavis> bmbouter: should we add it to the sprint?
14:55:38 <bmbouter> I think so
14:55:51 <bmbouter> and I can take as assigned, really the selinux team is going to do the work I was so pleased with their reply
14:57:33 <jsherrill> thanks guys, not sure how i missed that a while back when i looked through them all
14:57:49 <fabricioo0> #endmeeting
14:57:49 <fabricioo0> !end