14:31:10 <fabricioo0> #startmeeting Pulp Triage 2019-10-04
14:31:10 <fabricioo0> !start
14:31:10 <fabricioo0> #info fabricioo0 has joined triage
14:31:10 <pulpbot> Meeting started Fri Oct  4 14:31:10 2019 UTC.  The chair is fabricioo0. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:10 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:31:10 <pulpbot> The meeting name has been set to 'pulp_triage_2019-10-04'
14:31:10 <pulpbot> fabricioo0: fabricioo0 has joined triage
14:31:37 <daviddavis> #info daviddavis has joined triage
14:31:37 <daviddavis> !here
14:31:37 <pulpbot> daviddavis: daviddavis has joined triage
14:32:03 <ttereshc> #info ttereshc has joined triage
14:32:03 <ttereshc> !here
14:32:03 <pulpbot> ttereshc: ttereshc has joined triage
14:32:21 <fabricioo0> #info fabricioo0 has joined triage
14:32:21 <fabricioo0> !start
14:32:21 <pulpbot> fabricioo0: Error: Can't start another meeting, one is in progress.
14:32:22 <pulpbot> fabricioo0: fabricioo0 has joined triage
14:32:27 <fabricioo0> !next
14:32:28 <fabricioo0> #topic https://pulp.plan.io/issues/5539
14:32:28 <pulpbot> fabricioo0: 4 issues left to triage: 5539, 5538, 5536, 5530
14:32:29 <pulpbot> RM 5539 - bmbouter - NEW - general_create cannot report on the creation of multiple models if the serializer creates them
14:32:30 <pulpbot> https://pulp.plan.io/issues/5539
14:32:46 <daviddavis> story or task?
14:32:48 <dkliban> !jere
14:32:48 <pulpbot> dkliban: Error: "jere" is not a valid command.
14:32:51 <dkliban> #info dkliban has joined triage
14:32:51 <dkliban> !here
14:32:51 <pulpbot> dkliban: dkliban has joined triage
14:32:52 <bmbouter> #info bmbouter has joined triage
14:32:52 <bmbouter> !here
14:32:53 <pulpbot> bmbouter: bmbouter has joined triage
14:33:13 <bmbouter> either?
14:33:28 <daviddavis> both!
14:33:34 <daviddavis> tastory
14:33:43 <dkliban> storask
14:33:47 <ttereshc> does SingleArtifactContentUpload imply that only one content is created?
14:33:49 <dkliban> let's convert to story
14:33:59 <fabricioo0> #idea Proposed for #5539: change to story
14:33:59 <fabricioo0> !propose other change to story
14:33:59 <pulpbot> fabricioo0: Proposed for #5539: change to story
14:34:19 <ttereshc> I understand the need, I'm just wondering if the initial idea was to have only one content here
14:34:36 <daviddavis> SingleArtifact actually refers to the reverse: one artifact per content unit
14:34:45 <daviddavis> err
14:35:05 <bmbouter> ttereshc: yes the reverse
14:35:11 <daviddavis> content units have one and only one artifacts
14:35:21 <bmbouter> one artifact is the only claim, it could produce N content units
14:35:26 <daviddavis> but uploading an artifact could create multiple content units
14:36:08 <ttereshc> bmbouter, so for modularity - one artifact is uploaded, N artifacts created (1 per content unit), the initial artifact is removed
14:36:16 <ttereshc> is it ok use case for that ?^
14:36:23 <dkliban> i think so
14:36:57 <ttereshc> ok :) just wnated to make sure
14:37:02 <ttereshc> no strong opinion here
14:37:26 <fabricioo0> #agreed change to story
14:37:26 <fabricioo0> !accept
14:37:26 <pulpbot> fabricioo0: Current proposal accepted: change to story
14:37:27 <pulpbot> fabricioo0: 3 issues left to triage: 5538, 5536, 5530
14:37:28 <fabricioo0> #topic https://pulp.plan.io/issues/5538
14:37:28 <pulpbot> RM 5538 - dkliban@redhat.com - NEW - Add test_bindings.py and test_bindings.rb scripts to pulp_file
14:37:29 <pulpbot> https://pulp.plan.io/issues/5538
14:37:34 <daviddavis> task
14:37:38 <ttereshc> +1
14:38:05 <fabricioo0> #idea Proposed for #5538: change to task
14:38:05 <fabricioo0> !propose other change to task
14:38:05 <pulpbot> fabricioo0: Proposed for #5538: change to task
14:38:59 <fabricioo0> #agreed change to task
14:38:59 <fabricioo0> !accept
14:38:59 <pulpbot> fabricioo0: Current proposal accepted: change to task
14:38:59 <fabricioo0> #topic https://pulp.plan.io/issues/5536
14:39:00 <pulpbot> fabricioo0: 2 issues left to triage: 5536, 5530
14:39:01 <pulpbot> RM 5536 - mdellweg - POST - Bindings versioning for nightly releases is broken
14:39:02 <pulpbot> https://pulp.plan.io/issues/5536
14:39:08 <daviddavis> accept and add to sprint
14:39:13 <bmbouter> +1
14:39:18 <dkliban> +1
14:39:25 <fabricioo0> #idea Proposed for #5536: accept and add to sprint
14:39:25 <fabricioo0> !propose other accept and add to sprint
14:39:25 <pulpbot> fabricioo0: Proposed for #5536: accept and add to sprint
14:39:48 <fabricioo0> #agreed accept and add to sprint
14:39:48 <fabricioo0> !accept
14:39:48 <pulpbot> fabricioo0: Current proposal accepted: accept and add to sprint
14:39:49 <fabricioo0> #topic https://pulp.plan.io/issues/5530
14:39:49 <pulpbot> fabricioo0: 1 issues left to triage: 5530
14:39:50 <pulpbot> RM 5530 - mdellweg - NEW - I want to be able to use the posgresql extension debversion
14:39:51 <pulpbot> https://pulp.plan.io/issues/5530
14:39:56 <daviddavis> story/task
14:40:23 <fabricioo0> #idea Proposed for #5530: change to story
14:40:23 <fabricioo0> !propose other change to story
14:40:24 <pulpbot> fabricioo0: Proposed for #5530: change to story
14:40:41 <ttereshc> daviddavis, the question is do we agree/accept this task or not
14:41:57 <dkliban> i think we should accept
14:42:21 <ttereshc> if we accept, does it mean that we agree that it should be done at some point?
14:42:33 <dkliban> which part?
14:42:38 <daviddavis> should this be in the debian project?
14:42:39 <ttereshc> the story
14:43:37 <dkliban> the installer is already capable of this ... the limitation is taht it's only availabe as a deb package
14:44:22 <dkliban> x9c4: am i right about this?
14:44:30 <dkliban> or am i misunderstanding
14:44:31 <x9c4> exactly.
14:44:46 <x9c4> well its an installer pr...
14:44:52 <ttereshc> what is the deliverable of this story? any changes to our installer that are debian specific?
14:45:11 <daviddavis> and I am guessing packaging of debversion
14:46:07 <dkliban> can we come back to this at the ned of triage?
14:46:08 <x9c4> ttereshc it's not specific to running on debian, but to running the deb_plugin.
14:46:26 <ttereshc> dkliban, it's the last item
14:46:31 <dkliban> oh ok
14:46:33 <dkliban> great
14:46:57 <dkliban> if pulp_deb starts using this package, it will not run on Fedora or CentOS
14:47:14 <daviddavis> unless we package it
14:47:49 <ttereshc> ok
14:48:01 <daviddavis> I wonder if this would make sense as a prereq role like we did for rpm?
14:48:08 <daviddavis> instead of adding it to the installer
14:48:41 <daviddavis> oh but it probably has to be installed with/after postgres
14:48:43 <daviddavis> and not before
14:49:11 <bmbouter> the pre_req I think runs very early iirc
14:49:13 <x9c4> As for packaging, the requirements are: "Depends: libapt-pkg5.0 (>= 0.8.0), libc6 (>= 2.2.5), postgresql-11"
14:49:59 <ttereshc> +1 not to have any plugin specific things in the installer
14:50:17 <ttereshc> is there post_req_*? :)
14:50:24 <dkliban> yep
14:50:28 <dkliban> that's what i was thinking
14:51:05 <ttereshc> thanks for clarification
14:51:15 <ttereshc> +1 to convert to a story
14:51:19 <fabricioo0> #agreed change to story
14:51:19 <fabricioo0> !accept
14:51:19 <pulpbot> fabricioo0: Current proposal accepted: change to story
14:51:21 <pulpbot> fabricioo0: No issues to triage.
14:51:26 <fabricioo0> Open floor!
14:52:10 <daviddavis> can we go back to 5530?
14:52:22 <daviddavis> just want to make sure we have a plan besides converting it to a story
14:52:25 <fabricioo0> !5530
14:52:25 <pulpbot> fabricioo0: Error: "5530" is not a valid command.
14:52:32 <fabricioo0> !issue 5530
14:52:32 <fabricioo0> #topic https://pulp.plan.io/issues/5530
14:52:33 <pulpbot> RM 5530 - mdellweg - NEW - I want to be able to use the posgresql extension debversion
14:52:34 <pulpbot> https://pulp.plan.io/issues/5530
14:52:44 <daviddavis> maybe we can ping mikedep333 to work with the debian team on it?
14:53:46 <daviddavis> and I can comment about the idea of having post req roles for plugins
14:53:56 <bmbouter> if it's packaging work I'm hoping we can ask ehelms
14:54:02 <dkliban> i agree
14:54:27 <daviddavis> ok, I'll stay out of it then. the installer is not my expertise.
14:57:42 <dkliban> is that all?
14:57:56 <bmbouter> one thing
14:58:17 <bmbouter> some feedback on repo version validation
14:58:23 <bmbouter> on the mailing list would be a good thing
14:58:57 <fabricioo0> !next
14:58:58 <pulpbot> fabricioo0: No issues to triage.
14:59:07 <fabricioo0> Open floor!
15:00:35 <ttereshc> bmbouter, thanks for reminder!
15:00:54 <daviddavis> +1
15:01:03 <fabricioo0> #endmeeting
15:01:03 <fabricioo0> !end