14:32:19 <fabricioo0> #startmeeting Pulp Triage 2019-10-18
14:32:19 <fabricioo0> #info fabricioo0 has joined triage
14:32:19 <fabricioo0> !start
14:32:20 <pulpbot> Meeting started Fri Oct 18 14:32:19 2019 UTC.  The chair is fabricioo0. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:32:20 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:32:20 <pulpbot> The meeting name has been set to 'pulp_triage_2019-10-18'
14:32:20 <pulpbot> fabricioo0: fabricioo0 has joined triage
14:32:28 <ggainey> #info ggainey has joined triage
14:32:28 <ggainey> !here
14:32:28 <pulpbot> ggainey: ggainey has joined triage
14:33:13 <fabricioo0> !next
14:33:14 <pulpbot> fabricioo0: 4 issues left to triage: 5582, 5581, 5574, 5573
14:33:14 <fabricioo0> #topic https://pulp.plan.io/issues/5582
14:33:15 <pulpbot> RM 5582 - ttereshc - NEW - Outdated doc string for RepositoryVerison model
14:33:16 <pulpbot> https://pulp.plan.io/issues/5582
14:33:28 <ttereshc> #info ttereshc has joined triage
14:33:28 <ttereshc> !here
14:33:28 <pulpbot> ttereshc: ttereshc has joined triage
14:33:53 <ipanova> #info ipanova has joined triage
14:33:53 <ipanova> !here
14:33:53 <pulpbot> ipanova: ipanova has joined triage
14:34:22 <fabricioo0> #idea Proposed for #5582: Leave the issue as-is, accepting its current state.
14:34:22 <fabricioo0> !propose accept
14:34:22 <pulpbot> fabricioo0: Proposed for #5582: Leave the issue as-is, accepting its current state.
14:34:52 <ipanova> +1
14:35:02 <ggainey> aye, +1
14:35:05 <bmbouter> #info bmbouter has joined triage
14:35:05 <bmbouter> !here
14:35:05 <pulpbot> bmbouter: bmbouter has joined triage
14:35:15 <bmbouter> +1
14:35:31 <ttereshc> since our docs are autogenerated I'd fix it rather
14:35:53 <fabricioo0> #agreed Leave the issue as-is, accepting its current state.
14:35:53 <fabricioo0> !accept
14:35:53 <pulpbot> fabricioo0: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:35:55 <fabricioo0> #topic https://pulp.plan.io/issues/5581
14:35:55 <pulpbot> fabricioo0: 3 issues left to triage: 5581, 5574, 5573
14:35:56 <pulpbot> RM 5581 - ttereshc - NEW - Cron job in travis may disrupt the release process
14:35:57 <pulpbot> https://pulp.plan.io/issues/5581
14:37:07 <ipanova> #idea Proposed for #5581: Leave the issue as-is, accepting its current state.
14:37:07 <ipanova> !propose accept
14:37:07 <pulpbot> ipanova: Proposed for #5581: Leave the issue as-is, accepting its current state.
14:37:10 <bmbouter> I think accept and think about how this affects the release process
14:37:12 <bmbouter> +1
14:37:16 <ttereshc> accept and discuss as a part of release process discussion next week
14:37:17 <fabricioo0> +1
14:37:19 <ttereshc> +1
14:37:26 <fabricioo0> #agreed Leave the issue as-is, accepting its current state.
14:37:26 <fabricioo0> !accept
14:37:26 <pulpbot> fabricioo0: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:37:27 <fabricioo0> #topic https://pulp.plan.io/issues/5574
14:37:27 <pulpbot> fabricioo0: 2 issues left to triage: 5574, 5573
14:37:28 <pulpbot> RM 5574 - gmbnomis - NEW - Provide an easy to use way to ensure the ref_name attribute convention
14:37:29 <pulpbot> https://pulp.plan.io/issues/5574
14:38:24 <bmbouter> +1 accept and convert to story
14:38:36 <bmbouter> I hope gmbnomis submits a PR
14:38:36 <ipanova> yeah agreed
14:38:37 <ggainey> ah, good point
14:38:46 <ggainey> seconding
14:38:48 <fabricioo0> #idea Proposed for #5574: accept and convert to story
14:38:48 <fabricioo0> !propose other accept and convert to story
14:38:48 <pulpbot> fabricioo0: Proposed for #5574: accept and convert to story
14:39:09 <ttereshc> +1
14:39:26 <fabricioo0> #agreed accept and convert to story
14:39:26 <fabricioo0> !accept
14:39:26 <pulpbot> fabricioo0: Current proposal accepted: accept and convert to story
14:39:27 <pulpbot> fabricioo0: 1 issues left to triage: 5573
14:39:27 <fabricioo0> #topic https://pulp.plan.io/issues/5573
14:39:28 <pulpbot> RM 5573 - mihai.ibanescu@gmail.com - NEW - Publish won't create multiple checkecksummed copies of primary.xml, fileliststs.xml etc even when in fast-forward mode
14:39:29 <pulpbot> https://pulp.plan.io/issues/5573
14:39:49 <ttereshc> there is a pr for it I think
14:39:49 <ipanova> accept and and pulp2 tag
14:39:55 <ipanova> and/add
14:40:08 <fabricioo0> #idea Proposed for #5573: accept and add pulp2 tag
14:40:08 <fabricioo0> !propose other accept and add pulp2 tag
14:40:08 <pulpbot> fabricioo0: Proposed for #5573: accept and add pulp2 tag
14:40:30 <ttereshc> and remove urgent severity
14:40:46 <fabricioo0> #idea Proposed for #5573: accept and add pulp2 tag and remove urgent severity
14:40:46 <fabricioo0> !propose other accept and add pulp2 tag and remove urgent severity
14:40:46 <pulpbot> fabricioo0: Proposed for #5573: accept and add pulp2 tag and remove urgent severity
14:41:07 <fabricioo0> #agreed accept and add pulp2 tag and remove urgent severity
14:41:07 <fabricioo0> !accept
14:41:07 <pulpbot> fabricioo0: Current proposal accepted: accept and add pulp2 tag and remove urgent severity
14:41:08 <pulpbot> fabricioo0: No issues to triage.
14:41:18 <fabricioo0> Open floor!
14:41:29 <bmbouter> I believe CI of plugins is current affected by the settings change
14:41:37 <bmbouter> I just notified this via pulp-dev also
14:42:38 <bmbouter> fabricioo0: this is related to pulp_ansible's CI failing
14:42:46 <ggainey> ipanova: heh - you added the PR to 5573 20s before I pushed submit - very fast :)
14:42:49 <bmbouter> for open floor this was just a FYI ^
14:42:50 <fabricioo0> I imagine that
14:43:19 <ipanova> ggainey:  sorry >,>
14:43:28 <ggainey> ipanova: nono, no worries, I'm impressed is all :)
14:43:34 <bmbouter> the other item I want to call out is the "new plan" for plugin handlers for repo version creation. you can read about it here: https://pulp.plan.io/issues/3541
14:43:50 <fabricioo0> !issue 3541
14:43:50 <fabricioo0> #topic https://pulp.plan.io/issues/3541
14:43:51 <pulpbot> RM 3541 - amacdona@redhat.com - NEW - Core should not add/remove content to a repository or create a repository_version without plugin input
14:43:52 <pulpbot> https://pulp.plan.io/issues/3541
14:44:26 <bmbouter> the new plan is on there. we have a few details to figure out still (see comments at very bottom). we'll bring a final version to the list soon
14:45:20 <ggainey> yeah, the discussion has been great so far, clearly some bits to iron out yet - good to see in the issue, ttereshc bmbouter thanks for the occasional summaries you've added
14:46:33 <ttereshc> the last bit/comment is quite important one, bmbouter do you have any creative ideas on how to overcome that?
14:47:48 <bmbouter> ttereshc: yeah probably to carry through the params generically and instantiate it later
14:48:13 <bmbouter> we kind of do this already in other ways like the "context" of deferred_validate for the uploaders is a similar pattern
14:48:28 <ttereshc> I see
14:48:53 <bmbouter> you can see the "data" part here for example https://github.com/pulp/pulpcore/blob/583b305cb76290b010e37add81e00d73c1f03e66/pulpcore/app/viewsets/base.py#L348
14:50:23 <bmbouter> so we would do a similar "kwargs catch all" and pass along to be used by the handler alone here https://github.com/pulp/pulpcore/blob/2a62d16b537757a951d41cfafa32c5a5a2d63c52/pulpcore/app/viewsets/repository.py#L247
14:50:27 <gmbnomis> bmbouter, yes, I think deferred_validate may be a good blueprint. But that one works because the plugin has its own content viewset in which it can plug its specific serializer.
14:50:29 <bmbouter> I'm going to post about this
14:50:34 <bmbouter> gmbnomis!
14:51:19 <bmbouter> gmbnomis: the client would need to define the handler in some way...
14:51:56 <gmbnomis> bmbouter: There would have to be a link from content type -> handler?
14:52:35 <bmbouter> yeah maybe we could do it implicitly...
14:52:41 <ttereshc> yeah, I was about to say that we are back to thinking at a content type level
14:52:43 <bmbouter> every content type is known what plugin provides it
14:53:24 <bmbouter> I had imagined for general create it wouldn't "allow" for these extra options
14:53:30 <bmbouter> that's the other thing I was thinking
14:53:51 <bmbouter> and the third thing I was thinking is that maybe we should have master/detail repositories and make this plugin-controlled customization
14:53:57 <bmbouter> way out there idea that last one
14:54:20 <ttereshc> there can be content from different plugins in one request for a repo version creation, right?
14:54:54 <bmbouter> there can be theoretically but extremely unlikely
14:54:57 <bmbouter> in practice
14:56:19 <bmbouter> gmbnomis, ttereshc so I need to think on it some more
14:56:29 <bmbouter> I think we should end open floor b/c we're about to talk about the broken CI now
14:56:38 <ggainey> hang on, I have an open-floor request
14:56:39 <ttereshc> +1
14:57:11 <fabricioo0> !next
14:57:12 <pulpbot> fabricioo0: No issues to triage.
14:57:25 <ggainey> I just want to ask for someone to review/merge https://github.com/pulp/pulp/pull/3951 please - it fixes a prob that users are tripping over, and it's been sitting since August because I am terrible at nagging :)
14:58:31 <fabricioo0> !issue 4524
14:58:31 <fabricioo0> #topic https://pulp.plan.io/issues/4524
14:58:32 <pulpbot> RM 4524 - ttereshc - POST - Broken symlinks for subrepos are created during on_demand sync of kickstart trees
14:58:33 <pulpbot> https://pulp.plan.io/issues/4524
14:58:39 <ggainey> yus
14:59:31 <fabricioo0> #idea Proposed for #4524: code review - https://github.com/pulp/pulp/pull/3951
14:59:31 <fabricioo0> !propose other code review - https://github.com/pulp/pulp/pull/3951
14:59:31 <pulpbot> fabricioo0: Proposed for #4524: code review - https://github.com/pulp/pulp/pull/3951
14:59:39 <ggainey> yes please :)
15:00:14 <ttereshc> ggainey, probably not today, it needs a pulp2 environment, maybe we can look at it next week together
15:00:32 <ggainey> ttereshc: no rush, I just realized we had all (including me) forgotten it was there
15:00:41 <ttereshc> yup
15:00:49 <fabricioo0> #idea Proposed for #4524: review it together next week
15:00:49 <fabricioo0> !propose other review it together next week
15:00:50 <pulpbot> fabricioo0: Proposed for #4524: review it together next week
15:00:56 <ttereshc> #idea Proposed for #4524: ggainey will keep nagging
15:00:56 <ttereshc> !propose other ggainey will keep nagging
15:00:56 <pulpbot> ttereshc: Proposed for #4524: ggainey will keep nagging
15:00:57 <ggainey> +1
15:01:01 <ggainey> heh
15:01:05 <bmbouter> +1
15:01:06 <bmbouter> haha
15:01:10 <fabricioo0> #agreed ggainey will keep nagging
15:01:10 <fabricioo0> !accept
15:01:10 <pulpbot> fabricioo0: Current proposal accepted: ggainey will keep nagging
15:01:11 <pulpbot> fabricioo0: No issues to triage.
15:01:24 <fabricioo0> #endmeeting
15:01:24 <fabricioo0> !end