14:31:46 <fabricioo0> #startmeeting Pulp Triage 2019-10-29
14:31:46 <fabricioo0> #info fabricioo0 has joined triage
14:31:46 <fabricioo0> !start
14:31:46 <pulpbot> Meeting started Tue Oct 29 14:31:46 2019 UTC.  The chair is fabricioo0. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:46 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:31:46 <pulpbot> The meeting name has been set to 'pulp_triage_2019-10-29'
14:31:46 <pulpbot> fabricioo0: fabricioo0 has joined triage
14:31:56 <ggainey> #info ggainey has joined triage
14:31:56 <ggainey> !here
14:31:56 <pulpbot> ggainey: ggainey has joined triage
14:32:02 <dkliban> #info dkliban has joined triage
14:32:02 <dkliban> !here
14:32:02 <pulpbot> dkliban: dkliban has joined triage
14:32:04 <ppicka> #info ppicka has joined triage
14:32:04 <ppicka> !here
14:32:04 <pulpbot> ppicka: ppicka has joined triage
14:32:08 <daviddavis> #info daviddavis has joined triage
14:32:08 <daviddavis> !here
14:32:08 <pulpbot> daviddavis: daviddavis has joined triage
14:32:08 <ttereshc> #info ttereshc has joined triage
14:32:08 <ttereshc> !here
14:32:09 <pulpbot> ttereshc: ttereshc has joined triage
14:32:13 <fabricioo0> !next
14:32:14 <pulpbot> fabricioo0: 6 issues left to triage: 5631, 5629, 5626, 5624, 5623, 5617
14:32:14 <fabricioo0> #topic https://pulp.plan.io/issues/5631
14:32:15 <pulpbot> RM 5631 - ekohl - NEW - Make the storage status available via the API
14:32:16 <pulpbot> https://pulp.plan.io/issues/5631
14:32:22 <dkliban> convert to story
14:32:27 <bmbouter> #info bmbouter has joined triage
14:32:27 <bmbouter> !here
14:32:27 <pulpbot> bmbouter: bmbouter has joined triage
14:32:28 <daviddavis> +1
14:32:30 <ttereshc> +1
14:32:39 <daviddavis> also this has a PR so it should be in POST
14:32:40 <dawalker> #info dawalker has joined triage
14:32:40 <dawalker> !here
14:32:40 <pulpbot> dawalker: dawalker has joined triage
14:32:40 <fabricioo0> !propode other convert to story
14:32:41 <pulpbot> fabricioo0: Error: "propode" is not a valid command.
14:32:47 <fabricioo0> #idea Proposed for #5631: convert to story
14:32:47 <fabricioo0> !propose other convert to story
14:32:47 <pulpbot> fabricioo0: Proposed for #5631: convert to story
14:32:52 <fabricioo0> #agreed convert to story
14:32:52 <fabricioo0> !accept
14:32:52 <pulpbot> fabricioo0: Current proposal accepted: convert to story
14:32:53 <pulpbot> fabricioo0: 5 issues left to triage: 5629, 5626, 5624, 5623, 5617
14:32:54 <fabricioo0> #topic https://pulp.plan.io/issues/5629
14:32:54 <pulpbot> RM 5629 - bmbouter - ASSIGNED - Rename CONTENT_HOST to CONTENT_ORIGIN
14:32:55 <pulpbot> https://pulp.plan.io/issues/5629
14:33:04 <bmbouter> convert to story
14:33:05 <daviddavis> convert to task
14:33:08 <bmbouter> +1 task
14:33:10 <ttereshc> +1 to task
14:33:23 <dkliban> +1
14:33:23 <fabricioo0> #idea Proposed for #5629: convert to task
14:33:23 <fabricioo0> !propose other convert to task
14:33:23 <pulpbot> fabricioo0: Proposed for #5629: convert to task
14:33:39 <fabricioo0> #agreed convert to task
14:33:39 <fabricioo0> !accept
14:33:39 <pulpbot> fabricioo0: Current proposal accepted: convert to task
14:33:40 <pulpbot> fabricioo0: 4 issues left to triage: 5626, 5624, 5623, 5617
14:33:41 <fabricioo0> #topic https://pulp.plan.io/issues/5626
14:33:41 <pulpbot> RM 5626 - Timoses - NEW - Sync Task fails with "Cannot resolve keyword '_created' into field"
14:33:42 <pulpbot> https://pulp.plan.io/issues/5626
14:34:24 <ttereshc> it looks like a version mismatch between the pulpcore and pulpcore-plugin
14:34:30 <bmbouter> agreed
14:34:37 <ggainey> aye
14:34:41 <ttereshc> I'll comment
14:34:44 <dkliban> +1
14:34:48 <dkliban> thank you ttereshc
14:34:51 <ggainey> +1
14:35:02 <dawalker> +1
14:35:24 <ipanova> #info ipanova has joined triage
14:35:24 <ipanova> !here
14:35:24 <pulpbot> ipanova: ipanova has joined triage
14:36:02 <fabricioo0> #idea Proposed for #5626: ttereshc will comment on this
14:36:02 <fabricioo0> !propose other ttereshc will comment on this
14:36:02 <pulpbot> fabricioo0: Proposed for #5626: ttereshc will comment on this
14:36:06 <fabricioo0> #agreed ttereshc will comment on this
14:36:06 <fabricioo0> !accept
14:36:06 <pulpbot> fabricioo0: Current proposal accepted: ttereshc will comment on this
14:36:07 <pulpbot> fabricioo0: 3 issues left to triage: 5624, 5623, 5617
14:36:07 <fabricioo0> #topic https://pulp.plan.io/issues/5624
14:36:08 <pulpbot> RM 5624 - Timoses - NEW - OpenAPI generated client 'pulp-file-client' does not return 'pulp_href'
14:36:09 <pulpbot> https://pulp.plan.io/issues/5624
14:36:40 <ggainey> is this a similar mismatch?
14:37:04 <bmbouter> yup
14:37:08 <dkliban> i think so
14:37:43 <fabricioo0> I don't know what to propose for this one
14:37:46 <fabricioo0> close?
14:37:56 <dkliban> close not a bug .... the client is not new enough
14:38:02 <ttereshc> I can refer to the comment I made for the previous one
14:38:10 <ggainey> ah, yeah that makes sense
14:38:21 <fabricioo0> #idea Proposed for #5624: close not a bug
14:38:21 <fabricioo0> !propose other close not a bug
14:38:21 <pulpbot> fabricioo0: Proposed for #5624: close not a bug
14:38:22 <dkliban> bmbouter cleaned up PyPI yesterday
14:38:25 <fabricioo0> #agreed close not a bug
14:38:25 <fabricioo0> !accept
14:38:25 <pulpbot> fabricioo0: Current proposal accepted: close not a bug
14:38:26 <pulpbot> fabricioo0: 2 issues left to triage: 5623, 5617
14:38:26 <fabricioo0> #topic https://pulp.plan.io/issues/5623
14:38:27 <pulpbot> RM 5623 - Timoses - NEW - OpenAPI generated client - Failed to parse in urllib3
14:38:28 <pulpbot> https://pulp.plan.io/issues/5623
14:38:42 <dkliban> i commented ont his already
14:38:49 <dkliban> it's a documentation bug
14:38:58 <dkliban> so we should accept and add a documentation tag
14:39:01 <daviddavis> +1
14:39:07 <ttereshc> +1
14:39:16 <ggainey> concur
14:39:19 <bmbouter> +1
14:39:19 <fabricioo0> #idea Proposed for #5623: accept and add documentation tag
14:39:19 <fabricioo0> !propose other accept and add documentation tag
14:39:19 <pulpbot> fabricioo0: Proposed for #5623: accept and add documentation tag
14:39:21 <ipanova> +1
14:39:23 <fabricioo0> #agreed accept and add documentation tag
14:39:23 <fabricioo0> !accept
14:39:24 <pulpbot> fabricioo0: Current proposal accepted: accept and add documentation tag
14:39:24 <ggainey> just saw your comment dkliban
14:39:25 <fabricioo0> #topic https://pulp.plan.io/issues/5617
14:39:25 <pulpbot> fabricioo0: 1 issues left to triage: 5617
14:39:26 <pulpbot> RM 5617 - ragulb - NEW - Pulp-admin unable to login
14:39:27 <pulpbot> https://pulp.plan.io/issues/5617
14:40:02 <ttereshc> pulp 2 tag is needed
14:40:45 <dkliban> i am guessing it's user error
14:40:50 <dkliban> but there is not enough information
14:41:04 <dkliban> we can ask him to please provide the exact commands that he is running to logic
14:41:07 <dkliban> login
14:41:08 <ggainey> "unable to load CA Private Key"
14:41:21 <dkliban> ah
14:41:37 <dkliban> i don't think the user is actually logged in
14:41:42 <ggainey> also, I assume "Blocks 2.19.z" is meant to be "Platform Release 2.19.z"?
14:41:52 <ggainey> I'
14:41:58 <ggainey> ll add a comment asking for more info
14:42:09 <ggainey> and clean up the fields
14:42:12 <dkliban> yeah ... and fix that blcks release field
14:42:16 <dkliban> thanks!
14:42:29 <ttereshc> +1
14:42:30 <fabricioo0> #idea Proposed for #5617: ask for more info and add pulp 2 tag
14:42:30 <fabricioo0> !propose other ask for more info and add pulp 2 tag
14:42:31 <pulpbot> fabricioo0: Proposed for #5617: ask for more info and add pulp 2 tag
14:42:37 <ipanova> +1
14:43:07 <fabricioo0> #agreed ask for more info and add pulp 2 tag
14:43:07 <fabricioo0> !accept
14:43:07 <pulpbot> fabricioo0: Current proposal accepted: ask for more info and add pulp 2 tag
14:43:09 <pulpbot> fabricioo0: No issues to triage.
14:43:15 <fabricioo0> Open floor!
14:43:27 <dkliban> there was a bug about rpm bindings
14:43:33 <dkliban> daviddavis: what was that issue number?
14:43:43 <daviddavis> https://pulp.plan.io/issues/5611
14:43:51 <fabricioo0> !issue 5611
14:43:52 <fabricioo0> #topic https://pulp.plan.io/issues/5611
14:43:52 <pulpbot> RM 5611 - iballou - ASSIGNED - Argument error when calling ContentAdvisoriesApi list with Ruby bindings
14:43:53 <pulpbot> https://pulp.plan.io/issues/5611
14:44:02 <daviddavis> looks like pavel is looking into it
14:44:04 <daviddavis> ppicka:
14:44:17 <ppicka> yes
14:44:19 <daviddavis> ppicka++
14:44:19 <pulpbot> daviddavis: ppicka's karma is now 19
14:44:20 <dkliban> we should add to the sprint
14:44:23 <daviddavis> +1
14:44:31 <daviddavis> also https://pulp.plan.io/issues/5630
14:44:41 <daviddavis> probably should add that the sprint too
14:44:41 <fabricioo0> #idea Proposed for #5611: add to sprint
14:44:41 <fabricioo0> !propose other add to sprint
14:44:42 <pulpbot> fabricioo0: Proposed for #5611: add to sprint
14:44:56 <ttereshc> daviddavis, +1, fabricioo0 is on it
14:45:02 <daviddavis> fabricioo0++
14:45:02 <pulpbot> daviddavis: fabricioo0's karma is now 27
14:45:04 <daviddavis> great
14:45:08 <fabricioo0> #agreed add to sprint
14:45:08 <fabricioo0> !accept
14:45:08 <pulpbot> fabricioo0: Current proposal accepted: add to sprint
14:45:09 <pulpbot> fabricioo0: No issues to triage.
14:45:16 <gmbnomis> I would like to discuss whether https://pulp.plan.io/issues/5574 is a potential GA blocker (if done it will change the class model names in all plugin clients)
14:45:29 <fabricioo0> !issue 5630
14:45:30 <fabricioo0> #topic https://pulp.plan.io/issues/5630
14:45:30 <pulpbot> RM 5630 - iballou - ASSIGNED - Publication creation fails after syncing http://mirror.centos.org/centos-6/6.10/os/x86_64/
14:45:31 <pulpbot> https://pulp.plan.io/issues/5630
14:45:42 <fabricioo0> #idea Proposed for #5630: add to sprint
14:45:42 <fabricioo0> !propose other add to sprint
14:45:42 <pulpbot> fabricioo0: Proposed for #5630: add to sprint
14:45:43 <bmbouter> gmbnomis: I'm glad you brought this up
14:45:51 <fabricioo0> #agreed add to sprint
14:45:51 <fabricioo0> !accept
14:45:51 <pulpbot> fabricioo0: Current proposal accepted: add to sprint
14:45:52 <pulpbot> fabricioo0: No issues to triage.
14:46:06 <daviddavis> yea, I think we need to decide on a design for 5574
14:46:18 <daviddavis> before GA
14:46:22 <fabricioo0> !issue 5574
14:46:22 <fabricioo0> #topic https://pulp.plan.io/issues/5574
14:46:23 <pulpbot> RM 5574 - gmbnomis - NEW - Provide an easy to use way to ensure the ref_name attribute convention
14:46:24 <pulpbot> https://pulp.plan.io/issues/5574
14:47:35 <bmbouter> one of my questions was: how can we avoid FileFileContent?
14:47:51 <daviddavis> by having file_FileContent
14:47:54 <daviddavis> jk
14:48:11 <daviddavis> bmbouter: so you mean how can we avoid touching the bindings?
14:48:18 <bmbouter> as in solving it at the django model level without impacting the bindings name usability
14:48:20 <gmbnomis> the openapi generator seems to map file_FileContent to FileFileContent...
14:48:34 <bmbouter> yeah can we have the openapi generator handle the names in a different way
14:48:55 <bmbouter> as we introduce the ref_name by default
14:49:13 <dkliban> sure
14:49:34 <dkliban> but i would need concrete examples of what we want the openapigenerator to do
14:49:47 <bmbouter> yup
14:50:05 <bmbouter> daviddavis: did you and gmbnomis discuss what you mentioned about applying this automatically without a decorator?
14:50:19 <daviddavis> yes, and I am fine either way
14:50:33 <gmbnomis> me too
14:50:57 <gmbnomis> with a tendency to set it automatically
14:51:05 * bmbouter is listening for a suggestion :)
14:51:13 <bmbouter> that sounds good
14:51:18 <daviddavis> automatically sounds better to me too
14:51:22 <bmbouter> great
14:52:12 <daviddavis> so goal would be to keep binding names the same?
14:52:16 <bmbouter> I think so
14:52:17 <daviddavis> and merge https://github.com/pulp/pulpcore/pull/345 ?
14:53:07 <bmbouter> +1 but travis is failing
14:53:18 <daviddavis> right because of the bindings
14:53:22 <bmbouter> ah bindings!
14:53:40 <daviddavis> who can fix the bindings :)
14:54:15 <gmbnomis> In api.json this is global mapping, so we need unique names there.
14:54:30 <daviddavis> so we need FileFileContent ?
14:54:33 <bmbouter> mmmm
14:54:47 <bmbouter> dkliban: wdyt^?
14:55:09 <dkliban> i am a bit out of the loop ... that's why i was asking for concrete examples.
14:55:49 <dkliban> but here is what i can say on the matter ...
14:56:10 <dkliban> we need to have 1 behavior for generating the OpenAPI schema for bindings. and another behavior for generating docs
14:57:26 <dkliban> when the user loads the /pulp/api/v3/docs/ we will need to generate an openapi schema where every resource has a unique name
14:58:01 <daviddavis> should both cases produce unique names?
14:58:01 <dkliban> we can't have a content type from one plugin have the exact same name as a content type from another package
14:59:04 <daviddavis> other languages like ruby don't have built in namespacing so I think in all cases we need FileFileContent
14:59:47 <dkliban> we ship separate packages for each plugin
14:59:48 <gmbnomis> good point
15:00:05 <daviddavis> dkliban: we don't support generating bindings locally for an entire pulp install?
15:00:55 <dkliban> daviddavis: we don't recommend that
15:00:59 <daviddavis> I see
15:01:27 <daviddavis> I think then we can have the bindings openapi version rename FileFileContent to FileContent and we should be set?
15:01:37 <bmbouter> yes
15:01:41 <bmbouter> or start to use them globally
15:01:46 <bmbouter> either is ok w/ me
15:01:48 <fabricioo0> I'm lost, should I end the triage?
15:01:53 <daviddavis> fabricioo0: no
15:01:54 <bmbouter> no it's open floor
15:02:48 <daviddavis> I feel like having namespaced objects is the better way but I am fine with updating the schema generation for the bindings to keep it the same
15:04:22 <bmbouter> +1
15:04:24 <gmbnomis> So we would use "file_FileContent" and process the JSON dynamically (or do some post-processing) depending on the case?
15:05:10 <daviddavis> gmbnomis: it would be like this https://git.io/Jeu9a
15:05:22 <daviddavis> we check if the openapi schema is being used to generate bindings
15:05:45 <daviddavis> but yea
15:06:04 <gmbnomis> uh, this will need to change all the internal reference
15:06:05 <dkliban> can we summarize this work? i am lost
15:06:29 <gmbnomis> I meant "internal cross-references"
15:07:09 <daviddavis> dkliban: basically we have to get https://github.com/pulp/pulpcore/pull/345 passing by updating the openapi schema to keep the bindings references the same
15:07:18 <bmbouter> dkliban: yes, so it all started when a Tag model in ansible conflicted w/ a Tag model in Docker
15:07:38 <bmbouter> the "solution" was ^ PR to automatically apply 'ref_name' which is a django thing
15:07:55 <bmbouter> buuuut this changes the bindings names that are generated
15:08:08 <bmbouter> which is why travis is failing on just the bindings job
15:08:26 <daviddavis> and this PR sets the ref_name automatically to avoid future conflicts https://github.com/pulp/pulpcore/pull/345
15:09:33 <dkliban> gotcha
15:09:43 <dalley> throwing out crazy ideas we probably don't have time to do: do you think the routing would be a lot simpler if we used /file/content/file/, /rpm/repositories/rpm/ instead of /content/file/file(s)/, /repositories/rpm/rpm/
15:10:51 <dkliban> daviddavis: bmbouter: gmbnomis: i am surprised that Repository object is the one that fails to be imported in that faield Travis job
15:11:12 <daviddavis> Repository becomes CoreRepository
15:11:17 <dkliban> oh ok
15:11:36 <daviddavis> yea, it's brutal
15:11:41 <daviddavis> everything gets renamed I think
15:11:42 <gmbnomis> yes, but that it easy to avoid
15:11:50 <daviddavis> ah ok
15:12:15 <gmbnomis> I have a newer version of the change that does not change ref_name for the "core" app
15:12:24 <daviddavis> cool
15:12:46 <bmbouter> mmm
15:12:59 <daviddavis> this is hairy
15:13:02 <bmbouter> it is
15:13:37 <dkliban> yeah
15:14:37 <bmbouter> I think it's an unavoidable problem that we need namespaces
15:15:33 <daviddavis> yea, I think that's the best path forward. Katello and Galaxy are going to hate us though.
15:15:37 <bmbouter> how to get there is probably hard but not as hard as not knowing you need to go there
15:16:31 <fabricioo0> !addchair dkliban
15:16:31 <pulpbot> fabricioo0: Error: The command "addchair" is available in the MeetBot and PulpTriage plugins.  Please specify the plugin whose command you wish to call by using its name as a command before "addchair".
15:16:33 <bmbouter> alternatively the option is to have some plugins adoptit
15:16:36 <x9c4> you forgot about pulp-squeeze ;)
15:18:27 <fabricioo0> !addchair PulpTriage dkliban
15:18:27 <pulpbot> fabricioo0: Error: The command "addchair" is available in the MeetBot and PulpTriage plugins.  Please specify the plugin whose command you wish to call by using its name as a command before "addchair".
15:18:46 <fabricioo0> !PulpTriage addchair dkliban
15:18:46 <pulpbot> fabricioo0: Error: You don't have the admin capability. If you think that you should have this capability, be sure that you are identified before trying again. The 'whoami' command can tell you if you're identified.
15:19:04 <ggainey> heh
15:19:04 <dkliban> !PulpTriage addchair dkliban
15:19:04 <pulpbot> dkliban: Error: You don't have the admin capability. If you think that you should have this capability, be sure that you are identified before trying again. The 'whoami' command can tell you if you're identified.
15:19:45 <dkliban> !PulpTriage addchair dkliban
15:19:56 <dkliban> fabricioo0: it worked now
15:20:03 <fabricioo0> =D
15:20:05 <bmbouter> nice
15:20:08 <fabricioo0> dkliban++
15:20:08 <pulpbot> fabricioo0: dkliban's karma is now 379
15:20:12 <dkliban> anyway,
15:20:24 <dkliban> i am concerned about the /pulp/api/v3/docs/ endpoint
15:20:38 <bmbouter> me too, go on
15:21:08 <dkliban> and i am not sure what it looks like right now with this change
15:22:00 <dkliban> i suspect we have language in there now that looks like 'Core Repositories' and 'File FileContent'
15:22:27 <dkliban> i would like to take a closer look at this PR before continuing this discussion
15:22:52 <daviddavis> that sounds like a good idea
15:22:52 <bmbouter> that works for me
15:22:55 <dkliban> can we discuss again in 24 hours?
15:23:04 <dkliban> gmbnomis: ^
15:24:24 <dkliban> i would like to end Open Floor
15:24:30 <ggainey> cocnur
15:24:36 <ggainey> concur even
15:24:53 <daviddavis> +1
15:24:56 <dkliban> #endmeeting
15:24:56 <dkliban> !end
15:25:02 <bmbouter> +1
15:25:32 <bmbouter> FYI I wrote about a new problem here, it needs input also :/  https://www.redhat.com/archives/pulp-dev/2019-October/msg00086.html
15:26:10 <dkliban> !MeetBot addchair dkliban
15:26:10 <pulpbot> dkliban: (meetbot addchair <channel> <network> <nick>) -- Add a nick as a chair to the meeting.
15:26:29 <dkliban> !MeetBot addchair #pulp-dev freenode dkliban
15:26:29 <pulpbot> dkliban: Chair added: dkliban on (#pulp-dev, freenode).
15:26:34 <dkliban> !end
15:26:52 <dkliban> !end
15:27:39 <dkliban> !MeetBot addchair #pulp-dev dkliban
15:27:39 <pulpbot> dkliban: (meetbot addchair <channel> <network> <nick>) -- Add a nick as a chair to the meeting.
15:28:26 <dkliban> !MeetBot addchair #pulp-dev freenode.net dkliban
15:28:26 <pulpbot> dkliban: Meeting on channel #pulp-dev, network freenode.net not found
15:28:33 <dkliban> !MeetBot addchair #pulp-dev freenode dkliban
15:28:33 <pulpbot> dkliban: Chair added: dkliban on (#pulp-dev, freenode).
15:28:40 <gmbnomis> dkliban: Sorry, I had a local "interrupt" here. Yes, let's discuss tomorrow.
15:28:40 <dkliban> !end
15:29:15 <dkliban> !PulpTriage addchair #pulp-dev freenode dkliban
15:29:15 <pulpbot> dkliban: Error: freenode is not in #pulp-dev.
15:29:26 <dkliban> !PulpTriage addchair  dkliban
15:29:31 <dkliban> #endmeeting
15:29:31 <dkliban> !end