14:34:13 <fao89> #startmeeting Pulp Triage 2019-11-01
14:34:13 <fao89> #info fao89 has joined triage
14:34:13 <fao89> !start
14:34:13 <pulpbot> Meeting started Fri Nov  1 14:34:13 2019 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:34:13 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:34:13 <pulpbot> The meeting name has been set to 'pulp_triage_2019-11-01'
14:34:13 <pulpbot> fao89: fao89 has joined triage
14:34:21 <mikedep333> #info mikedep333 has joined triage
14:34:21 <mikedep333> !here
14:34:21 <pulpbot> mikedep333: mikedep333 has joined triage
14:34:24 <bmbouter> #info bmbouter has joined triage
14:34:24 <bmbouter> !here
14:34:24 <pulpbot> bmbouter: bmbouter has joined triage
14:34:29 <fao89> !next
14:34:30 <pulpbot> fao89: 3 issues left to triage: 5642, 5636, 5626
14:34:31 <fao89> #topic https://pulp.plan.io/issues/5642
14:34:31 <pulpbot> RM 5642 - mdellweg - NEW - Pulp client api is broken
14:34:32 <pulpbot> https://pulp.plan.io/issues/5642
14:34:39 <dawalker> daviddavis, sounds like you don't
14:34:40 <dawalker> #info dawalker has joined triage
14:34:40 <dawalker> !here
14:34:40 <pulpbot> dawalker: dawalker has joined triage
14:35:02 <ppicka> #info ppicka has joined triage
14:35:02 <ppicka> !here
14:35:02 <pulpbot> ppicka: ppicka has joined triage
14:35:18 <fao89> #idea Proposed for #5642: Leave the issue as-is, accepting its current state.
14:35:18 <fao89> !propose accept
14:35:18 <pulpbot> fao89: Proposed for #5642: Leave the issue as-is, accepting its current state.
14:35:18 <ttereshc> #info ttereshc has joined triage
14:35:18 <ttereshc> !here
14:35:19 <pulpbot> ttereshc: ttereshc has joined triage
14:35:23 <ipanova> #info ipanova has joined triage
14:35:23 <ipanova> !here
14:35:24 <pulpbot> ipanova: ipanova has joined triage
14:35:36 <daviddavis> #info daviddavis has joined triage
14:35:36 <daviddavis> !here
14:35:36 <pulpbot> daviddavis: daviddavis has joined triage
14:36:09 <dkliban> #info dkliban has joined triage
14:36:09 <dkliban> !here
14:36:09 <pulpbot> dkliban: dkliban has joined triage
14:36:38 <dkliban> accept and add to sprint
14:36:40 <daviddavis> +1
14:36:52 <fao89> #idea Proposed for #5642: accept and add to sprint
14:36:52 <fao89> !propose other accept and add to sprint
14:36:52 <pulpbot> fao89: Proposed for #5642: accept and add to sprint
14:36:56 <fao89> #agreed accept and add to sprint
14:36:56 <fao89> !accept
14:36:56 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:36:57 <fao89> #topic https://pulp.plan.io/issues/5655
14:36:57 <pulpbot> fao89: 3 issues left to triage: 5655, 5636, 5626
14:36:58 <ttereshc> should it have a more specific title?
14:36:59 <pulpbot> RM 5655 - iballou - NEW - RPM repo remote URL without trailing slash causes 404
14:37:00 <pulpbot> https://pulp.plan.io/issues/5655
14:37:08 <dkliban> yeah
14:37:28 <ttereshc> I think this one is not rpm specific, so I moved to to pulp
14:37:58 <bmbouter> can we retitle it a bit also?
14:38:01 <ipanova> not every plugin expects the slash i think
14:38:24 <dawalker> shouldn't that be consistent?
14:38:26 <daviddavis> I think ansible requires there to not be one
14:38:32 <daviddavis> pulp_ansible that is
14:39:13 <ipanova> depends on the client dawalker
14:39:20 <ttereshc> I think the problem is in removing everything after last slash
14:39:23 <bmbouter> yeah agreed pulp_ansible needs all sorts of data there
14:39:29 <ipanova> think we should accept and move to rpm
14:39:56 <ttereshc> I don't think rpm plugin removes anything from the url
14:39:59 <fao89> #idea Proposed for #5655: accept and move to rpm
14:39:59 <fao89> !propose other accept and move to rpm
14:39:59 <pulpbot> fao89: Proposed for #5655: accept and move to rpm
14:40:04 <ttereshc> that's why I moved it here
14:40:13 <ttereshc> ok, I can move it back, fair enough
14:40:37 <bmbouter> ttereshc: if there is something core can do we want to, but I'm not sure what atm
14:40:46 <bmbouter> since it's interpreted in FirstStage
14:41:07 <dkliban> +1
14:41:17 <ttereshc> bmbouter,  and url is not modified/validated in a ny way before that?
14:41:45 <bmbouter> not that I'm aware of
14:41:59 <ttereshc> this:  "Pulp chopped the 'x86_64' off" made me worriede
14:42:00 <ttereshc> ok
14:42:02 <dkliban> ttereshc: just a simple validation of it not being None when a remote is created
14:42:07 <ttereshc> we can move on
14:42:31 <fao89> #agreed accept and move to rpm
14:42:31 <fao89> !accept
14:42:31 <pulpbot> fao89: Current proposal accepted: accept and move to rpm
14:42:32 <fao89> #topic https://pulp.plan.io/issues/5636
14:42:32 <pulpbot> fao89: 2 issues left to triage: 5636, 5626
14:42:33 <pulpbot> RM 5636 - Timoses - NEW - Dependency version conflicts between pulp plugins and pulp installation with ansible-pulp
14:42:34 <pulpbot> https://pulp.plan.io/issues/5636
14:43:06 <ipanova> we have not released docker compatible with rc7
14:44:06 <daviddavis> I feel like this is unsolvable?
14:44:22 <daviddavis> plugins could depend on different versions of core
14:44:34 <dkliban> i agree
14:44:46 <daviddavis> GA should help mitigate this though
14:45:03 <bmbouter> until the plugin api stabalizes it's unsafe for a plugin to allow users to receive the 3.y+1
14:45:09 <dalley> bmbouter, ttereshc, daviddavis one thing that occurs to me is that "name" on repository, remote, etc. is universally unique, meaning you can't have a file repo named "foo" if you also have an RPM repo named "foo"
14:45:31 <bmbouter> dalley: oof, let's revisit at open floor
14:45:36 <ttereshc> +1
14:45:38 <bmbouter> GA should help some though I agree
14:45:42 <dalley> sorry
14:45:46 <bmbouter> dalley: np at all
14:46:20 <bmbouter> for this bug I think the resolution is for docker to release?
14:46:24 <daviddavis> +1
14:46:43 <ipanova> yes, i will reply that a new release of docker is needed
14:46:48 <dawalker> +1
14:47:49 <fao89> #idea Proposed for #5636: ipanova will reply that a new release of docker is needed
14:47:49 <fao89> !propose other ipanova will reply that a new release of docker is needed
14:47:49 <pulpbot> fao89: Proposed for #5636: ipanova will reply that a new release of docker is needed
14:47:51 <fao89> #agreed ipanova will reply that a new release of docker is needed
14:47:51 <fao89> !accept
14:47:51 <pulpbot> fao89: Current proposal accepted: ipanova will reply that a new release of docker is needed
14:47:53 <fao89> #topic https://pulp.plan.io/issues/5626
14:47:53 <pulpbot> fao89: 1 issues left to triage: 5626
14:47:54 <pulpbot> RM 5626 - Timoses - NEW - Sync Task fails with "Cannot resolve keyword '_created' into field"
14:47:55 <pulpbot> https://pulp.plan.io/issues/5626
14:48:14 <daviddavis> closed worksforme
14:48:19 <ipanova> +1
14:48:24 <dkliban> +1
14:48:39 <fao89> #idea Proposed for #5626: closed worksforme
14:48:39 <fao89> !propose other closed worksforme
14:48:39 <pulpbot> fao89: Proposed for #5626: closed worksforme
14:48:43 <fao89> #agreed closed worksforme
14:48:43 <fao89> !accept
14:48:43 <pulpbot> fao89: Current proposal accepted: closed worksforme
14:48:44 <pulpbot> fao89: No issues to triage.
14:48:48 <fao89> Open floor!
14:50:05 <daviddavis> ok so detail model unique names
14:50:09 <daviddavis> discuss!
14:50:33 <ttereshc> there should be no problem with it at db level, so I'm curious where it is
14:50:38 <bmbouter> how do we handle this with remotes?
14:50:50 <daviddavis> we don't I don't think
14:51:24 <daviddavis> I believe all detail names are stored in a table with a unique constraint so I think the db level is where the problem lies?
14:51:30 <bmbouter> then I think we can ignore at least through the wed merge and handle separately
14:51:40 <daviddavis> is it a problem though?
14:51:42 <bmbouter> that's more of a tactical recommendation than a technical one
14:51:44 <dalley> ttereshc, it's because each master/detail model is split across 2 tables, the "Repository/rRmote" table and the "FileRepository/FileRemote" table, and the "name" and other shared attributes are in the former table
14:51:53 <bmbouter> it is a problem I think
14:52:16 <bmbouter> what if we just make it not unique?
14:52:40 <daviddavis> you could then have two rpm repos with the same name for instance. not sure if that's a problem I guess.
14:52:49 <ipanova> bmbouter: why do you see it as a problem?
14:52:58 <ttereshc> yeah, I see it now, I thought it's the other way around, that name is stored n the detail table
14:53:02 <dalley> we use HREFs basically everywhere which is unique. it wouldn't be a "problem" but it would be confusing to the user, which might be a problem
14:53:18 <ipanova> dalley: at least it won't be new to them
14:53:31 <ipanova> i think pulp2 works same way :)
14:53:39 <daviddavis> yea
14:53:43 <dalley> multiple (object) with the same name?
14:53:44 <bmbouter> ipanova: it's not a big problem, just a usability problem
14:54:00 <daviddavis> dalley: no the reverse, universally unique names across types
14:54:05 <bmbouter> like two users using 1 pulp system, now at least 1 user looses to the other
14:54:12 <dalley> ah
14:54:19 <ipanova> dalley: ou cannot have file repo foo and rpm repo foo
14:54:43 <daviddavis> bmbouter: I could also see the opposite: two users each with the same rpm repo with the same name
14:55:04 <daviddavis> s/with the same/with a/
14:55:34 <ttereshc> ipanova, I think now with dalley's changes you will be able to
14:55:53 <daviddavis> I don't think so
14:55:56 <ttereshc> hit the same problem
14:56:01 <daviddavis> oh
14:56:15 <dalley> ttereshc, no, my PR doesn't really change anything
14:56:20 <dalley> in that respect
14:57:02 <ttereshc> I mean that repos are now master-detail so they have the same issue
14:57:13 <daviddavis> can we do unique_together for type and name?
14:57:23 <ttereshc> never mind, I'll explain myself later t ipanova
14:57:26 <dalley> we can
14:57:45 <dawalker> daviddavis, +1
14:58:00 <ipanova> i think i am inclined having 1 repo name across the types
14:58:40 <bmbouter> yeah I think this is debatable about what is right
14:58:45 <dkliban> i like david's idea ... you can't list all repositories in one place now
14:59:16 <dkliban> so it would make sense to only have unique names per type
14:59:40 <dkliban> now = with typed repositories
14:59:49 <daviddavis> I can file an issue for this and we can discuss further
14:59:55 <ttereshc> we discussed last week that we might add such view to show all repos
14:59:58 <bmbouter> yeah I like this idea ... in 3.1
15:00:11 <ipanova> dkliban: we might still add the ability to list all repos..later
15:00:11 <ttereshc> in any case, +1 to unique_together
15:00:25 <ipanova> ttereshc: is faster :-P
15:00:28 <bmbouter> +1 to file and we can chat it up
15:00:42 <daviddavis> great
15:00:46 <ipanova> +1
15:01:52 <dkliban> +1
15:02:08 <bmbouter> I've got a two topics
15:02:09 <dawalker> +1
15:02:11 <bmbouter> both shorties
15:02:18 <dalley> the same is true of remotes, same solution there?
15:02:26 <bmbouter> yup
15:02:36 <ttereshc> all master/detail ones?
15:04:06 <dalley> distributions as well, can't think of any others atm
15:04:21 <ttereshc> content guards?
15:04:50 <dalley> yup
15:05:24 <bmbouter> yup
15:05:41 <ttereshc> publisher? exporter? :)
15:05:45 <ttereshc> ok, I guess all
15:05:48 <bmbouter> one of the thing I want to mention is I think conference submission deadlines are today is that right?
15:06:54 <ttereshc> I applied for devconf cz booth
15:07:08 <ttereshc> CfgMgmtCamp is till  Sunday 3 November 23:59:59 CET
15:07:15 <bmbouter> excellent!
15:07:29 <bmbouter> I'm organizing my talk to there and will submit
15:07:39 <dkliban> fosdem is end of november
15:07:55 <dkliban> there are actully 2 rooms at FOSDEM that would work for Pulp
15:08:05 <bmbouter> great
15:08:11 <dkliban> Dependency Management room
15:08:13 <bmbouter> so for sunday's deadline who else is submitting again?
15:08:25 <dkliban> I am submitting for Sunday's deadline
15:08:35 <bmbouter> I believ x9c4 is also and I'll email him
15:08:39 <dkliban> cool
15:09:55 <ttereshc> do we need 4? or 3 is enough?
15:10:03 <bmbouter> I was hoping for 4
15:10:44 <dkliban> same here
15:11:04 <bmbouter> also we need to put in for a plugin writer workshop, was that the 4th?
15:11:47 <ttereshc> I think it's separate
15:12:09 <ttereshc> for the 3rd day there are 2 options - fringe and workshop
15:12:27 <dkliban> yeah .. we want to do a workshop on that da
15:12:34 <ttereshc> we better go with 1 or 2 workshops
15:12:36 <bmbouter> ok I can submit that
15:12:40 <bmbouter> yes
15:12:43 <ttereshc> yeah, it's 3 hours
15:12:47 <ttereshc> while fringe is 8
15:12:53 <bmbouter> yeah not fringe again
15:13:52 <bmbouter> ok I'll submit one plugin writer workshop
15:14:12 <ipanova> +1 for the workshop and not fringe
15:14:16 <ipanova> bmbouter++
15:14:16 <pulpbot> ipanova: bmbouter's karma is now 206
15:14:36 <bmbouter> anyone can join and collab, I just want to make sure we have a submission in
15:15:23 <dkliban> thank you
15:15:35 <ttereshc> yeah, thank you!
15:16:04 <fao89> #endmeeting
15:16:04 <fao89> !end