15:31:34 <fao89> #startmeeting Pulp Triage 2019-11-19
15:31:34 <fao89> #info fao89 has joined triage
15:31:34 <fao89> !start
15:31:35 <pulpbot> Meeting started Tue Nov 19 15:31:34 2019 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:31:35 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:31:35 <pulpbot> The meeting name has been set to 'pulp_triage_2019-11-19'
15:31:35 <pulpbot> fao89: fao89 has joined triage
15:31:43 <daviddavis> #info daviddavis has joined triage
15:31:43 <daviddavis> !here
15:31:43 <pulpbot> daviddavis: daviddavis has joined triage
15:31:43 <fao89> !next
15:31:44 <pulpbot> fao89: 4 issues left to triage: 5733, 5707, 5706, 5694
15:31:45 <fao89> #topic https://pulp.plan.io/issues/5733
15:31:45 <pulpbot> RM 5733 - daviddavis - POST - Detail models __str__ incorrectly displays TYPE for pulp_type
15:31:46 <pulpbot> https://pulp.plan.io/issues/5733
15:31:47 <ppicka> #info ppicka has joined triage
15:31:47 <ppicka> !here
15:31:48 <pulpbot> ppicka: ppicka has joined triage
15:32:10 <ttereshc> #info ttereshc has joined triage
15:32:10 <ttereshc> !here
15:32:10 <pulpbot> ttereshc: ttereshc has joined triage
15:32:11 <fao89> #idea Proposed for #5733: accept and add to sprint
15:32:11 <fao89> !propose other accept and add to sprint
15:32:12 <pulpbot> fao89: Proposed for #5733: accept and add to sprint
15:32:15 <dkliban> +1
15:32:20 <daviddavis> +1, also I could use a review on the PR
15:32:28 <ttereshc> +1
15:32:47 <fao89> #agreed accept and add to sprint
15:32:47 <fao89> !accept
15:32:47 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:32:48 <pulpbot> fao89: 3 issues left to triage: 5707, 5706, 5694
15:32:48 <fao89> #topic https://pulp.plan.io/issues/5707
15:32:49 <pulpbot> RM 5707 - bmbouter - NEW - base_version can cause content can show as being added and removed in the same version
15:32:50 <pulpbot> https://pulp.plan.io/issues/5707
15:33:13 <dkliban> #idea Proposed for #5707: accept and add to sprint
15:33:13 <dkliban> #info dkliban has joined triage
15:33:13 <dkliban> !propose other accept and add to sprint
15:33:13 <pulpbot> dkliban: dkliban has joined triage
15:33:14 <pulpbot> dkliban: Proposed for #5707: accept and add to sprint
15:33:27 <mikedep333> #info mikedep333 has joined triage
15:33:27 <mikedep333> !here
15:33:27 <pulpbot> mikedep333: mikedep333 has joined triage
15:33:46 <fao89> +1
15:34:08 <daviddavis> +1
15:34:11 <ttereshc> +1
15:34:45 <fao89> #agreed accept and add to sprint
15:34:45 <fao89> !accept
15:34:45 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:34:46 <fao89> #topic https://pulp.plan.io/issues/5706
15:34:46 <pulpbot> fao89: 2 issues left to triage: 5706, 5694
15:34:47 <pulpbot> RM 5706 - bmbouter - NEW - base_version can cause content to show as added, even though it was in the previous version
15:34:48 <pulpbot> https://pulp.plan.io/issues/5706
15:35:32 <ttereshc> !propose other accept and add to sprint
15:35:41 <ttereshc> #idea Proposed for #5706: accept and add to sprint
15:35:41 <ttereshc> !propose other accept and add to sprint
15:35:41 <pulpbot> ttereshc: Proposed for #5706: accept and add to sprint
15:35:42 <dkliban> +1
15:35:48 <fao89> +1
15:36:10 <fao89> #agreed accept and add to sprint
15:36:10 <fao89> !accept
15:36:10 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:36:11 <pulpbot> fao89: 1 issues left to triage: 5694
15:36:11 <fao89> #topic https://pulp.plan.io/issues/5694
15:36:12 <pulpbot> RM 5694 - cassell - NEW - http_proxy via environment
15:36:13 <pulpbot> https://pulp.plan.io/issues/5694
15:36:39 <dkliban> this is a feature request
15:36:51 <dkliban> we should convert to a story and implement for 3.1
15:37:06 <ttereshc> +1 to stor
15:37:07 <fao89> #idea Proposed for #5694: change to story
15:37:07 <fao89> !propose other change to story
15:37:07 <pulpbot> fao89: Proposed for #5694: change to story
15:37:07 <ttereshc> y
15:37:12 <ipanova> #info ipanova has joined triage
15:37:12 <ipanova> !here
15:37:12 <pulpbot> ipanova: ipanova has joined triage
15:37:16 <daviddavis> +1
15:37:24 <mikedep333> +1
15:37:29 <fao89> #agreed change to story
15:37:29 <fao89> !accept
15:37:30 <pulpbot> fao89: Current proposal accepted: change to story
15:37:31 <pulpbot> fao89: No issues to triage.
15:37:48 <fao89> Open floor!
15:37:52 <fao89> !pulp
15:37:52 <pulpbot> 🍊 Yay, Pulp! 🍊 Go team go! 🍊
15:38:09 <daviddavis> the cron jobs are failing for pulp_file. I could use a review: https://github.com/pulp/pulp_file/pull/316
15:38:58 <dkliban> daviddavis: approved
15:39:29 <ipanova> ttereshc:  noticed that we did not tweet our latest release with plugins, i am going to tweet now, thoughts?
15:40:10 <daviddavis> dkliban++
15:40:10 <pulpbot> daviddavis: dkliban's karma is now 396
15:40:18 <daviddavis> ipanova: +1
15:40:47 <mikedep333> We should implement a standard Environment file (under /etc/default IIRC) for #5694 .
15:40:52 <mikedep333> We did this for Pulp 2.
15:41:00 <ipanova> daviddavis: cool
15:41:55 <ttereshc> Is it valid/expected behaviour from file downloader? should we just catch it and handle in rpm plugin https://pulp.plan.io/issues/5732 ?
15:42:22 <fao89> !issue 5732
15:42:22 <fao89> #topic https://pulp.plan.io/issues/5732
15:42:23 <pulpbot> RM 5732 - ttereshc - NEW - Syncing from filesystem results in FileNotFoundError if there is no Distribution Tree in a repo
15:42:24 <pulpbot> https://pulp.plan.io/issues/5732
15:42:58 <dkliban> what happens when syncing from remote?
15:43:13 <mikedep333> Actually it's under /etc/sysconfig/ . Apps (often with multiple services / systemd units) will use a single environment file for all of them. So /etc/sysconfig/pulp should be the systemd EnvironmentFile for all Pulp services.
15:43:47 <fao89> dkliban, from remote it gets 404 and it is treated
15:43:57 <dkliban> mikedep333: please leave a comment on the issue with that idea
15:44:03 <mikedep333> dkliban: Will do.
15:44:04 <ttereshc> dkliban, we have a back-off error few times and continue, it doesn't fail the task
15:44:26 <fao89> dkliban, https://github.com/pulp/pulp_rpm/blob/master/pulp_rpm/app/kickstart/treeinfo.py#L21-L26
15:45:08 <dkliban> yeah ... i think we should be catching the FileNotFoundError there also
15:45:25 <ttereshc> ok
15:45:33 <ttereshc> we can move on to the next item then
15:45:35 <ttereshc> thanks
15:46:05 <fao89> !next
15:46:06 <pulpbot> fao89: No issues to triage.
15:46:49 <ttereshc> I'd like to let RPM folks know that I'm filing a bunch of docs tasks which will need input/grooming. Just a heads-up.
15:47:17 <dkliban> that's great
15:50:55 <fao89> #endmeeting
15:50:55 <fao89> !end